jsoncpp-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157
  1. Name: jsoncpp
  2. Version: 0.7.1
  3. Release: 1%{?_dist_release}
  4. Summary: JSON library implemented in C++
  5. Summary(ja): C++ で実装された JSON ライブラリ
  6. Group: System Environment/Libraries
  7. License: Public Domain or MIT
  8. URL: http://sourceforge.net/projects/%{name}/
  9. Source0: https://github.com/open-source-parsers/jsoncpp/archive/0.7.1.tar.gz
  10. Source1: jsoncpp.pc
  11. Patch0: asstring.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: python scons doxygen
  14. BuildRequires: graphviz
  15. %description
  16. %{name} is an implementation of a JSON (http://json.org) reader and writer in
  17. C++. JSON (JavaScript Object Notation) is a lightweight data-interchange format.
  18. It is easy for humans to read and write. It is easy for machines to parse and
  19. generate.
  20. %package devel
  21. Summary: Development headers and library for %{name}
  22. Summary(ja): %{name} の開発用ヘッダファイルとライブラリ
  23. Group: Development/Libraries
  24. Requires: %{name} = %{version}-%{release}
  25. %description devel
  26. This package contains the development headers and library for %{name}.
  27. %package doc
  28. Summary: Documentation for %{name}
  29. Summary(ja): %{name} のドキュメント
  30. Group: Documentation
  31. BuildArch: noarch
  32. %description doc
  33. This package contains the documentation for %{name}
  34. %prep
  35. %setup -q
  36. #%patch0 -dsrc/lib_json -p1
  37. grep -e "-Wall" SConstruct
  38. sed 's/CCFLAGS = "-Wall"/CCFLAGS = "%{optflags}"/' -i SConstruct
  39. sed 's/README\.txt/README\.md/' -i SConstruct
  40. %build
  41. scons platform=linux-gcc %{?_smp_mflags}
  42. # Now, lets make a proper shared lib. :P
  43. g++ -o libjsoncpp.so.0.0.0 -shared -Wl,-soname,libjsoncpp.so.0 buildscons/linux-gcc-*/src/lib_json/*.os -lpthread
  44. # Build the doc
  45. python doxybuild.py --with-dot --doxygen %{_bindir}/doxygen
  46. %check
  47. # Fails due to patch0
  48. # scons platform=linux-gcc check %{?_smp_mflags}
  49. %install
  50. rm -rf $RPM_BUILD_ROOT
  51. install -p -D lib%{name}.so.0.0.0 $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.0.0.0
  52. ln -s %{_libdir}/lib%{name}.so.0.0.0 $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
  53. ln -s %{_libdir}/lib%{name}.so.0.0.0 $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.0
  54. install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/json
  55. install -p -m 0644 include/json/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/json
  56. mkdir -p $RPM_BUILD_ROOT%{_docdir}/%{name}/html
  57. for f in AUTHORS LICENSE NEWS.txt README.md; do
  58. install -p -m 0644 $f $RPM_BUILD_ROOT%{_docdir}/%{name}
  59. done
  60. install -p -m 0644 dist/doxygen/*/*.{html,png} $RPM_BUILD_ROOT%{_docdir}/%{name}/html
  61. install -d $RPM_BUILD_ROOT%{_libdir}/pkgconfig
  62. install -p -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
  63. sed -i 's|@@LIBDIR@@|%{_libdir}|g' $RPM_BUILD_ROOT%{_libdir}/pkgconfig/jsoncpp.pc
  64. %clean
  65. rm -rf $RPM_BUILD_ROOT
  66. %post -p /sbin/ldconfig
  67. %postun -p /sbin/ldconfig
  68. %files
  69. %{_docdir}/%{name}/
  70. %exclude %{_docdir}/%{name}/html
  71. %{_libdir}/lib%{name}.so.0
  72. %{_libdir}/lib%{name}.so.0.0.0
  73. %files devel
  74. %{_libdir}/lib%{name}.so
  75. %{_includedir}/%{name}/
  76. %{_libdir}/pkgconfig/jsoncpp.pc
  77. %files doc
  78. %{_docdir}/%{name}/
  79. %changelog
  80. * Tue Jan 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.7.1-1
  81. - Initial build for Vine Linux
  82. * Sun Sep 21 2014 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.14.rc2
  83. - Allow int values to be converted to string (#1143774)
  84. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.13.rc2
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  86. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.12.rc2
  87. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  88. * Tue Sep 10 2013 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.11.rc2
  89. - https://bugzilla.redhat.com/show_bug.cgi?id=998149 : applied Michael Schwendt's
  90. patch to fix duplicated documentation
  91. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.10.rc2
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  93. * Fri Mar 15 2013 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.9.rc2
  94. - Changed Summary
  95. - Added %%doc files to the doc package
  96. - Added python as an explicit BuildRequires
  97. * Fri Feb 15 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.8.rc2
  98. - Added documentation sub-package
  99. * Sun Jan 20 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.7.rc2
  100. - Added graphviz as a BuildRequire
  101. * Sat Jan 19 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.6.rc2
  102. - Install the corrected library
  103. * Sat Dec 22 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.5.rc2
  104. - Added libjsoncpp.so.0
  105. - Moved the shared lib build to the correct section
  106. * Fri Dec 21 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.4.rc2
  107. - Removed doc subpackage
  108. - Added .pc file
  109. - Fixed shared lib
  110. * Wed Dec 12 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.3.rc2
  111. - Removed static package
  112. - Preserving timestamp on installed files
  113. - Added guard grep to the sed expression
  114. - Removed duplicated doc files
  115. - Removed dependency on pkgconfig
  116. - Changed base package group
  117. * Sun Dec 02 2012 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.2.rc2
  118. - Changed license field to Public Domain or MIT
  119. * Tue Nov 27 2012 Sébastien Willmann <sebastien.willmann@gmail.com> 0.6.0-0.1.rc2
  120. - Creation of the spec file