perl-Crypt-SSLeay-vl.spec 7.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261
  1. # -*- coding: utf-8 -*-
  2. # Disable network tests by default
  3. %bcond_with network_tests
  4. %define origname Crypt-SSLeay
  5. Name: perl-Crypt-SSLeay
  6. Summary: OpenSSL glue that provides LWP https support
  7. Version: 0.72
  8. Release: 1%{?_dist_release}
  9. License: GPL or Artistic
  10. Group: Development/Libraries
  11. URL: http://search.cpan.org/dist/Crypt-SSLeay/
  12. Source0: http://www.cpan.org/authors/id/D/DL/DLAND/%{origname}-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: openssl-devel
  15. BuildRequires: perl(ExtUtils::MakeMaker)
  16. BuildRequires: perl(Path::Class)
  17. BuildRequires: perl(Test::Pod::Coverage)
  18. BuildRequires: perl(Try::Tiny)
  19. BuildRequires: perl(URI)
  20. BuildRequires: perl-libwww-perl
  21. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  22. Requires: openssl
  23. Distribution: Vine Linux
  24. Vendor: Project Vine
  25. Packager: iwaim
  26. %description
  27. This perl module provides support for the https protocol under LWP, so
  28. that a LWP::UserAgent can make https GET & HEAD & POST
  29. requests. Please see perldoc LWP for more information on POST
  30. requests.
  31. The Crypt::SSLeay package contains Net::SSL, which is automatically
  32. loaded by LWP::Protocol::https on https requests, and provides the
  33. necessary SSL glue for that module to work.
  34. %prep
  35. %setup -q -n %{origname}-%{version}
  36. # Filter unwanted Provides:
  37. cat << EOF > %{name}-prov
  38. #!/bin/sh
  39. %{__perl_provides} $* |\
  40. sed -e '/perl(DB)/d'
  41. EOF
  42. %define __perl_provides %{_builddir}/Crypt-SSLeay-%{version}/%{name}-prov
  43. chmod +x %{__perl_provides}
  44. %build
  45. if pkg-config openssl ; then
  46. export INC="$CFLAGS `pkg-config --cflags-only-I openssl`"
  47. export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
  48. fi
  49. %{__perl} Makefile.PL --%{!?with_network_tests:no-}live-tests \
  50. INC="$INC" LDFLAGS="$LDFLAGS" INSTALLDIRS=vendor OPTIMIZE="%{optflags}" \
  51. </dev/null
  52. make %{?_smp_mflags}
  53. %clean
  54. rm -rf $RPM_BUILD_ROOT
  55. %install
  56. rm -rf $RPM_BUILD_ROOT
  57. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  58. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  59. find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  60. find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  61. chmod -R u+w $RPM_BUILD_ROOT/*
  62. chmod -R 644 eg/*
  63. chmod -R 644 certs/*
  64. %check
  65. make test
  66. %files
  67. %defattr(-,root,root,-)
  68. %doc Changes eg/* certs/*
  69. %{perl_vendorarch}/auto/Crypt/
  70. %{perl_vendorarch}/Crypt/
  71. %{perl_vendorarch}/Net/
  72. %{_mandir}/man3/*.3*
  73. %changelog
  74. * Mon May 9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.72-1
  75. - new upstream release.
  76. - removed all patches (fixed in upstream).
  77. - added BR:perl(Path::Class) and BR:perl(Try::Tiny).
  78. * Sun Dec 21 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.57-3
  79. - rebuilt with perl 5.16.3
  80. * Sun Apr 3 2011 IWAI, Masaharu <iwai@alib.jp> 0.57-2vl6
  81. - build with perl 5.12.3
  82. * Wed Apr 7 2010 IWAI, Masaharu <iwai@alib.jp> 0.57-1
  83. - initial build for Vine Linux
  84. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.57-16
  85. - rebuild against perl 5.10.1
  86. * Wed Nov 25 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.57-14
  87. - change Makefile for openssl 1.0, which couldn't be found properly before
  88. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.57-13
  89. - rebuilt with new openssl
  90. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.57-12
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  92. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.57-11
  93. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  94. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.57-10
  95. - rebuild with new openssl
  96. * Mon Oct 6 2008 Marcela Maslanova <mmaslano@redhat.com> - 0.57-9
  97. - add examples into doc
  98. * Wed Sep 24 2008 Marcela Maslanova <mmaslano@redhat.com> - 0.57-8
  99. - fix patches for fuzz
  100. * Wed Mar 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.57-7
  101. - rebuild for new perl
  102. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.57-6
  103. - Autorebuild for GCC 4.3
  104. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.57-5
  105. - Rebuild for deps
  106. * Wed Dec 5 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-4
  107. - Rebuild for new openssl
  108. * Sat Oct 27 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-3
  109. - Remove unnecessary BR: pkgconfig
  110. * Fri Oct 26 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-2
  111. - Fix buildroot per package review
  112. - Resolves: bz#226248
  113. * Thu Oct 25 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-1
  114. - Update to latest upstream version.
  115. - Remove old patch (patch applied to upstream)
  116. - Several fixes for package review:
  117. - Fixed BuildRequires (added Test::Pod and LWP::UserAgent)
  118. - Apply patch to avoid prompting for input when building Makefile
  119. - Fix defattr line
  120. - Resolves: bz#226248
  121. * Mon Aug 27 2007 Robin Norwood <rnorwood@redhat.com> - 0.56-2
  122. - perl(ExtUtils::MakeMaker::Coverage) is now available
  123. * Mon Aug 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.56-1
  124. - 0.56 is the latest CPAN version, not 0.55
  125. * Mon Aug 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.55-2
  126. - Update to latest version from CPAN: 0.55
  127. - Remove two old patches, update lib64 patch for Makefile.PL changes.
  128. * Tue Feb 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.53-1
  129. - New version: 0.53
  130. * Mon Nov 27 2006 Robin Norwood <rnorwood@redhat.com> - 0.51-12
  131. - Resolves: bug#217138
  132. - fix a segfault on x86_64
  133. * Tue Oct 17 2006 Robin Norwood <rnorwood@redhat.com> - 0.51-10
  134. - Filter out Provides perl(DB)
  135. - bug #205562
  136. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.2.1
  137. - rebuild
  138. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.2
  139. - bump again for double-long bug on ppc(64)
  140. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.1
  141. - rebuilt for new gcc4.1 snapshot and glibc changes
  142. * Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 0.51-9.2
  143. - rebuild for new perl-5.8.8 / gcc / glibc
  144. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  145. - rebuilt for new gcc
  146. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  147. - rebuilt for new gcj
  148. * Thu Nov 10 2005 Tomas Mraz <tmraz@redhat.com> 0.51-9
  149. - rebuilt against new openssl
  150. - added missing SSL_library_init()
  151. * Sat Sep 24 2005 Ville Skyttä <ville.skytta at iki.fi> 0.51-8
  152. - Own more installed dirs (#73908).
  153. - Enable rpmbuild's internal dependency generator, drop unneeded dependencies.
  154. - Require perl(:MODULE_COMPAT_*).
  155. - Run tests in the %%check section.
  156. - Fix License, Source0, URL, and Group tags.
  157. * Wed Mar 30 2005 Warren Togami <wtogami@redhat.com> 0.51-7
  158. - remove brp-compress
  159. * Tue Mar 8 2005 Joe Orton <jorton@redhat.com> 0.51-6
  160. - rebuild
  161. * Tue Aug 31 2004 Chip Turner <cturner@redhat.com> 0.51-5
  162. - build for FC3
  163. * Tue Aug 31 2004 Chip Turner <cturner@redhat.com> 0.51-4
  164. - build for RHEL3 U4
  165. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  166. - rebuilt
  167. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  168. - rebuilt
  169. * Fri Feb 13 2004 Chip Turner <cturner@redhat.com> 0.51-1
  170. - update to upstream 0.51
  171. * Thu Jun 05 2003 Elliot Lee <sopwith@redhat.com>
  172. - rebuilt
  173. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com>
  174. - pass openssl includes to make as INC and ldflags in as LDFLAGS
  175. * Thu Nov 21 2002 Chip Turner <cturner@redhat.com>
  176. - patch to support /usr/lib64 before /usr/lib
  177. * Wed Nov 20 2002 Chip Turner <cturner@redhat.com>
  178. - rebuild
  179. * Tue Aug 6 2002 Chip Turner <cturner@redhat.com>
  180. - automated release bump and build
  181. * Thu Jun 27 2002 Chip Turner <cturner@redhat.com>
  182. - description update
  183. * Tue Jun 25 2002 Chip Turner <cturner@redhat.com>
  184. - move to 0.39
  185. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  186. - automated rebuild
  187. * Fri Dec 7 2001 root <root@redhat.com>
  188. - Spec file was autogenerated.