robin-map-vl.spec 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117
  1. %global debug_package %{nil}
  2. Name: robin-map
  3. Summary: C++ implementation of a fast hash map and hash set using robin hood hashing
  4. Version: 0.6.3
  5. Release: 4%{?_dist_release}
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: MIT
  10. URL: https://github.com/Tessil/robin-map
  11. Source0: https://github.com/Tessil/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
  12. BuildArch: noarch
  13. BuildRequires: cmake gcc-c++
  14. BuildRequires: libboost-devel
  15. BuildRequires: libboost-test
  16. %description
  17. The robin-map library is a C++ implementation of a fast hash map and hash set
  18. using open-addressing and linear robin hood hashing with backward shift
  19. deletion to resolve collisions.
  20. *** This is a header only library. ***
  21. The package you want is %{name}-devel.
  22. %package devel
  23. Summary: %{summary}
  24. Group: programming
  25. %description devel
  26. The robin-map library is a C++ implementation of a fast hash map and hash set
  27. using open-addressing and linear robin hood hashing with backward shift
  28. deletion to resolve collisions.
  29. Four classes are provided: tsl::robin_map, tsl::robin_set, tsl::robin_pg_map
  30. and tsl::robin_pg_set. The first two are faster and use a power of two growth
  31. policy, the last two use a prime growth policy instead and are able to cope
  32. better with a poor hash function. Use the prime version if there is a chance of
  33. repeating patterns in the lower bits of your hash (e.g. you are storing
  34. pointers with an identity hash function). See GrowthPolicy for details.
  35. A benchmark of tsl::robin_map against other hash maps may be found here. This
  36. page also gives some advices on which hash table structure you should try for
  37. your use case (useful if you are a bit lost with the multiple hash tables
  38. implementations in the tsl namespace).
  39. %prep
  40. %autosetup -p1
  41. %build
  42. %cmake
  43. %install
  44. DESTDIR="%{buildroot}" %__cmake --install .
  45. %check
  46. pushd tests
  47. %cmake
  48. %__cmake --build .
  49. ./tsl_robin_map_tests
  50. %files devel
  51. %license LICENSE
  52. %doc README.md
  53. %{_datadir}/cmake/tsl-%{name}/*.cmake
  54. %{_includedir}/tsl/
  55. %changelog
  56. * Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.3-4
  57. - initial build for Vine Linux.
  58. * Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.3-3
  59. - Second attempt - Rebuilt for
  60. https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  61. * Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.3-2
  62. - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  63. * Sun Jun 21 2020 Richard Shaw <hobbes1069@gmail.com> - 0.6.3-1
  64. - Update to 0.6.3.
  65. * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.2-2
  66. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  67. * Tue Nov 12 2019 Richard Shaw <hobbes1069@gmail.com> - 0.6.2-1
  68. - Update to 0.6.2.
  69. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1-2
  70. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  71. * Wed Feb 27 2019 Richard Shaw <hobbes1069@gmail.com> - 0.6.1-1
  72. - Update to 0.6.1.
  73. * Tue Feb 12 2019 Richard Shaw <hobbes1069@gmail.com> - 0.6.0-2
  74. - Add patch for GCC 9 warnings.
  75. * Mon Feb 11 2019 Richard Shaw <hobbes1069@gmail.com> - 0.6.0-1
  76. - Update to 0.6.0.
  77. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-3
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  79. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-2
  80. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  81. * Mon Jun 11 2018 Richard Shaw <hobbes1069@gmail.com> - 0.2.0-1
  82. - Initial packaging.