opencv-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726
  1. %bcond_with test
  2. %bcond_without gstreamer
  3. #global indice a
  4. Name: opencv
  5. Version: 4.5.0
  6. Release: 1%{?_dist_release}
  7. Summary: Collection of algorithms for computer vision
  8. Summary(ja): コンピュータビジョン用のアルゴリズム集
  9. Group: graphics
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. # This is normal three clause BSD.
  13. License: BSD
  14. URL: https://opencv.org
  15. # RUN opencv-clean.sh TO PREPARE TARBALLS
  16. #
  17. # Need to remove copyrighted lena.jpg images from tarball (rhbz#1295173)
  18. # and SIFT/SURF from tarball, due to legal concerns.
  19. #
  20. #Source0: https://github.com/opencv/opencv/archive/%{version}.tar.gz
  21. Source0: %{name}-clean-%{version}.tar.gz
  22. Source1: %{name}_contrib-clean-%{version}.tar.gz
  23. Source2: %{name}_extra-clean-%{version}.tar.gz
  24. Source3: face_landmark_model.dat.xz
  25. # from https://github.com/opencv/ade/archive/v0.1.1f.zip
  26. Source4: b624b995ec9c439cbc2e9e6ee940d3a2-v0.1.1f.zip
  27. Source5: xorg.conf
  28. Source100: opencv-clean.sh
  29. Patch0: opencv-4.1.0-install_3rdparty_licenses.patch
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  31. BuildRequires: libtool
  32. BuildRequires: cmake >= 2.6.3
  33. BuildRequires: chrpath
  34. BuildRequires: eigen3-devel
  35. BuildRequires: libtheora-devel
  36. BuildRequires: libvorbis-devel
  37. #BuildRequires: libraw1394-devel
  38. #BuildRequires: libdc1394-devel
  39. BuildRequires: jasper-devel
  40. BuildRequires: libpng-devel
  41. BuildRequires: libjpeg-devel
  42. BuildRequires: libtiff-devel
  43. BuildRequires: libv4l-devel
  44. BuildRequires: libwebp-devel
  45. BuildRequires: mesa-libGL-devel
  46. BuildRequires: OpenEXR-devel
  47. BuildRequires: openjpeg2-devel
  48. #ifarch %{ix86} x86_64
  49. #BuildRequires: openni-devel
  50. #BuildRequires: openni-primesense
  51. #endif
  52. BuildRequires: tbb-devel
  53. BuildRequires: qt5-qtbase-devel
  54. BuildRequires: freetype2-devel
  55. BuildRequires: harfbuzz-devel
  56. BuildRequires: zlib-devel pkgconfig
  57. BuildRequires: python3-devel
  58. BuildRequires: python3-setuptools
  59. BuildRequires: python3-rpm-macros
  60. BuildRequires: python3-numpy
  61. BuildRequires: swig >= 1.3.24
  62. #BuildRequires: python-sphinx
  63. #BuildRequires: ffmpeg-devel >= 0.4.9
  64. BuildRequires: gstreamer1-devel
  65. BuildRequires: gstreamer1-plugins-base-devel
  66. #BuildRequires: xine-lib-devel
  67. #BuildRequires: opencl-headers
  68. BuildRequires: vulkan-headers
  69. BuildRequires: mesa-dri-drivers
  70. BuildRequires: xorg-x11-drv-dummy
  71. Requires: opencv-core = %{version}-%{release}
  72. %description
  73. OpenCV means Intel® Open Source Computer Vision Library. It is a collection of
  74. C functions and a few C++ classes that implement some popular Image Processing
  75. and Computer Vision algorithms.
  76. %package core
  77. Summary: OpenCV core libraries
  78. Summary(ja): OpenCV コアライブラリ
  79. Group: graphics
  80. Obsoletes: %{name}-python < %{version}-%{release}
  81. %description core
  82. This package contains the OpenCV C/C++ core libraries.
  83. %package devel
  84. Summary: Development files for using the OpenCV library
  85. Summary(ja): OpenCV ライブラリを使用するための開発用ファイル
  86. Group: programming
  87. Requires: opencv = %{version}-%{release}
  88. %description devel
  89. This package contains the OpenCV C/C++ library and header files, as well as
  90. documentation. It should be installed if you want to develop programs that
  91. will use the OpenCV library. You should consider installing opencv-devel-docs
  92. package.
  93. %package -n python3-opencv
  94. Summary: Python bindings for apps which use OpenCV
  95. Summary(ja): OpenCV を使用するアプリケーション用の Python バインディング
  96. Group: programming
  97. Requires: opencv = %{version}-%{release}
  98. Requires: python3-numpy
  99. %description -n python3-opencv
  100. This package contains Python bindings for the OpenCV library.
  101. %package contrib
  102. Summary: OpenCV contributed functionality
  103. Summary(ja): 寄付された OpenCV の追加機能
  104. Group: graphics
  105. %description contrib
  106. This package is intended for development of so-called "extra" modules, contribut
  107. ed
  108. functionality. New modules quite often do not have stable API, and they are not
  109. well-tested. Thus, they shouldn't be released as a part of official OpenCV
  110. distribution, since the library maintains binary compatibility, and tries
  111. to provide decent performance and stability.
  112. %debug_package
  113. %prep
  114. %setup -q -a1 -a2
  115. # we don't use pre-built contribs except quirc
  116. pushd 3rdparty
  117. shopt -s extglob
  118. rm -r !(openexr|openvx|quirc)
  119. shopt -u extglob
  120. popd &>/dev/null
  121. %patch0 -p1 -b .install_3rdparty_licenses
  122. # Install ADE, needed for opencv_gapi
  123. mkdir -p .cache/ade
  124. install -pm 0644 %{SOURCE4} .cache/ade/
  125. %build
  126. # enabled by default if libraries are presents at build time:
  127. # GTK, GSTREAMER, 1394, V4L
  128. # non available on Fedora: FFMPEG, XINE
  129. mkdir -p build
  130. pushd build
  131. rm -rf share/opencv4/testdata/cv/face
  132. mkdir -p share/opencv4/testdata/cv/face
  133. install -pm 0644 %{SOURCE3} share/opencv4/testdata/cv/face
  134. pushd share/opencv4/testdata/cv/face
  135. xz -d face_landmark_model.dat.xz
  136. popd
  137. # disabling IPP because it is closed source library from intel
  138. %cmake CMAKE_VERBOSE=1 \
  139. -DWITH_IPP=OFF \
  140. -DWITH_ITT=OFF \
  141. -DWITH_QT=ON \
  142. -DWITH_OPENGL=ON \
  143. -DOpenGL_GL_PREFERENCE=GLVND \
  144. -DWITH_GDAL=ON \
  145. -DWITH_OPENEXR=ON \
  146. -DWITH_UNICAP=ON \
  147. -DCMAKE_SKIP_RPATH=ON \
  148. -DWITH_CAROTENE=OFF \
  149. %ifnarch x86_64 ia64
  150. -DENABLE_SSE=0 \
  151. -DENABLE_SSE2=0 \
  152. %else
  153. -DCPU_BASELINE=SSE2 \
  154. %endif
  155. -DENABLE_PRECOMPILED_HEADERS=OFF \
  156. -DCMAKE_BUILD_TYPE=ReleaseWithDebInfo \
  157. -DBUILD_opencv_java=OFF \
  158. %{?with_tbb: -DWITH_TBB=ON } \
  159. %{!?with_gstreamer: -DWITH_GSTREAMER=OFF } \
  160. -DWITH_FFMPEG=OFF \
  161. %{?with_openni: -DWITH_OPENNI=ON } \
  162. -DWITH_XINE=OFF \
  163. -DBUILD_DOCS=OFF \
  164. -DBUILD_EXAMPLES=OFF \
  165. -DBUILD_opencv_python2=OFF \
  166. -DINSTALL_C_EXAMPLES=OFF \
  167. -DINSTALL_PYTHON_EXAMPLES=OFF \
  168. -DPYTHON3_EXECUTABLE=%{__python3} \
  169. -DPYTHON3_PACKAGES_PATH=%{python3_sitearch} \
  170. -DENABLE_PYLINT=ON \
  171. -DBUILD_PROTOBUF=OFF \
  172. -DPROTOBUF_UPDATE_FILES=ON \
  173. -DWITH_OPENCL=OFF \
  174. -DOPENCV_SKIP_PYTHON_LOADER=ON \
  175. -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
  176. -DWITH_LIBV4L=ON \
  177. -DWITH_OPENMP=ON \
  178. -DOPENCV_CONFIG_INSTALL_PATH=%{_lib}/cmake/OpenCV \
  179. -DOPENCV_GENERATE_PKGCONFIG=ON \
  180. -DOPENCV_TEST_DATA_PATH=opencv_extra-%{version}/testdata \
  181. %{?with_gdcm: -DWITH_GDCM=ON } \
  182. %{?with_libmfx: -DWITH_MFX=ON } \
  183. %{?with_clp: -DWITH_CLP=ON } \
  184. %{?with_va: -DWITH_VA=ON } \
  185. -DWITH_VTK=OFF \
  186. -DWITH_TBB=1 -DTBB_LIB_DIR=%{_libdir} \
  187. -DWITH_VULKAN=ON -DVULKAN_INCLUDE_DIRS=%{_includedir}/vulkan \
  188. ..
  189. make VERBOSE=1 %{?_smp_mflags}
  190. popd
  191. %install
  192. rm -rf %{buildroot}
  193. %make_install -C build
  194. find %{buildroot} -name '*.la' -delete
  195. rm -rf %{buildroot}%{_datadir}/OpenCV/licenses/
  196. %if %{with test}
  197. %check
  198. # Check fails since we don't support most video
  199. # read/write capability and we don't provide a display
  200. # ARGS=-V increases output verbosity
  201. pushd build
  202. cp %SOURCE5 .
  203. if [ -x /usr/libexec/Xorg ]; then
  204. Xorg=/usr/libexec/Xorg
  205. else
  206. Xorg=/usr/libexec/Xorg.bin
  207. fi
  208. $Xorg -noreset +extension GLX +extension RANDR +extension RENDER -logfile ./xorg.log -config ./xorg.conf -configdir . :99 &
  209. export DISPLAY=:99
  210. LD_LIBRARY_PATH=%{_builddir}/%{name}-%{version}/build/lib:$LD_LIBARY_PATH make test ARGS=-V || :
  211. popd
  212. %endif
  213. %clean
  214. rm -rf %{buildroot}
  215. %post core -p /sbin/ldconfig
  216. %postun core -p /sbin/ldconfig
  217. %post -p /sbin/ldconfig
  218. %postun -p /sbin/ldconfig
  219. %post contrib -p /sbin/ldconfig
  220. %postun contrib -p /sbin/ldconfig
  221. %files
  222. %doc README.md
  223. %{_bindir}/opencv_*
  224. %dir %{_datadir}/opencv4
  225. %{_datadir}/opencv4/haarcascades
  226. %{_datadir}/opencv4/lbpcascades
  227. %{_datadir}/opencv4/valgrind*
  228. %{_datadir}/opencv4/quality
  229. %files core
  230. %license LICENSE
  231. %{_datadir}/licenses/opencv4/
  232. %{_libdir}/libopencv_alphamat.so.*
  233. %{_libdir}/libopencv_core.so.*
  234. %{_libdir}/libopencv_cvv.so.*
  235. %{_libdir}/libopencv_features2d.so.*
  236. %{_libdir}/libopencv_flann.so.*
  237. %{_libdir}/libopencv_gapi.so.*
  238. %{_libdir}/libopencv_hfs.so.*
  239. %{_libdir}/libopencv_highgui.so.*
  240. %{_libdir}/libopencv_imgcodecs.so.*
  241. %{_libdir}/libopencv_imgproc.so.*
  242. %{_libdir}/libopencv_intensity_transform.so.*
  243. %{_libdir}/libopencv_ml.so.*
  244. %{_libdir}/libopencv_objdetect.so.*
  245. %{_libdir}/libopencv_photo.so.*
  246. %{_libdir}/libopencv_rapid.so.*
  247. %{_libdir}/libopencv_shape.so.*
  248. %{_libdir}/libopencv_stitching.so.*
  249. %{_libdir}/libopencv_superres.so.*
  250. %{_libdir}/libopencv_video.so.*
  251. %{_libdir}/libopencv_videoio.so.*
  252. %{_libdir}/libopencv_videostab.so.*
  253. %files devel
  254. %dir %{_includedir}/opencv4
  255. %{_includedir}/opencv4/opencv2
  256. %{_libdir}/lib*.so
  257. %{_libdir}/pkgconfig/opencv*.pc
  258. %{_libdir}/cmake/OpenCV/*.cmake
  259. %files -n python3-opencv
  260. %exclude %{_bindir}/setup_vars_opencv4.sh
  261. %{python3_sitearch}/cv2.cpython-3*.so
  262. %files contrib
  263. %{_libdir}/libopencv_aruco.so.*
  264. %{_libdir}/libopencv_bgsegm.so.*
  265. %{_libdir}/libopencv_bioinspired.so.*
  266. %{_libdir}/libopencv_calib3d.so.*
  267. %{_libdir}/libopencv_ccalib.so.*
  268. %{_libdir}/libopencv_datasets.so.*
  269. # needs protobuf
  270. #{_libdir}/libopencv_dnn.so.*
  271. #{_libdir}/libopencv_dnn_objdetect.so.*
  272. #{_libdir}/libopencv_dnn_superres.so.*
  273. %{_libdir}/libopencv_dpm.so.*
  274. %{_libdir}/libopencv_face.so.*
  275. %{_libdir}/libopencv_freetype.so.*
  276. %{_libdir}/libopencv_fuzzy.so.*
  277. # needs hdf5
  278. #{_libdir}/libopencv_hdf.so.*
  279. %{_libdir}/libopencv_img_hash.so.*
  280. %{_libdir}/libopencv_line_descriptor.so.*
  281. %{_libdir}/libopencv_optflow.so.*
  282. %{_libdir}/libopencv_phase_unwrapping.so.*
  283. %{_libdir}/libopencv_plot.so.*
  284. %{_libdir}/libopencv_reg.so.*
  285. %{_libdir}/libopencv_rgbd.so.*
  286. %{_libdir}/libopencv_quality.so.*
  287. %{_libdir}/libopencv_saliency.so.*
  288. %{_libdir}/libopencv_stereo.so.*
  289. %{_libdir}/libopencv_structured_light.so.*
  290. %{_libdir}/libopencv_surface_matching.so.*
  291. # needs tesseract
  292. #{_libdir}/libopencv_text.so.*
  293. %{_libdir}/libopencv_tracking.so.*
  294. %{_libdir}/libopencv_ximgproc.so.*
  295. %{_libdir}/libopencv_xobjdetect.so.*
  296. %{_libdir}/libopencv_xphoto.so.*
  297. %changelog
  298. * Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.5.0-1
  299. - new upstream release.
  300. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.4.0-1
  301. - new upstream release.
  302. - enabled vulkan compute backend
  303. * Tue Jun 30 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-1
  304. - new upstream release.
  305. * Mon Mar 27 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-8
  306. - use eigen2 on Vine Linux 6.x
  307. - disable tbb/v4l on Vine Linux 6.x
  308. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 2.4.9-7
  309. - rebuild with gcc-5.4.0
  310. * Wed Mar 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-6
  311. - built with tbb
  312. - moved main package to System Environment/Libraries Group
  313. * Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-5
  314. - Initial build for Vine Linux
  315. * Tue Nov 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-4
  316. - rebuild (openexr)
  317. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.9-3
  318. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  319. * Fri Jul 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-2
  320. - backport support for GStreamer 1 (#1123078)
  321. * Thu Jul 03 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.9-1
  322. - Update to 2.4.9
  323. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.7-7
  324. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  325. * Sat Apr 26 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-6
  326. - revert pkgcmake2 patch (#1070428)
  327. * Fri Jan 17 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-5
  328. - Fix opencv_ocl isn't part of -core
  329. * Thu Jan 16 2014 Christopher Meng <rpm@cicku.me> - 2.4.7-4
  330. - Enable OpenCL support.
  331. - SPEC small cleanup.
  332. * Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-3
  333. - rebuild (openexr)
  334. * Mon Nov 18 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-2
  335. - OpenCV cmake configuration broken (#1031312)
  336. * Wed Nov 13 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-1
  337. - Update to 2.4.7
  338. * Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.6.1-2
  339. - rebuild (openexr)
  340. * Wed Jul 24 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.6.1-1
  341. - Update to 2.4.6.1
  342. * Thu May 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.5-1
  343. - Update to 2.4.5-clean
  344. - Spec file clean-up
  345. - Split core libraries into a sub-package
  346. * Sat May 11 2013 François Cami <fcami@fedoraproject.org> - 2.4.4-3
  347. - change project URL.
  348. * Tue Apr 02 2013 Tom Callaway <spot@fedoraproject.org> - 2.4.4-2
  349. - make clean source without SIFT/SURF
  350. * Sat Mar 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-1
  351. - Update to 2.4.4a
  352. - Fix ttb-devel architecture conditionals
  353. * Sun Mar 10 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.4-0.2.beta
  354. - rebuild (OpenEXR)
  355. * Mon Feb 18 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-0.1.beta
  356. - Update to 2.4.4 beta
  357. - Drop python-imaging also from requires
  358. - Drop merged patch for additionals codecs
  359. - Disable the java binding for now (untested)
  360. * Fri Jan 25 2013 Honza Horak <hhorak@redhat.com> - 2.4.3-7
  361. - Do not build with 1394 libs in rhel
  362. * Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 2.4.3-6
  363. - rebuild due to "jpeg8-ABI" feature drop
  364. * Sun Jan 20 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-5
  365. - Add more FourCC for gstreamer - rhbz#812628
  366. - Allow to use python-pillow - rhbz#895767
  367. * Mon Nov 12 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-3
  368. - Switch Build Type to ReleaseWithDebInfo to avoid -03
  369. * Sun Nov 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-2
  370. - Disable SSE3 and allow --with sse3 build conditional.
  371. - Disable gpu module as we don't build cuda
  372. - Update to 2.4.3
  373. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.2-2
  374. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  375. * Mon Jul 09 2012 Honza Horak <hhorak@redhat.com> - 2.4.2-1
  376. - Update to 2.4.2
  377. * Fri Jun 29 2012 Honza Horak <hhorak@redhat.com> - 2.4.1-2
  378. - Fixed cmake script for generating opencv.pc file
  379. - Fixed OpenCVConfig script file
  380. * Mon Jun 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.1-1
  381. - Update to 2.4.1
  382. - Rework dependencies - rhbz#828087
  383. Re-enable using --with tbb,opennpi,eigen2,eigen3
  384. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-8
  385. - Rebuilt for c++ ABI breakage
  386. * Mon Jan 16 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-7
  387. - Update gcc46 patch for ARM FTBFS
  388. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-6
  389. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  390. * Mon Dec 05 2011 Adam Jackson <ajax@redhat.com> 2.3.1-5
  391. - Rebuild for new libpng
  392. * Thu Oct 20 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-4
  393. - Rebuilt for tbb silent ABI change
  394. * Mon Oct 10 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-3
  395. - Update to 2.3.1a
  396. * Mon Sep 26 2011 Dan Horák <dan[at]danny.cz> - 2.3.1-2
  397. - openni is exclusive for x86/x86_64
  398. * Fri Aug 19 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-1
  399. - Update to 2.3.1
  400. - Add BR openni-devel python-sphinx
  401. - Remove deprecated cmake options
  402. - Add --with cuda conditional (wip)
  403. - Disable make test (unavailable)
  404. * Thu May 26 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-6
  405. - Backport fixes from branch 2.2 to date
  406. * Tue May 17 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-5
  407. - Re-enable v4l on f15
  408. - Remove unused cmake options
  409. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-3
  410. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  411. * Wed Feb 02 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-2
  412. - Fix with gcc46
  413. - Disable V4L as V4L1 is disabled for Fedora 15
  414. * Thu Jan 06 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-1
  415. - Update to 2.2.0
  416. - Disable -msse and -msse2 on x86_32
  417. * Wed Aug 25 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.1.0-5
  418. - -devel: include OpenCVConfig.cmake (#627359)
  419. * Thu Jul 22 2010 Dan Horák <dan[at]danny.cz> - 2.1.0-4
  420. - TBB is available only on x86/x86_64 and ia64
  421. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.0-3
  422. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  423. * Fri Jun 25 2010 Nicolas Chauvet <kwizart@gmail.com> - 2.1.0-2
  424. - Move samples from main to -devel
  425. - Fix spurious permission
  426. - Add BR tbb-devel
  427. - Fix CFLAGS
  428. * Fri Apr 23 2010 Nicolas Chauvet <kwizart@fedoraproject.org> - 2.1.0-1
  429. - Update to 2.1.0
  430. - Update libdir patch
  431. * Tue Apr 13 2010 Karel Klic <kklic@redhat.com> - 2.0.0-10
  432. - Fix nonstandard executable permissions
  433. * Tue Mar 09 2010 Karel Klic <kklic@redhat.com> - 2.0.0-9
  434. - apply the previously added patch
  435. * Mon Mar 08 2010 Karel Klic <kklic@redhat.com> - 2.0.0-8
  436. - re-enable testing on CMake build system
  437. - fix memory corruption in the gaussian random number generator
  438. * Sat Feb 27 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-7
  439. - replaced BR unicap-devel by libucil-devel (unicap split)
  440. * Thu Feb 25 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-6
  441. - use cmake build system
  442. - applications renamed to opencv_xxx instead of opencv-xxx
  443. - add devel-docs subpackage #546605
  444. - add OpenCVConfig.cmake
  445. - enable openmp build
  446. - enable old SWIG based python wrappers
  447. - opencv package is a good boy and use global instead of define
  448. * Tue Feb 16 2010 Karel Klic <kklic@redhat.com> - 2.0.0-5
  449. - Set CXXFLAXS without -match=i386 for i386 architecture #565074
  450. * Sat Jan 09 2010 Rakesh Pandit <rakesh@fedoraproject.org> - 2.0.0-4
  451. - Updated opencv-samples-Makefile (Thanks Scott Tsai) #553697
  452. * Wed Jan 06 2010 Karel Klic <kklic@redhat.com> - 2.0.0-3
  453. - Fixed spec file issues detected by rpmlint
  454. * Sun Dec 06 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-2
  455. - Fix autotools scripts (missing LBP features) - #544167
  456. * Fri Nov 27 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-1
  457. - Updated to 2.0.0
  458. - Removed upstream-ed patches
  459. - Ugly hack (added cvconfig.h)
  460. - Disable %%check on ppc64
  461. * Thu Sep 10 2009 Karsten Hopp <karsten@redhat.com> - 1.1.0-0.7.pre1
  462. - fix build on s390x where we don't have libraw1394 and devel
  463. * Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.6.pre1
  464. - Fix typo I introduced that prevented build on i386/i586
  465. * Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.5.pre1
  466. - Added 1394 libs and unicap support
  467. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-0.4.pre1
  468. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  469. * Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.3.pre1
  470. - Build with gstreamer support - #491223
  471. - Backport gcc43 fix from trunk
  472. * Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.2.pre1
  473. - Fix FTBFS #511705
  474. * Fri Apr 24 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.1.pre1
  475. - Update to 1.1pre1
  476. - Disable CXXFLAGS hardcoded optimization
  477. - Add BR: python-imaging, numpy
  478. - Disable make check failure for now
  479. * Wed Apr 22 2009 kwizart < kwizart at gmail.com > - 1.0.0-14
  480. - Fix for gcc44
  481. - Enable BR jasper-devel
  482. - Disable ldconfig run on python modules (uneeded)
  483. - Prevent timestamp change on install
  484. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-13
  485. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  486. * Mon Dec 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 1.0.0-12
  487. - fix URL field
  488. * Fri Dec 19 2008 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.0.0-11
  489. - Adopt latest python spec rules.
  490. - Rebuild for Python 2.6 once again.
  491. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.0-10
  492. - Rebuild for Python 2.6
  493. * Thu May 22 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.0.0-9
  494. - fix license tag
  495. * Sun May 11 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-8
  496. - Adjust library order in opencv.pc.in (BZ 445937).
  497. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-7
  498. - Autorebuild for GCC 4.3
  499. * Sun Feb 10 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-6
  500. - Rebuild for gcc43.
  501. * Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.0.0-5
  502. - Rebuild for selinux ppc32 issue.
  503. * Wed Aug 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-4
  504. - Mass rebuild.
  505. * Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-3
  506. - Fix %%{_datadir}/opencv/samples ownership.
  507. - Adjust timestamp of cvconfig.h.in to avoid re-running autoheader.
  508. * Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-2
  509. - Move all of the python module to pyexecdir (BZ 233128).
  510. - Activate the testsuite.
  511. * Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-1
  512. - Upstream update.
  513. * Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-4
  514. - Remove python-abi.
  515. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.9.9-3
  516. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  517. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-2
  518. - Stop configure.in from hacking CXXFLAGS.
  519. - Activate testsuite.
  520. - Let *-devel require pkgconfig.
  521. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-1
  522. - Upstream update.
  523. - Don't BR: autotools.
  524. - Install samples' Makefile as GNUmakefile.
  525. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-18
  526. - Un'%%ghost *.pyo.
  527. - Separate %%{pythondir} from %%{pyexecdir}.
  528. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-17
  529. - Rebuild for FC6.
  530. - BR: libtool.
  531. * Fri Mar 17 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-16
  532. - Rebuild.
  533. * Wed Mar 8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-15
  534. - Force a re-run of Autotools by calling autoreconf.
  535. * Wed Mar 8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-14
  536. - Added build dependency on Autotools.
  537. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-13
  538. - Changed intrinsics patch so that it matches upstream.
  539. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-12
  540. - More intrinsics patch fixing.
  541. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-11
  542. - Don't do "make check" because it doesn't run any tests anyway.
  543. - Back to main intrinsics patch.
  544. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-10
  545. - Using simple intrinsincs patch.
  546. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-9
  547. - Still more fixing of intrinsics patch for Python bindings on x86_64.
  548. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-8
  549. - Again fixed intrinsics patch so that Python modules build on x86_64.
  550. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-7
  551. - Fixed intrinsics patch so that it works.
  552. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-6
  553. - Fixed Python bindings location on x86_64.
  554. * Mon Mar 6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-5
  555. - SSE2 support on x86_64.
  556. * Mon Mar 6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-4
  557. - Rebuild
  558. * Sun Oct 16 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-3
  559. - Removed useless sample compilation makefiles/project files and replaced them
  560. with one that works on Fedora Core.
  561. - Removed shellbang from Python modules.
  562. * Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-2
  563. - Made FFMPEG dependency optional (needs to be disabled for inclusion in FE).
  564. * Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-1
  565. - Initial package.