fmt-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225
  1. %undefine __cmake_in_source_build
  2. %bcond_with doc
  3. Name: fmt
  4. Summary: Small, safe and fast formatting library for C++
  5. Version: 7.1.3
  6. Release: 2%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: BSD
  11. URL: https://github.com/fmtlib/%{name}
  12. Source0: %{url}/archive/%{version}.tar.gz
  13. # See https://github.com/fmtlib/fmt/issues/443 and https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/LVKYLDLJVWAVJE4MQVKDO6PYZRD5MCP6/
  14. Patch1: doc-build-removed-all-pip-internet-stuff.patch
  15. Patch3: doc-build-do-not-create-virtual-environment.patch
  16. Patch4: doc-_templates-layout-stripped-Google-Analytics.patch
  17. Patch5: doc-_templates-layout-stripped-download-links.patch
  18. Patch6: doc-index-removed-GitHub-iframe.patch
  19. Patch7: doc-build-use-sphinx-build-3.patch
  20. BuildRequires: gcc
  21. BuildRequires: gcc-c++
  22. BuildRequires: ninja
  23. BuildRequires: cmake
  24. %if %{with doc}
  25. BuildRequires: doxygen
  26. BuildRequires: nodejs
  27. BuildRequires: python3-sphinx
  28. BuildRequires: python3-breathe
  29. %else
  30. Provides: %{name}-doc = %{?epoch:%{epoch}:}%{version}-%{release}
  31. Obsoletes: %{name}-doc < %{?epoch:%{epoch}:}%{version}-%{release}
  32. %endif
  33. # This package replaces the old name of cppformat
  34. Provides: cppformat = %{?epoch:%{epoch}:}%{version}-%{release}
  35. Obsoletes: cppformat < %{?epoch:%{epoch}:}%{version}-%{release}
  36. %description
  37. C++ Format is an open-source formatting library for C++. It can be used as a
  38. safe alternative to printf or as a fast alternative to IOStreams.
  39. %package devel
  40. Summary: Development files for %{name}
  41. Group: programming
  42. Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
  43. # This package replaces the old name of cppformat
  44. Provides: cppformat-devel = %{?epoch:%{epoch}:}%{version}-%{release}
  45. Obsoletes: cppformat-devel < %{?epoch:%{epoch}:}%{version}-%{release}
  46. %description devel
  47. This package contains the header file for using %{name}.
  48. %if %{with doc}
  49. %package doc
  50. Summary: Documentation files for %{name}
  51. Group: documentation
  52. License: Python
  53. BuildArch: noarch
  54. # This package replaces the old name of cppformat
  55. Provides: cppformat-doc = %{?epoch:%{epoch}:}%{version}-%{release}
  56. Obsoletes: cppformat-doc < %{?epoch:%{epoch}:}%{version}-%{release}
  57. %description doc
  58. This package contains documentation for developer documentation for %{name}.
  59. %endif
  60. %debug_package
  61. %prep
  62. %autosetup -p1
  63. %if %{with doc}
  64. # Remove --clean-css since that plugin isn't available
  65. sed -i "s/'--clean-css',//" doc/build.py
  66. %endif
  67. %build
  68. %cmake \
  69. -G Ninja \
  70. -DCMAKE_BUILD_TYPE=RelWithDebInfo \
  71. -DCMAKE_POSITION_INDEPENDENT_CODE=ON \
  72. -DFMT_CMAKE_DIR=%{_datadir}/cmake/%{name} \
  73. -DFMT_LIB_DIR=%{_libdir}
  74. %__cmake --build . \
  75. %if %{with doc}
  76. --target doc \
  77. %endif
  78. --target all
  79. %if %{with doc}
  80. # Remove temporary build products
  81. rm -rf %{_vpath_builddir}/doc/html/{.buildinfo,.doctrees,objects.inv}
  82. %endif
  83. %install
  84. DESTDIR="%{buildroot}" %__cmake --install .
  85. #%check
  86. #%ctest
  87. %files
  88. %license LICENSE.rst
  89. %doc ChangeLog.rst README.rst
  90. %{_libdir}/lib%{name}.so.7*
  91. %files devel
  92. %{_includedir}/%{name}
  93. %{_libdir}/lib%{name}.so
  94. %{_datadir}/cmake/%{name}
  95. %{_libdir}/pkgconfig/%{name}.pc
  96. %if %{with doc}
  97. %files doc
  98. %doc %{_datadir}/doc/%{name}
  99. %license doc/python-license.txt
  100. %endif
  101. %changelog
  102. * Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.1.3-2
  103. - initial build for Vine Linux.
  104. * Sun Nov 29 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.1.3-1
  105. - Updated to version 7.1.3.
  106. * Tue Nov 10 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.1.2-1
  107. - Updated to version 7.1.2.
  108. * Sat Aug 08 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.0.3-1
  109. - Updated to version 7.0.3.
  110. * Wed Jul 29 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.0.2-1
  111. - Updated to version 7.0.2.
  112. * Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 7.0.1-2
  113. - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  114. * Wed Jul 08 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.0.1-1
  115. - Updated to version 7.0.1.
  116. * Sat May 09 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 6.2.1-1
  117. - Updated to version 6.2.1.
  118. * Thu Apr 30 2020 Kefu Chai <tchaikov@gmail.com> - 6.2.0-2
  119. - Incorporate patch from upstream to address https://github.com/fmtlib/fmt/issues/1631
  120. * Mon Apr 06 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 6.2.0-1
  121. - Updated to version 6.2.0.
  122. * Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.2-2
  123. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  124. * Wed Dec 18 2019 Vitaly Zaitsev <vitaly@easycoding.org> - 6.1.2-1
  125. - Updated to version 6.1.2.
  126. - Recreated all documentation patches.
  127. - SPEC file cleanup.
  128. * Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.3.0-2
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  130. * Mon Jun 10 2019 Jan Staněk <jstanek@redhat.com> - 5.3.0-1
  131. - Update to 5.3.0
  132. - Recreate documentation build patches
  133. - Package new pkg-config files
  134. * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.1-2
  135. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  136. * Thu Oct 11 2018 Kefu Chai <tchaikov@gmail.com> - 5.2.1-1
  137. - Update to 5.2.1
  138. - Build using python3 packages on fedora
  139. - Remove links in document accessing network
  140. - Package ChangeLog.rst and README.rst
  141. - Drop fmt-static package
  142. * Fri Aug 31 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.0.2-7
  143. - Fix python2 issue for doc
  144. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-6
  145. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  146. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-5
  147. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  148. * Wed Aug 09 2017 Dave Johansen <davejohansen@gmail.com> - 3.0.2-4
  149. - Patch for Test 8 segfault
  150. * Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-3
  151. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  152. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-2
  153. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  154. * Sat Jun 24 2017 Dave Johansen <davejohansen@gmail.com> - 3.0.2-1
  155. - Upstream release
  156. * Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.1-3
  157. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
  158. * Tue Dec 27 2016 Dave Johansen <davejohansen@gmail.com> - 3.0.1-2
  159. - Build documentation
  160. * Fri Nov 25 2016 Dave Johansen <davejohansen@gmail.com> - 3.0.1-1
  161. - Upstream release
  162. * Tue Nov 15 2016 Dave Johansen <davejohansen@gmail.com> - 3.0.0-2
  163. - Fix expected unqualified-id before numeric constant error
  164. * Wed Aug 24 2016 Dave Johansen <davejohansen@gmail.com> - 3.0.0-1
  165. - Initial RPM release