OpenEXR-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294
  1. %bcond_with check
  2. Name: OpenEXR
  3. Summary: A high dynamic-range (HDR) image file format
  4. Summary(ja): 高ダイナミックレンジ(HDR)画像ファイルフォーマット
  5. Version: 2.5.3
  6. Release: 1%{?_dist_release}
  7. Group: graphics
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: BSD
  11. URL: http://www.openexr.com/
  12. Source0: https://github.com/openexr/openexr/archive/v%{version}.tar.gz#/openexr-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: cmake
  15. BuildRequires: zlib-devel
  16. BuildRequires: pkgconfig
  17. # https://github.com/openexr/openexr/issues/130
  18. BuildConflicts: OpenEXR-devel < 2.2.0
  19. Requires: %{name}-libs = %{version}-%{release}
  20. Obsoletes: openexr < %{version}-%{release}
  21. Provides: openexr = %{version}-%{release}
  22. %description
  23. OpenEXR is a high dynamic-range (HDR) image file format developed by Industrial
  24. Light & Magic for use in computer imaging applications. This package contains
  25. sample applications for handling the format.
  26. %package libs
  27. Summary: %{name} runtime libraries
  28. Summary(ja): %{name} のランタイムライブラリ
  29. Group: system
  30. %description libs
  31. %{summary}.
  32. %package devel
  33. Summary: Development files for %{name}
  34. Summary(ja): %{name} の開発用ファイル
  35. Group: programming
  36. Requires: %{name}-libs = %{version}-%{release}
  37. Requires: ilmbase-devel
  38. Obsoletes: openexr-devel < %{version}-%{release}
  39. Provides: openexr-devel = %{version}-%{release}
  40. %description devel
  41. %{summary}.
  42. %package -n ilmbase
  43. Summary: Abraction/convenience libraries
  44. Group: system
  45. BuildRequires: libGL-devel
  46. BuildRequires: libGLU-devel
  47. %description -n ilmbase
  48. Half is a class that encapsulates the ilm 16-bit floating-point format.
  49. IlmThread is a thread abstraction library for use with OpenEXR
  50. and other software packages.
  51. Imath implements 2D and 3D vectors, 3x3 and 4x4 matrices, quaternions
  52. and other useful 2D and 3D math functions.
  53. Iex is an exception-handling library.
  54. %package -n ilmbase-devel
  55. Summary: Headers and libraries for building apps that use ilmbase
  56. Summary(ja): ilmbaseを使うアプリケーションをビルドするためのヘッダファイル及びライブラリ
  57. Group: programming
  58. Requires: ilmbase = %{version}-%{release}
  59. Requires: pkgconfig
  60. Requires: libGL-devel
  61. Requires: libGLU-devel
  62. %description -n ilmbase-devel
  63. Headers and libraries for building apps that use ilmbase.
  64. %debug_package
  65. %prep
  66. %setup -q -n openexr-%{version}
  67. %build
  68. mkdir build
  69. pushd build
  70. %cmake \
  71. -DPYILMBASE_ENABLE=no \
  72. -DOPENEXR_VIEWERS_ENABLE=no \
  73. ..
  74. make %{?_smp_mflags}
  75. popd
  76. %install
  77. rm -rf %{buildroot}
  78. pushd build
  79. make install DESTDIR=%{buildroot}
  80. popd
  81. # prepare docs
  82. mkdir -p rpmdocs
  83. cp -a %{buildroot}%{_docdir}/OpenEXR/* rpmdocs/
  84. rm -rf %{buildroot}%{_docdir}/OpenEXR
  85. %if %{with check}
  86. %check
  87. pushd build
  88. %ifarch %{ix86}
  89. make %{_smp_mflags} test ||:
  90. %else
  91. make %{_smp_mflags} test
  92. %endif
  93. popd
  94. %endif
  95. %clean
  96. rm -rf %{buildroot}
  97. %post libs -p /sbin/ldconfig
  98. %postun libs -p /sbin/ldconfig
  99. %files
  100. %defattr(-,root,root,-)
  101. %license LICENSE.md
  102. %doc README.md
  103. %{_bindir}/*
  104. %files libs
  105. %defattr(-,root,root,-)
  106. %license LICENSE.md
  107. %doc OpenEXR/README.md
  108. %doc rpmdocs/*
  109. %{_libdir}/libIlmImf*.so.*
  110. %files devel
  111. %defattr(-,root,root,-)
  112. %{_includedir}/OpenEXR/Imf*.h
  113. %{_includedir}/OpenEXR/OpenEXRConfig.h
  114. %{_libdir}/lib*.so
  115. %dir %{_libdir}/pkgconfig
  116. %{_libdir}/pkgconfig/OpenEXR.pc
  117. %dir %{_libdir}/cmake
  118. %{_libdir}/cmake/OpenEXR
  119. %files -n ilmbase
  120. %doc IlmBase/README.md
  121. %license LICENSE.md
  122. %{_libdir}/lib*.so.*
  123. %exclude %{_libdir}/libIlmImf*.so.*
  124. %files -n ilmbase-devel
  125. %dir %{_includedir}/OpenEXR/
  126. %{_includedir}/OpenEXR/Iex*.h
  127. %{_includedir}/OpenEXR/Ilm*.h
  128. %{_includedir}/OpenEXR/Imath*.h
  129. %{_includedir}/OpenEXR/half*.h
  130. %{_libdir}/lib*.so
  131. %exclude %{_libdir}/libIlmImf*.so
  132. %dir %{_libdir}/pkgconfig
  133. %{_libdir}/pkgconfig/IlmBase.pc
  134. %dir %{_libdir}/cmake
  135. %{_libdir}/cmake/IlmBase
  136. %changelog
  137. * Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.5.3-1
  138. - new upstream release.
  139. * Fri Jul 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.2-1
  140. - new upstream release.
  141. * Sat Apr 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.1-1
  142. - new upstream release.
  143. * Fri Oct 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.0-1
  144. - new upstream release.
  145. - unified IlmBase into OpenEXR.
  146. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.0-2
  147. - rebuild with gcc-5.4.0
  148. * Thu Dec 18 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.2.0-1
  149. - new upstream release
  150. - removed Patch100 and 101
  151. - built with ilmbase 2.2.0
  152. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
  153. - new upstream release
  154. - remove Patch1,2,102
  155. - update Patch100 (openexr-2.1.0-CVE-2009-1720-1.patch)
  156. - update Patch101 (openexr-2.1.0-CVE-2009-1720-2.patch)
  157. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-3
  158. - rebuilt with rpm-4.8.1 for pkg-config
  159. * Wed Aug 5 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.1-2
  160. - add Patch100,101 for fix CVE-2009-1720 (Integer BOF)
  161. - add Patch102 for fix CVE-2009-1721
  162. - Patch100-102 are from FC11
  163. * Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.1-1
  164. - initial build for Vine Linux
  165. * Fri May 09 2008 Rex Dieter <rdieter@fedoraproject.org> 1.6.1-4
  166. - drop: Obsoletes: OpenEXR-utils (see OpenEXR_Viewers review, bug #428228c3)
  167. * Fri Feb 01 2008 Rex Dieter <rdieter@fedoraproject.org> 1.6.1-3
  168. - gcc43 patch
  169. - purge rpaths
  170. * Wed Jan 09 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.1-2
  171. - hack to omit unused-direct-shlib-dependencies
  172. - conditionalize -libs (f8+)
  173. * Mon Jan 07 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.1-1
  174. - openexr-1.6.1
  175. * Tue Oct 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-5
  176. - multiarch conflicts in OpenEXR (#342781)
  177. - don't own %%_includedir/OpenEXR (leave that to ilmbase)
  178. * Mon Oct 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-4
  179. - -libs: %%post/%%postun -p /sbin/ldconfig
  180. * Fri Oct 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.6.0-2
  181. - openexr-1.6.0
  182. * Mon Sep 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.0a-6
  183. - libs: -Requires: %%name
  184. * Wed Aug 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.4.0a-5
  185. - -libs: new subpkg to be multilib friendly
  186. - -utils: package exrdisplay separately (separate fltk dep)
  187. * Sat Oct 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-4
  188. - Obsoletes/Provides: openexr(-devel) (rpmforge compatibility)
  189. * Thu Sep 14 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-3
  190. - pkgconfig patch to use Libs.private
  191. * Thu Sep 14 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-2
  192. - -devel: +Requires: pkgconfig
  193. * Tue Aug 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.4.0a-1
  194. - openexr-1.4.0a
  195. * Sat Feb 18 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-7
  196. - Further zlib fixes (#165729)
  197. * Mon Feb 13 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-6
  198. - Rebuild for Fedora Extras 5
  199. * Wed Aug 17 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-5
  200. - Remove *.a from %%files devel
  201. * Tue Aug 16 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-4
  202. - Removed -devel dep on zlib-devel (#165729)
  203. - Added --disable-static to %%configure
  204. - Fixed build with GCC 4.0.1
  205. - Added .so links to -devel
  206. * Wed May 18 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-3
  207. - Add zlib-devel to BR
  208. - Delete all .la files (#157652)
  209. * Mon May 9 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-2
  210. - Add disttag
  211. * Sun May 8 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-2
  212. - Fix BuildRequires
  213. - Fix Requires on -devel
  214. - Add %%post[un] scriptlets
  215. - Fix ownership in -devel
  216. - Don't have .deps files in %%doc
  217. * Wed Mar 30 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.2.2-1
  218. - Initial RPM release