ModemManager-vl.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242
  1. #%define snapshot .git20100720
  2. %define snapshot %{nil}
  3. %define ppp_version 2.4.5
  4. Summary: Mobile broadband modem management service
  5. Summary(ja): Mobile broadband modem management service
  6. Name: ModemManager
  7. Version: 0.4
  8. Release: 2%{?snapshot}%{?_dist_release}
  9. License: GPLv2+
  10. Group: System Environment/Base
  11. URL: http://www.gnome.org/projects/NetworkManager/
  12. #
  13. # Source from git://anongit.freedesktop.org/ModemManager/ModemManager
  14. # tarball built with:
  15. # ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
  16. # make distcheck
  17. #
  18. Source: %{name}-%{version}%{?snapshot}.tar.bz2
  19. Patch1: %{name}-0.3-jp-modems.patch
  20. Patch20: %{name}-0.4-git20110428.patch
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. Requires: dbus-glib
  23. Requires: glib2
  24. BuildRequires: glib2-devel >= 2.26.1
  25. BuildRequires: dbus-glib-devel >= 0.92
  26. BuildRequires: libgudev-devel >= 143
  27. BuildRequires: ppp = %{ppp_version}
  28. BuildRequires: ppp-devel = %{ppp_version}
  29. BuildRequires: polkit-devel
  30. BuildRequires: automake autoconf intltool libtool
  31. # for xsltproc
  32. BuildRequires: libxslt
  33. %description
  34. The ModemManager service provides a consistent API to operate many different
  35. modems, including mobile broadband (3G) devices.
  36. %prep
  37. %setup -q
  38. %patch1 -p1 -b .jp-modems
  39. %patch20 -p1 -b .git20110428
  40. %build
  41. autoreconf -i
  42. pppddir=`ls -1d %{_libdir}/pppd/2*`
  43. %configure \
  44. --enable-more-warnings=yes \
  45. --with-udev-base-dir=/lib/udev \
  46. --with-tests=yes \
  47. --with-docs=yes \
  48. --disable-static \
  49. --with-pppd-plugin-dir=$pppddir \
  50. --with-polkit=no
  51. make %{?_smp_mflags}
  52. %check
  53. make check
  54. %install
  55. make install DESTDIR=$RPM_BUILD_ROOT
  56. rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
  57. rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.la
  58. rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
  59. rm -f $RPM_BUILD_ROOT%{_includedir}/mm/mm-modem.h
  60. %post
  61. /sbin/ldconfig
  62. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  63. %postun
  64. /sbin/ldconfig
  65. if [ $1 -eq 0 ]; then
  66. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  67. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  68. fi
  69. %posttrans
  70. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  71. %files
  72. %defattr(0644, root, root, 0755)
  73. %doc COPYING README
  74. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager.conf
  75. %{_datadir}/dbus-1/interfaces/*.xml
  76. %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager.service
  77. %attr(0755,root,root) %{_sbindir}/modem-manager
  78. %dir %{_libdir}/%{name}
  79. %attr(0755,root,root) %{_libdir}/%{name}/*.so*
  80. /lib/udev/rules.d/*
  81. %{_datadir}/polkit-1/actions/*.policy
  82. %{_datadir}/icons/hicolor/22x22/apps/modem-manager.png
  83. %changelog
  84. * Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
  85. - update Patch20 (ModemManager-0.4-git20110428.patch)
  86. - delete Patch21,22
  87. * Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
  88. - update to 0.4
  89. - add Patch20 (ModemManager-0.4-git20100720.patch)
  90. - add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
  91. - add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
  92. * Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
  93. - initial build for Vine Linux
  94. * Sun May 2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
  95. - core: ignore some failures on disconnect (rh #578280)
  96. - core: add support for platform serial devices
  97. - gsm: better Blackberry DUN support
  98. - gsm: periodically poll access technology
  99. - cdma: prevent crash on modem removal (rh #571921)
  100. - mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
  101. - novatel: better signal strength reporting on CDMA cards
  102. - novatel: add access technology and mode preference support on GSM cards
  103. - zte: fix mode preference retrieval
  104. - longcheer: add support for Zoom modems (4595, 4596, etc)
  105. - longcheer: add access technology and mode preference support
  106. * Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
  107. - Silence %%post
  108. - Update scripts
  109. * Fri Apr 9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
  110. - gsm: fix parsing Blackberry supported character sets response
  111. * Thu Apr 8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
  112. - mbm: fix retrieval of current allowed mode
  113. - gsm: fix initialization issues with some devices (like Blackberries)
  114. * Mon Apr 5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
  115. - core: fix detection of some generic devices (rh #579247)
  116. - core: fix detection regression of some Huawei devices in 0.3-5
  117. - cdma: periodically poll registration state and signal quality
  118. - cdma: really fix registration detection on various devices (rh #569067)
  119. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
  120. - core: fix PPC/SPARC/etc builds
  121. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
  122. - core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
  123. - cdma: handle signal quality requests while connected for more devices
  124. - cdma: handle serving system requests while connected for more devices
  125. - gsm: determine current access technology earlier
  126. - huawei: work around automatic registration issues on some devices
  127. * Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
  128. - core: ensure enabled modems are disabled when MM stops
  129. - core: better capability detection for Blackberry devices (rh #573510)
  130. - cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
  131. - gsm: don't block modem when it requires PIN2
  132. - option: fix access technology updates
  133. * Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
  134. - mbm: add device IDs for C3607w
  135. - mbm: fail earlier during connection failures
  136. - mbm: fix username/password authentication when checked by the network
  137. - hso: implement asynchronous signal quality updates
  138. - option: implement asynchronous signal quality updates
  139. - novatel: correctly handle CDMA signal quality
  140. - core: basic PolicyKit support
  141. - core: fix direct GSM registration information requests
  142. - core: general GSM PIN/PUK unlock fixes
  143. - core: poll GSM registration state internally for quicker status updates
  144. - core: implement GSM 2G/3G preference
  145. - core: implement GSM roaming allowed/disallowed preference
  146. - core: emit signals on access technology changes
  147. - core: better handling of disconnections
  148. - core: fix simple CDMA status requests
  149. * Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
  150. - core: startup speed improvements
  151. - core: GSM PIN checking improvements
  152. - huawei: fix EVDO-only connections on various devices (rh #553199)
  153. - longcheer: add support for more devices
  154. * Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
  155. - anydata: new plugin for AnyData CDMA modems (rh #547294)
  156. - core: fix crashes when devices are unplugged during operation (rh #553953)
  157. - cdma: prefer primary port for status/registration queries
  158. - core: fix probing/detection of some PIN-locked devices (rh #551376)
  159. - longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
  160. - gsm: fix Nokia N80 network scan parsing
  161. * Fri Jan 1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
  162. - core: fix apparent hangs by limiting retried serial writes
  163. - gsm: ensure modem state is reset when disabled
  164. * Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
  165. - sierra: fix CDMA registration detection in some cases (rh #547513)
  166. * Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
  167. - sierra: ensure CDMA device is powered up when trying to use it
  168. - cdma: better signal quality parsing (fixes ex Huawei EC168C)
  169. - zte: handle unsolicited messages better during probing
  170. * Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
  171. - cdma: fix signal strength reporting on some devices
  172. - cdma: better registration state detection when dialing (ex Sierra 5275)
  173. - option: always use the correct tty for dialing commands
  174. * Mon Dec 7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
  175. - core: fix reconnect after manual disconnect (rh #541314)
  176. - core: fix various segfaults during registration
  177. - core: fix probing of various modems on big-endian architectures (ie PPC)
  178. - core: implement modem states to avoid duplicate operations
  179. - hso: fix authentication for Icera-based devices like iCON 505
  180. - zte: use correct port for new devices
  181. - nozomi: fix detection
  182. * Thu Nov 5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
  183. - Update to latest git
  184. - core: fix pppd 2.4.5 errors about 'baudrate 0'
  185. - cdma: wait for network registration before trying to connect
  186. - gsm: add cell access technology reporting
  187. - gsm: allow longer-running network scans
  188. - mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
  189. - nokia: don't power down phones on disconnect
  190. - hso: fix disconnection/disable
  191. * Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
  192. - Fixes for Motorola and Ericsson devices
  193. - Fixes for CDMA "serving-system" command parsing
  194. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
  195. - Fix a typo in one of the udev rules files
  196. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
  197. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  198. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
  199. - Fix source repo location
  200. - Fix directory ownership
  201. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
  202. - Initial version