cups-filters-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462
  1. # we build CUPS also with relro
  2. %global _hardened_build 1
  3. %define _unpackaged_files_terminate_build 1
  4. Summary: OpenPrinting CUPS filters and backends
  5. Name: cups-filters
  6. Version: 1.8.3
  7. Release: 1%{?_dist_release}
  8. # For a breakdown of the licensing, see COPYING file
  9. # GPLv2: filters: commandto*, imagetoraster, pdftops, rasterto*,
  10. # imagetopdf, pstopdf, texttopdf
  11. # backends: parallel, serial
  12. # GPLv2+: filters: gstopxl, textonly, texttops, imagetops
  13. # GPLv3: filters: bannertopdf
  14. # GPLv3+: filters: urftopdf
  15. # LGPLv2+: utils: cups-browsed
  16. # MIT: filters: gstoraster, pdftoijs, pdftoopvp, pdftopdf, pdftoraster
  17. License: GPLv2 and GPLv2+ and GPLv3 and GPLv3+ and LGPLv2+ and MIT
  18. Group: System Environment/Base
  19. Url: http://www.linuxfoundation.org/collaborate/workgroups/openprinting/cups-filters
  20. Source0: http://www.openprinting.org/download/cups-filters/cups-filters-%{version}.tar.xz
  21. Requires: cups
  22. Requires: cups-filters-libs%{?_isa} = %{version}-%{release}
  23. # Obsolete cups-php (bug #971741)
  24. Obsoletes: cups-php < 1:1.6.0-1
  25. # Don't Provide it because we don't build the php module
  26. #Provides: cups-php = 1:1.6.0-1
  27. BuildRequires: cups-devel
  28. # pdftopdf
  29. BuildRequires: qpdf-devel
  30. # pdftops
  31. BuildRequires: poppler-utils
  32. # pdftoijs, pdftoopvp, pdftoraster, gstoraster
  33. BuildRequires: poppler-devel
  34. BuildRequires: libjpeg-devel
  35. BuildRequires: libpng-devel
  36. BuildRequires: libtiff-devel
  37. BuildRequires: zlib-devel
  38. BuildRequires: pkgconfig dbus-devel
  39. # libijs
  40. BuildRequires: ghostscript-devel
  41. BuildRequires: freetype2-devel
  42. BuildRequires: fontconfig-devel
  43. BuildRequires: lcms2-devel
  44. # cups-browsed
  45. BuildRequires: avahi-devel avahi-glib-devel
  46. # Make sure we get postscriptdriver tags.
  47. BuildRequires: python-cups
  48. # Testing font for test scripts.
  49. BuildRequires: TrueType-dejavu
  50. # autogen.sh
  51. BuildRequires: autoconf
  52. BuildRequires: automake
  53. BuildRequires: libtool
  54. Requires: poppler-utils
  55. # pstopdf
  56. Requires: bc grep sed
  57. # cups-browsed
  58. #Requires(post): systemd
  59. #Requires(preun): systemd
  60. #Requires(postun): systemd
  61. # Ghostscript CUPS filters live here since Ghostscript 9.08.
  62. Provides: ghostscript-cups = 9.08
  63. Obsoletes: ghostscript-cups < 9.08
  64. Vendor: Project Vine
  65. Distribution: Vine Linux
  66. Packager: tomop
  67. %package libs
  68. Summary: OpenPrinting CUPS filters and backends - cupsfilters and fontembed libraries
  69. Group: System Environment/Libraries
  70. # LGPLv2: libcupsfilters
  71. # MIT: libfontembed
  72. License: LGPLv2 and MIT
  73. %package devel
  74. Summary: OpenPrinting CUPS filters and backends - development environment
  75. Group: Development/Libraries
  76. License: LGPLv2 and MIT
  77. Requires: cups-filters-libs%{?_isa} = %{version}-%{release}
  78. %description
  79. Contains backends, filters, and other software that was
  80. once part of the core CUPS distribution but is no longer maintained by
  81. Apple Inc. In addition it contains additional filters developed
  82. independently of Apple, especially filters for the PDF-centric printing
  83. workflow introduced by OpenPrinting.
  84. %description libs
  85. This package provides cupsfilters and fontembed libraries.
  86. %description devel
  87. This is the development package for OpenPrinting CUPS filters and backends.
  88. %prep
  89. %setup -q
  90. %build
  91. # work-around Rpath
  92. ./autogen.sh
  93. # --with-pdftops=hybrid - use Poppler's pdftops instead of Ghostscript for
  94. # Brother, Minolta, and Konica Minolta to work around
  95. # bugs in the printer's PS interpreters
  96. # --with-rcdir=no - don't install SysV init script
  97. export IJS_CFLAGS="-I/usr/include/ijs"
  98. export IJS_LIBS="-lijs"
  99. %configure --disable-static \
  100. --disable-silent-rules \
  101. --with-pdftops=hybrid \
  102. --enable-dbus \
  103. --with-rcdir=%{_sysconfdir} \
  104. --with-test-font-path=/usr/share/fonts/TrueType-dejavu/DejaVuSans.ttf
  105. make %{?_smp_mflags}
  106. %install
  107. make install DESTDIR=%{buildroot}
  108. # https://fedoraproject.org/wiki/Packaging_tricks#With_.25doc
  109. mkdir __doc
  110. mv %{buildroot}%{_datadir}/doc/cups-filters/* __doc
  111. rm -rf %{buildroot}%{_datadir}/doc/cups-filters
  112. # Don't ship libtool la files.
  113. rm -f %{buildroot}%{_libdir}/lib*.la
  114. # Not sure what is this good for.
  115. rm -f %{buildroot}%{_bindir}/ttfread
  116. # systemd unit file
  117. #mkdir -p %{buildroot}%{_unitdir}
  118. #install -p -m 644 utils/cups-browsed.service %{buildroot}%{_unitdir}
  119. # SysV initscripts
  120. rm -rf %{buildroot}%{_sysconfdir}/rc{0,2,3,5}.d
  121. rm -rf %{buildroot}%{_sysconfdir}/rc.d
  122. mkdir -p %{buildroot}%{_sysconfdir}/rc.d
  123. mv -f %{buildroot}%{_sysconfdir}/init.d %{buildroot}%{_sysconfdir}/rc.d/
  124. for f in %{buildroot}%{_cups_serverbin}/filter/*; do
  125. if [ -f $f ]; then
  126. chmod 755 $f
  127. fi
  128. done
  129. %check
  130. make check
  131. %post
  132. #%systemd_post cups-browsed.service
  133. # Initial installation
  134. if [ $1 -eq 1 ] ; then
  135. IN=%{_sysconfdir}/cups/cupsd.conf
  136. OUT=%{_sysconfdir}/cups/cups-browsed.conf
  137. keyword=BrowsePoll
  138. # We can remove this after few releases, it's just for the introduction of cups-browsed.
  139. if [ -f "$OUT" ]; then
  140. echo -e "\n# NOTE: This file is not part of CUPS. You need to start & enable cups-browsed service." >> "$OUT"
  141. fi
  142. # move BrowsePoll from cupsd.conf to cups-browsed.conf
  143. if [ -f "$IN" ] && grep -iq ^$keyword "$IN"; then
  144. if ! grep -iq ^$keyword "$OUT"; then
  145. (cat >> "$OUT" <<EOF
  146. # Settings automatically moved from cupsd.conf by RPM package:
  147. EOF
  148. ) || :
  149. (grep -i ^$keyword "$IN" >> "$OUT") || :
  150. #systemctl enable cups-browsed.service >/dev/null 2>&1 || :
  151. fi
  152. sed -i -e "s,^$keyword,#$keyword directive moved to cups-browsed.conf\n#$keyword,i" "$IN" || :
  153. fi
  154. fi
  155. %preun
  156. #%systemd_preun cups-browsed.service
  157. %postun
  158. #%systemd_postun_with_restart cups-browsed.service
  159. %post libs
  160. /sbin/ldconfig
  161. %postun libs
  162. /sbin/ldconfig
  163. %files
  164. %doc __doc/README __doc/AUTHORS __doc/NEWS
  165. %config(noreplace) %{_sysconfdir}/cups/cups-browsed.conf
  166. %config(noreplace) %{_sysconfdir}/fonts/conf.d/99pdftoopvp.conf
  167. %{_bindir}/foomatic-rip
  168. %attr(-,root,root) %{_cups_serverbin}/filter/*
  169. %exclude %{_cups_serverbin}/filter/pdftoraster
  170. %exclude %{_cups_serverbin}/filter/textonly
  171. %attr(0755,root,root) %{_cups_serverbin}/backend/beh
  172. %attr(0755,root,root) %{_cups_serverbin}/backend/implicitclass
  173. %attr(0755,root,root) %{_cups_serverbin}/backend/parallel
  174. # Serial backend needs to run as root (bug #212577#c4).
  175. %attr(0700,root,root) %{_cups_serverbin}/backend/serial
  176. %{_datadir}/cups/banners
  177. %{_datadir}/cups/braille
  178. %{_datadir}/cups/charsets
  179. %{_datadir}/cups/data/*
  180. # this needs to be in the main package because of cupsfilters.drv
  181. %{_datadir}/cups/drv/*
  182. %{_datadir}/cups/mime/*
  183. %{_datadir}/ppd/*
  184. %{_datadir}/cups/ppdc/*
  185. %{_sbindir}/cups-browsed
  186. #%{_unitdir}/cups-browsed.service
  187. %{_initdir}/cups-browsed
  188. %{_mandir}/man1/foomatic-rip.1.gz
  189. %{_mandir}/man8/cups-browsed.8.gz
  190. %{_mandir}/man5/cups-browsed.conf.5.gz
  191. %files libs
  192. %doc __doc/COPYING fontembed/README
  193. %{_libdir}/libcupsfilters.so.*
  194. %{_libdir}/libfontembed.so.*
  195. %files devel
  196. %{_includedir}/cupsfilters
  197. %{_includedir}/fontembed
  198. %{_datadir}/cups/ppdc/escp.h
  199. %{_libdir}/pkgconfig/libcupsfilters.pc
  200. %{_libdir}/pkgconfig/libfontembed.pc
  201. %{_libdir}/libcupsfilters.so
  202. %{_libdir}/libfontembed.so
  203. %changelog
  204. * Tue May 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.3-1
  205. - new upstream release.
  206. * Mon May 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.76-3
  207. - rebuild with poppler-0.43.0
  208. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.76-2
  209. - rebuild with poppler-0.37.0
  210. * Sun Oct 4 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.76-1
  211. - new upstream release.
  212. * Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.54-2
  213. - rebuild with poppler-0.26.2
  214. * Sun Jun 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.54-1
  215. - new upstream release.
  216. * Fri May 16 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.53-1
  217. - update to 1.0.53
  218. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.43-1
  219. - new upstream release.
  220. - initial build for Vine Linux.
  221. * Tue Nov 19 2013 Tim Waugh <twaugh@redhat.com> - 1.0.41-4
  222. - Adjust filter costs so application/vnd.adobe-read-postscript input
  223. doesn't go via pstotiff (bug #1008166).
  224. * Thu Nov 14 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.41-3
  225. - Fix memory leaks in cups-browsed (bug #1027317).
  226. * Wed Nov 6 2013 Tim Waugh <twaugh@redhat.com> - 1.0.41-2
  227. - Include dbus so that colord support works (bug #1026928).
  228. * Wed Oct 30 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.41-1
  229. - 1.0.41 - PPD-less printing support
  230. * Mon Oct 21 2013 Tim Waugh <twaugh@redhat.com> - 1.0.40-4
  231. - Fix socket leaks in the BrowsePoll code (bug #1021512).
  232. * Wed Oct 16 2013 Tim Waugh <twaugh@redhat.com> - 1.0.40-3
  233. - Ship the gstoraster MIME conversion rule now we provide that filter
  234. (bug #1019261).
  235. * Fri Oct 11 2013 Tim Waugh <twaugh@redhat.com> - 1.0.40-2
  236. - Fix PDF landscape printing (bug #768811).
  237. * Fri Oct 11 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.40-1
  238. - 1.0.40
  239. - Use new "hybrid" pdftops renderer.
  240. * Thu Oct 03 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.39-1
  241. - 1.0.39
  242. - Removed obsolete patches "pdf-landscape" and "browsepoll-notifications"
  243. * Tue Oct 1 2013 Tim Waugh <twaugh@redhat.com> - 1.0.38-4
  244. - Use IPP notifications for BrowsePoll when possible (bug #975241).
  245. * Tue Oct 1 2013 Tim Waugh <twaugh@redhat.com> - 1.0.38-3
  246. - Fixes for some printf-type format mismatches (bug #1014093).
  247. * Tue Sep 17 2013 Tim Waugh <twaugh@redhat.com> - 1.0.38-2
  248. - Fix landscape printing for PDFs (bug #768811).
  249. * Wed Sep 04 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.38-1
  250. - 1.0.38
  251. * Thu Aug 29 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.37-1
  252. - 1.0.37.
  253. * Tue Aug 27 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.36-5
  254. - Added build dependency - font required for running tests
  255. * Tue Aug 27 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.36-4
  256. - Added checking phase (make check)
  257. * Wed Aug 21 2013 Tim Waugh <twaugh@redhat.com> - 1.0.36-3
  258. - Upstream patch to re-work filter costs (bug #998977). No longer need
  259. text filter costs patch as paps gets used by default now if
  260. installed.
  261. * Mon Aug 19 2013 Marek Kasik <mkasik@redhat.com> - 1.0.36-2
  262. - Rebuild (poppler-0.24.0)
  263. * Tue Aug 13 2013 Tim Waugh <twaugh@redhat.com> - 1.0.36-1
  264. - 1.0.36.
  265. * Tue Aug 13 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-7
  266. - Upstream patch to move in filters from ghostscript.
  267. * Tue Jul 30 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-6
  268. - Set cost for text filters to 200 so that the paps filter gets
  269. preference for the time being (bug #988909).
  270. * Wed Jul 24 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-5
  271. - Handle page-label when printing n-up as well.
  272. * Tue Jul 23 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-4
  273. - Added support for page-label (bug #987515).
  274. * Thu Jul 11 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.35-3
  275. - Rebuild (qpdf-5.0.0)
  276. * Mon Jul 01 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.35-2
  277. - add cups-browsed(8) and cups-browsed.conf(5)
  278. - don't reverse lookup IP address in URI (#975822)
  279. * Wed Jun 26 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.35-1
  280. - 1.0.35
  281. * Mon Jun 24 2013 Marek Kasik <mkasik@redhat.com> - 1.0.34-9
  282. - Rebuild (poppler-0.22.5)
  283. * Wed Jun 19 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-8
  284. - fix the note we add in cups-browsed.conf
  285. * Wed Jun 12 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-7
  286. - Obsolete cups-php (#971741)
  287. * Wed Jun 05 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-6
  288. - one more cups-browsed leak fixed (#959682)
  289. * Wed Jun 05 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-5
  290. - perl is actually not required by pstopdf, because the calling is in dead code
  291. * Mon Jun 03 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-4
  292. - fix resource leaks and other problems found by Coverity & Valgrind (#959682)
  293. * Wed May 15 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-3
  294. - ship ppdc/pcl.h because of cupsfilters.drv
  295. * Tue May 07 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-2
  296. - pstopdf requires bc (#960315)
  297. * Thu Apr 11 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-1
  298. - 1.0.34
  299. * Fri Apr 05 2013 Fridolin Pokorny <fpokorny@redhat.com> - 1.0.33-1
  300. - 1.0.33
  301. - removed cups-filters-1.0.32-null-info.patch, accepted by upstream
  302. * Thu Apr 04 2013 Fridolin Pokorny <fpokorny@redhat.com> - 1.0.32-2
  303. - fixed segfault when info is NULL
  304. * Thu Apr 04 2013 Fridolin Pokorny <fpokorny@redhat.com> - 1.0.32-1
  305. - 1.0.32
  306. * Fri Mar 29 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.31-3
  307. - add note to cups-browsed.conf
  308. * Thu Mar 28 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.31-2
  309. - check cupsd.conf existence prior to grepping it (#928816)
  310. * Fri Mar 22 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.31-1
  311. - 1.0.31
  312. * Tue Mar 19 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-4
  313. - revert previous change
  314. * Wed Mar 13 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-3
  315. - don't ship banners for now (#919489)
  316. * Tue Mar 12 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-2
  317. - move BrowsePoll from cupsd.conf to cups-browsed.conf in %%post
  318. * Fri Mar 08 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-1
  319. - 1.0.30: CUPS browsing and broadcasting in cups-browsed
  320. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.29-4
  321. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  322. * Sat Jan 19 2013 Rex Dieter <rdieter@fedoraproject.org> 1.0.29-3
  323. - backport upstream buildfix for poppler-0.22.x
  324. * Fri Jan 18 2013 Adam Tkac <atkac redhat com> - 1.0.29-2
  325. - rebuild due to "jpeg8-ABI" feature drop
  326. * Thu Jan 03 2013 Jiri Popelka <jpopelka@redhat.com> 1.0.29-1
  327. - 1.0.29
  328. * Wed Jan 02 2013 Jiri Popelka <jpopelka@redhat.com> 1.0.28-1
  329. - 1.0.28: cups-browsed daemon and service
  330. * Thu Nov 29 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.25-1
  331. - 1.0.25
  332. * Fri Sep 07 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.24-1
  333. - 1.0.24
  334. * Wed Aug 22 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.23-1
  335. - 1.0.23: old pdftopdf removed
  336. * Tue Aug 21 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.22-1
  337. - 1.0.22: new pdftopdf (uses qpdf instead of poppler)
  338. * Wed Aug 08 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-4
  339. - rebuild
  340. * Thu Aug 02 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-3
  341. - commented multiple licensing breakdown (#832130)
  342. - verbose build output
  343. * Thu Aug 02 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-2
  344. - BuildRequires: poppler-cpp-devel (to build against poppler-0.20)
  345. * Mon Jul 23 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-1
  346. - 1.0.20
  347. * Tue Jul 17 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.19-1
  348. - 1.0.19
  349. * Wed May 30 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.18-1
  350. - initial spec file