WebKit-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328
  1. %define add_to_doc_files() \
  2. mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
  3. cp -p %1 %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
  4. echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
  5. #define svn_revision 43436
  6. # --with coverage: Enables compile-time checking of code coverage. (default: no)
  7. %bcond_with coverage
  8. # --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
  9. #%bcond_with jit
  10. # --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
  11. %bcond_with pango
  12. # --with wml: Build support for WML
  13. %bcond_with wml
  14. Name: WebKit
  15. Version: 1.2.6
  16. Release: 1%{?_dist_release}
  17. Summary: Web content engine library
  18. Summary(ja): ウェブコンテンツエンジンライブラリ
  19. Group: Development/Libraries
  20. License: LGPLv2+ and BSD
  21. URL: http://webkitgtk.org/
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: yasumichi
  25. Source0: http://www.webkitgtk.org/webkit-%{version}.tar.gz
  26. Patch0: WebKit-1.2.5-gir.patch
  27. # upstream patch
  28. Patch100: WebKit-icu44-36381.patch
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  30. BuildRequires: bison
  31. BuildRequires: flex
  32. BuildRequires: gperf
  33. BuildRequires: gtk2-devel
  34. BuildRequires: libicu-devel
  35. BuildRequires: libjpeg-turbo-devel
  36. BuildRequires: libtool
  37. BuildRequires: libxslt-devel
  38. BuildRequires: libXt-devel
  39. BuildRequires: pcre-devel
  40. BuildRequires: sqlite3-devel
  41. BuildRequires: geoclue-devel
  42. BuildRequires: gnome-keyring-devel
  43. BuildRequires: gstreamer-devel
  44. BuildRequires: gstreamer-plugins-base-devel
  45. BuildRequires: enchant-devel
  46. BuildRequires: gobject-introspection-devel
  47. %if %{with pango}
  48. BuildRequires: pango-devel
  49. %else
  50. BuildRequires: cairo-devel
  51. BuildRequires: fontconfig-devel
  52. BuildRequires: freetype2-devel
  53. %endif
  54. BuildRequires: libsoup-devel >= 2.28.2
  55. %description
  56. WebKit is an open source web browser engine.
  57. %package gtk
  58. Summary: GTK+ port of WebKit
  59. Summary(ja): WebKit の GTK+ ポート
  60. Group: Development/Libraries
  61. %description gtk
  62. %{name} is an open-source Web content engine library. This package contains
  63. the shared libraries for the WebKit GTK+ port as well as the sample
  64. GtkLauncher tool.
  65. %package gtk-devel
  66. Summary: Development package for %{name}
  67. Summary(ja): %{name} の開発パッケージ
  68. Group: Development/Libraries
  69. Requires: %{name}-gtk = %{version}-%{release}
  70. Requires: pkgconfig
  71. Requires: gtk2-devel
  72. Requires: libsoup-devel >= 2.28.2
  73. %description gtk-devel
  74. The %{name}-gtk-devel package contains libraries, build data, and header
  75. files for developing applications that use %{name}-gtk.
  76. Please note that the WebKit/GTK+ API is not yet stable. This should
  77. only be used as a "preview" rather than a stable platform library.
  78. %package doc
  79. Summary: Documentation for %{name}
  80. Summary(ja): %{name} のドキュメント
  81. Group: Documentation
  82. %description doc
  83. %{name} is an open-source Web content engine library. This package contains
  84. the documentation for %{name}, including various LICENSE, README, and
  85. AUTHORS files.
  86. %prep
  87. %setup -q -n webkit-%{version}
  88. %patch0 -p1 -b .gir_vine
  89. # upstream
  90. ## %patch100 -p0
  91. %build
  92. %configure \
  93. --enable-icon-database \
  94. --enable-geolocation \
  95. --enable-introspection=yes \
  96. %{?with_coverage: --enable-coverage } \
  97. %{?with_pango: --with-font-backend=pango } \
  98. %{?with_wml: --enable-wml }
  99. make %{?_smp_mflags}
  100. # workaround for bug 488112
  101. # Compile libJavaScriptCore.a with -fno-strict-aliasing
  102. touch JavaScriptCore/AllInOneFile.cpp
  103. make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
  104. %install
  105. rm -rf %{buildroot}
  106. make install DESTDIR=%{buildroot}
  107. install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
  108. install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
  109. ## Finally, copy over and rename the various files for %%doc inclusion.
  110. rm -f docfiles.list
  111. %add_to_doc_files JavaScriptCore/COPYING.LIB
  112. %add_to_doc_files JavaScriptCore/icu/LICENSE
  113. %add_to_doc_files WebKit/LICENSE
  114. %add_to_doc_files WebCore/LICENSE-APPLE
  115. %add_to_doc_files WebCore/LICENSE-LGPL-2
  116. %add_to_doc_files WebCore/LICENSE-LGPL-2.1
  117. %add_to_doc_files WebCore/icu/LICENSE
  118. %add_to_doc_files JavaScriptCore/AUTHORS
  119. %add_to_doc_files JavaScriptCore/pcre/AUTHORS
  120. %add_to_doc_files JavaScriptCore/THANKS
  121. %find_lang webkit
  122. %clean
  123. rm -rf %{buildroot}
  124. %post gtk -p /sbin/ldconfig
  125. %postun gtk -p /sbin/ldconfig
  126. %files -f webkit.lang gtk
  127. %defattr(-,root,root,-)
  128. %doc
  129. %{_libdir}/libwebkit-1.0.so.*
  130. %{_libexecdir}/WebKit/
  131. %{_bindir}/jsc
  132. %{_libdir}/girepository-1.0/*.typelib
  133. %files gtk-devel
  134. %defattr(-,root,root,-)
  135. %exclude %{_libdir}/*.la
  136. %{_includedir}/webkit-1.0
  137. %{_datadir}/webkit-1.0
  138. %{_libdir}/libwebkit-1.0.so
  139. %{_libdir}/pkgconfig/webkit-1.0.pc
  140. %{_datadir}/gir-1.0/*.gir
  141. %files doc -f docfiles.list
  142. %defattr(-,root,root,-)
  143. %changelog
  144. * Sat Jan 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.6-1
  145. - new upstream release
  146. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.5-1
  147. - new upstream release
  148. - add BuildRequires: gobject-introspection-devel
  149. - add configure option (--enable-introspection=yes)
  150. - add Patch0 (WebKit-1.2.5-gir.patch)
  151. * Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.4-1
  152. - new upstream release (built with rpm-4.8.1-1 for pkg-config file)
  153. - changed BuildRequires: libjpeg-devel to libjpeg-turbo-devel
  154. * Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.3-1
  155. - new upstream release
  156. - add Requires: libsoup-devel (devel package)
  157. - fix configure (remove unrecognized option)
  158. - drop Patch100
  159. * Wed Apr 14 2010 MATSUBAYASHI Kohji <shaoliN@vinelinux.org> - 1.2.0-2
  160. - rebuilt again on ppc
  161. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
  162. - new upstream release
  163. - rebuilt with libicu-4.4
  164. - added Patch100 for compiling with libicu-4.4
  165. - s/sqlite-devel/sqlite3-devel/
  166. - s/freetype-devel/freetype2-devel/
  167. * Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
  168. - updated to 1.1.18
  169. * Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
  170. - change BR from libsoup to libsoup-devel
  171. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
  172. - new upstream release.
  173. - add Vendor, Distribution and Packager.
  174. * Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
  175. - update to webkit-1.1.10 release version
  176. - added BuildRequires: enchant-devel
  177. * Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
  178. - update to webkit-1.1.6 release version
  179. * Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
  180. - update to new upstream snapshot (svn r41944)
  181. * Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
  182. - update to new upstream snapshot (svn r40471)
  183. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
  184. - update to new upstream snapshot (svn r37056)
  185. - disable html5video by default
  186. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
  187. - update to new upstream snapshot (svn r36882)
  188. - build with gnome-2.24
  189. * Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
  190. - build without pango by default.
  191. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
  192. - update to new upstream snapshot (svn r36053)
  193. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
  194. - update to new upstream snapshot (svn r34655)
  195. * Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1.svn34279
  196. - initial build for Vine Linux
  197. * Tue Jun 3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
  198. - rebuild for new icu
  199. * Tue Jun 3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
  200. - Update to new upstream snapshot (SVN 34279) anyway
  201. - Add BR: libXt-devel
  202. * Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
  203. - Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
  204. of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
  205. subdirectories either.)
  206. - Reference: bug 442200 (RFE: WebKit Migration)
  207. - Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
  208. tree).
  209. * Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
  210. - Update to new upstream snapshot (SVN 32531).
  211. - Fix bug 443048 and hopefully fix bug 444445
  212. - Modify the process of building GTK+ port a bit
  213. - on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
  214. * Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
  215. - Update to new upstream snapshot (SVN 31787).
  216. - Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
  217. CVE-2008-1011 (bug 438531: Cross-Site Scripting).
  218. - Switch to using autotools for building the GTK+ port.
  219. * Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
  220. - Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
  221. bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
  222. - Thanks to Mamoru Tasaka for helping find and squash these many bugs.
  223. * Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
  224. - Fix include directory naming. Resolves: bug 435561 (Header file <> header
  225. file location mismatch)
  226. - Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
  227. Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
  228. * Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
  229. - Update to new upstream snapshot (SVN 30667)
  230. - Add some build fixes for GCC 4.3:
  231. + gcc43.patch
  232. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
  233. - Autorebuild for GCC 4.3
  234. * Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
  235. - Update to new upstream snapshot (SVN 29336).
  236. - Drop TCSpinLock pthread workaround (fixed upstream):
  237. - TCSpinLock-use-pthread-stubs.patch
  238. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
  239. - Add proper %%defattr line to qt, qt-devel, and doc subpackages.
  240. - Add patch to forcibly build the TCSpinLock code using the pthread
  241. implementation:
  242. + TCSpinLock-use-pthread-stubs.patch
  243. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
  244. - Package renamed from WebKitGtk.
  245. - Update to SVN 28482.
  246. - Build both the GTK and Qt ports, putting each into their own respective
  247. subpackages.
  248. - Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
  249. the build-webkit script from upstream.
  250. - Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
  251. * Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
  252. - Initial packaging for Fedora.