zsh-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456
  1. # -*- Mode: rpm-spec -*-
  2. %define name zsh
  3. %define version 5.2
  4. %define rversion %{version}
  5. %define dversion %{version}
  6. %define release 1%{?_dist_release}
  7. ## %define _sysconfdir /etc
  8. Summary: A shell with lots of features.
  9. Summary(ja): 多機能シェル
  10. Name: %{name}
  11. Version: %{version}
  12. Release: %{release}
  13. License: distributable (see LICENCE file)
  14. Group: System Environment/Shells
  15. Url: http://www.zsh.org
  16. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.xz
  17. Source1: zcfg-vine.tar.bz2
  18. # fixed that _apt fail completions rpm package name.
  19. Patch0: zsh-4.3.4-apt4rpm.patch
  20. Patch1: zsh-4.3.4-sshcomp.patch
  21. Patch2: zsh-4.2.0-completion_tar_archive.patch
  22. Patch3: zsh-5.0.7-fixpath.patch
  23. Requires(post,preun): /sbin/install-info
  24. Requires(post,postun): grep
  25. BuildRoot: %{_tmppath}/%{name}-buildroot
  26. BuildRequires: texinfo, ncurses-devel
  27. BuildRequires: findutils grep
  28. BuildRequires: man-db
  29. Vendor: Project Vine
  30. Distribution: Vine Linux
  31. Packager: iwaim
  32. Epoch: 1
  33. %description
  34. Zsh is a UNIX command interpreter (shell) usable as an
  35. interactive login shell and as a shell script command
  36. processor. Of the standard shells, zsh most closely resembles
  37. ksh but includes many enhancements. Zsh has command-line editing,
  38. built-in spelling correction, programmable command completion,
  39. shell functions (with autoloading), a history mechanism, and a
  40. lots of other features
  41. Install the zsh package if you'd like to try out a different shell.
  42. %description -l ja
  43. Zsh 対話的に使える コマンドラインインタプリタ(シェル)です。
  44. 規格上Zsh はksh ににているが多くの拡張がされている。
  45. スペルコレクション,プログラマブル補完,
  46. シェルファンクションズ(オートロード),等の多くの機能がある。
  47. %prep
  48. %setup -q -a 1 -n %{name}-%{rversion}
  49. #%patch0 -p1
  50. #%patch1 -p1
  51. #%patch2 -p1
  52. %patch3 -p1
  53. # remove temporary files
  54. find|grep '~$'|xargs rm -f
  55. %build
  56. %ifnarch sparc
  57. %configure \
  58. --enable-etcdir=%{_sysconfdir} \
  59. --enable-fndir=%{_datadir}/zsh/functions \
  60. --enable-site-fndir=%{_datadir}/zsh/site-functions \
  61. --enable-function-subdirs \
  62. --enable-scriptdir=%{_datadir}/zsh/scripts \
  63. --enable-site-scriptdir=%{_datadir}/zsh/site-scripts \
  64. --with-tcsetpgrp
  65. %else
  66. %configure \
  67. --enable-etcdir=%{_sysconfdir} \
  68. --enable-fndir=%{_datadir}/zsh/functions \
  69. --enable-site-fndir=%{_datadir}/zsh/site-functions \
  70. --enable-function-subdirs \
  71. --enable-scriptdir=%{_datadir}/zsh/scripts \
  72. --enable-site-scriptdir=%{_datadir}/zsh/site-scripts
  73. --disable-lfs
  74. %endif
  75. make
  76. %install
  77. rm -rf $RPM_BUILD_ROOT
  78. %makeinstall fndir=%{buildroot}%{_datadir}/zsh/functions sitefndir=%{buildroot}%{_datadir}/zsh/site-functions scriptdir=%{buildroot}%{_datadir}/zsh/scripts sitescriptdir=%{buildroot}%{_datadir}/zsh/site-scripts \
  79. runhelpdir=%{buildroot}%{_datadir}/zsh/${VERSION}/help
  80. make install.info DESTDIR=$RPM_BUILD_ROOT
  81. mkdir -p %{buildroot}%{_sysbindir}
  82. pushd %{buildroot}%{_sysbindir} && {
  83. ln -s ..%{_bindir}/zsh ./zsh
  84. } && popd
  85. # copy Mandrake Configuration files.
  86. mkdir -p %{buildroot}%{_sysconfdir}
  87. cp -a zcfg/* %{buildroot}%{_sysconfdir}
  88. # Copy documentation.
  89. #rm -rf docroot
  90. mkdir -p docroot/{Info_html,Examples,Documentation}/
  91. cp -a README docroot/
  92. cp -a Functions/Misc/* Misc/* Util/* docroot/Examples/
  93. cp -a INSTALL ChangeLog* docroot/Documentation
  94. cp -a StartupFiles docroot/
  95. cp -a Etc/* docroot/Documentation
  96. cp -a NEWS docroot/
  97. #cp -a Doc/*html docroot/Info_html/
  98. find docroot/ -type f|xargs perl -p -i -e 's|^#!%{prefix}/local/bin/zsh|#!%{_bi
  99. ndir}/zsh|'
  100. find docroot/ -type f|xargs perl -p -i -e 's|^#!%{prefix}/local/bin/perl|#!%{_b
  101. indir}/perl|'
  102. rm -f docroot/StartupFiles/.distfiles
  103. rm -f docroot/Examples/{Makefile*,*.yo}
  104. rm -f docroot/Documentation/{Makefile*,*.yo}
  105. mv docroot/Examples/compctl-examples docroot/StartupFiles
  106. find docroot/ -name 'Makefile*' -o -name '.yo'|xargs rm -f
  107. %clean
  108. rm -rf %{buildroot}
  109. %post
  110. if [ ! -f %{_sysconfdir}/shells ]; then
  111. echo "/bin/zsh" > %{_sysconfdir}/shells
  112. else
  113. grep '^/bin/zsh' %{_sysconfdir}/shells > /dev/null || echo "/bin/zsh" >> /etc/shells
  114. fi
  115. /sbin/install-info %{_infodir}/zsh.info.gz %{_infodir}/dir
  116. %preun
  117. if [ "$1" = 0 ]; then
  118. /sbin/install-info --delete %{_infodir}/zsh.info.gz %{_infodir}/dir
  119. fi
  120. %postun
  121. if [ ! -x /bin/zsh ]; then
  122. grep -v '^/bin/zsh$' %{_sysconfdir}/shells | grep -v '^/bin/zsh$'> /etc/shells.rpm
  123. mv %{_sysconfdir}/shells.rpm /etc/shells
  124. fi
  125. %files
  126. %defattr(-,root,root,0755)
  127. %doc LICENCE
  128. %doc docroot/README docroot/NEWS
  129. %doc docroot/Documentation/ docroot/Examples/ docroot/Info_html/ docroot/StartupFiles/
  130. %config %{_sysconfdir}/z*
  131. %{_sysbindir}/zsh
  132. %{_bindir}/zsh*
  133. %{_libdir}/zsh
  134. %{_infodir}/*.info*
  135. %exclude %{_infodir}/dir*
  136. %{_mandir}/man*/*
  137. %{_datadir}/zsh
  138. %changelog
  139. * Thu Dec 31 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 5.2-1
  140. - update to 5.2
  141. - fix buit date for 5.0.7-1 in changelog
  142. * Thu Jan 1 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 5.0.7-1
  143. - update to 5.0.7
  144. - add BuildRequires: man-db
  145. - update fixpath patch (Patch3)
  146. - add install path 'runhelpdir'
  147. - add help files
  148. - drop too old Zsh Guide (Source3)
  149. * Tue Dec 31 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 5.0.2-2
  150. - rebuild with current VineSeed
  151. * Tue Dec 25 2012 IWAI, Masaharu <iwai@alib.jp> 5.0.2-1
  152. - new upstream release
  153. * Thu Nov 29 2012 IWAI, Masaharu <iwai@alib.jp> 5.0.0-1
  154. - new upstream release
  155. * Sat Aug 6 2011 IWAI, Masaharu <iwai@alib.jp> 4.3.12-1
  156. - new upstream release
  157. * Tue Dec 21 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.11-1
  158. - new upstream release
  159. * Sun Aug 15 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.10-2
  160. - rebuild with new toolchain
  161. * Tue Feb 23 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.10-1
  162. - new upstream release
  163. - update fixpath patch (Patch3)
  164. - drop unnecessary patch: fix subversion completion patch (Patch4)
  165. - fix '--with-tcsetpgrp' option: apply besides SPARC arch
  166. - add LICENCE file in %%doc directory: fixed typo
  167. - exclude %%{_infodir}/dir* in %%files section
  168. - drop Prefix tag
  169. - replace Prereq to Requires(*)
  170. - BuildRequires: findutils grep
  171. * Wed Jan 27 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.3.4-4
  172. - fix files error (LICENSE is no longer exist)
  173. * Wed Jan 27 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.3.4-3
  174. - add --with-tcsetpgrp into configure section
  175. - add BR: texinfo, ncurses-devel
  176. * Thu Jan 7 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.4-2
  177. - add fix subversion completion patch (Patch4): <BTS:VineLinux:869>
  178. - see http://svn.haxx.se/users/archive-2008-06/0095.shtml
  179. - add Packager tag
  180. - add LICENSE file in %%doc directory
  181. - fix License tag's value
  182. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 4.3.4-1vl5
  183. - applied new versioning policy, spec in utf-8
  184. * Wed Oct 31 2007 IWAI, Masaharu <iwai@alib.jp> 4.3.4-0vl1
  185. - new upstream release
  186. - update apt4rpm patch ( Patch0 )
  187. - update sshcomp patch ( Patch1 )
  188. - add fixpath patch ( Patch3 )
  189. - update %%build and %%install section
  190. * Tue Apr 12 2005 IWAI, Masaharu <iwai@alib.jp> 4.2.5-0vl1
  191. - new upstream release
  192. * Tue Mar 8 2005 IWAI, Masaharu <iwai@alib.jp> 4.2.4-0vl1
  193. - new upstream release
  194. * Sat Aug 14 2004 IWAI, Masaharu <iwai@alib.jp> 4.2.1-0vl1
  195. - new upstream release
  196. - update apt4rpm patch ( Patch0 )
  197. - drop unnecessary patch for fixed upstream: job_table_full patch ( Patch3 )
  198. - update 'Copy documentation' script: moved NEWS document in upstream archive
  199. * Sat Jul 7 2004 HAYASHI Kentarou <linjian@gigo-ice.org> 4.2.0-0vl2
  200. - add job_table_full.patch (Patch3)
  201. see Zsh Mailing List 2004/msg00488.html
  202. * Mon Mar 29 2004 IWAI, Masaharu <iwai@alib.jp> 4.2.0-0vl1
  203. - new upstream release
  204. - update completion tar archive patch (Patch2)
  205. - update file list: include directories in %%{_libdir} and %%{_datadir}
  206. * Sun Dec 28 2003 IWAI, Masaharu <iwai@alib.jp> 4.0.9-0vl1
  207. - upstream update
  208. - update apt4rpm.patch (Patch0)
  209. * Fri Jun 20 2003 IWAI Masaharu <iwai@alib.jp> 4.0.7-0vl1
  210. - upstream update
  211. - update apt4rpm.patch(Patch0)
  212. * Sat May 3 2003 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl3
  213. - add completion_tar_archive.patch (Patch2)
  214. for tar's "z" option to accept bz2 tarball with zsh completion.
  215. * Mon Dec 2 2002 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl2
  216. - add apt-cache showsrc option in apt4rpm patch (Patch0)
  217. * Thu Aug 15 2002 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl1
  218. - upstream update
  219. * Sun Aug 11 2002 IWAI Masaharu <iwai@alib.jp> 4.0.5-0vl1
  220. - upstream update
  221. - apt-cache showsrc option changed unavailable in apt4rpm patch (Patch0)
  222. * Tue Dec 4 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.4-0vl1
  223. - loading vine specific profile scripts moved from zshrc to zprofile
  224. - fixed other bug($PATH,zmodload)
  225. * Mon Aug 27 2001 Shoji Matsumoto <shom@vinelinux.org> 4.0.2-0vl3
  226. - rebuilding current Seed
  227. - change ssh completion (Patch1)
  228. * Thu Aug 16 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.2-0vl2
  229. - fixed bug rpm package name completions in _apt
  230. * Thu Jul 19 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.2-0vl1
  231. - 4.0.2
  232. * Sun Jun 3 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl1
  233. - upstream 4.0.1 release
  234. - fixed bug zshrc( add /usr/X11R6/bin $PATH)
  235. - fixed lack 'Epoch:'
  236. * Thu Apr 26 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.4.pre.3
  237. - fixed version number invalid
  238. * Fri Apr 20 2001 <sagami@vinelinux.org>
  239. - 4.0.1-0vl0.3.pre.4
  240. - install infopage/manpage and added PreReq = /sbin/install-info
  241. - fixed/added scripts in post/postun/preun for install-info
  242. * Fri Apr 13 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.3.pre.3
  243. - upstream update
  244. - fixed /etc/zshrc bugs
  245. * Tue Apr 3 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.0.pre.2
  246. - upstream update
  247. - remove all patches
  248. * Tue Oct 3 2000 Kazuhisa TAKEI<takei@vinelinux.org> 3.1.9-4vl1
  249. - can read /etc/profile.d/*.sh
  250. * Wed Sep 13 2000 Kazuhisa TAKEI<takei@vinelinux.org>
  251. - 3.1.9-4vl0
  252. - convert from Mandrake Linux to Vine Linux
  253. - add Japanise Summary and description
  254. * Sat Aug 26 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-4mdk
  255. - Set some %config file to (noreplace).
  256. - Make -A to complete spec file for _rpm.
  257. * Thu Jul 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-3mdk
  258. - Get /usr/share/man also in the completion for perl manpages.
  259. - BM.
  260. * Wed Jul 5 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-2mdk
  261. - Fix buildroot hardcoded in binary.
  262. * Wed Jun 21 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-1mdk
  263. - Use makeinstall macros (not easy this one :\).
  264. - 3.1.9.
  265. * Mon Jun 5 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.8-1mdk
  266. - 3.1.8.
  267. * Sun May 28 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-3mdk
  268. - Fix path (%{prefix}/ucb -> %{_bindir}/X11)
  269. - Fix keys (home-end-suppr-delete) directly in the zsh binary.
  270. * Sun Apr 16 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-2mdk
  271. - Remove doble .so in %{_libdir}/zsh/*.
  272. * Thu Apr 13 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-1mdk
  273. - 3.1.6dev22.
  274. * Fri Mar 31 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-3mdk
  275. - Fix completion of rpm with -qp*.
  276. * Mon Mar 27 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-2mdk
  277. - Upgrade zshguide.
  278. * Sat Mar 25 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-1mdk
  279. - 3.1.6-dev20
  280. * Wed Mar 22 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-3mdk
  281. - Move global configuration here.
  282. - Adjust groups.
  283. * Tue Feb 22 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-2mdk
  284. - Add new zshguide from pws.
  285. - Separate the doc to the doc package
  286. * Sun Feb 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-1mdk
  287. - Clean Up spec (thanks specs-helper).
  288. - Remove all our patchs (now all is commited to upstream main).
  289. - 3.1.6dev19.
  290. * Fri Feb 18 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-3mdk
  291. - Recompile with glibc2.1.3 (first one).
  292. * Thu Feb 17 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-2mdk
  293. - Add --freshen completion.
  294. * Tue Feb 15 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-1mdk
  295. - Fix descriptions and summary.
  296. - 3.1.6dev18.
  297. * Thu Feb 10 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev17-2mdk
  298. - Remove Makefile in %doc.
  299. - BuildRequires: autoconf tetex.
  300. - Lot of modications in the default config as suggested by Bart
  301. Schaefer <schaefer@zsh.org>.
  302. - 3.1.6dev17.
  303. * Mon Jan 24 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev16-1mdk
  304. - dev16.
  305. - Redo the tar_archive patchs.
  306. * Tue Jan 18 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev15-1mdk
  307. - dev15.
  308. - Fix doc generation with dev15.
  309. - remove META-FAQ.
  310. - disable lfs on sparc.
  311. * Thu Jan 6 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev14-1mdk
  312. - dev14 (note the name change).
  313. * Mon Jan 3 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6pws13-3mdk
  314. - Remove temporary files.
  315. * Fri Dec 31 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  316. - 3.1.6pws13 (mainly bug fixes).
  317. - fix %post.
  318. - fix rpm completion
  319. * Thu Dec 09 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  320. - 3.1.6pws11 (mainly bug fixes).
  321. * Tue Dec 7 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  322. - Add run-help and perl-build the documentation.
  323. * Tue Nov 30 1999 Francis Galiegue <francis@mandrakesoft.com>
  324. - Completion machine patch - we use GNU make and GNU tar
  325. - Small fix to %post script
  326. * Tue Nov 30 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  327. - 3.1.6pws10
  328. - Fix zprofile.
  329. - Clean-up Franciseries.
  330. - Clean-up specs.
  331. * Mon Nov 29 1999 Francis Galiegue <francis@mandrakesoft.com>
  332. - Grrr... Rebuilt on kenobi, toy ain't a cooker
  333. * Mon Nov 29 1999 Francis Galiegue <francis@mandrakesoft.com>
  334. - Completion system now handles bzip2'ed manpages and tarballs
  335. - Some cool options
  336. * Wed Nov 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  337. - Add zshguide.txt to documentation.
  338. * Thu Oct 07 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  339. - Fix bug in %{_sysconfdir}/zsh use USERNAME instead of USER.
  340. - Improve %{_sysconfdir}/z* to source the /etc/profile.d/ files.
  341. * Mon Oct 04 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  342. - 3.1.6-pws6
  343. - Fix bad link.
  344. - Fix bad manpages.
  345. * Tue Aug 17 1999 Thierry Vignaud <tvignaud@mandrakesoft.com>
  346. - fix typo in examples directory name
  347. * Sun Aug 8 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  348. - Copy documentation (yes a lot).
  349. - Remove the completion machine and put them in [[ {etc,root}(skel|files) ]] package.
  350. * Sat Aug 7 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
  351. - By defaut we launch the completion machine.
  352. - Put zsh in %{_bindir}/
  353. - Rewrite of Spec file for this new major version.
  354. # end of file