utf8proc-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155
  1. Summary: Library for processing UTF-8 encoded Unicode strings
  2. Name: utf8proc
  3. Version: 2.4.0
  4. Release: 2%{?_dist_release}
  5. License: Unicode and MIT
  6. URL: http://julialang.org/utf8proc/
  7. Source: https://github.com/JuliaLang/utf8proc/archive/v%{version}.tar.gz#/%{name}-v%{version}.tar.gz
  8. BuildRequires: gcc
  9. BuildRequires: perl
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. %description
  13. utf8proc is a library for processing UTF-8 encoded Unicode strings.
  14. Some features are Unicode normalization, stripping of default ignorable
  15. characters, case folding and detection of grapheme cluster boundaries.
  16. A special character mapping is available, which converts for example
  17. the characters “Hyphen” (U+2010), “Minus” (U+2212) and “Hyphen-Minus
  18. (U+002D, ASCII Minus) all into the ASCII minus sign, to make them
  19. equal for comparisons.
  20. This package only contains the C library.
  21. %package devel
  22. Summary: Header files, libraries and development documentation for %{name}
  23. Requires: %{name}%{?_isa} = %{version}-%{release}
  24. %description devel
  25. Contains header files for developing applications that use the %{name}
  26. library.
  27. The documentation for the C library is found in the utf8proc.h header file.
  28. "utf8proc_map" is most likely the function you will be using for mapping UTF-8
  29. strings, unless you want to allocate memory yourself.
  30. %prep
  31. %setup -qn %{name}-%{version}
  32. # Disable slow tests and tests which require network access
  33. sed -i '/-C bench/d;/\ttest.* data/d' Makefile
  34. touch data/NormalizationTest.txt data/GraphemeBreakTest.txt
  35. %build
  36. export CFLAGS="%{optflags}"
  37. make %{?_smp_mflags}
  38. %check
  39. make %{?_smp_mflags} check
  40. %install
  41. make install DESTDIR=%{buildroot} prefix=%{_prefix} includedir=%{_includedir} libdir=%{_libdir}
  42. rm %{buildroot}%{_libdir}/libutf8proc.a
  43. %post -p /sbin/ldconfig
  44. %postun -p /sbin/ldconfig
  45. %files
  46. %license LICENSE.md
  47. %doc NEWS.md README.md
  48. %{_libdir}/libutf8proc.so.*
  49. %files devel
  50. %{_includedir}/utf8proc.h
  51. %{_libdir}/libutf8proc.so
  52. %{_libdir}/pkgconfig/libutf8proc.pc
  53. %changelog
  54. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.4.0-2
  55. - initial build for Vine Linux.
  56. * Thu May 16 2019 Milan Bouchet-Valat <nalimilan@club.fr> - 2.4.0-1
  57. - New upstream release.
  58. * Sun Apr 21 2019 Milan Bouchet-Valat <nalimilan@club.fr> - 2.3.0-1
  59. - New upstream release.
  60. * Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.1-5
  61. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  62. * Mon Jul 23 2018 Joe Orton <jorton@redhat.com> - 2.1.1-4
  63. - update License tag to Unicode and MIT
  64. - BR gcc (#1606627)
  65. - run minimal tests
  66. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.1-3
  67. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  68. * Mon Apr 30 2018 Milan Bouchet-Valat <nalimilan@club.fr> - 2.1.1-2
  69. - Fix missing build flags (RHBZ #1573115).
  70. * Fri Apr 27 2018 Milan Bouchet-Valat <nalimilan@club.fr> - 2.1.1-1
  71. - New upstream release.
  72. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-5
  73. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  74. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-4
  75. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  76. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-3
  77. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  78. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-2
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  80. * Sat Jan 7 2017 Milan Bouchet-Valat <nalimilan@club.fr> - 2.1.0
  81. - New upstream release.
  82. * Thu Sep 15 2016 Milan Bouchet-Valat <nalimilan@club.fr> - 2.0.2-1
  83. - New upstream release.
  84. * Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-2
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  86. * Tue Nov 03 2015 Milan Bouchet-Valat <nalimilan@club.fr> - 1.3.1-1
  87. - New upstream release.
  88. * Tue Aug 11 2015 Milan Bouchet-Valat <nalimilan@club.fr> - 1.3-1
  89. - New upstream release.
  90. * Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-2
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  92. * Sat Mar 28 2015 Milan Bouchet-Valat <nalimilan@club.fr> - 1.2-1
  93. - New upstream release.
  94. * Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.6-5
  95. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  96. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.6-4
  97. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  98. * Sun May 4 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 1.1.6-3
  99. - Add downstream SONAME version 0.1 since upstream does not set one.
  100. * Fri Feb 14 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 1.1.6-2
  101. - Fix package Group.
  102. - Do not remove build root on install phase.
  103. * Sun Jan 26 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 1.1.6-1
  104. - Adapt package to Fedora.
  105. - Updated to release 1.1.6.
  106. * Sat Aug 29 2009 Dries Verachtert <dries@ulyssis.org> - 1.1.4-1 - 7981/dag
  107. - Updated to release 1.1.4.
  108. * Sun Jul 29 2007 Dries Verachtert <dries@ulyssis.org> - 1.1.2-1
  109. - Updated to release 1.1.2.
  110. * Mon Jul 23 2007 Dries Verachtert <dries@ulyssis.org> - 1.1.1-1
  111. - Updated to release 1.1.1.
  112. * Tue Apr 17 2007 Dries Verachtert <dries@ulyssis.org> - 1.0.3-1
  113. - Initial package.