unbound-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716
  1. %bcond_with systemd
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %global with_munin 0
  4. %{?!enable_gost: %global enable_gost 1}
  5. # not ready yet
  6. %{?!with_python: %global with_python 0}
  7. %define _sharedstatedir /var/lib
  8. Summary: Validating, recursive, and caching DNS(SEC) resolver
  9. Name: unbound
  10. Version: 1.13.1
  11. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  12. Group: servers
  13. Distribution: Vine Linux
  14. Vendor: Project Vine
  15. Packager: iwaim, daisuke
  16. License: BSD
  17. Url: http://www.unbound.net/
  18. Source: https://nlnetlabs.nl/downloads/unbound/%{name}-%{version}.tar.gz
  19. Source1: unbound.init
  20. Source3: unbound.munin
  21. Source4: dlv.isc.org.key
  22. Source5: root.key
  23. Source6: root.anchor
  24. Source7: icannbundle.pem
  25. Source8: unbound.cron
  26. Source9: example.com.key
  27. Source10: example.com.conf
  28. Source11: block-example.com.conf
  29. Source100: unbound.service
  30. Source101: unbound-keygen.service
  31. Source102: unbound-anchor.service
  32. Source103: unbound-anchor.timer
  33. Source104: tmpfiles-unbound.conf
  34. Source105: unbound.sysconfig
  35. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  36. BuildRequires: flex
  37. BuildRequires: libevent-devel
  38. BuildRequires: expat-devel
  39. %if %{with_python}
  40. BuildRequires: python3-devel python3-rpm-macros swig
  41. %endif
  42. %if %{enable_gost}
  43. BuildRequires: openssl-devel >= 1.0.0
  44. %else
  45. BuildRequires: openssl-devel
  46. %endif
  47. BuildRequires: libnghttp2-devel
  48. # Required for SVN versions
  49. #BuildRequires: bison
  50. %if %{with systemd}
  51. %global piddir /run/%{name}
  52. BuildRequires: systemd
  53. %{?systemd_requires}
  54. %else
  55. %global piddir %{_localstatedir}/run/%{name}
  56. Requires(post): chkconfig
  57. Requires(preun): chkconfig
  58. Requires(preun): initscripts
  59. Requires(postun): initscripts
  60. %endif
  61. Requires(pre): shadow-utils
  62. %description
  63. Unbound is a validating, recursive, and caching DNS(SEC) resolver.
  64. The C implementation of Unbound is developed and maintained by NLnet
  65. Labs. It is based on ideas and algorithms taken from a java prototype
  66. developed by Verisign labs, Nominet, Kirei and ep.net.
  67. Unbound is designed as a set of modular components, so that also
  68. DNSSEC (secure DNS) validation and stub-resolvers (that do not run
  69. as a server, but are linked into an application) are easily possible.
  70. %if %{with_munin}
  71. %package munin
  72. Summary: Plugin for the munin / munin-node monitoring package
  73. Summary(ja): munin/munin-node モニタリングパッケージ用のプラグイン
  74. Group: servers
  75. Requires: munin-node
  76. Requires: %{name} = %{version}-%{release}, bc
  77. %description munin
  78. Plugin for the munin / munin-node monitoring package
  79. %endif
  80. %package devel
  81. Summary: Development package that includes the unbound header files
  82. Group: programming
  83. Requires: %{name}-libs = %{version}-%{release}, openssl-devel
  84. %description devel
  85. The devel package contains the unbound library and the include files
  86. %package libs
  87. Summary: Libraries used by the unbound server and client applications
  88. Group: system
  89. Requires(post): /sbin/ldconfig
  90. Requires(postun): /sbin/ldconfig
  91. Requires: openssl >= 0.9.8g-12
  92. %description libs
  93. Contains libraries used by the unbound server and client applications
  94. %if %{with_python}
  95. %package python
  96. Summary: Python modules and extensions for unbound
  97. Group: programming
  98. Requires: %{name}-libs = %{version}-%{release}
  99. %description python
  100. Python modules and extensions for unbound
  101. %endif
  102. %package -n compat32-%{name}-libs
  103. Summary: Libraries used by the unbound server and client applications
  104. Group: system
  105. Requires: %{name}-libs = %{version}-%{release}
  106. Requires(post): /sbin/ldconfig
  107. Requires(postun): /sbin/ldconfig
  108. Requires: openssl >= 0.9.8g-12
  109. %description -n compat32-%{name}-libs
  110. Contains libraries used by the unbound server and client applications
  111. %debug_package
  112. %prep
  113. %setup -q
  114. %build
  115. %configure --with-libevent --with-pthreads --with-ssl \
  116. --disable-rpath --enable-debug --disable-static \
  117. --enable-relro-now --enable-pie \
  118. --enable-subnet --enable-ipsecmod \
  119. --with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
  120. --with-pidfile=%{piddir}/%{name}.pid \
  121. %if %{with_python}
  122. --with-pythonmodule --with-pyunbound \
  123. %endif
  124. %if !%{enable_gost}
  125. --disable-gost \
  126. %endif
  127. --enable-sha2 \
  128. --disable-sha1 \
  129. --with-libnghttp2 \
  130. --with-rootkey-file=%{_sharedstatedir}/unbound/root.key
  131. %{__make} %{?_smp_mflags}
  132. %install
  133. rm -rf %{buildroot}
  134. %{__make} DESTDIR=%{buildroot} install
  135. install -d 0755 %{buildroot}%{_initrddir}
  136. %if %{with systemd}
  137. install -d -m 0755 %{buildroot}%{_unitdir} %{buildroot}%{_sysconfdir}/sysconfig
  138. install -p -m 0644 %{SOURCE100} %{buildroot}%{_unitdir}/unbound.service
  139. install -p -m 0644 %{SOURCE101} %{buildroot}%{_unitdir}/unbound-keygen.service
  140. install -p -m 0644 %{SOURCE103} %{buildroot}%{_unitdir}/unbound-anchor.timer
  141. install -p -m 0644 %{SOURCE102} %{buildroot}%{_unitdir}/unbound-anchor.service
  142. install -p -m 0644 %{SOURCE105} %{buildroot}%{_sysconfdir}/sysconfig/unbound
  143. # Install tmpfiles.d config
  144. install -d -m 0755 %{buildroot}%{_tmpfilesdir} %{buildroot}%{_sharedstatedir}/unbound
  145. install -m 0644 %{SOURCE104} %{buildroot}%{_tmpfilesdir}/unbound.conf
  146. %else
  147. install -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/unbound
  148. install -d 0755 %{buildroot}%{_sysconfdir}/cron.d
  149. install -p -m 0644 %{SOURCE8} %{buildroot}%{_sysconfdir}/cron.d/unbound-anchor
  150. %endif
  151. install -m 0644 %{SOURCE7} %{buildroot}%{_sysconfdir}/unbound
  152. echo "include: %{_sysconfdir}/unbound/conf.d/*.conf" >> %{buildroot}%{_sysconfdir}/unbound/unbound.conf
  153. %if %{with_munin}
  154. # Install munin plugin and its softlinks
  155. install -d 0755 %{buildroot}%{_sysconfdir}/munin/plugin-conf.d
  156. install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/munin/plugin-conf.d/unbound
  157. install -d 0755 %{buildroot}%{_datadir}/munin/plugins/
  158. install -m 0755 contrib/unbound_munin_ %{buildroot}%{_datadir}/munin/plugins/unbound
  159. for plugin in unbound_munin_hits unbound_munin_queue \
  160. unbound_munin_memory unbound_munin_by_type \
  161. unbound_munin_by_class unbound_munin_by_opcode \
  162. unbound_munin_by_rcode unbound_munin_by_flags \
  163. unbound_munin_histogram; do
  164. ln -s unbound %{buildroot}%{_datadir}/munin/plugins/$plugin
  165. done
  166. %endif
  167. # install root and DLV key
  168. install -m 0644 %{SOURCE4} %{SOURCE5} %{buildroot}%{_sysconfdir}/unbound/
  169. install -d -m 0755 %{buildroot}%{_sharedstatedir}/unbound
  170. install -m 0644 %{SOURCE6} %{buildroot}%{_sharedstatedir}/unbound/root.key
  171. # remove static library from install (fedora packaging guidelines)
  172. rm -rf %{buildroot}%{_libdir}/*.la
  173. %if %{with_python}
  174. rm -rf %{buildroot}%{python_sitelib}/*/*.la
  175. %endif
  176. mkdir -p %{buildroot}%{_localstatedir}/run/unbound
  177. # Install directories for easier config file drop in
  178. install -d -m 0755 %{buildroot}%{_sysconfdir}/unbound/{keys.d,local.d,conf.d}
  179. install -p %{SOURCE9} %{buildroot}%{_sysconfdir}/unbound/keys.d/
  180. install -p %{SOURCE10} %{buildroot}%{_sysconfdir}/unbound/conf.d/
  181. install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/unbound/local.d/
  182. %clean
  183. rm -rf ${RPM_BUILD_ROOT}
  184. %files
  185. %defattr(-,root,root,-)
  186. %license doc/LICENSE
  187. %doc doc/README doc/CREDITS doc/FEATURES
  188. %if %{with systemd}
  189. %attr(0644,root,root) %{_tmpfilesdir}/unbound.conf
  190. %{_unitdir}/%{name}.service
  191. %{_unitdir}/%{name}-keygen.service
  192. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  193. %else
  194. %attr(0755,root,root) %{_initrddir}/%{name}
  195. %endif
  196. %attr(0755,root,root) %dir %{_sysconfdir}/%{name}
  197. %attr(0755,unbound,unbound) %dir %{_localstatedir}/run/%{name}
  198. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/unbound.conf
  199. %dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/keys.d
  200. %attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/keys.d/*.key
  201. %dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/conf.d
  202. %attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/conf.d/*.conf
  203. %dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/local.d
  204. %attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/local.d/*.conf
  205. %{_sbindir}/*
  206. %exclude %{_sbindir}/unbound-anchor
  207. %{_mandir}/*/*
  208. %if %{with_python}
  209. %files python
  210. %{python3_sitelib}/*
  211. %endif
  212. %if %{with_munin}
  213. %files munin
  214. %defattr(-,root,root,-)
  215. %config(noreplace) %{_sysconfdir}/munin/plugin-conf.d/unbound
  216. %{_datadir}/munin/plugins/unbound*
  217. %endif
  218. %files devel
  219. %defattr(-,root,root,-)
  220. %{_libdir}/libunbound.so
  221. %{_includedir}/unbound.h
  222. %{_libdir}/pkgconfig/libunbound.pc
  223. %doc README
  224. %files libs
  225. %defattr(-,root,root,-)
  226. %license doc/LICENSE
  227. %doc doc/README
  228. %{_sbindir}/unbound-anchor
  229. %{_libdir}/libunbound.so.*
  230. %{_sysconfdir}/%{name}/icannbundle.pem
  231. %dir %attr(0755,unbound,unbound) %{_sharedstatedir}/%{name}
  232. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/dlv.isc.org.key
  233. %attr(0644,unbound,unbound) %config(noreplace) %{_sharedstatedir}/%{name}/root.key
  234. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/root.key
  235. %if %{with systemd}
  236. %{_unitdir}/unbound-anchor.timer
  237. %{_unitdir}/unbound-anchor.service
  238. %else
  239. %attr(0644,root,root) %{_sysconfdir}/cron.d/unbound-anchor
  240. %endif
  241. %if %{build_compat32}
  242. %files -n compat32-%{name}-libs
  243. %defattr(-,root,root,-)
  244. %{_libdir}/libunbound.so.*
  245. %endif
  246. %pre libs
  247. getent group unbound >/dev/null || groupadd -r unbound
  248. getent passwd unbound >/dev/null || \
  249. useradd -r -g unbound -d %{_sysconfdir}/unbound -s /sbin/nologin \
  250. -c "Unbound DNS resolver" unbound
  251. exit 0
  252. %post libs
  253. /sbin/ldconfig
  254. /sbin/runuser --command="%{_sbindir}/unbound-anchor -a %{_sharedstatedir}/unbound/root.key -c %{_sysconfdir}/unbound/icannbundle.pem" --shell /bin/sh unbound ||:
  255. %if %{with systemd}
  256. %systemd_post unbound-anchor.timer
  257. # start the timer only if installing the package to prevent starting it, if it was stopped on purpose
  258. if [ "$1" -eq 1 ]; then
  259. # the Unit is in presets, but would be started after reboot
  260. /bin/systemctl start unbound-anchor.timer >/dev/null 2>&1 || :
  261. fi
  262. %endif
  263. %if %{with systemd}
  264. %preun libs
  265. %systemd_preun unbound-anchor.timer
  266. %endif
  267. %postun libs
  268. /sbin/ldconfig
  269. %if %{with systemd}
  270. %systemd_postun_with_restart unbound-anchor.timer
  271. %endif
  272. %post
  273. %if %{with systemd}
  274. %systemd_post unbound.service
  275. %systemd_post unbound-keygen.service
  276. %else
  277. /sbin/chkconfig --add %{name}
  278. %endif
  279. # dnssec-conf used to contain our DLV key, but now we include it via unbound
  280. # If unbound had previously been configured with dnssec-configure, we need
  281. # to migrate the location of the DLV key file (to keep DLV enabled, and because
  282. # unbound won't start with a bad location for a DLV key file.
  283. sed -i "s:/etc/pki/dnssec-keys[/]*dlv:/etc/unbound:" %{_sysconfdir}/unbound/unbound.conf
  284. %preun
  285. %if %{with systemd}
  286. %systemd_preun unbound.service
  287. %systemd_preun unbound-keygen.service
  288. %else
  289. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  290. /sbin/service %{name} stop >/dev/null 2>&1
  291. /sbin/chkconfig --del %{name}
  292. fi
  293. %endif
  294. %postun
  295. %if %{with systemd}
  296. %systemd_postun_with_restart unbound.service
  297. %systemd_postun unbound-keygen.service
  298. %else
  299. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  300. /sbin/service %{name} condrestart >/dev/null 2>&1 || :
  301. fi
  302. %endif
  303. %post -n compat32-%{name}-libs
  304. /sbin/ldconfig
  305. %postun -n compat32-%{name}-libs
  306. /sbin/ldconfig
  307. %changelog
  308. * Wed Feb 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.1-1
  309. - updated to 1.13.1.
  310. * Thu Dec 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.0-1
  311. - updated to 1.13.0.
  312. * Thu Oct 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
  313. - updated to 1.12.0.
  314. * Mon Jul 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.0-1
  315. - updated to 1.11.1.
  316. * Tue May 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
  317. - updated to 1.10.1.
  318. * Tue Apr 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-2
  319. - rebuilt with libevent-2.1.11.
  320. * Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-1
  321. - updated to 1.10.0.
  322. - added systemd support (disabled as default).
  323. - disabled munin.
  324. * Mon Dec 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.6-1
  325. - updated to 1.9.6.
  326. * Fri Oct 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.4-1
  327. - updated to 1.9.4.
  328. * Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.3-1
  329. - updated to 1.9.3.
  330. * Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-1
  331. - updated to 1.9.2.
  332. * Fri Nov 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-2
  333. - added a subpackage 'compat32-unbound-libs'.
  334. * Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-1
  335. - updated to 1.8.1.
  336. - rebuilt with openssl-1.1.1 and libevent-2.1.8.
  337. - updated root.key and root.anchor.
  338. * Thu Oct 4 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.0-1
  339. - update to 1.8.0
  340. - drop mesh patch (Patch0): upstream fixed
  341. * Thu May 24 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-3
  342. - Fix mesh state assertion failure due to callback removal. (Patch0)
  343. * Sun May 6 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-2
  344. - enable ECDSA support
  345. - enable GOST support
  346. * Sat May 5 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-1
  347. - update to 1.7.1
  348. - add pkgconfig file in devel sub package
  349. * Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.7-1
  350. - updated to 1.6.7.
  351. * Mon Jul 31 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.4-1
  352. - update to 1.6.4
  353. * Sat Jun 24 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.3-1
  354. - update to 1.6.3
  355. * Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.2-1
  356. - update to 1.6.2
  357. - disables SHA1 support
  358. * Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.1-1
  359. - update to 1.6.1
  360. * Mon Jan 30 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-2
  361. - fix Requires and BuildRequres
  362. - drop ldns
  363. * Thu Dec 29 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-1
  364. - update to 1.6.0
  365. * Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.9-1
  366. - new upstream release.
  367. * Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.8-1
  368. - new upstream release.
  369. * Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.7-1
  370. - new upstream release.
  371. * Tue Nov 3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-1
  372. - new upstream release.
  373. * Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.5.3-1
  374. - update to 1.5.3
  375. * Tue Dec 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.1-1
  376. - update to 1.5.1
  377. * Tue Jun 17 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-3
  378. - move create user script to libs subpackage
  379. * Wed Jun 11 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-2
  380. - add {B,C}.ROOT-SERVERS.NET. IPv6 address
  381. * Wed Apr 16 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.22-1
  382. - update to 1.4.22
  383. - move root.key to /var/lib/unbound
  384. - add icannbundle.pem from http://data.iana.org/root-anchors/icannbundle.pem
  385. - add unbound.cron
  386. - move keys and unbound-anchor to libs subpackage
  387. * Mon Oct 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.21-1
  388. - new upstream release
  389. * Tue Mar 26 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.20-1
  390. - new upstream release
  391. * Thu Dec 13 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.19-1
  392. - new upstream release
  393. - drop glob patch (Patch1): upstream merged
  394. * Wed Dec 5 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.18-1
  395. - new upstream release
  396. * Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.17-1
  397. - update to 1.4.17
  398. - add root.key for DNSSEC
  399. - enable munin subpackage by default
  400. - buildrequire ldns-devel >= 1.6.13
  401. * Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-2
  402. - rebuild with python-2.7.2
  403. * Wed Dec 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.14-1
  404. - new upstream release
  405. * Sat Sep 3 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.12-1
  406. - new upstream release
  407. * Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.10-1
  408. - new upstream releas
  409. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.9-1
  410. - new upstream release
  411. * Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.8-1
  412. - new upstream release
  413. * Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.7-2
  414. - rebuilt with libevent-2.0.10
  415. * Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.7-1
  416. - new upstream release
  417. - add enable_gost flag: default disable
  418. - add BuildRequires: expat-devel
  419. * Thu Sep 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.6-1
  420. - new upstream release
  421. * Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.5-1
  422. - new upstream release
  423. * Wed May 5 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.4-1
  424. - initial build for Vine Linux: based Fedora 1.4.3-1.fc14
  425. - update to 1.4.4
  426. - build without munin
  427. * Thu Mar 11 2010 Paul Wouters <paul@xelerance.com> - 1.4.3-1
  428. - Update to 1.4.3 that fixes 64bit crasher
  429. * Tue Mar 09 2010 Paul Wouters <paul@xelerance.com> - 1.4.2-1
  430. - Updated to 1.4.2
  431. - Updated unbound.conf with new options
  432. - Enabled pre-fetching DNSKEY records (DNSSEC speedup)
  433. - Enabled re-fetching popular records before they expire
  434. - Enabled logging of DNSSEC validation errors
  435. * Mon Mar 01 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-5
  436. - Overriding -D_GNU_SOURCE is no longer needed. This fixes DSO issues
  437. with pthreads
  438. * Wed Feb 24 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-3
  439. - Change make/configure lines to attempt to fix -lphtread linking issue
  440. * Thu Feb 18 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-2
  441. - Removed dependancy for dnssec-conf
  442. - Added ISC DLV key (formerly in dnssec-conf)
  443. - Fixup old DLV locations in unbound.conf file via %%post
  444. - Fix parent child disagreement handling and no-ipv6 present [svn r1953]
  445. * Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-1
  446. - Updated to 1.4.1
  447. - Changed %%define to %%global
  448. * Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-2
  449. - Bump version
  450. * Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-1
  451. - Upgraded to 1.3.4. Security fix with validating NSEC3 records
  452. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.3-2
  453. - rebuilt with new openssl
  454. * Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 1.3.3-1
  455. - Updated to 1.3.3
  456. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
  457. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  458. * Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
  459. - Added missing glob patch to cvs
  460. - Place python macros within the %%with_python check
  461. * Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
  462. - Updated to 1.3.0
  463. - Added unbound-python sub package. disabled for now
  464. - Patch from svn to fix DLV lookups
  465. - Patches from svn to detect wrong truncated response from BIND 9.6.1 with
  466. minimal-responses)
  467. - Added Default-Start and Default-Stop to unbound.init
  468. - Re-enabled --enable-sha2
  469. - Re-enabled glob.patch
  470. * Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-7
  471. - unbound-iterator.patch was not commited
  472. * Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-6
  473. - Fix for https://bugzilla.redhat.com/show_bug.cgi?id=499793
  474. * Tue Mar 17 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-5
  475. - Use --nocheck to avoid giving an error on missing unbound-remote certs/keys
  476. * Tue Mar 10 2009 Adam Tkac <atkac redhat com> - 1.2.1-4
  477. - enable DNSSEC only if it is enabled in sysconfig/dnssec
  478. * Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 1.2.1-3
  479. - add DNSSEC support to initscript and enabled it per default
  480. - add requires dnssec-conf
  481. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
  482. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  483. * Tue Feb 10 2009 Paul Wouters <paul@xelerance.com - 1.2.1-1
  484. - updated to 1.2.1
  485. * Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.0-2
  486. - rebuild with new openssl
  487. * Wed Jan 14 2009 Paul Wouters <paul@xelerance.com - 1.2.0-1
  488. - Updated to 1.2.0
  489. - Added dependancy on minimum SSL for CVE-2008-5077
  490. - Added dependancy on bc for unbound-munin
  491. - Added minimum requirement of libevent 1.4.5. Crashes with older versions
  492. (note: libevent is stale in EL-4 and not in EL-5, needs fixing there)
  493. - Removed dependancy on selinux-policy (will get used when available)
  494. - Enable options as per draft-wijngaards-dnsext-resolver-side-mitigation-00.txt
  495. - Enable unwanted-reply-threshold to mitigate against a Kaminsky attack
  496. - Enable val-clean-additional to drop addition unsigned data from signed
  497. response.
  498. - Removed patches (got merged into upstream)
  499. * Mon Jan 5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-7
  500. - Modified scandir patch to silently fail when wildcard matches nothing
  501. - Patch to allow unbound-checkconf to find empty wildcard matches
  502. * Mon Jan 5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-6
  503. - Added scandir patch for trusted-keys-file: option, which
  504. is used to load multiple dnssec keys in bind file format
  505. * Mon Dec 8 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-4
  506. - Added Requires: for selinux-policy >= 3.5.13-33 for proper SElinux rules.
  507. * Mon Dec 1 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-3
  508. - We did not own the /etc/unbound directory (#474020)
  509. - Fixed cvs anomalies
  510. * Fri Nov 28 2008 Adam Tkac <atkac redhat com> - 1.1.1-2
  511. - removed all obsolete chroot related stuff
  512. - label control certs after generation correctly
  513. * Thu Nov 20 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-1
  514. - Updated to unbound 1.1.1 which fixes a crasher and
  515. addresses nlnetlabs bug #219
  516. * Wed Nov 19 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-3
  517. - Remove the chroot, obsoleted by SElinux
  518. - Add additional munin plugin links supported by unbound plugin
  519. - Move configuration directory from /var/lib/unbound to /etc/unbound
  520. - Modified unbound.init and unbound.conf to account for chroot changes
  521. - Updated unbound.conf with new available options
  522. - Enabled dns-0x20 protection per default
  523. * Wed Nov 19 2008 Adam Tkac <atkac redhat com> - 1.1.0-2
  524. - unbound-1.1.0-log_open.patch
  525. - make sure log is opened before chroot call
  526. - tracked as http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=219
  527. - removed /dev/log and /var/run/unbound and /etc/resolv.conf from
  528. chroot, not needed
  529. - don't mount files in chroot, it causes problems during updates
  530. - fixed typo in default config file
  531. * Fri Nov 14 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-1
  532. - Updated to version 1.1.0
  533. - Updated unbound.conf's statistics options and remote-control
  534. to work properly for munin
  535. - Added unbound-munin package
  536. - Generate unbound remote-control key/certs on first startup
  537. - Required ldns is now 1.4.0
  538. * Wed Oct 22 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-5
  539. - Only call ldconfig in -libs package
  540. - Move configure into build section
  541. - devel subpackage should only depend on libs subpackage
  542. * Tue Oct 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-4
  543. - Fix CFLAGS getting lost in build
  544. - Don't enable interface-automatic:yes because that
  545. causes unbound to listen on 0.0.0.0 instead of 127.0.0.1
  546. * Sun Oct 19 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-3
  547. - Split off unbound-libs, make build verbose
  548. * Thu Oct 9 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-2
  549. - FSB compliance, chroot fixes, initscript fixes
  550. * Thu Sep 11 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-1
  551. - Upgraded to 1.0.2
  552. * Wed Jul 16 2008 Paul Wouters <paul@xelerance.com> - 1.0.1-1
  553. - upgraded to new release
  554. * Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-2
  555. - Build against ldns-1.3.0
  556. * Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-1
  557. - Split of -devel package, fixed dependancies, make rpmlint happy
  558. * Fri Apr 25 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.12
  559. - Using parts from ports collection entry by Jaap Akkerhuis.
  560. - Using Fedoraproject wiki guidelines.
  561. * Wed Apr 23 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.11
  562. - Initial version.