suricata-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547
  1. %bcond_with systemd
  2. %bcond_with libprelude
  3. Summary: Intrusion Detection System
  4. Name: suricata
  5. Version: 5.0.3
  6. Release: 2%{?_dist_release}%{?with_systemd:.systemd}
  7. Group: network
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPLv2
  11. URL: https://suricata-ids.org/
  12. Source0: https://www.openinfosecfoundation.org/download/%{name}-%{version}.tar.gz
  13. Source1: suricata.sysconfig
  14. Source2: fedora.notes
  15. Source3: suricata-tmpfiles.conf
  16. Source1000: suricata.init
  17. Source1001: suricata.logrotate
  18. # Irrelevant docs are getting installed, drop them
  19. Patch1: suricata-2.0.9-docs.patch
  20. # Suricata service file needs some options supplied
  21. Patch2: suricata-4.1.1-service.patch
  22. # Linux 5.2 headers moved SIOCGSTAMP to linux/sockios.h. Glibc will
  23. # include it via sys/socket.h in a future release. This is temporary
  24. # and should not be needed on other kernel/glibc combos.
  25. Patch3: suricata-4.1.4-socket.patch
  26. BuildRequires: gcc gcc-c++
  27. BuildRequires: rust cargo
  28. BuildRequires: libyaml-devel python3-pyyaml
  29. BuildRequires: libnfnetlink-devel libnetfilter_queue-devel libnet-devel
  30. BuildRequires: zlib-devel pcre-devel libcap-ng-devel
  31. BuildRequires: lz4-devel libpcap-devel
  32. BuildRequires: nspr-devel nss-devel file-devel
  33. BuildRequires: jansson-devel libmaxminddb-devel python3-devel lua-devel
  34. BuildRequires: python3-rpm-macros
  35. # Next line is for eBPF support
  36. %ifarch x86_64
  37. BuildRequires: clang llvm libbpf-devel
  38. %endif
  39. BuildRequires: autoconf automake libtool
  40. %if %{with systemd}
  41. BuildRequires: systemd
  42. %endif
  43. BuildRequires: hiredis-devel
  44. BuildRequires: libevent-devel
  45. %if %{with libprelude}
  46. BuildRequires: libprelude-devel
  47. %endif
  48. BuildRequires: gnutls-devel
  49. %ifarch x86_64
  50. BuildRequires: hyperscan-devel
  51. %endif
  52. Requires: python3-pyyaml
  53. Requires(pre): /usr/sbin/useradd
  54. %if %{with systemd}
  55. Requires(post): systemd
  56. Requires(preun): systemd
  57. Requires(postun): systemd
  58. %endif
  59. %description
  60. The Suricata Engine is an Open Source Next Generation Intrusion
  61. Detection and Prevention Engine. This engine is not intended to
  62. just replace or emulate the existing tools in the industry, but
  63. will bring new ideas and technologies to the field. This new Engine
  64. supports Multi-threading, Automatic Protocol Detection (IP, TCP,
  65. UDP, ICMP, HTTP, TLS, FTP and SMB! ), Gzip Decompression, Fast IP
  66. Matching, and GeoIP identification.
  67. %debug_package
  68. %prep
  69. %setup -q
  70. install -m 644 %{SOURCE2} doc/
  71. %patch1 -p1
  72. %patch2 -p1
  73. %patch3 -p1
  74. sed -i 's/(datadir)/(sysconfdir)/' etc/Makefile.am
  75. %ifarch x86_64
  76. sed -i 's/-D__KERNEL__/-D__KERNEL__ -D__x86_64__/' ebpf/Makefile.am
  77. %endif
  78. autoreconf -fv --install
  79. %build
  80. %configure --enable-gccprotect --enable-pie --disable-gccmarch-native \
  81. --disable-coccinelle --enable-nfqueue --enable-af-packet \
  82. --with-libnspr-includes=/usr/include/nspr4 \
  83. --with-libnss-includes=/usr/include/nss3 \
  84. --enable-jansson --enable-geoip --enable-lua --enable-hiredis \
  85. %if %{with libprelude}
  86. --enable-prelude \
  87. %endif
  88. --enable-rust \
  89. %ifarch x86_64
  90. --enable-ebpf-build --enable-ebpf \
  91. %endif
  92. --enable-python
  93. %make_build
  94. %install
  95. make DESTDIR="%{buildroot}" "bindir=%{_sbindir}" install
  96. # Setup etc directory
  97. mkdir -p %{buildroot}%{_sysconfdir}/%{name}/rules
  98. #install -m 640 rules/*.rules %{buildroot}%{_sysconfdir}/%{name}/rules
  99. for f in rules/*.rules; do
  100. touch %{buildroot}%{_sysconfdir}/%{name}/$f
  101. done
  102. install -m 600 *.config %{buildroot}%{_sysconfdir}/%{name}
  103. install -m 600 suricata.yaml %{buildroot}%{_sysconfdir}/%{name}
  104. %if %{with systemd}
  105. mkdir -p %{buildroot}%{_unitdir}
  106. install -m 0644 etc/%{name}.service %{buildroot}%{_unitdir}/
  107. sed -i -e 's|/var/run/|/run/|' %{buildroot}%{_unitdir}/%{name}.service
  108. %else
  109. mkdir -p %{buildroot}%{_initdir}
  110. install -m 0644 %{SOURCE1000} %{buildroot}%{_initdir}/%{name}
  111. %endif
  112. mkdir -p %{buildroot}%{_sysconfdir}/sysconfig
  113. install -m 0755 %{SOURCE1} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  114. # Set up logging
  115. mkdir -p %{buildroot}/%{_var}/log/%{name}
  116. mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
  117. #install -m 644 etc/%{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  118. #sed -i -e 's|/var/run/%{name}\.pid|/var/run/%{name}/%{name}.pid|' %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  119. install -m 644 %{SOURCE1001} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  120. # Remove a couple things so they don't get picked up
  121. rm -rf %{buildroot}%{_includedir}
  122. rm -f %{buildroot}%{_libdir}/libhtp.la
  123. rm -f %{buildroot}%{_libdir}/libhtp.a
  124. rm -f %{buildroot}%{_libdir}/libhtp.so
  125. rm -rf %{buildroot}%{_libdir}/pkgconfig
  126. # Setup suricata-update data directory
  127. mkdir -p %{buildroot}/%{_var}/lib/%{name}
  128. # Setup tmpdirs
  129. %if %{with systemd}
  130. mkdir -p %{buildroot}%{_tmpfilesdir}
  131. install -m 0644 %{SOURCE3} %{buildroot}%{_tmpfilesdir}/%{name}.conf
  132. %endif
  133. mkdir -p %{buildroot}/run
  134. install -d -m 0755 %{buildroot}/run/%{name}/
  135. cp suricata-update/README.rst doc/suricata-update-README.rst
  136. %check
  137. make check
  138. %pre
  139. getent passwd suricata >/dev/null || useradd -r -M -s /sbin/nologin suricata
  140. %post
  141. %if %{with systemd}
  142. %systemd_post suricata.service
  143. %else
  144. if [ $1 -gt 0 ]; then
  145. /sbin/chkconfig --add suricata
  146. fi
  147. %endif
  148. %preun
  149. %if %{with systemd}
  150. %systemd_preun suricata.service
  151. %else
  152. if [ $1 -eq 0 -o -x /bin/systemctl ]; then
  153. /sbin/service suricata stop
  154. /sbin/chkconfig suricata off ||:
  155. /sbin/chkconfig --del suricata
  156. fi
  157. %endif
  158. %postun
  159. %if %{with systemd}
  160. %systemd_postun_with_restart suricata.service
  161. %else
  162. if [ $1 -gt 0 -a -f /var/run/suricata/suricata.pid -a ! -x /bin/systemctl ]; then
  163. /sbin/service suricata restart
  164. fi
  165. %endif
  166. %files
  167. %doc doc/Basic_Setup.txt doc/suricata-update-README.rst
  168. %doc doc/Setting_up_IPSinline_for_Linux.txt doc/fedora.notes
  169. %{!?_licensedir:%global license %%doc}
  170. %license COPYING
  171. %attr(644,root,root) %{_mandir}/man1/*
  172. %{_sbindir}/suricata
  173. %{_bindir}/suricatasc
  174. %{_bindir}/suricatactl
  175. %{_bindir}/suricata-update
  176. %{_libdir}/libhtp*
  177. %{python3_sitelib}/suricatasc/*
  178. %{python3_sitelib}/suricata/*
  179. %{python3_sitelib}/*egg-info
  180. %config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/suricata.yaml
  181. %config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/*.config
  182. %ghost %config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/rules/*.rules
  183. %config(noreplace) %attr(0600,suricata,root) %{_sysconfdir}/sysconfig/%{name}
  184. %config(noreplace) %attr(644,root,root) %{_sysconfdir}/logrotate.d/%{name}
  185. %attr(750,suricata,suricata) %dir %{_var}/log/%{name}
  186. %attr(750,suricata,suricata) %dir %{_sysconfdir}/%{name}
  187. %attr(750,suricata,suricata) %dir %{_sysconfdir}/%{name}/rules
  188. %attr(2770,suricata,suricata) %dir %{_var}/lib/%{name}
  189. %attr(2770,suricata,suricata) %dir /run/%{name}/
  190. %if %{with systemd}
  191. %attr(644,root,root) %{_unitdir}/suricata.service
  192. %{_tmpfilesdir}/%{name}.conf
  193. %else
  194. %attr(0755,root,root) %{_initdir}/%{name}
  195. %endif
  196. %{_datadir}/%{name}/rules
  197. %changelog
  198. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.3-2
  199. - rebuilt with python-3.8.
  200. * Tue May 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.3-1
  201. - new upstream release.
  202. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-2
  203. - rebuilt with libevent-2.1.11.
  204. * Sat Mar 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-1
  205. - new upstream release.
  206. * Wed Oct 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.0-3
  207. - initial build for Vine Linux.
  208. * Fri Oct 18 2019 Steve Grubb <sgrubb@redhat.com> 5.0.0-2
  209. - New feature release (which also fixes a security issue)
  210. - Enable ebpf on x86_64 only
  211. - Disable building on ppc64le due to rust problems
  212. * Thu Aug 01 2019 Steve Grubb <sgrubb@redhat.com> 4.1.4-4
  213. - Fix FTBFS bz 1736727
  214. * Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.1.4-3
  215. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  216. * Mon Jul 22 2019 Steve Grubb <sgrubb@redhat.com> 4.1.4-2
  217. - Rebuild for libprelude so bump
  218. * Tue Apr 30 2019 Jason Taylor <jtfas90@gmail.com> 4.1.4-1
  219. - Upstream bugfix release
  220. * Thu Mar 07 2019 Steve Grubb <sgrubb@redhat.com> 4.1.3-1
  221. - Upstream bugfix release
  222. * Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.1.2-2
  223. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  224. * Fri Dec 21 2018 Jason Taylor <jtfas90@gmail.com> 4.1.2-1
  225. - Upstream bugfix release
  226. - Updated source to use official download site
  227. * Thu Dec 20 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-4
  228. - Adjust permissions on /run/suricata and /var/lib/suricata to group writable
  229. * Mon Dec 17 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-2
  230. - Remove ragel requirement
  231. * Mon Dec 17 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-1
  232. - Make log directory group readable
  233. - Allow users of the suricata group to run suricata-update
  234. - Add lz4-devel BuildRequires to support pcap compression
  235. - Update service file for systemd security protections
  236. - Upstream bugfix update
  237. * Tue Nov 20 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-3
  238. - Use the upstream service and logrote files (#1330331)
  239. - Make the log directory readable by members of the suricata group (#1651394)
  240. * Wed Nov 07 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-2
  241. - Add cargo BuildRequires
  242. * Tue Nov 06 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-1
  243. - Latest upstream major release
  244. - Fixes CVE-2018-18956 Segmentation fault in the ProcessMimeEntity function
  245. * Mon Aug 13 2018 Steve Grubb <sgrubb@redhat.com> - 4.0.5-3
  246. - Consolidate branches so that everything is in sync (#1614935)
  247. * Fri Aug 10 2018 Jason Taylor <jtfas90@gmail.com> 4.0.5-2
  248. - fixes bz#1614935
  249. * Wed Jul 18 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.5-1
  250. - upstream security fix release
  251. - addresses CVE-2018-10242, CVE-2018-10243, CVE-2018-10244
  252. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.4-3
  253. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  254. * Mon Jul 09 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-2
  255. - bumped release for build against hyperscan 5.0.0
  256. * Mon Jul 09 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-1
  257. - added gcc-c++ buildrequires
  258. * Thu Feb 15 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-1
  259. - fixes bz#1543250 and bz#1543251
  260. - multiple upstream bugfixes
  261. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.3-3
  262. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  263. * Mon Dec 11 2017 Jason Taylor <jtfas90@gmail.com> 4.0.3-2
  264. - Added prelude support
  265. * Fri Dec 08 2017 Jason Taylor <jtfas90@gmail.com> 4.0.3-1
  266. - Upstream bugfix release
  267. * Wed Oct 18 2017 Steve Grubb <sgrubb@redhat.com> 4.0.1-1
  268. - Upstream bugfix update
  269. * Tue Sep 26 2017 Steve Grubb <sgrubb@redhat.com> 4.0.0-2
  270. - Make suricata user own /run/suricata (#1396150)
  271. * Mon Jul 31 2017 Jason Taylor <jtfas90@gmail.com> 4.0.0-1
  272. - Latest upstream major release
  273. - Build now has hyperscan and redis support
  274. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.3-2
  275. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  276. * Thu Jul 13 2017 Jason Taylor <jtfas90@gmail.com> 3.2.3-1
  277. - Upstream bugfix update
  278. * Wed Jun 07 2017 Steve Grubb <sgrubb@redhat.com> 3.2.2-1
  279. - Upstream bugfix update
  280. * Wed Feb 15 2017 Steve Grubb <sgrubb@redhat.com> 3.2.1-1
  281. - Upstream security update
  282. * Mon Feb 13 2017 Steve Grubb <sgrubb@redhat.com> 3.2-1
  283. - New upstream feature release
  284. - Rotate /var/log/suricata/eve.json (#1396151)
  285. - Fix ownership of /run/suricata (#1396150)
  286. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.3-2
  287. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  288. * Tue Nov 01 2016 Steve Grubb <sgrubb@redhat.com> 3.1.3-1
  289. - New upstream bug fix release
  290. * Wed Sep 07 2016 Steve Grubb <sgrubb@redhat.com> 3.1.2-1
  291. - New upstream bug fix release
  292. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.1-2
  293. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  294. * Wed Jul 13 2016 Steve Grubb <sgrubb@redhat.com> 3.1.1-1
  295. - New upstream bug fix release
  296. * Wed Jun 22 2016 Steve Grubb <sgrubb@redhat.com> 3.1-1
  297. - New upstream bug fix release
  298. * Mon Apr 04 2016 Steve Grubb <sgrubb@redhat.com> 3.0.1-1
  299. - New upstream bug fix release
  300. * Wed Mar 16 2016 Steve Grubb <sgrubb@redhat.com> 3.0-2
  301. - Fixed Bug 1227085 - Have Suricata start after the network is online
  302. * Mon Mar 07 2016 Steve Grubb <sgrubb@redhat.com> 3.0-1
  303. - New upstream bug fix release
  304. * Wed Feb 10 2016 Peter Schiffer <pschiffe@redhat.com> 2.0.11-3
  305. - Run suricata under suricata user
  306. * Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.11-2
  307. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  308. * Mon Dec 28 2015 Steve Grubb <sgrubb@redhat.com> 2.0.11-1
  309. - New upstream bug fix release
  310. * Wed Nov 25 2015 Steve Grubb <sgrubb@redhat.com> 2.0.10-1
  311. - New upstream bug fix release
  312. * Sat Oct 03 2015 Steve Grubb <sgrubb@redhat.com> 2.0.9-1
  313. - New upstream bug fix release
  314. * Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.8-2
  315. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  316. * Wed May 06 2015 Steve Grubb <sgrubb@redhat.com> 2.0.8-1
  317. - New upstream security bug fix release
  318. * Thu Feb 26 2015 Steve Grubb <sgrubb@redhat.com> 2.0.7-1
  319. - New upstream security bug fix release for CVE-2015-0928
  320. * Thu Jan 15 2015 Steve Grubb <sgrubb@redhat.com> 2.0.6-1
  321. - New upstream bug fix release
  322. - Don't use the system libhtp library
  323. * Fri Dec 12 2014 Steve Grubb <sgrubb@redhat.com> 2.0.5-1
  324. - New upstream bug fix release
  325. - Use the system libhtp library
  326. * Wed Sep 24 2014 Steve Grubb <sgrubb@redhat.com> 2.0.4-1
  327. - New upstream bug fix release
  328. - Fixes CVE-2014-6603 out-of-bounds access in SSH parser
  329. * Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3-2
  330. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  331. * Fri Aug 08 2014 Steve Grubb <sgrubb@redhat.com> 2.0.3-1
  332. - New upstream bug fix release
  333. * Sat Jun 28 2014 Steve Grubb <sgrubb@redhat.com> 2.0.2-2
  334. - Specfile cleanups (#1113413)
  335. * Wed Jun 25 2014 Steve Grubb <sgrubb@redhat.com> 2.0.2-1
  336. - New upstream bug fix release
  337. - Enable liblua support
  338. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.1-2
  339. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  340. * Wed May 21 2014 Steve Grubb <sgrubb@redhat.com> 2.0.1-1
  341. - New upstream bug fix release
  342. * Wed Mar 26 2014 Steve Grubb <sgrubb@redhat.com> 2.0-1
  343. - Major new upstream release with new features
  344. * Tue Jan 21 2014 Dan Horák <dan[at]danny.cz> 1.4.7-3
  345. - luajit available only on selected arches
  346. * Sat Jan 11 2014 Steve Grubb <sgrubb@redhat.com> 1.4.7-2
  347. - Enable luajit support
  348. * Wed Dec 18 2013 Steve Grubb <sgrubb@redhat.com> 1.4.7-1
  349. - New upstream bug fix release
  350. * Fri Oct 04 2013 Steve Grubb <sgrubb@redhat.com> 1.4.6-1
  351. - New upstream bug fix release
  352. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3-3
  353. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  354. * Fri Jun 21 2013 Steve Grubb <sgrubb@redhat.com> 1.4.3-2
  355. - Drop prelude support
  356. * Fri Jun 21 2013 Steve Grubb <sgrubb@redhat.com> 1.4.3-1
  357. - New upstream bug fix release
  358. * Mon Jun 03 2013 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
  359. - New upstream bug fix release
  360. * Sun Mar 10 2013 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
  361. - New upstream bugfix release
  362. - Enable libgeoip support
  363. - Switch to stack-protector-all
  364. * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-2
  365. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  366. * Thu Dec 20 2012 Steve Grubb <sgrubb@redhat.com> 1.4-1
  367. - New upstream feature enhancement release
  368. * Thu Dec 06 2012 Steve Grubb <sgrubb@redhat.com> 1.3.5-1
  369. - New upstream bugfix release
  370. * Tue Nov 27 2012 Steve Grubb <sgrubb@redhat.com> 1.3.4-1
  371. - New upstream release
  372. * Mon Nov 05 2012 Steve Grubb <sgrubb@redhat.com> 1.3.3-1
  373. - New upstream release
  374. * Tue Oct 09 2012 Steve Grubb <sgrubb@redhat.com> 1.3.2-2
  375. - Add nss-devel build require and systemd macros
  376. * Mon Oct 08 2012 Steve Grubb <sgrubb@redhat.com> 1.3.2-1
  377. - New upstream release
  378. * Sat Aug 25 2012 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
  379. - New upstream release
  380. - Switch startup to use systemd
  381. * Fri Jul 06 2012 Steve Grubb <sgrubb@redhat.com> 1.3-1
  382. - New upstream release
  383. * Fri Mar 30 2012 Jon Ciesla <limburgher@gmail.com> - 1.2.1-3
  384. - Rebuild for updated libnet.
  385. * Fri Feb 10 2012 Petr Pisar <ppisar@redhat.com> - 1.2.1-2
  386. - Rebuild against PCRE 8.30
  387. * Thu Feb 02 2012 Steve Grubb <sgrubb@redhat.com> 1.2.1-1
  388. - New upstream release
  389. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-3
  390. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  391. * Thu Dec 22 2011 Steve Grubb <sgrubb@redhat.com> 1.1.1-2
  392. - Enable AF_PACKET support
  393. * Wed Dec 07 2011 Steve Grubb <sgrubb@redhat.com> 1.1.1-1
  394. - New upstream release
  395. * Mon Jul 25 2011 Steve Grubb <sgrubb@redhat.com> 1.0.5-1
  396. - New upstream release
  397. * Fri Jun 24 2011 Steve Grubb <sgrubb@redhat.com> 1.0.4-1
  398. - New upstream release
  399. * Thu Apr 28 2011 Dan Horák <dan[at]danny.cz> 1.0.3-2
  400. - don't override -march set by the buildsystem (fixes build on non-x86)
  401. * Sat Apr 23 2011 Steve Grubb <sgrubb@redhat.com> 1.0.3-1
  402. - New upstream release
  403. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
  404. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  405. * Wed Nov 10 2010 Steve Grubb <sgrubb@redhat.com> 1.0.2-1
  406. - New upstream release (#651978)
  407. * Thu Jul 01 2010 Steve Grubb <sgrubb@redhat.com> 1.0.0-1
  408. - New upstream release
  409. * Fri May 07 2010 Steve Grubb <sgrubb@redhat.com> 0.9.0-1
  410. - New upstream release
  411. * Tue Apr 20 2010 Steve Grubb <sgrubb@redhat.com> 0.8.2-1
  412. - New upstream release
  413. * Sat Feb 27 2010 Steve Grubb <sgrubb@redhat.com> 0.8.1-1
  414. - Initial packaging