shflags-vl.spec 2.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980
  1. %define ver 1.0.3
  2. %define rel 1
  3. Name: shflags
  4. Version: %{ver}
  5. Release: %{rel}%{?_dist_release}
  6. Summary: Simple handling of command-line flags in Bourne based Unix scripts
  7. Group: Development/Languages
  8. License: LGPLv2
  9. URL: http://code.google.com/p/shflags/
  10. Source0: http://shflags.googlecode.com/files/shflags-1.0.3.tgz
  11. BuildArch: noarch
  12. Requires: util-linux
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. Packager: iwaim
  16. %description
  17. Shell Flags (shFlags) is a library written to greatly simplify the handling of
  18. command-line flags in Bourne based Unix shell scripts (bash, dash, ksh, sh, zsh)
  19. on many Unix OSes (Linux, Solaris, Mac OS X, etc.).
  20. Most shell scripts use getopt for flags processing, but the different versions
  21. of getopt on various OSes make writing portable shell scripts difficult. shFlags
  22. instead provides an API that doesn't change across shell and OS versions so the
  23. script writer can be confident that the script will work.
  24. shFlags is a port of the google-gflags C++/Python library.
  25. %prep
  26. %setup -q
  27. # Make the examples non-executable.. we're putting them in /usr/share.
  28. chmod -x examples/*.sh
  29. %build
  30. # This section is empty because this package ccontains shell scripts
  31. # to be sourced: there's nothing to build
  32. %check
  33. pushd src
  34. sh shflags_test_defines.sh
  35. sh shflags_test_parsing.sh
  36. sh shflags_test_public.sh
  37. sh shflags_test_private.sh
  38. sh shflags_test.sh
  39. popd
  40. %install
  41. mkdir -p %{buildroot}/%{_datadir}/%{name}
  42. cp -p src/shflags %{buildroot}/%{_datadir}/%{name}/.
  43. %files
  44. %doc README.txt README.html doc/ examples/
  45. %{_datadir}/%{name}
  46. %changelog
  47. * Fri Jan 18 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.3-1
  48. - initial build for Vine Linux
  49. * Mon Dec 17 2012 Ralph Bean <rbean@redhat.com> - 1.0.3-4
  50. - Updated the license field to LGPLv2 after receiving feedback from upstream.
  51. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.3-3
  52. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  53. * Fri Jul 06 2012 Ralph Bean <rbean@redhat.com> - 1.0.3-2
  54. - Updated the license field to LGPLv2+
  55. - Removed BuildRequires util-linux. Superfluous!
  56. - Ownership taken for %%{_datadir}/%%{name}
  57. - Copying with '-p' to preserve
  58. - Made examples non-exectuable.
  59. - Added %%check section.
  60. * Mon Jun 25 2012 Ralph Bean <rbean@redhat.com> - 1.0.3-1
  61. - Initial packaging for Fedora.