redis-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404
  1. %bcond_with systemd
  2. # Check for status of man pages
  3. # http://code.google.com/p/redis/issues/detail?id=202
  4. # Commit IDs for the (unversioned) redis-doc repository
  5. # https://fedoraproject.org/wiki/Packaging:SourceURL "Commit Revision"
  6. #global doc_commit 4f1da37c03daa943f2cf3cd5fda8dbd1bf1f22d7
  7. %global doc_commit 0ee00bbc97dda36d09a2559f20dafd236d5426a2
  8. %global short_doc_commit %(c=%{doc_commit}; echo ${c:0:7})
  9. # %%{rpmmacrodir} not usable on EL-6
  10. %global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
  11. %ifarch %{ix86} x86_64 ppc
  12. # available only on selected architectures
  13. %global with_perftools 1
  14. %endif
  15. Name: redis
  16. Version: 6.0.9
  17. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  18. Summary: A persistent in-memory key-value database
  19. Summary(ja): 永続化可能なキー・バリュー型インメモリデータベース
  20. Group: servers
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. Packager: daisuke
  24. License: BSD
  25. URL: https://redis.io
  26. Source0: https://github.com/redis-io/redis/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
  27. Source1: %{name}.logrotate
  28. Source2: %{name}-sentinel.service
  29. Source3: %{name}.service
  30. Source4: %{name}-sentinel.init
  31. Source5: %{name}.init
  32. Source6: %{name}-shutdown
  33. Source7: %{name}-limit-systemd
  34. Source8: %{name}-limit-init
  35. Source9: macros.%{name}
  36. Source10: https://github.com/redis/%{name}-doc/archive/%{doc_commit}/%{name}-doc-%{short_doc_commit}.tar.gz
  37. # To refresh patches:
  38. # tar xf redis-xxx.tar.gz && cd redis-xxx && git init && git add . && git commit -m "%%{version} baseline"
  39. # git am %%{patches}
  40. # Then refresh your patches
  41. # git format-patch HEAD~<number of expected patches>
  42. # Update configuration for Fedora
  43. # https://github.com/antirez/redis/pull/3491 - man pages
  44. Patch0001: 0001-1st-man-pageis-for-redis-cli-redis-benchmark-redis-c.patch
  45. # https://github.com/antirez/redis/pull/3494 - symlink
  46. Patch0002: 0002-install-redis-check-rdb-as-a-symlink-instead-of-dupl.patch
  47. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  48. %if %{?with_perftools}
  49. BuildRequires: gperftools-devel
  50. %endif
  51. Requires: logrotate
  52. %if %{with systemd}
  53. BuildRequires: systemd
  54. Requires(post): systemd
  55. Requires(preun): systemd
  56. Requires(postun): systemd
  57. %else
  58. Requires(post): chkconfig
  59. Requires(postun): initscripts
  60. Requires(preun): chkconfig
  61. Requires(preun): initscripts
  62. %endif
  63. Requires(pre): shadow-utils
  64. %global redis_modules_abi 1
  65. %global redis_modules_dir %{_libdir}/%{name}/modules
  66. Provides: redis(modules_abi)%{?_isa} = %{redis_modules_abi}
  67. %description
  68. Redis is an advanced key-value store. It is similar to memcached but the data
  69. set is not volatile, and values can be strings, exactly like in memcached, but
  70. also lists, sets, and ordered sets. All this data types can be manipulated with
  71. atomic operations to push/pop elements, add/remove elements, perform server side
  72. union, intersection, difference between sets, and so forth. Redis supports
  73. different kind of sorting abilities.
  74. %package devel
  75. Summary: Development header for Redis module development
  76. Group: programming
  77. # Header-Only Library (https://fedoraproject.org/wiki/Packaging:Guidelines)
  78. Provides: %{name}-static = %{version}-%{release}
  79. %description devel
  80. Header file required for building loadable Redis modules. Detailed
  81. API documentation is available in the redis-doc package.
  82. %package doc
  83. Summary: Documentation for Redis including man pages
  84. Group: documentation
  85. License: CC-BY-SA
  86. BuildArch: noarch
  87. # http://fedoraproject.org/wiki/Packaging:Conflicts "Splitting Packages"
  88. Conflicts: redis < 4.0
  89. %description doc
  90. Manual pages and detailed documentation for many aspects of Redis use,
  91. administration and development.
  92. %debug_package
  93. %prep
  94. %setup -q -b 10
  95. %setup -q
  96. mv ../%{name}-doc-%{doc_commit} doc
  97. %patch0001 -p1
  98. %patch0002 -p1
  99. mv deps/lua/COPYRIGHT COPYRIGHT-lua
  100. mv deps/hiredis/COPYING COPYING-hiredis
  101. # Configuration file changes
  102. sed -i -e 's|^logfile .*$|logfile /var/log/redis/redis.log|g' redis.conf
  103. sed -i -e 's|^logfile .*$|logfile /var/log/redis/sentinel.log|g' sentinel.conf
  104. sed -i -e 's|^dir .*$|dir /var/lib/redis|g' redis.conf
  105. sed -i -e 's|^daemonize no$|daemonize yes|g' redis.conf
  106. sed -i -e 's|^protected-mode no$|protected-mode yes|g' redis.conf
  107. sed -i -e 's|^# bind 127\.0\.0\.1$|bind 127.0.0.1|g' redis.conf
  108. # Module API version safety check
  109. api=`sed -n -e 's/#define REDISMODULE_APIVER_[0-9][0-9]* //p' src/redismodule.h`
  110. if test "$api" != "%{redis_modules_abi}"; then
  111. : Error: Upstream API version is now ${api}, expecting %%{redis_modules_abi}.
  112. : Update the redis_modules_abi macro, the rpmmacros file, and rebuild.
  113. exit 1
  114. fi
  115. %global make_flags DEBUG="" V="echo" LDFLAGS="%{?__global_ldflags}" CFLAGS+="%{optflags} -fPIC" INSTALL="install -p" PREFIX=%{buildroot}%{_prefix}
  116. %build
  117. make %{?_smp_mflags} %{make_flags} all
  118. %check
  119. # make test
  120. %install
  121. make %{make_flags} install
  122. # Filesystem.
  123. install -d %{buildroot}%{_sharedstatedir}/%{name}
  124. install -d %{buildroot}%{_localstatedir}/log/%{name}
  125. install -d %{buildroot}%{_localstatedir}/run/%{name}
  126. install -d %{buildroot}%{redis_modules_dir}
  127. # Install logrotate file.
  128. install -pDm644 %{S:1} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  129. # Install configuration files.
  130. mkdir -p %{buildroot}%{_sysconfdir}/%{name}
  131. install -pDm640 %{name}.conf %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf
  132. install -pDm640 sentinel.conf %{buildroot}%{_sysconfdir}/%{name}/%{name}-sentinel.conf
  133. %if %{with systemd}
  134. # Install systemd unit files.
  135. mkdir -p %{buildroot}%{_unitdir}
  136. install -pm644 %{S:3} %{buildroot}%{_unitdir}
  137. install -pm644 %{S:2} %{buildroot}%{_unitdir}
  138. # Install systemd limit files (requires systemd >= 204)
  139. install -p -D -m 644 %{S:7} %{buildroot}%{_sysconfdir}/systemd/system/%{name}.service.d/limit.conf
  140. install -p -D -m 644 %{S:7} %{buildroot}%{_sysconfdir}/systemd/system/%{name}-sentinel.service.d/limit.conf
  141. %else
  142. mkdir -p %{buildroot}%{_initdir}
  143. install -pm755 %{S:4} %{buildroot}%{_initdir}/%{name}-sentinel
  144. install -pm755 %{S:5} %{buildroot}%{_initdir}/%{name}
  145. install -pm755 %{S:8} %{buildroot}%{_initdir}/%{name}-limit
  146. %endif
  147. # Fix non-standard-executable-perm error.
  148. chmod 755 %{buildroot}%{_bindir}/%{name}-*
  149. # Install redis-shutdown
  150. install -pDm755 %{S:6} %{buildroot}%{_libexecdir}/%{name}-shutdown
  151. # Install redis module header
  152. install -pDm644 src/%{name}module.h %{buildroot}%{_includedir}/%{name}module.h
  153. # Install man pages
  154. man=$(dirname %{buildroot}%{_mandir})
  155. for page in man/man?/*; do
  156. install -Dpm644 $page $man/$page
  157. done
  158. ln -s redis-server.1 %{buildroot}%{_mandir}/man1/redis-sentinel.1
  159. ln -s redis.conf.5 %{buildroot}%{_mandir}/man5/redis-sentinel.conf.5
  160. # Install documentation and html pages
  161. doc=$(echo %{buildroot}/%{_docdir}/%{name})
  162. for page in 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO; do
  163. install -Dpm644 $page $doc/$page
  164. done
  165. for page in $(find doc -name \*.md | sed -e 's|.md$||g'); do
  166. base=$(echo $page | sed -e 's|doc/||g')
  167. install -Dpm644 $page.md $doc/$base.md
  168. done
  169. # Install rpm macros for redis modules
  170. mkdir -p %{buildroot}%{macrosdir}
  171. install -pDm644 %{S:9} %{buildroot}%{macrosdir}/macros.%{name}
  172. %post
  173. %if %{with systemd}
  174. %systemd_post %{name}.service
  175. %systemd_post %{name}-sentinel.service
  176. %else
  177. if [ $1 -eq 1 ]; then
  178. /sbin/chkconfig --add %{name}
  179. /sbin/chkconfig --add %{name}-sentinel
  180. fi
  181. %endif
  182. %pre
  183. getent group %{name} &> /dev/null || \
  184. groupadd -r %{name} &> /dev/null
  185. getent passwd %{name} &> /dev/null || \
  186. useradd -r -g %{name} -d %{_sharedstatedir}/%{name} -s /sbin/nologin \
  187. -c 'Redis Database Server' %{name} &> /dev/null
  188. exit 0
  189. %preun
  190. %if %{with systemd}
  191. %systemd_preun %{name}.service
  192. %systemd_preun %{name}-sentinel.service
  193. %else
  194. if [ $1 -eq 0 -o -x /sbin/systemctl ]; then
  195. /sbin/service %{name} stop ||:
  196. /sbin/service %{name}-sentinel stop ||:
  197. /sbin/chkconfig --del %{name}
  198. /sbin/chkconfig --del %{name}-sentinel
  199. fi
  200. %endif
  201. %postun
  202. %if %{with systemd}
  203. %systemd_postun_with_restart %{name}.service
  204. %systemd_postun_with_restart %{name}-sentinel.service
  205. %else
  206. if [ $1 -gt 0 ]; then
  207. if [ -x /sbin/systemctl ]; then
  208. /sbin/service %{name} stop ||:
  209. else
  210. /sbin/service %{name} condrestart ||:
  211. fi
  212. fi
  213. %endif
  214. %files
  215. %{!?_licensedir:%global license %%doc}
  216. %license COPYING
  217. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  218. %dir %{_sysconfdir}/%{name}
  219. %attr(0640, redis, root) %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
  220. %attr(0640, redis, root) %config(noreplace) %{_sysconfdir}/%{name}/%{name}-sentinel.conf
  221. %dir %attr(0750, redis, redis) %{_libdir}/%{name}
  222. %dir %attr(0750, redis, redis) %{redis_modules_dir}
  223. %dir %attr(0750, redis, redis) %{_sharedstatedir}/%{name}
  224. %dir %attr(0750, redis, redis) %{_localstatedir}/log/%{name}
  225. %exclude %{macrosdir}
  226. %exclude %{_includedir}
  227. %exclude %{_docdir}/%{name}/*
  228. %{_bindir}/%{name}-*
  229. %{_libexecdir}/%{name}-*
  230. %{_mandir}/man1/%{name}*
  231. %{_mandir}/man5/%{name}*
  232. %if %{with systemd}
  233. %{_unitdir}/%{name}.service
  234. %{_unitdir}/%{name}-sentinel.service
  235. %dir %{_sysconfdir}/systemd/system/%{name}.service.d
  236. %config(noreplace) %{_sysconfdir}/systemd/system/%{name}.service.d/limit.conf
  237. %dir %{_sysconfdir}/systemd/system/%{name}-sentinel.service.d
  238. %config(noreplace) %{_sysconfdir}/systemd/system/%{name}-sentinel.service.d/limit.conf
  239. %else
  240. %{_initdir}/*
  241. %endif
  242. %dir %attr(0755, redis, redis) %{_localstatedir}/run/%{name}
  243. %files devel
  244. %license COPYING
  245. %license COPYRIGHT-lua
  246. %license COPYING-hiredis
  247. %{_includedir}/%{name}module.h
  248. %{macrosdir}/*
  249. %files doc
  250. %docdir %{_docdir}/%{name}
  251. %{_docdir}/%{name}
  252. %changelog
  253. * Sat Dec 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.9-1
  254. - new upstream release.
  255. * Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.5-1
  256. - new upstream release.
  257. * Fri Apr 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.8-1
  258. - new upstream release.
  259. * Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.5-1
  260. - new upstream release.
  261. * Mon Mar 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.10-1
  262. - update to 2.6.10
  263. * Sat Oct 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.15-1
  264. - initial build for Vine Linux
  265. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.15-3
  266. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  267. * Sun Jul 08 2012 Silas Sewell <silas@sewell.org> - 2.4.15-2
  268. - Remove TODO from docs
  269. * Sun Jul 08 2012 Silas Sewell <silas@sewell.org> - 2.4.15-1
  270. - Update to redis 2.4.15
  271. * Sat May 19 2012 Silas Sewell <silas@sewell.org> - 2.4.13-1
  272. - Update to redis 2.4.13
  273. * Sat Mar 31 2012 Silas Sewell <silas@sewell.org> - 2.4.10-1
  274. - Update to redis 2.4.10
  275. * Fri Feb 24 2012 Silas Sewell <silas@sewell.org> - 2.4.8-1
  276. - Update to redis 2.4.8
  277. * Sat Feb 04 2012 Silas Sewell <silas@sewell.org> - 2.4.7-1
  278. - Update to redis 2.4.7
  279. * Wed Feb 01 2012 Fabian Deutsch <fabiand@fedoraproject.org> - 2.4.6-4
  280. - Fixed a typo in the spec
  281. * Tue Jan 31 2012 Fabian Deutsch <fabiand@fedoraproject.org> - 2.4.6-3
  282. - Fix .service file, to match config (Type=simple).
  283. * Tue Jan 31 2012 Fabian Deutsch <fabiand@fedoraproject.org> - 2.4.6-2
  284. - Fix .service file, credits go to Timon.
  285. * Thu Jan 12 2012 Fabian Deutsch <fabiand@fedoraproject.org> - 2.4.6-1
  286. - Update to 2.4.6
  287. - systemd unit file added
  288. - Compiler flags changed to compile 2.4.6
  289. - Remove doc/ and Changelog
  290. * Sun Jul 24 2011 Silas Sewell <silas@sewell.org> - 2.2.12-1
  291. - Update to redis 2.2.12
  292. * Fri May 06 2011 Dan Horák <dan[at]danny.cz> - 2.2.5-2
  293. - google-perftools exists only on selected architectures
  294. * Sat Apr 23 2011 Silas Sewell <silas@sewell.ch> - 2.2.5-1
  295. - Update to redis 2.2.5
  296. * Sat Mar 26 2011 Silas Sewell <silas@sewell.ch> - 2.2.2-1
  297. - Update to redis 2.2.2
  298. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.4-2
  299. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  300. * Sun Dec 19 2010 Silas Sewell <silas@sewell.ch> - 2.0.4-1
  301. - Update to redis 2.0.4
  302. * Tue Oct 19 2010 Silas Sewell <silas@sewell.ch> - 2.0.3-1
  303. - Update to redis 2.0.3
  304. * Fri Oct 08 2010 Silas Sewell <silas@sewell.ch> - 2.0.2-1
  305. - Update to redis 2.0.2
  306. - Disable checks section for el5
  307. * Sat Sep 11 2010 Silas Sewell <silas@sewell.ch> - 2.0.1-1
  308. - Update to redis 2.0.1
  309. * Sat Sep 04 2010 Silas Sewell <silas@sewell.ch> - 2.0.0-1
  310. - Update to redis 2.0.0
  311. * Thu Sep 02 2010 Silas Sewell <silas@sewell.ch> - 1.2.6-3
  312. - Add Fedora build flags
  313. - Send all scriplet output to /dev/null
  314. - Remove debugging flags
  315. - Add redis.conf check to init script
  316. * Mon Aug 16 2010 Silas Sewell <silas@sewell.ch> - 1.2.6-2
  317. - Don't compress man pages
  318. - Use patch to fix redis.conf
  319. * Tue Jul 06 2010 Silas Sewell <silas@sewell.ch> - 1.2.6-1
  320. - Initial package