readline-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370
  1. Summary: A library for editing typed in command lines.
  2. Summary(ja): Readline ライブラリ
  3. Name: readline
  4. Version: 8.0.4
  5. %global shortver %(echo %{version} | cut -d . -f 1-2)
  6. %global shortver_nodots %(echo %{shortver} | tr -d ".")
  7. Release: 1%{?_dist_release}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPLv3+
  12. URL: http://tiswww.tis.case.edu/~chet/readline/rltop.html
  13. %global baseurl https://ftp.gnu.org/gnu/readline
  14. Source: %{baseurl}/readline-%{shortver}.tar.gz
  15. # upstream patches
  16. Patch1: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-001
  17. Patch2: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-002
  18. Patch3: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-003
  19. Patch4: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-004
  20. # fix file permissions, remove RPATH, use CFLAGS
  21. Patch100: readline-8.0-shlib.patch
  22. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. BuildRequires: sed
  24. BuildRequires: ncurses-devel
  25. Requires(post): /sbin/install-info, /sbin/ldconfig
  26. Requires(preun): /sbin/install-info
  27. Requires(postun): /sbin/ldconfig
  28. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  29. %description
  30. The Readline library provides a set of functions that allow users to
  31. edit command lines. Both Emacs and vi editing modes are available. The
  32. Readline library includes additional functions for maintaining a list
  33. of previously-entered command lines for recalling or editing those
  34. lines, and for performing csh-like history expansion on previous
  35. commands.
  36. %description -l ja
  37. Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
  38. Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
  39. これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
  40. %package devel
  41. Summary: Files needed to develop programs which use the readline library.
  42. Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
  43. Group: programming
  44. Requires: readline = %{version}
  45. Requires: ncurses-devel
  46. %description devel
  47. The Readline library provides a set of functions that allow users to
  48. edit typed command lines. If you want to develop programs that will
  49. use the readline library, you need to have the readline-devel package
  50. installed. You also need to have the readline package installed.
  51. %package -n compat32-%{name}
  52. Summary: A library for editing typed in command lines.
  53. Summary(ja): Readline ライブラリ
  54. Group: system
  55. Requires: %{name} = %{version}-%{release}
  56. %description -n compat32-%{name}
  57. The Readline library provides a set of functions that allow users to
  58. edit command lines. Both Emacs and vi editing modes are available. The
  59. Readline library includes additional functions for maintaining a list
  60. of previously-entered command lines for recalling or editing those
  61. lines, and for performing csh-like history expansion on previous
  62. commands.
  63. %description -n compat32-%{name} -l ja
  64. Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
  65. Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
  66. これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
  67. %package -n compat32-%{name}-devel
  68. Summary: Files needed to develop programs which use the readline library.
  69. Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
  70. Group: programming
  71. Requires: %{name} = %{version}-%{release}
  72. Requires: %{name}-devel = %{version}-%{release}
  73. Requires: compat32-ncurses-devel
  74. %description -n compat32-%{name}-devel
  75. The Readline library provides a set of functions that allow users to
  76. edit typed command lines. If you want to develop programs that will
  77. use the readline library, you need to have the readline-devel package
  78. installed. You also need to have the readline package installed.
  79. %debug_package
  80. %prep
  81. %setup -q -n %{name}-%{shortver}
  82. # upstream patches
  83. %patch1 -p0 -b .001
  84. %patch2 -p0 -b .002
  85. %patch3 -p0 -b .003
  86. %patch4 -p0 -b .004
  87. %patch100 -p1 -b .shlib
  88. %build
  89. %configure --with-curses --disable-install-examples
  90. make %{?_smp_mflags}
  91. %install
  92. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  93. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  94. make DESTDIR=$RPM_BUILD_ROOT install
  95. mkdir $RPM_BUILD_ROOT/%{_lib}
  96. mv $RPM_BUILD_ROOT%{_libdir}/libreadline.so.* $RPM_BUILD_ROOT/%{_lib}
  97. for l in $RPM_BUILD_ROOT%{_libdir}/libreadline.so; do
  98. ln -sf $(echo %{_libdir} | \
  99. sed 's,\(^/\|\)[^/][^/]*,..,g')/%{_lib}/$(readlink $l) $l
  100. done
  101. rm -rf $RPM_BUILD_ROOT%{_docdir}/readline
  102. rm -rf $RPM_BUILD_ROOT%{_datadir}/readline
  103. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  104. %clean
  105. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  106. %post
  107. /sbin/ldconfig
  108. /sbin/install-info %{_infodir}/history.info.gz %{_infodir}/dir &> /dev/null
  109. /sbin/install-info %{_infodir}/rluserman.info.gz %{_infodir}/dir &> /dev/null
  110. :
  111. %postun -p /sbin/ldconfig
  112. %post -n compat32-%{name} -p /sbin/ldconfig
  113. %postun -n compat32-%{name} -p /sbin/ldconfig
  114. %preun
  115. if [ $1 = 0 ]; then
  116. /sbin/install-info --delete %{_infodir}/history.info.gz %{_infodir}/dir &> /dev/null
  117. /sbin/install-info --delete %{_infodir}/rluserman.info.gz %{_infodir}/dir &> /dev/null
  118. fi
  119. :
  120. %post devel
  121. /sbin/install-info %{_infodir}/readline.info.gz %{_infodir}/dir &> /dev/null
  122. :
  123. %preun devel
  124. if [ $1 = 0 ]; then
  125. /sbin/install-info --delete %{_infodir}/readline.info.gz %{_infodir}/dir &> /dev/null
  126. fi
  127. :
  128. %files
  129. %defattr(-,root,root)
  130. %license COPYING
  131. %doc CHANGES NEWS README USAGE
  132. /%{_lib}/libreadline*.so.*
  133. %{_libdir}/libhistory*.so.*
  134. %{_infodir}/history.info*
  135. %{_infodir}/rluserman.info*
  136. %files devel
  137. %defattr(-,root,root)
  138. %doc examples/*.c examples/*.h examples/rlfe
  139. %{_includedir}/readline
  140. %{_libdir}/lib*.a
  141. %{_libdir}/lib*.so
  142. %{_libdir}/pkgconfig/*.pc
  143. %{_infodir}/readline.info*
  144. %{_mandir}/man*/*
  145. %if %{build_compat32}
  146. %files -n compat32-%{name}
  147. %defattr(-,root,root)
  148. /%{_lib}/libreadline*.so.*
  149. %{_libdir}/libhistory*.so.*
  150. %files -n compat32-%{name}-devel
  151. %defattr(-,root,root)
  152. %{_libdir}/lib*.a
  153. %{_libdir}/lib*.so
  154. %{_libdir}/pkgconfig/*.pc
  155. %endif
  156. %changelog
  157. * Sat Sep 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0.4-1
  158. - updated to patchlevel 004.
  159. * Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0-1
  160. - new upstream release.
  161. - dropped all of official patches.
  162. - added Patch1.
  163. - dropped Patch9.
  164. - updated Patch10.
  165. * Sat Mar 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.3-1
  166. - new upstream release
  167. - update upstream patches (patch1-8)
  168. * Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2-5
  169. - rebuild with VineSeed environment
  170. * Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 5.2-4
  171. - add upstream patches 13,14 (Patch13,14)
  172. * Fri Mar 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.2-3
  173. - rebuilt with new toolchain
  174. - add Requires(post,pre): /sbin/ldconfig
  175. * Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2-2vl5
  176. - build with ncurses-devel
  177. - spec in utf8
  178. - move libncurses.so.* to %%_lib from %%_libdir
  179. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-1vl5
  180. - added upstream patches (patch8-12)
  181. * Fri Oct 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-0vl1
  182. - new upstream release
  183. - update upstream patches (patch1-7)
  184. * Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 5.1-0vl1
  185. - new upstream release
  186. - update upstream patches (patch1-4)
  187. - add doc/*.{html,pdf} instead of doc/
  188. * Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.3-5vl3
  189. - s/Copyright/License/
  190. - add URL
  191. - update source URL
  192. - add PreReq: ldconfig
  193. - move outdated.patch (patch1) to patch10
  194. - add upstream patches (patch1-5)
  195. - add no_rpath.patch (patch11)
  196. * Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 4.3-5vl2
  197. - added compat32- packages for x86_64 architecture support
  198. - fixed %files section (TODO* has been removed)
  199. * Sat Mar 8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3-5vl1
  200. - new upstream release 4.3
  201. - merged with rawhide package.
  202. * Wed Nov 20 2002 Tim Powers <timp@redhat.com>
  203. - rebuild in current collinst
  204. - BuildRequires autoconf only
  205. * Wed Aug 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-3
  206. - Fixed Esc-O-M stack overflow bug.
  207. * Mon Jul 22 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-1
  208. - Updated to latest readline release 4.3
  209. * Thu Jul 11 2002 Phil Knirsch <pknirsch@redhat.com> 4.2a-7
  210. - Fixed problem with alpha build.
  211. * Wed Jul 10 2002 Phil Knirsch <pknirsch@redhat.com>
  212. - Fixed utf8 problem (originally observed in bash).
  213. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 4.2a-6
  214. - automated rebuild
  215. * Thu May 23 2002 Tim Powers <timp@redhat.com> 4.2a-5
  216. - automated rebuild
  217. * Wed Mar 20 2002 Trond Eivind Glomsrod <teg@redhat.com> 4.2a-4
  218. - Use autoconf 2.53, not 2.52
  219. * Mon Mar 4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-3
  220. - Rebuild
  221. * Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 4.2a-2
  222. - removed the manual symlinking of .so, readline handles this by itself
  223. - call only %%makeinstall, not %%makeinstall install install-shared as
  224. this makes bogus .old files in the buildroot
  225. * Tue Nov 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-1
  226. - 4.2a
  227. * Tue Oct 2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-4
  228. - Work around autoconf bug
  229. * Mon Oct 1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-3
  230. - Don't use readline's internal re-implementation of strpbrk on systems
  231. that have strpbrk - the system implementation is faster and better maintained.
  232. * Tue Aug 7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-2
  233. - Make sure headers can be included from C++ applications (#51131)
  234. (Patch based on Debian's with the bugs removed ;) )
  235. * Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  236. - update to 4.2 and adapt patches
  237. * Fri Apr 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  238. - change the paths listed for the header files in the man page to reflect
  239. the location changes from previous versions (#35073)
  240. - note that "on" is acceptable instead of "On" in the man page (#21327)
  241. * Thu Mar 8 2001 Preston Brown <pbrown@redhat.com>
  242. - fix reading of end key termcap value (@7 is correct, was kH) (#30884)
  243. * Tue Jan 30 2001 Nalin Dahyabhai <nalin@redhat.com>
  244. - mark the man page as currently out-of-date (#25294)
  245. * Tue Sep 4 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl5
  246. - remove texi2dvi and texi2html from doc/
  247. * Fri Jun 29 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl4
  248. - added doc and examples
  249. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  250. - 4.1-6vl3
  251. - rebuilt for VineSeed
  252. * Wed Dec 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  253. - 4.1-6vl2
  254. - Oops, spec was written in SJIS...
  255. * Sat Dec 9 2000 Jun Nishii <jun@vinelinux.org>
  256. - 4.1-6vl1
  257. - got i18n patch from Kondara
  258. * Thu Sep 7 2000 Jeff Johnson <jbj@redhat.com>
  259. - FHS packaging (64bit systems need to use libdir).
  260. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  261. - summaries from specspo.
  262. * Wed Aug 2 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  263. - use "rm -f" in specfile
  264. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  265. - automatic rebuild
  266. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  267. - FHS packaging.
  268. * Tue Mar 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  269. - 4.1
  270. * Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
  271. - update to 4.0
  272. * Fri Apr 09 1999 Michael K. Johnson <johnsonm@redhat.com>
  273. - added guard patch from Taneli Huuskonen <huuskone@cc.helsinki.fi>
  274. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  275. - auto rebuild in the new build environment (release 4)
  276. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  277. - updated to 2.2.1
  278. * Wed May 06 1998 Prospector System <bugs@redhat.com>
  279. - translations modified for de, fr, tr
  280. * Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
  281. - don't package /usr/info/dir
  282. * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
  283. - devel package moved to Development/Libraries
  284. * Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
  285. - updated to 2.2
  286. * Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
  287. - spec file cleanups
  288. * Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
  289. - added proper sonames
  290. * Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
  291. - updated to readline 2.1
  292. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  293. - built against glibc