qzion-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. Name: qzion
  4. Summary: A canvas abstraction
  5. Version: 0.4.0
  6. Release: 8%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: GPLv3+
  9. URL: http://code.openbossa.org/projects/qzion
  10. Source0: http://code.openbossa.org/projects/%{name}/repos/mainline/archive/d32223eae1bba7f1b191c334668f3f7dd662f582.tar.gz
  11. Patch0: qzion-0.4.0-fix_python_install.patch
  12. Patch1: qzion-0.4.0-fix_char_conversion.patch
  13. #Make configure_file use full path so that qzion.pc can be found correctly.
  14. Patch2: qzion-0.4.0-fix_configure_paths.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: qt4-devel
  17. BuildRequires: PyQt4-devel
  18. BuildRequires: cmake
  19. BuildRequires: pkgconfig
  20. BuildRequires: python-devel
  21. BuildRequires: sip-devel
  22. %description
  23. QZion is an canvas abstraction used by and made for QEdje.
  24. %package devel
  25. Summary: Development files for %{name}
  26. Group: Development/Libraries
  27. Requires: cmake
  28. Requires: pkgconfig
  29. Requires: %{name} = %{version}-%{release}
  30. %description devel
  31. The %{name}-devel package contains libraries and header files for
  32. developing applications that use %{name}.
  33. %package python
  34. Summary: Python bindings for %{name}
  35. Group: Development/Libraries
  36. Requires: PyQt4
  37. %description python
  38. The %{name}-python package contains python bindings for %{name}
  39. %package python-devel
  40. Summary: Python bindings for %{name}
  41. Group: Development/Libraries
  42. Requires: sip
  43. Requires: PyQt4-devel
  44. Requires: %{name}-python = %{version}-%{release}
  45. %description python-devel
  46. The %{name}-python-devel package contains the development files for
  47. the python bindings for %{name}
  48. %prep
  49. %setup -q -n %{name}-mainline
  50. %patch0 -p1
  51. %patch1 -p1
  52. %patch2 -p1
  53. %build
  54. mkdir -p %{_target_platform}
  55. pushd %{_target_platform}
  56. %cmake \
  57. -DPYTHON_SITE_PACKAGES_DIR=%{python_sitearch} \
  58. ..
  59. popd
  60. make %{?_smp_mflags} -C %{_target_platform}
  61. %install
  62. rm -rf %{buildroot}
  63. make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
  64. %clean
  65. rm -rf %{buildroot}
  66. %post -p /sbin/ldconfig
  67. %postun -p /sbin/ldconfig
  68. %files
  69. %defattr(-,root,root,-)
  70. %doc README COPYING
  71. %{_libdir}/*.so.*
  72. %files devel
  73. %defattr(-,root,root,-)
  74. %{_libdir}/*.so
  75. %{_includedir}/*
  76. %{_libdir}/pkgconfig/%{name}.pc
  77. %files python
  78. %defattr(-,root,root,-)
  79. %{python_sitearch}/%{name}
  80. %files python-devel
  81. %defattr(-,root,root,-)
  82. %{_datadir}/sip/%{name}
  83. %changelog
  84. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.0-8
  85. - rebuild with gcc-5.4.0
  86. * Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-7
  87. - rebuilt with rpm-4.8.1 for pkg-config
  88. * Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.0-6
  89. - rebuilt with python2.6
  90. * Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 0.4.0-5
  91. - use %%cmake macro
  92. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.4.0-4
  93. - Initial build for Vine Linux
  94. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-3
  95. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  96. * Thu Jul 16 2009 John5342 <john5342 at, fedoraproject.org> 0.4.0-2
  97. - Fix char* conversion (#511583)
  98. * Fri Mar 06 2009 John5342 <john5342 at, fedoraproject.org> 0.4.0-1
  99. - Updated to new upstream release (0.4.0)
  100. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-3
  101. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  102. * Fri Dec 19 2008 John5342 <john5342 at, fedoraproject.org> 0.3.0-2
  103. - Implemented package review suggestions
  104. - Remove BR: eet-devel
  105. * Fri Dec 19 2008 John5342 <john5342 at, fedoraproject.org> 0.3.0-1
  106. - Initial package