qt5-qtwebengine-vl.spec 29 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776
  1. %global qt_module qtwebengine
  2. %global _hardened_build 1
  3. # define to build docs, need to undef this for bootstrapping
  4. # where qt5-qttools builds are not yet available
  5. # only primary archs (for now), allow secondary to bootstrap
  6. %ifarch %{arm} %{ix86} x86_64
  7. #global docs 1
  8. %endif
  9. %if 0
  10. # need libvpx >= 1.8.0
  11. %global use_system_libvpx 1
  12. %endif
  13. %if 0
  14. # need libwebp >= 0.4.3
  15. %global use_system_libwebp 1
  16. %endif
  17. #global prerelease rc
  18. # spellchecking dictionary directory
  19. %global _qtwebengine_dictionaries_dir %{_qt5_datadir}/qtwebengine_dictionaries
  20. %global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
  21. # exclude plugins (all architectures) and libv8.so (i686, it's static everywhere
  22. # else)
  23. %global __provides_exclude ^lib.*plugin\\.so.*|libv8\\.so$
  24. # exclude libv8.so (i686, it's static everywhere else)
  25. %global __requires_exclude ^libv8\\.so$
  26. # and designer plugins
  27. %global __provides_exclude_from ^%{_qt5_plugindir}/.*\\.so$
  28. %global qt5_minorver 5.12
  29. %global qt5_version 5.12.8
  30. #global qt5_patchlevel 1
  31. Summary: Qt5 - QtWebEngine components
  32. Name: qt5-qtwebengine
  33. Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
  34. Release: 2%{?_dist_release}
  35. # See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
  36. # See also http://qt-project.org/doc/qt-5.0/qtdoc/licensing.html
  37. # The other licenses are from Chromium and the code it bundles
  38. License: (LGPLv2 with exceptions or GPLv3 with exceptions) and BSD and LGPLv2+ and ASL 2.0 and IJG and MIT and GPLv2+ and ISC and OpenSSL and (MPLv1.1 or GPLv2 or LGPLv2)
  39. URL: https://www.qt.io/
  40. Vendor: Project Vine
  41. Distribution: Vine Linux
  42. # cleaned tarball with patent-encumbered codecs removed from the bundled FFmpeg
  43. # wget https://download.qt.io/official_releases/qt/5.6/5.6.1-1/submodules/qtwebengine-everywhere-src-5.6.1-1.tar.xz
  44. # ./clean_qtwebengine.sh 5.6.1-1
  45. Source0: %{qt_module}-everywhere-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}-clean.tar.xz
  46. # cleanup scripts used above
  47. Source1: clean_qtwebengine.sh
  48. Source2: clean_ffmpeg.sh
  49. Source3: get_free_ffmpeg_source_files.py
  50. # macros
  51. Source10: macros.qt5-qtwebengine
  52. # pulseaudio headers
  53. Source20: pulseaudio-12.2-headers.tar.gz
  54. # some tweaks to linux.pri (system yasm, link libpci, run unbundling script)
  55. Patch0: qtwebengine-everywhere-src-5.10.0-linux-pri.patch
  56. # quick hack to avoid checking for the nonexistent icudtl.dat and silence the
  57. # resulting warnings - not upstreamable as is because it removes the fallback
  58. # mechanism for the ICU data directory (which is not used in our builds because
  59. # we use the system ICU, which embeds the data statically) completely
  60. Patch1: qtwebengine-everywhere-src-5.11.0-no-icudtl-dat.patch
  61. # fix extractCFlag to also look in QMAKE_CFLAGS_RELEASE, needed to detect the
  62. # ARM flags with our %%qmake_qt5 macro, including for the next patch
  63. Patch2: qtwebengine-opensource-src-5.12.4-fix-extractcflag.patch
  64. # disable NEON vector instructions on ARM where the NEON code FTBFS due to
  65. # GCC bug https://bugzilla.redhat.com/show_bug.cgi?id=1282495
  66. Patch3: qtwebengine-opensource-src-5.9.0-no-neon.patch
  67. # workaround FTBFS against kernel-headers-5.2.0+
  68. Patch4: qtwebengine-SIOCGSTAMP.patch
  69. # remove Android dependencies from openmax_dl ARM NEON detection (detect.c)
  70. Patch10: qtwebengine-opensource-src-5.9.0-openmax-dl-neon.patch
  71. # Force verbose output from the GN bootstrap process
  72. Patch21: qtwebengine-everywhere-src-5.12.0-gn-bootstrap-verbose.patch
  73. # Fix/workaround FTBFS on aarch64 with newer glibc
  74. Patch24: qtwebengine-everywhere-src-5.11.3-aarch64-new-stat.patch
  75. # handled by qt5-srpm-macros, which defines %%qt5_qtwebengine_arches
  76. ExclusiveArch: %{qt5_qtwebengine_arches}
  77. BuildRequires: qt5-rpm-macros
  78. BuildRequires: qt5-srpm-macros
  79. BuildRequires: qt5-qtbase-devel
  80. BuildRequires: qt5-qtbase-private-devel
  81. # TODO: check of = is really needed or if >= would be good enough -- rex
  82. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  83. BuildRequires: qt5-qtdeclarative-devel
  84. BuildRequires: qt5-qtxmlpatterns-devel
  85. BuildRequires: qt5-qtlocation-devel
  86. BuildRequires: qt5-qtsensors-devel
  87. BuildRequires: qt5-qtwebchannel-devel
  88. BuildRequires: qt5-qttools-static
  89. # for examples?
  90. BuildRequires: qt5-qtquickcontrols2-devel
  91. BuildRequires: ninja
  92. BuildRequires: cmake
  93. BuildRequires: bison
  94. BuildRequires: flex
  95. BuildRequires: gcc-c++
  96. # gn links statically (for now)
  97. BuildRequires: libstdc++-static
  98. BuildRequires: git-core
  99. BuildRequires: gperf
  100. BuildRequires: krb5-devel
  101. BuildRequires: libicu-devel
  102. BuildRequires: libjpeg-turbo-devel
  103. #BuildRequires: re2-devel
  104. BuildRequires: snappy-devel
  105. %ifarch %{ix86} x86_64
  106. BuildRequires: yasm
  107. %endif
  108. BuildRequires: pkgconfig(expat)
  109. BuildRequires: pkgconfig(gobject-2.0)
  110. BuildRequires: pkgconfig(glib-2.0)
  111. BuildRequires: pkgconfig(fontconfig)
  112. BuildRequires: pkgconfig(freetype2)
  113. BuildRequires: pkgconfig(gl)
  114. BuildRequires: pkgconfig(egl)
  115. BuildRequires: pkgconfig(jsoncpp)
  116. BuildRequires: pkgconfig(libpng)
  117. BuildRequires: pkgconfig(libudev)
  118. %if 0%{?use_system_libwebp}
  119. BuildRequires: pkgconfig(libwebp) >= 0.6.0
  120. %endif
  121. BuildRequires: pkgconfig(harfbuzz)
  122. BuildRequires: pkgconfig(libdrm)
  123. BuildRequires: opus-devel
  124. BuildRequires: pkgconfig(protobuf)
  125. BuildRequires: pkgconfig(libevent)
  126. BuildRequires: zlib-devel
  127. #BuildRequires: pkgconfig(minizip)
  128. BuildRequires: pkgconfig(x11)
  129. BuildRequires: pkgconfig(xi)
  130. BuildRequires: libXcursor-devel
  131. BuildRequires: pkgconfig(xext)
  132. BuildRequires: pkgconfig(xfixes)
  133. BuildRequires: pkgconfig(xrender)
  134. BuildRequires: pkgconfig(xdamage)
  135. BuildRequires: pkgconfig(xcomposite)
  136. BuildRequires: pkgconfig(xtst)
  137. BuildRequires: pkgconfig(xrandr)
  138. BuildRequires: pkgconfig(xscrnsaver)
  139. BuildRequires: pkgconfig(libcap)
  140. BuildRequires: pkgconfig(libpulse)
  141. BuildRequires: pkgconfig(alsa)
  142. BuildRequires: pciutils-devel
  143. BuildRequires: pkgconfig(dbus-1)
  144. BuildRequires: pkgconfig(nss)
  145. BuildRequires: pkgconfig(lcms2)
  146. BuildRequires: perl
  147. BuildRequires: python
  148. BuildRequires: python-rpm-macros
  149. %if 0%{?use_system_libvpx}
  150. BuildRequires: pkgconfig(vpx) >= 1.7.0
  151. %endif
  152. # extra (non-upstream) functions needed, see
  153. # src/3rdparty/chromium/third_party/sqlite/README.chromium for details
  154. #BuildRequires: pkgconfig(sqlite3)
  155. ## Various bundled libraries that Chromium does not support unbundling :-(
  156. ## Only the parts actually built are listed.
  157. ## Query for candidates:
  158. ## grep third_party/ build.log | sed 's!third_party/!\nthird_party/!g' | \
  159. ## grep third_party/ | sed 's!^third_party/!!g' | sed 's!/.*$!!g' | \
  160. ## sed 's/\;.*$//g' | sed 's/ .*$//g' | sort | uniq | less
  161. ## some false positives where only shim headers are generated for some reason
  162. ## some false positives with dummy placeholder dirs (swiftshader, widevine)
  163. ## some false negatives where a header-only library is bundled (e.g. x86inc)
  164. ## Spot's chromium.spec also has a list that I checked.
  165. # Of course, Chromium itself is bundled. It cannot be unbundled because it is
  166. # not a library, but forked (modified) application code.
  167. # Some security fixes are backported, see:
  168. # http://code.qt.io/cgit/qt/qtwebengine-chromium.git/log/?h=45-based
  169. Provides: bundled(chromium) = 61.0.3163.140
  170. # Bundled in src/3rdparty/chromium/third_party:
  171. # Check src/3rdparty/chromium/third_party/*/README.chromium for version numbers,
  172. # except where specified otherwise.
  173. Provides: bundled(angle) = 2422
  174. # Google's fork of OpenSSL
  175. # We cannot build against NSS instead because it no longer works with NSS 3.21:
  176. # HTTPS on, ironically, Google's sites (Google, YouTube, etc.) stops working
  177. # completely and produces only ERR_SSL_PROTOCOL_ERROR errors:
  178. # http://kaosx.us/phpBB3/viewtopic.php?t=1235
  179. # https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1520568
  180. # So we have to do what Chromium 47 now defaults to: a "chimera build", i.e.,
  181. # use the BoringSSL code and the system NSS certificates.
  182. Provides: bundled(boringssl)
  183. Provides: bundled(brotli)
  184. # Don't get too excited. MPEG and other legally problematic stuff is stripped
  185. # out. See clean_qtwebengine.sh, clean_ffmpeg.sh, and process_ffmpeg_gyp.py.
  186. # see src/3rdparty/chromium/third_party/ffmpeg/Changelog for the version number
  187. Provides: bundled(ffmpeg) = 3.3
  188. Provides: bundled(hunspell) = 1.6.0
  189. Provides: bundled(iccjpeg)
  190. # bundled as "khronos", headers only
  191. Provides: bundled(khronos_headers)
  192. # bundled as "leveldatabase"
  193. Provides: bundled(leveldb) = 1.20
  194. # bundled as "libjingle_xmpp"
  195. Provides: bundled(libjingle)
  196. # see src/3rdparty/chromium/third_party/libsrtp/CHANGES for the version number
  197. Provides: bundled(libsrtp) = 2.1.0
  198. %if !0%{?use_system_libvpx}
  199. # claims "Version: 1.6.0", but according to the fine print, this is actually a
  200. # snapshot from master from after the 1.6.1 release
  201. Provides: bundled(libvpx) = 1.6.1
  202. %endif
  203. %if !0%{?use_system_libwebp}
  204. Provides: bundled(libwebp) = 0.6.0
  205. %endif
  206. # bundled as "libxml"
  207. # see src/3rdparty/chromium/third_party/libxml/linux/include/libxml/xmlversion.h
  208. Provides: bundled(libxml2) = 2.9.4
  209. # see src/3rdparty/chromium/third_party/libxslt/linux/config.h for version
  210. Provides: bundled(libxslt) = 1.1.29
  211. Provides: bundled(libXNVCtrl) = 302.17
  212. Provides: bundled(libyuv) = 1658
  213. Provides: bundled(modp_b64)
  214. Provides: bundled(openmax_dl) = 1.0.2
  215. Provides: bundled(ots)
  216. # see src/3rdparty/chromium/third_party/protobuf/CHANGES.txt for the version
  217. #Provides: bundled(protobuf) = 3.0.0-0.1.beta3
  218. Provides: bundled(qcms) = 4
  219. Provides: bundled(sfntly)
  220. Provides: bundled(skia)
  221. # bundled as "smhasher"
  222. Provides: bundled(SMHasher) = 0-0.1.svn147
  223. Provides: bundled(sqlite) = 3.20
  224. Provides: bundled(usrsctp)
  225. Provides: bundled(webrtc) = 90
  226. %ifarch %{ix86} x86_64
  227. # bundled by ffmpeg and libvpx:
  228. # header (for assembly) only
  229. Provides: bundled(x86inc)
  230. %endif
  231. # Bundled in src/3rdparty/chromium/base/third_party:
  232. # Check src/3rdparty/chromium/third_party/base/*/README.chromium for version
  233. # numbers, except where specified otherwise.
  234. Provides: bundled(dmg_fp)
  235. Provides: bundled(dynamic_annotations) = 4384
  236. Provides: bundled(superfasthash) = 0
  237. Provides: bundled(symbolize)
  238. # bundled as "valgrind", headers only
  239. Provides: bundled(valgrind.h)
  240. # bundled as "xdg_mime"
  241. Provides: bundled(xdg-mime)
  242. # bundled as "xdg_user_dirs"
  243. Provides: bundled(xdg-user-dirs) = 0.10
  244. # Bundled in src/3rdparty/chromium/net/third_party:
  245. # Check src/3rdparty/chromium/third_party/net/*/README.chromium for version
  246. # numbers, except where specified otherwise.
  247. Provides: bundled(mozilla_security_manager) = 1.9.2
  248. # Bundled in src/3rdparty/chromium/url/third_party:
  249. # Check src/3rdparty/chromium/third_party/url/*/README.chromium for version
  250. # numbers, except where specified otherwise.
  251. # bundled as "mozilla", file renamed and modified
  252. Provides: bundled(nsURLParsers)
  253. # Bundled outside of third_party, apparently not considered as such by Chromium:
  254. Provides: bundled(mojo)
  255. # see src/3rdparty/chromium/v8/include/v8_version.h for the version number
  256. Provides: bundled(v8) = 6.1.534.44
  257. # bundled by v8 (src/3rdparty/chromium/v8/src/base/ieee754.cc)
  258. # The version number is 5.3, the last version that upstream released, years ago:
  259. # http://www.netlib.org/fdlibm/readme
  260. Provides: bundled(fdlibm) = 5.3
  261. %{?_qt5_version:Requires: qt5-qtbase%{?_isa} >= %{_qt5_version}}
  262. %description
  263. %{summary}.
  264. %package devel
  265. Summary: Development files for %{name}
  266. Requires: %{name}%{?_isa} = %{version}-%{release}
  267. Requires: qt5-qtbase-devel%{?_isa}
  268. Requires: qt5-qtdeclarative-devel%{?_isa}
  269. # not arch'd for now, see if can get away with avoiding multilib'ing -- rex
  270. Requires: %{name}-devtools = %{version}-%{release}
  271. %description devel
  272. %{summary}.
  273. %package devtools
  274. Summary: WebEngine devtools_resources
  275. Requires: %{name}%{?_isa} = %{version}-%{release}
  276. %description devtools
  277. Support for remote debugging.
  278. %package examples
  279. Summary: Example files for %{name}
  280. %description examples
  281. %{summary}.
  282. %if 0%{?docs}
  283. %package doc
  284. Summary: API documentation for %{name}
  285. BuildRequires: qt5-qhelpgenerator
  286. BuildRequires: qt5-qdoc
  287. BuildArch: noarch
  288. %description doc
  289. %{summary}.
  290. %endif
  291. %debug_package
  292. %prep
  293. %setup -q -n %{qt_module}-everywhere-src-%{qt5_version}
  294. %if 0
  295. tar xvf %{SOURCE20}
  296. mv pulse src/3rdparty/chromium/
  297. %endif
  298. %patch0 -p1 -b .linux-pri
  299. %patch1 -p1 -b .no-icudtl-dat
  300. %patch2 -p1 -b .fix-extractcflag
  301. %if !0%{?arm_neon}
  302. %patch3 -p1 -b .no-neon
  303. %endif
  304. %patch4 -p1 -b .SIOCGSTAMP
  305. ## upstream patches
  306. %patch10 -p1 -b .openmax-dl-neon
  307. ## NEEDSWORK
  308. #patch21 -p1 -b .gn-bootstrap-verbose
  309. %patch24 -p1 -b .aarch64-new-stat
  310. # fix // in #include in content/renderer/gpu to avoid debugedit failure
  311. #sed -i -e 's!gpu//!gpu/!g' \
  312. # src/3rdparty/chromium/content/renderer/gpu/compositor_forwarding_message_filter.cc
  313. # and another one in 2 files in WebRTC
  314. sed -i -e 's!audio_processing//!audio_processing/!g' \
  315. src/3rdparty/chromium/third_party/webrtc/modules/audio_processing/utility/ooura_fft.cc \
  316. src/3rdparty/chromium/third_party/webrtc/modules/audio_processing/utility/ooura_fft_sse2.cc
  317. # remove ./ from #line commands in ANGLE to avoid debugedit failure (?)
  318. sed -i -e 's!\./!!g' \
  319. src/3rdparty/chromium/third_party/angle/src/compiler/preprocessor/Tokenizer.cpp \
  320. src/3rdparty/chromium/third_party/angle/src/compiler/translator/glslang_lex.cpp
  321. # delete all "toolprefix = " lines from build/toolchain/linux/BUILD.gn, as we
  322. # never cross-compile in native Fedora RPMs, fixes ARM and aarch64 FTBFS
  323. sed -i -e '/toolprefix = /d' -e 's/\${toolprefix}//g' \
  324. src/3rdparty/chromium/build/toolchain/linux/BUILD.gn
  325. # http://bugzilla.redhat.com/1337585
  326. # can't just delete, but we'll overwrite with system headers to be on the safe side
  327. #cp -bv /usr/include/re2/*.h src/3rdparty/chromium/third_party/re2/src/re2/
  328. %if 0
  329. #ifarch x86_64
  330. # enable this to force -g2 on x86_64 (most arches run out of memory with -g2)
  331. # DISABLED BECAUSE OF:
  332. # /usr/lib/rpm/find-debuginfo.sh: line 188: 3619 Segmentation fault
  333. # (core dumped) eu-strip --remove-comment $r $g -f "$1" "$2"
  334. sed -i -e 's/symbol_level=1/symbol_level=2/g' src/core/config/common.pri
  335. %endif
  336. # generate qtwebengine-3rdparty.qdoc, it is missing from the tarball
  337. pushd src/3rdparty
  338. %{__python} chromium/tools/licenses.py \
  339. --file-template ../../tools/about_credits.tmpl \
  340. --entry-template ../../tools/about_credits_entry.tmpl \
  341. credits >../webengine/doc/src/qtwebengine-3rdparty.qdoc
  342. popd
  343. # copy the Chromium license so it is installed with the appropriate name
  344. cp -p src/3rdparty/chromium/LICENSE LICENSE.Chromium
  345. %build
  346. export STRIP=strip
  347. export NINJAFLAGS="%{?__ninja_common_opts}"
  348. export NINJA_PATH=%{_bindir}/ninja-build
  349. export RE2_INCLUDE=$(pwd)/src/3rdparty/chromium/third_party/re2
  350. export CFLAGS="%{optflags}"
  351. #ifnarch x86_64
  352. # most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
  353. export CFLAGS=`echo "$CFLAGS" | sed -e 's/ -g / -g1 /g'`
  354. #endif
  355. export CXXFLAGS="%{optflags} -fno-delete-null-pointer-checks"
  356. #ifnarch x86_64
  357. # most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
  358. export CXXFLAGS=`echo "$CXXFLAGS" | sed -e 's/ -g / -g1 /g'`
  359. #endif
  360. mkdir %{_target_platform}
  361. pushd %{_target_platform}
  362. %{qmake_qt5} \
  363. %{?debug_config:CONFIG+="%{debug_config}"} \
  364. CONFIG+="link_pulseaudio" \
  365. QMAKE_EXTRA_ARGS+="-system-webengine-icu" \
  366. QMAKE_EXTRA_ARGS+="-webengine-kerberos" \
  367. ..
  368. # if we keep these set here, gyp picks up duplicate flags
  369. unset CFLAGS
  370. export CFLAGS
  371. unset CXXFLAGS
  372. export CXXFLAGS
  373. # workaround, disable parallel compilation as it fails to compile in brew
  374. make %{?_smp_mflags}
  375. %if 0%{?docs}
  376. make %{?_smp_mflags} docs
  377. %endif
  378. popd
  379. %install
  380. rm -rf %{buildroot}
  381. make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  382. %if 0%{?docs}
  383. make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  384. %endif
  385. # rpm macros
  386. install -p -m644 -D %{SOURCE10} \
  387. %{buildroot}%{rpm_macros_dir}/macros.qt5-qtwebengine
  388. sed -i \
  389. -e "s|@@NAME@@|%{name}|g" \
  390. -e "s|@@EPOCH@@|%{?epoch}%{!?epoch:0}|g" \
  391. -e "s|@@VERSION@@|%{version}|g" \
  392. -e "s|@@EVR@@|%{?epoch:%{epoch:}}%{version}-%{release}|g" \
  393. %{buildroot}%{rpm_macros_dir}/macros.qt5-qtwebengine
  394. # hardlink files to {_bindir}
  395. mkdir -p %{buildroot}%{_bindir}
  396. pushd %{buildroot}%{_qt5_bindir}
  397. for i in * ; do
  398. ln -v ${i} %{buildroot}%{_bindir}/${i}
  399. done
  400. popd
  401. ## .prl/.la file love
  402. # nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
  403. pushd %{buildroot}%{_qt5_libdir}
  404. for prl_file in libQt5*.prl ; do
  405. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
  406. if [ -f "$(basename ${prl_file} .prl).so" ]; then
  407. rm -fv "$(basename ${prl_file} .prl).la"
  408. sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
  409. fi
  410. done
  411. popd
  412. # explicitly omit, at least until there's a real library installed associated with it -- rex
  413. rm -fv %{buildroot}%{_libdir}/Qt5WebEngineCore.la
  414. mkdir -p %{buildroot}%{_qtwebengine_dictionaries_dir}
  415. # adjust cmake dep(s) to allow for using the same Qt5 that was used to build it
  416. # using the lesser of %%version, %%_qt5_version
  417. %global lesser_version $(echo -e "%{version}\\n%{_qt5_version}" | sort -V | head -1)
  418. sed -i -e "s|%{version} \${_Qt5WebEngine|%{lesser_version} \${_Qt5WebEngine|" \
  419. %{buildroot}%{_qt5_libdir}/cmake/Qt5WebEngine*/Qt5WebEngine*Config.cmake
  420. %post -p /sbin/ldconfig
  421. %postun -p /sbin/ldconfig
  422. %files
  423. %license LICENSE.* src/webengine/doc/src/qtwebengine-3rdparty.qdoc
  424. %{_qt5_libdir}/libQt5*.so.*
  425. %{_bindir}/qwebengine_convert_dict
  426. %{_qt5_bindir}/qwebengine_convert_dict
  427. %{_qt5_libdir}/qt5/qml/*
  428. %{_qt5_libdir}/qt5/libexec/QtWebEngineProcess
  429. #ifarch %{ix86}
  430. %if 0%{?sse2}
  431. # shared V8 library and its SSE2 version
  432. %{_qt5_libdir}/qtwebengine/
  433. %endif
  434. %{_qt5_plugindir}/designer/libqwebengineview.so
  435. %dir %{_qt5_datadir}/resources/
  436. %{_qt5_datadir}/resources/qtwebengine_resources_100p.pak
  437. %{_qt5_datadir}/resources/qtwebengine_resources_200p.pak
  438. %{_qt5_datadir}/resources/qtwebengine_resources.pak
  439. %dir %{_qtwebengine_dictionaries_dir}
  440. %dir %{_qt5_translationdir}/qtwebengine_locales
  441. %lang(am) %{_qt5_translationdir}/qtwebengine_locales/am.pak
  442. %lang(ar) %{_qt5_translationdir}/qtwebengine_locales/ar.pak
  443. %lang(bg) %{_qt5_translationdir}/qtwebengine_locales/bg.pak
  444. %lang(bn) %{_qt5_translationdir}/qtwebengine_locales/bn.pak
  445. %lang(ca) %{_qt5_translationdir}/qtwebengine_locales/ca.pak
  446. %lang(cs) %{_qt5_translationdir}/qtwebengine_locales/cs.pak
  447. %lang(da) %{_qt5_translationdir}/qtwebengine_locales/da.pak
  448. %lang(de) %{_qt5_translationdir}/qtwebengine_locales/de.pak
  449. %lang(el) %{_qt5_translationdir}/qtwebengine_locales/el.pak
  450. %lang(en) %{_qt5_translationdir}/qtwebengine_locales/en-GB.pak
  451. %lang(en) %{_qt5_translationdir}/qtwebengine_locales/en-US.pak
  452. %lang(es) %{_qt5_translationdir}/qtwebengine_locales/es-419.pak
  453. %lang(es) %{_qt5_translationdir}/qtwebengine_locales/es.pak
  454. %lang(et) %{_qt5_translationdir}/qtwebengine_locales/et.pak
  455. %lang(fa) %{_qt5_translationdir}/qtwebengine_locales/fa.pak
  456. %lang(fi) %{_qt5_translationdir}/qtwebengine_locales/fi.pak
  457. %lang(fil) %{_qt5_translationdir}/qtwebengine_locales/fil.pak
  458. %lang(fr) %{_qt5_translationdir}/qtwebengine_locales/fr.pak
  459. %lang(gu) %{_qt5_translationdir}/qtwebengine_locales/gu.pak
  460. %lang(he) %{_qt5_translationdir}/qtwebengine_locales/he.pak
  461. %lang(hi) %{_qt5_translationdir}/qtwebengine_locales/hi.pak
  462. %lang(hr) %{_qt5_translationdir}/qtwebengine_locales/hr.pak
  463. %lang(hu) %{_qt5_translationdir}/qtwebengine_locales/hu.pak
  464. %lang(id) %{_qt5_translationdir}/qtwebengine_locales/id.pak
  465. %lang(it) %{_qt5_translationdir}/qtwebengine_locales/it.pak
  466. %lang(ja) %{_qt5_translationdir}/qtwebengine_locales/ja.pak
  467. %lang(kn) %{_qt5_translationdir}/qtwebengine_locales/kn.pak
  468. %lang(ko) %{_qt5_translationdir}/qtwebengine_locales/ko.pak
  469. %lang(lt) %{_qt5_translationdir}/qtwebengine_locales/lt.pak
  470. %lang(lv) %{_qt5_translationdir}/qtwebengine_locales/lv.pak
  471. %lang(ml) %{_qt5_translationdir}/qtwebengine_locales/ml.pak
  472. %lang(mr) %{_qt5_translationdir}/qtwebengine_locales/mr.pak
  473. %lang(ms) %{_qt5_translationdir}/qtwebengine_locales/ms.pak
  474. %lang(nb) %{_qt5_translationdir}/qtwebengine_locales/nb.pak
  475. %lang(nl) %{_qt5_translationdir}/qtwebengine_locales/nl.pak
  476. %lang(pl) %{_qt5_translationdir}/qtwebengine_locales/pl.pak
  477. %lang(pt_BR) %{_qt5_translationdir}/qtwebengine_locales/pt-BR.pak
  478. %lang(pt_PT) %{_qt5_translationdir}/qtwebengine_locales/pt-PT.pak
  479. %lang(ro) %{_qt5_translationdir}/qtwebengine_locales/ro.pak
  480. %lang(ru) %{_qt5_translationdir}/qtwebengine_locales/ru.pak
  481. %lang(sk) %{_qt5_translationdir}/qtwebengine_locales/sk.pak
  482. %lang(sl) %{_qt5_translationdir}/qtwebengine_locales/sl.pak
  483. %lang(sr) %{_qt5_translationdir}/qtwebengine_locales/sr.pak
  484. %lang(sv) %{_qt5_translationdir}/qtwebengine_locales/sv.pak
  485. %lang(sw) %{_qt5_translationdir}/qtwebengine_locales/sw.pak
  486. %lang(ta) %{_qt5_translationdir}/qtwebengine_locales/ta.pak
  487. %lang(te) %{_qt5_translationdir}/qtwebengine_locales/te.pak
  488. %lang(th) %{_qt5_translationdir}/qtwebengine_locales/th.pak
  489. %lang(tr) %{_qt5_translationdir}/qtwebengine_locales/tr.pak
  490. %lang(uk) %{_qt5_translationdir}/qtwebengine_locales/uk.pak
  491. %lang(vi) %{_qt5_translationdir}/qtwebengine_locales/vi.pak
  492. %lang(zh_CN) %{_qt5_translationdir}/qtwebengine_locales/zh-CN.pak
  493. %lang(zh_TW) %{_qt5_translationdir}/qtwebengine_locales/zh-TW.pak
  494. %files devel
  495. %{rpm_macros_dir}/macros.qt5-qtwebengine
  496. %{_qt5_headerdir}/Qt*/
  497. %{_qt5_libdir}/libQt5*.so
  498. %{_qt5_libdir}/libQt5*.prl
  499. #{_qt5_libdir}/Qt5WebEngineCore.la
  500. %{_qt5_libdir}/cmake/Qt5*/
  501. %{_qt5_libdir}/pkgconfig/Qt5*.pc
  502. %{_qt5_archdatadir}/mkspecs/modules/*.pri
  503. %files devtools
  504. %{_qt5_datadir}/resources/qtwebengine_devtools_resources.pak
  505. %files examples
  506. %{_qt5_examplesdir}/
  507. %if 0%{?docs}
  508. %files doc
  509. %{_qt5_docdir}/*
  510. %endif
  511. %changelog
  512. * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-2
  513. - rebuilt with icu-67.
  514. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-1
  515. - new upstream release.
  516. - built with libevent-2.1.11.
  517. * Mon Mar 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.7-1
  518. - new upstream release.
  519. - dropped Patch1000: fixed in upstream.
  520. * Sun Oct 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.5-1
  521. - new upstream release.
  522. * Fri Nov 16 2018 Toshiaki Ara <ara_t@384.jp> - 5.6.3-2
  523. - rebuild with libevent-2.1.8
  524. * Tue Jan 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.3-1
  525. - new upstream release.
  526. * Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
  527. - new upstream release.
  528. - initial build for Vine Linux.
  529. - updated Source1.
  530. * Tue Jun 14 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-3
  531. - rebuild (glibc)
  532. * Sun Jun 12 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
  533. - add versioned qt5-qtbase runtime dep
  534. * Sat Jun 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.1-1
  535. - Update to 5.6.1
  536. - Rebase linux-pri patch (drop the parts already fixed upstream)
  537. - Drop backported chimera-nss-init patch, already applied upstream
  538. - Rebase no-sse2 patch (the core_module.pro change)
  539. - Add the new designer/libqwebengineview.so plugin to the file list
  540. * Mon Jun 06 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-8
  541. - workaround stackmashing runtime errors in re2-related bundled headers (#1337585)
  542. * Sat May 21 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-7
  543. - rebuild (pciutuils)
  544. * Wed May 18 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-6
  545. - BR: git-core
  546. * Fri Apr 15 2016 David Tardon <dtardon@redhat.com> - 5.6.0-5
  547. - rebuild for ICU 57.1
  548. * Fri Apr 08 2016 Than Ngo <than@redhat.com> - 5.6.0-4
  549. - drop ppc ppc64 ppc64le from ExclusiveArch, it's not supported yet
  550. * Thu Mar 24 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-3
  551. - Build with CONFIG+="webcore_debug v8base_debug force_debug_info"
  552. - Force -fno-delete-null-pointer-checks through CXXFLAGS, Qt flags not used here
  553. - Use -g1 instead of -g on non-x86_64 to avoid memory exhaustion
  554. - Work around debugedit failure by removing "./" from #line commands and
  555. changing "//" to "/" in an #include command
  556. * Fri Mar 18 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-2
  557. - Avoid checking for the nonexistent icudtl.dat and silence the warnings
  558. * Thu Mar 17 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-1
  559. - Update to 5.6.0 (final)
  560. - Drop system-icu54 patch, fixed upstream
  561. * Thu Feb 25 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.19.rc
  562. - Update to 5.6.0 RC
  563. - Rebase linux-pri and no-sse2 patches
  564. - Remove BuildRequires pkgconfig(flac), pkgconfig(speex), no longer needed
  565. - Update file list for 5.6.0 RC (resources now in resources/ subdirectory)
  566. - Tag translations with correct %%lang tags
  567. * Wed Feb 24 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.18.beta
  568. - no-sse2 patch: Fix FFT (RealFourier) in webrtc on non-SSE2 x86
  569. * Tue Feb 23 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.17.beta
  570. - Fix FTBFS on aarch64: Respin tarball with fixed clean_ffmpeg.sh (#1310753).
  571. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.16.beta
  572. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  573. * Tue Jan 19 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.15.beta
  574. - Build V8 as a shared library on i686 to allow for swappable backends
  575. - Build both the x87 version and the SSE2 version of V8 on i686
  576. - Add the private library directory to the file list on i686
  577. - Add Provides/Requires filtering for libv8.so (i686) and for plugins
  578. * Sun Jan 17 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.14.beta
  579. - Do not require SSE2 on i686
  580. * Thu Jan 14 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.13.beta
  581. - Drop nss321 backport (and the related nss-headers patch), it did not help
  582. - Do an NSS/BoringSSL "chimera build" as will be the default in Chromium 47
  583. - Update License accordingly (add "OpenSSL")
  584. - Fix the "chimera build" to call EnsureNSSHttpIOInit (backport from Chromium)
  585. * Wed Jan 13 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.12.beta
  586. - Update forked NSS SSL code to 3.21, match system NSS (backport from Chromium)
  587. * Wed Jan 13 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.11.beta
  588. - Add an (optimistic) ExclusiveArch list because of V8 (tracking bug: #1298011)
  589. * Tue Jan 12 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.10.beta
  590. - Unbundle prtime.cc, use the system NSPR instead (which is already required)
  591. - Unbundle icu_utf.cc, use the system ICU instead (which is already required)
  592. * Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.9.beta
  593. - linux-pri.patch: Set icu_use_data_file_flag=0 for system ICU
  594. * Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.8.beta
  595. - Build against the system libvpx also on F23 (1.4.0), worked in Copr
  596. * Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.7.beta
  597. - Use the system libvpx on F24+ (1.5.0)
  598. - Fixes to Provides: bundled(*): libwebp if bundled, x86inc only on x86
  599. * Sun Jan 10 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.6.beta
  600. - Fix extractCFlag to also look in QMAKE_CFLAGS_RELEASE (needed for ARM)
  601. - Fix FTBFS on ARM: Disable NEON due to #1282495 (GCC bug)
  602. * Sat Jan 09 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.5.beta
  603. - Fix FTBFS on ARM: linux-pri patch: Set use_system_yasm only on x86_64 and i386
  604. - Fix FTBFS on ARM: Respin tarball with: clean_ffmpeg.sh: Add missing ARM files
  605. * Sat Jan 09 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.4.beta.1
  606. - Use more specific BuildRequires for docs (thanks to rdieter)
  607. - Fix FTBFS against ICU 54 (F22/F23), thanks to spot for the Chromium fix
  608. * Fri Jan 08 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.4.beta
  609. - Fix License tag
  610. - Use %%_qt5_examplesdir macro
  611. - Add Provides: bundled(*) for all the bundled libraries that I found
  612. * Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.3.beta
  613. - linux-pri patch: Add use_system_protobuf, went missing in the 5.6 rebase
  614. * Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.2.beta
  615. - linux-pri patch: Add missing newline at the end of the log line
  616. - Use export for NINJA_PATH (fixes system ninja-build use)
  617. * Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.1.beta
  618. - Readd BR pkgconfig(jsoncpp) because linux.pri now checks for it
  619. - BR yasm only on x86 (i686, x86_64)
  620. - Add dot at the end of %%description
  621. - Rebase no-format patch
  622. - Replace unbundle-gyp.patch with new linux-pri.patch
  623. - Use system ninja-build instead of the bundled one
  624. - Run the unbundling script replace_gyp_files.py in linux.pri rather than here
  625. - Update file list for 5.6.0-beta (no more libffmpegsumo since Chromium 45)
  626. * Tue Jan 05 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-4
  627. - Remove unused BRs flex, libgcrypt-devel, bzip2-devel, pkgconfig(gio-2.0),
  628. pkgconfig(hunspell), pkgconfig(libpcre), pkgconfig(libssl),
  629. pkgconfig(libcrypto), pkgconfig(jsoncpp), pkgconfig(libmtp),
  630. pkgconfig(libexif), pkgconfig(liblzma), pkgconfig(cairo), pkgconfig(libusb),
  631. perl(version), perl(Digest::MD5), perl(Text::ParseWords), ruby
  632. - Add missing explicit BRs on pkgconfig(x11), pkgconfig(xext),
  633. pkgconfig(xfixes), pkgconfig(xdamage), pkgconfig(egl)
  634. - Fix BR pkgconfig(flac++) to pkgconfig(flac) (libFLAC++ not used, only libFLAC)
  635. - Fix BR python-devel to python
  636. - Remove unused -Duse_system_openssl=1 flag (QtWebEngine uses NSS instead)
  637. - Remove unused -Duse_system_jsoncpp=1 and -Duse_system_libusb=1 flags
  638. * Mon Jan 04 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-3
  639. - Update file list for 5.5.1 (add qtwebengine_resources_[12]00p.pak)
  640. * Mon Jan 04 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-2
  641. - Add missing explicit BRs on pkgconfig(expat) and pkgconfig(libxml-2.0)
  642. - Remove unused BR v8-devel (cannot currently be unbundled)
  643. * Thu Dec 24 2015 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-1
  644. - Update to 5.5.1
  645. - Remove patent-encumbered codecs in the bundled FFmpeg from the tarball
  646. * Fri Jul 17 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-2
  647. - Update with unbundle flags. Adapted from original 5.4 Suse package
  648. - Disable vpx and sqlite as unbundle due some compilation issues
  649. - Enable verbose build
  650. * Fri Jul 17 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-1
  651. - Initial spec
  652. * Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
  653. - Update for official RC1 released packages