qt5-qtwebchannel-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215
  1. %global qt_module qtwebchannel
  2. #define docs 1
  3. #define prerelease
  4. %global qt5_minorver 5.12
  5. %global qt5_version 5.12.8
  6. #global qt5_patchlevel 1
  7. Summary: Qt5 - WebChannel component
  8. Name: qt5-%{qt_module}
  9. Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
  10. Release: 1%{?_dist_release}
  11. # See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
  12. # See also http://doc.qt.io/qt-5/licensing.html
  13. License: LGPLv2 with exceptions or GPLv3 with exceptions
  14. Url: https://qt.io/
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Source0: https://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-everywhere-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
  18. BuildRequires: cmake
  19. BuildRequires: qt5-rpm-macros
  20. BuildRequires: qt5-srpm-macros
  21. BuildRequires: qt5-qtbase-devel >= %{version}
  22. BuildRequires: qt5-qtbase-private-devel
  23. #libQt5Core.so.5(Qt_5_PRIVATE_API)(64bit)
  24. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  25. BuildRequires: qt5-qtdeclarative-devel
  26. BuildRequires: qt5-qtwebsockets-devel
  27. %description
  28. The Qt WebChannel module provides a library for seamless integration of C++
  29. and QML applications with HTML/JavaScript clients. Any QObject can be
  30. published to remote clients, where its public API becomes available.
  31. %package devel
  32. Summary: Development files for %{name}
  33. Requires: %{name}%{?_isa} = %{version}-%{release}
  34. Requires: qt5-qtbase-devel%{?_isa}
  35. %description devel
  36. %{summary}.
  37. %if 0%{?docs}
  38. %package doc
  39. Summary: API documentation for %{name}
  40. License: GFDL
  41. Requires: %{name} = %{version}-%{release}
  42. BuildRequires: qt5-qdoc
  43. BuildRequires: qt5-qhelpgenerator
  44. BuildArch: noarch
  45. %description doc
  46. %{summary}.
  47. %endif
  48. %package examples
  49. Summary: Programming examples for %{name}
  50. Requires: %{name}%{?_isa} = %{version}-%{release}
  51. %description examples
  52. %{summary}.
  53. %prep
  54. %setup -q -n %{qt_module}-everywhere-src-%{qt5_version}
  55. %build
  56. mkdir %{_target_platform}
  57. pushd %{_target_platform}
  58. %{qmake_qt5} ..
  59. make %{?_smp_mflags}
  60. %if 0%{?docs}
  61. # HACK to avoid multilib conflicts in noarch content
  62. # see also https://bugreports.qt.io/browse/QTBUG-42071
  63. QT_HASH_SEED=0; export QT_HASH_SEED
  64. make %{?_smp_mflags} docs
  65. %endif
  66. popd
  67. %install
  68. make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  69. %if 0%{?docs}
  70. make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  71. %endif
  72. ## .prl/.la file love
  73. # nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
  74. pushd %{buildroot}%{_qt5_libdir}
  75. for prl_file in libQt5*.prl ; do
  76. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
  77. if [ -f "$(basename ${prl_file} .prl).so" ]; then
  78. rm -fv "$(basename ${prl_file} .prl).la"
  79. sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
  80. fi
  81. done
  82. popd
  83. %post -p /sbin/ldconfig
  84. %postun -p /sbin/ldconfig
  85. %files
  86. %license LICENSE.*
  87. %{_qt5_libdir}/libQt5WebChannel.so.5*
  88. %{_qt5_archdatadir}/qml/QtWebChannel/
  89. %files devel
  90. %{_qt5_headerdir}/QtWebChannel/
  91. %{_qt5_libdir}/libQt5WebChannel.so
  92. %{_qt5_libdir}/libQt5WebChannel.prl
  93. %dir %{_qt5_libdir}/cmake/Qt5WebChannel/
  94. %{_qt5_libdir}/cmake/Qt5WebChannel/Qt5WebChannelConfig*.cmake
  95. %{_qt5_libdir}/pkgconfig/Qt5WebChannel.pc
  96. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_webchannel*.pri
  97. %if 0%{?docs}
  98. %files doc
  99. %license LICENSE.FDL
  100. %{_qt5_docdir}/%{qt_module}.qch
  101. %{_qt5_docdir}/%{qt_module}/
  102. %endif
  103. %if 0%{?_qt5_examplesdir:1}
  104. %files examples
  105. %{_qt5_examplesdir}/
  106. %endif
  107. %changelog
  108. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-1
  109. - new upstream release.
  110. * Mon Mar 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.7-1
  111. - new upstream release.
  112. * Sun Oct 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.5-1
  113. - new upstream release.
  114. * Tue Jan 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.3-1
  115. - new upstream release.
  116. * Sun Jul 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
  117. - initial build for Vine Linux.
  118. - new upstream release.
  119. * Wed Jun 15 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
  120. - drop pkg-config-style deps, BR: qt5-qtbase-private-devel
  121. * Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
  122. - Update to 5.6.1
  123. * Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
  124. - rebuild
  125. * Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
  126. - rebuild
  127. * Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
  128. - 5.6.0 final release
  129. * Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.8.rc
  130. - Update to final RC
  131. * Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.7
  132. - Update RC release
  133. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.6.rc
  134. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  135. * Mon Dec 28 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.5.rc
  136. - update source URL, use %%license, BR: cmake
  137. * Mon Dec 21 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.4
  138. - Update to final rc release
  139. * Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.3
  140. - Official rc release
  141. * Sun Dec 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.2
  142. - restore bootstrap macro support
  143. * Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
  144. - Start to implement 5.6.0 rc
  145. * Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
  146. - Update for final qt 5.5.1
  147. * Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
  148. - Update to Qt 5.5.1 RC1
  149. * Wed Jul 29 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-3
  150. - -docs: BuildRequires: qt5-qhelpgenerator, standardize bootstrapping
  151. * Thu Jul 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-2
  152. - tighten qtbase dep (#1233829)
  153. * Thu Jul 09 2015 Jan Grulich <jgrulich@redhat.com> - 5.5.0-1
  154. - 5.5.0
  155. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.4.2-2
  156. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  157. * Sun Jun 07 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.2-1
  158. - 5.4.2
  159. * Tue Dec 23 2014 Taylor Braun-Jones <taylor.braun-jones@ge.com> - 5.4.0-1
  160. - Initial release.