qt5-qtquickcontrols2-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209
  1. %global qt_module qtquickcontrols2
  2. #define docs 1
  3. #define prerelease
  4. %global qt5_minorver 5.12
  5. %global qt5_version 5.12.8
  6. #global qt5_patchlevel 1
  7. Name: qt5-%{qt_module}
  8. Summary: Qt5 - module with set of QtQuick controls for embedded
  9. Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
  10. Release: 1%{?_dist_release}
  11. License: GPLv2+ or LGPLv3 and GFDL
  12. Url: https://www.qt.io/
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. Source0: https://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-everywhere-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
  16. # filter qml provides
  17. %global __provides_exclude_from ^%{_qt5_archdatadir}/qml/.*\\.so$
  18. BuildRequires: qt5-rpm-macros
  19. BuildRequires: qt5-qtbase-devel >= %{version}
  20. BuildRequires: qt5-qtbase-private-devel
  21. #libQt53DRender.so.5(Qt_5_PRIVATE_API)(64bit)
  22. #libQt5Core.so.5(Qt_5_PRIVATE_API)(64bit)
  23. #libQt5Gui.so.5(Qt_5_PRIVATE_API)(64bit)
  24. #libQt5Qml.so.5(Qt_5_PRIVATE_API)(64bit)
  25. #libQt5Quick.so.5(Qt_5_PRIVATE_API)(64bit)
  26. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  27. BuildRequires: qt5-qtdeclarative-devel
  28. Requires: qt5-qtdeclarative%{?_isa} >= %{version}
  29. Requires: qt5-qtgraphicaleffects%{_isa} >= %{version}
  30. %description
  31. The Qt Labs Controls module provides a set of controls that can be used to
  32. build complete interfaces in Qt Quick.
  33. Unlike Qt Quick Controls, these controls are optimized for embedded systems
  34. and so are preferred for hardware with limited resources.
  35. %if 0%{?docs}
  36. %package doc
  37. Summary: API documentation for %{name}
  38. License: GFDL
  39. Requires: %{name} = %{version}-%{release}
  40. BuildRequires: qt5-qdoc
  41. BuildRequires: qt5-qhelpgenerator
  42. BuildArch: noarch
  43. %description doc
  44. %{summary}.
  45. %endif
  46. %package devel
  47. Summary: Development files for %{name}
  48. Requires: %{name}%{?_isa} = %{version}-%{release}
  49. Requires: qt5-qtbase-devel%{?_isa}
  50. Requires: qt5-qtdeclarative-devel%{?_isa}
  51. %description devel
  52. %{summary}.
  53. %package examples
  54. Summary: Examples for %{name}
  55. Requires: %{name}%{?_isa} = %{version}-%{release}
  56. %description examples
  57. %{summary}.
  58. %prep
  59. %setup -q -n %{qt_module}-everywhere-src-%{qt5_version}
  60. %if 0%{?prerelease}
  61. syncqt.pl -version %{version}
  62. %endif
  63. %build
  64. mkdir %{_target_platform}
  65. pushd %{_target_platform}
  66. %{qmake_qt5} ..
  67. make %{?_smp_mflags}
  68. %if 0%{?docs}
  69. make %{?_smp_mflags} docs
  70. %endif
  71. popd
  72. %install
  73. make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  74. %if 0%{?docs}
  75. make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  76. %endif
  77. ## .prl/.la file love
  78. # nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
  79. pushd %{buildroot}%{_qt5_libdir}
  80. for prl_file in libQt5*.prl ; do
  81. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
  82. if [ -f "$(basename ${prl_file} .prl).so" ]; then
  83. rm -fv "$(basename ${prl_file} .prl).la"
  84. sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
  85. fi
  86. done
  87. popd
  88. # Remove .la leftovers
  89. rm -f %{buildroot}%{_qt5_libdir}/libQt5*.la
  90. %post -p /sbin/ldconfig
  91. %postun -p /sbin/ldconfig
  92. %files
  93. %license LICENSE.LGPLv3 LICENSE.GPLv3
  94. %{_qt5_libdir}/libQt5QuickTemplates2.so.5*
  95. %{_qt5_libdir}/libQt5QuickControls2.so.5*
  96. %{_qt5_qmldir}/Qt/labs/calendar
  97. %{_qt5_qmldir}/Qt/labs/platform
  98. %{_qt5_archdatadir}/qml/QtQuick/Controls.2/
  99. %{_qt5_archdatadir}/qml/QtQuick/Templates.2/
  100. %if 0%{?docs}
  101. %files doc
  102. %license LICENSE.FDL LICENSE.LGPLv3 LICENSE.GPLv3
  103. %dir %{_qt5_docdir}/qtlabscontrols/
  104. %{_qt5_docdir}/qtlabscontrols/*
  105. %{_qt5_docdir}/qtlabscontrols.qch
  106. %endif
  107. %files devel
  108. %{_qt5_headerdir}/
  109. %{_qt5_libdir}/pkgconfig/*.pc
  110. %{_qt5_libdir}/libQt5QuickTemplates2.so
  111. %{_qt5_libdir}/libQt5QuickControls2.so
  112. %{_qt5_libdir}/libQt5QuickTemplates2.prl
  113. %{_qt5_libdir}/libQt5QuickControls2.prl
  114. %{_qt5_libdir}/qt5/mkspecs/modules/*
  115. %{_libdir}/cmake/Qt5QuickControls2/
  116. %{_libdir}/cmake/Qt5QuickTemplates2/
  117. %files examples
  118. %{_qt5_examplesdir}/quickcontrols2/
  119. %changelog
  120. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-1
  121. - new upstream release.
  122. * Mon Mar 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.7-1
  123. - new upstream release.
  124. * Sun Oct 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.5-1
  125. - new upstream release.
  126. * Fri Jan 12 2018 Toshiaki Ara <ara_t@384.jp> - 5.6.3-1
  127. - update to 5.6.3
  128. * Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
  129. - new upstream release.
  130. - initial build for Vine Linux.
  131. * Sat Jun 11 2016 Pier Luigi Fiorini <pierluigi.fiorini@gmail.com> - 5.6.1-2
  132. - Add qt5-qtgraphicaleffects dependency
  133. * Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
  134. - Update to 5.6.1
  135. * Sun Apr 17 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-4
  136. - BR: qt5-qtbase-private-devel qt5-qtdeclarative-private-devel
  137. * Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
  138. - rebuild
  139. * Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
  140. - rebuild
  141. * Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org>
  142. - 5.6.0 final release
  143. * Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
  144. - 5.6.0 final release
  145. * Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.4.rc
  146. - Update to final RC
  147. * Thu Feb 18 2016 Pier Luigi Fiorini <pierluigi.fiorini@gmail.com> - 5.6.0-0.3.rc
  148. - Update to rc
  149. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.2.beta
  150. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  151. * Fri Jan 15 2016 Pier Luigi Fiorini <pierluigi.fiorini@gmail.com> - 5.6.0-0.1.beta
  152. - Initial packaging