qt5-qtlocation-vl.spec 9.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334
  1. %global qt_module qtlocation
  2. # define to build docs, need to undef this for bootstrapping
  3. # where qt5-qttools builds are not yet available
  4. # only primary archs (for now), allow secondary to bootstrap
  5. #global bootstrap 1
  6. %if ! 0%{?bootstrap}
  7. %ifarch %{arm} %{ix86} x86_64
  8. #define docs 1
  9. %endif
  10. %endif
  11. #define prerelease
  12. %global qt5_minorver 5.12
  13. %global qt5_version 5.12.8
  14. #global qt5_patchlevel 1
  15. Summary: Qt5 - Location component
  16. Name: qt5-%{qt_module}
  17. Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
  18. Release: 2%{?_dist_release}
  19. # See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
  20. License: LGPLv2 with exceptions or GPLv3 with exceptions
  21. Url: https://www.qt.io/
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Source0: https://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-everywhere-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
  25. # build failure with gcc10
  26. # various C++ runtime headers indirectly included <string> which in turn
  27. # included <local> and <cerrno>. Those indirect inclusions have been
  28. # eliminated which in turn forces packages to include the C++ headers they
  29. # actually need.
  30. Patch0: qtlocation-gcc10.patch
  31. # filter plugin/qml provides
  32. %global __provides_exclude_from ^(%{_qt5_archdatadir}/qml/.*\\.so|%{_qt5_plugind
  33. ir}/.*\\.so)$
  34. BuildRequires: cmake
  35. BuildRequires: qt5-rpm-macros
  36. BuildRequires: qt5-srpm-macros
  37. BuildRequires: qt5-qtbase-devel >= %{version}
  38. BuildRequires: qt5-qtdeclarative-devel >= %{version}
  39. # QtPositioning core-private
  40. BuildRequires: qt5-qtbase-private-devel
  41. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  42. BuildRequires: pkgconfig(icu-i18n)
  43. BuildRequires: openssl-devel
  44. BuildRequires: zlib-devel
  45. %description
  46. The Qt Location and Qt Positioning APIs gives developers the ability to
  47. determine a position by using a variety of possible sources, including
  48. satellite, or wifi, or text file, and so on.
  49. %package devel
  50. Summary: Development files for %{name}
  51. Requires: %{name}%{?_isa} = %{version}-%{release}
  52. Requires: qt5-qtbase-devel%{?_isa}
  53. %description devel
  54. %{summary}.
  55. %if 0%{?docs}
  56. %package doc
  57. Summary: API documentation for %{name}
  58. Requires: %{name} = %{version}-%{release}
  59. BuildRequires: qt5-qdoc
  60. BuildRequires: qt5-qhelpgenerator
  61. BuildArch: noarch
  62. %description doc
  63. %{summary}.
  64. %endif
  65. %package examples
  66. Summary: Programming examples for %{name}
  67. Requires: %{name}%{?_isa} = %{version}-%{release}
  68. %description examples
  69. %{summary}.
  70. %debug_package
  71. %prep
  72. %setup -q -n %{qt_module}-everywhere-src-%{qt5_version}
  73. %patch0 -p1 -b .gcc10
  74. %build
  75. mkdir %{_target_platform}
  76. pushd %{_target_platform}
  77. %{qmake_qt5} ..
  78. make %{?_smp_mflags}
  79. %if 0%{?docs}
  80. make %{?_smp_mflags} docs
  81. %endif
  82. popd
  83. %install
  84. make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  85. %if 0%{?docs}
  86. make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  87. %endif
  88. ## .prl/.la file love
  89. # nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
  90. pushd %{buildroot}%{_qt5_libdir}
  91. for prl_file in libQt5*.prl ; do
  92. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
  93. if [ -f "$(basename ${prl_file} .prl).so" ]; then
  94. rm -fv "$(basename ${prl_file} .prl).la"
  95. sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
  96. fi
  97. done
  98. popd
  99. %post -p /sbin/ldconfig
  100. %postun -p /sbin/ldconfig
  101. %files
  102. %license LICENSE.GPL* LICENSE.LGPL*
  103. %{_qt5_libdir}/libQt5Location.so.5*
  104. %{_qt5_archdatadir}/qml/QtLocation/
  105. %{_qt5_plugindir}/geoservices/
  106. %{_qt5_libdir}/libQt5Positioning.so.5*
  107. %dir %{_qt5_archdatadir}/qml/QtPositioning
  108. %{_qt5_archdatadir}/qml/QtPositioning/*
  109. %{_qt5_plugindir}/position/
  110. %{_qt5_libdir}/libQt5PositioningQuick.so.5*
  111. %dir %{_qt5_archdatadir}/qml/Qt
  112. %dir %{_qt5_archdatadir}/qml/Qt/labs
  113. %{_qt5_archdatadir}/qml/Qt/labs/location
  114. %files devel
  115. %{_qt5_headerdir}/QtLocation/
  116. %{_qt5_libdir}/libQt5Location.so
  117. %{_qt5_libdir}/libQt5Location.prl
  118. %{_qt5_headerdir}/QtPositioning/
  119. %{_qt5_libdir}/libQt5Positioning.so
  120. %{_qt5_libdir}/libQt5Positioning.prl
  121. %{_qt5_headerdir}/QtPositioningQuick/
  122. %{_qt5_libdir}/libQt5PositioningQuick.so
  123. %{_qt5_libdir}/libQt5PositioningQuick.prl
  124. %{_qt5_libdir}/pkgconfig/Qt5Location.pc
  125. %dir %{_qt5_libdir}/cmake/Qt5Location
  126. %{_qt5_libdir}/cmake/Qt5Location/Qt5Location*.cmake
  127. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_location*.pri
  128. %{_qt5_libdir}/pkgconfig/Qt5Positioning.pc
  129. %dir %{_qt5_libdir}/cmake/Qt5Positioning
  130. %{_qt5_libdir}/cmake/Qt5Positioning/Qt5Positioning*.cmake
  131. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_positioning*.pri
  132. %{_qt5_libdir}/pkgconfig/Qt5PositioningQuick.pc
  133. %dir %{_qt5_libdir}/cmake/Qt5PositioningQuick/
  134. %{_qt5_libdir}/cmake/Qt5PositioningQuick/Qt5PositioningQuick*.cmake
  135. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_positioning*.pri
  136. %if 0%{?docs}
  137. %files doc
  138. %license LICENSE.FDL
  139. %{_qt5_docdir}/qtlocation.qch
  140. %{_qt5_docdir}/qtlocation/
  141. %{_qt5_docdir}/qtpositioning.qch
  142. %{_qt5_docdir}/qtpositioning/
  143. %endif
  144. %if 0%{?_qt5_examplesdir:1}
  145. %files examples
  146. %{_qt5_examplesdir}/
  147. %endif
  148. %changelog
  149. * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-2
  150. - rebuilt with icu-67.
  151. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-1
  152. - new upstream release.
  153. * Mon Mar 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.7-1
  154. - new upstream release.
  155. * Sun Oct 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.5-1
  156. - new upstream release.
  157. * Tue Jan 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.3-1
  158. - new upstream release.
  159. * Sun Jul 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
  160. - initial build for Vine Linux.
  161. - new upstream release.
  162. * Wed Jun 15 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
  163. - drop pkgconfig-style Qt5 deps
  164. * Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
  165. - Update to 5.6.1
  166. * Thu Apr 21 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-4
  167. - BR: qt5-qtbase-private-devel
  168. * Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
  169. - rebuild
  170. * Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
  171. - rebuild
  172. * Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
  173. - 5.6.0 final release
  174. * Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.10.rc
  175. - Update to final RC
  176. * Sun Feb 21 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.9.rc
  177. - rebuild
  178. * Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.8
  179. - Update RC release
  180. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.7.beta
  181. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  182. * Mon Dec 28 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.6.beta
  183. - update source URL, use %%license, BR: cmake
  184. * Mon Dec 21 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.5
  185. - Update to final beta release
  186. * Fri Dec 11 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-0.4
  187. - (re) add bootstrap macro support
  188. - drop geoclue(1) dep (unused at build time anyway (#1286886)
  189. - drop (deprecated) gypsy support (#1069225)
  190. * Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.3
  191. - Official beta release
  192. * Sun Dec 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.2
  193. - (re)add bootstrap macro support
  194. * Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
  195. - Start to implement 5.6.0 beta
  196. * Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
  197. - Update to final release 5.5.1
  198. * Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
  199. - Update to Qt 5.5.1 RC1
  200. * Wed Jul 29 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-3
  201. - -docs: BuildRequires: qt5-qhelpgenerator, standardize bootstrapping
  202. * Thu Jul 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-2
  203. - tighten qtbase dep (#1233829), .spec cosmetics, (re)enable docs
  204. * Wed Jul 1 2015 Helio Chissini de Castro <helio@kde.org> 5.5.0-1
  205. - New final upstream release Qt 5.5.0
  206. * Wed Jun 24 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
  207. - Update for official RC1 released packages
  208. * Mon Jun 15 2015 Daniel Vrátil <dvratil@redhat.com> - 5.5.0-0.1.rc
  209. - Qt 5.5.0 RC1
  210. * Wed Jun 03 2015 Jan Grulich <jgrulich@redhat.com> - 5.4.2-1
  211. - 5.4.2
  212. * Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 5.4.1-3
  213. - Rebuilt for GCC 5 C++11 ABI change
  214. * Fri Feb 27 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-2
  215. - rebuild (gcc5)
  216. * Tue Feb 24 2015 Jan Grulich <jgrulich@redhat.com> 5.4.1-1
  217. - 5.4.1
  218. * Mon Feb 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-3
  219. - rebuild (gcc5)
  220. * Wed Dec 31 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-2
  221. - BR: pkgconfig(Qt5Qml) > 5.4.0 (#1177986)
  222. * Wed Dec 10 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-1
  223. - 5.4.0 (final)
  224. * Fri Nov 28 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.3.rc
  225. - 5.4.0-rc
  226. * Mon Nov 03 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.2.beta
  227. - out-of-tree build, use %%qmake_qt5
  228. * Sun Oct 19 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.1.beta
  229. - 5.4.0-beta
  230. * Tue Sep 16 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-1
  231. - 5.3.2
  232. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
  233. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  234. * Tue Jun 17 2014 Jan Grulich <jgrulich@redhat.com> - 5.3.1-1
  235. - 5.3.1
  236. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-2
  237. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  238. * Wed May 21 2014 Jan Grulich <jgrulich@redhat.com> 5.3.0-1
  239. - 5.3.0
  240. * Mon May 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-2
  241. - sanitize .prl file(s)
  242. * Wed Feb 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
  243. - 5.2.1
  244. * Mon Jan 27 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-3
  245. - build -examples only when supported
  246. * Sun Jan 26 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-2
  247. - -examples subpkg
  248. * Thu Jan 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-1
  249. - first try