qt5-qtenginio-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185
  1. %global qt_module qtenginio
  2. # define to build docs, need to undef this for bootstrapping
  3. %define docs 1
  4. #define prerelease
  5. Summary: Qt5 - Enginio component
  6. Name: qt5-%{qt_module}
  7. Version: 1.6.3
  8. Release: 1%{?_dist_release}
  9. # See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
  10. # See also http://doc.qt.io/qt-5/licensing.html
  11. License: LGPLv2 with exceptions or GPLv3 with exceptions
  12. Url: http://www.qt.io
  13. Source0: http://download.qt.io/official_releases/qt/5.6/5.6.3/submodules/%{qt_module}-opensource-src-%{version}.tar.xz
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. BuildRequires: qt5-qtbase-devel >= 5.6
  17. BuildRequires: qt5-qtdeclarative-devel
  18. %description
  19. Client library for accessing Enginio service from Qt and QML code.
  20. %package devel
  21. Summary: Development files for %{name}
  22. Requires: %{name}%{?_isa} = %{version}-%{release}
  23. Requires: qt5-qtbase-devel%{?_isa}
  24. %description devel
  25. %{summary}.
  26. %if 0%{?docs}
  27. %package doc
  28. Summary: API documentation for %{name}
  29. License: GFDL
  30. #Requires: %{name} = %{version}-%{release}
  31. BuildRequires: qt5-qdoc
  32. BuildRequires: qt5-qhelpgenerator
  33. BuildArch: noarch
  34. %description doc
  35. %{summary}.
  36. %endif
  37. %package examples
  38. Summary: Programming examples for %{name}
  39. Requires: %{name}%{?_isa} = %{version}-%{release}
  40. %description examples
  41. %{summary}.
  42. %prep
  43. %setup -q -n %{qt_module}-opensource-src-%{version}
  44. %build
  45. mkdir %{_target_platform}
  46. pushd %{_target_platform}
  47. %{qmake_qt5} ..
  48. make %{?_smp_mflags}
  49. %if 0%{?docs}
  50. # HACK to avoid multilib conflicts in noarch content
  51. # see also https://bugreports.qt.io/browse/QTBUG-42071
  52. QT_HASH_SEED=0; export QT_HASH_SEED
  53. make %{?_smp_mflags} docs
  54. %endif
  55. popd
  56. %install
  57. make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  58. %if 0%{?docs}
  59. make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  60. %endif
  61. ## .prl/.la file love
  62. # nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
  63. pushd %{buildroot}%{_qt5_libdir}
  64. for prl_file in libEng*.prl ; do
  65. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
  66. if [ -f "$(basename ${prl_file} .prl).so" ]; then
  67. rm -fv "$(basename ${prl_file} .prl).la"
  68. sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
  69. fi
  70. done
  71. popd
  72. %post -p /sbin/ldconfig
  73. %postun -p /sbin/ldconfig
  74. %files
  75. %license LICENSE* LGPL_EXCEPTION.txt
  76. %{_qt5_libdir}/libEnginio.so.1*
  77. %{_qt5_archdatadir}/qml/Enginio/
  78. %files devel
  79. %{_qt5_headerdir}/Enginio/
  80. %{_qt5_libdir}/libEnginio.so
  81. %{_qt5_libdir}/libEnginio.prl
  82. %dir %{_qt5_libdir}/cmake/Qt5Enginio/
  83. %{_qt5_libdir}/cmake/Qt5Enginio/Qt5EnginioConfig*.cmake
  84. %{_qt5_libdir}/pkgconfig/Enginio.pc
  85. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_enginio*.pri
  86. %if 0%{?docs}
  87. %files doc
  88. %{_qt5_docdir}/qtenginio.qch
  89. %{_qt5_docdir}/qtenginio
  90. %{_qt5_docdir}/qtenginiooverview.qch
  91. %{_qt5_docdir}/qtenginiooverview
  92. %{_qt5_docdir}/qtenginioqml.qch
  93. %{_qt5_docdir}/qtenginioqml
  94. %endif
  95. %if 0%{?_qt5_examplesdir:1}
  96. %files examples
  97. %{_qt5_examplesdir}/
  98. %endif
  99. %changelog
  100. * Fri Jan 12 2018 Toshiaki Ara <ara_t@384.jp> - 1.6.3-1
  101. - update to 1.6.3
  102. * Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.6.1-3
  103. - initial build for Vine Linux.
  104. - dropped Epoch.
  105. * Wed Jun 15 2016 Rex Dieter <rdieter@fedoraproject.org> - 1:1.6.1-2
  106. - drop pkgconfig-style Qt5 deps
  107. * Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> -1:1.6.1-1
  108. - Update to 1.6.1
  109. * Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 1:1.6.0-3
  110. - rebuild
  111. * Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 1:1.6.0-2
  112. - rebuild
  113. * Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 1.6.0-1
  114. - 1.6.0 final release
  115. - Epoch to adjust the version
  116. * Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.7.rc
  117. - Update to final RC
  118. * Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.6
  119. - Update RC release
  120. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.5.beta1
  121. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  122. * Thu Jan 21 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.4.beta1
  123. - Fix Release, Fix sources, -docs: fix deps
  124. * Mon Dec 21 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.3
  125. - Update to final beta release
  126. * Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.2
  127. - Official beta release
  128. * Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
  129. - Start to implement 5.6.0 beta
  130. * Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
  131. - Update to final release 5.5.1
  132. * Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
  133. - Update to Qt 5.5.1 RC1
  134. * Wed Jul 1 2015 Helio Chissini de Castro <helio@kde.org> 5.5.0-1
  135. - New final upstream release Qt 5.5.0
  136. * Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
  137. - Update for official RC1 released packages
  138. * Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.1.rc
  139. - First release