qt-assistant-adp-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175
  1. Name: qt-assistant-adp
  2. Version: 4.6.3
  3. Release: 7%{?_dist_release}
  4. Summary: Compatibility version of Qt Assistant
  5. Summary(ja): Qt Assistant の互換性を維持するためのライブラリ
  6. Group: System Environment/Libraries
  7. # See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
  8. License: LGPLv2 with exceptions or GPLv3 with exceptions
  9. URL: http://qt.nokia.com/doc/4.6/qassistantclient.html
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Source: ftp://ftp.qt.nokia.com/qt/source/qt-assistant-qassistantclient-library-compat-src-%{version}.tar.gz
  13. # missing header files from Debian (Fathi Boudra)
  14. Source1: QAssistantClient
  15. Source2: QtAssistant
  16. # build fixes from Debian (Fathi Boudra)
  17. Patch1: 01_build_system.diff
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: qt4-devel >= 4.7.2-2%{?_dist_release}
  20. %description
  21. The old version of Qt Assistant, based on Assistant Document Profile (.adp)
  22. files, and the associated QtAssistantClient library, for compatibility with
  23. applications providing help in that format.
  24. New applications should use the new version of Qt Assistant introduced in Qt
  25. 4.4, based on the Qt Help Framework also introduced in Qt 4.4, instead.
  26. %package devel
  27. Summary: Development files for the compatibility QAssistantClient
  28. Summary(ja): QAssistantClient 互換の開発用ファイル
  29. Group: Development/Libraries
  30. Requires: %{name} = %{version}-%{release}
  31. Requires: qt4-devel
  32. %description devel
  33. This package contains the files necessary to build applications using the
  34. deprecated QAssistantClient class (in the deprecated QtAssistantClient library),
  35. which is used together with the legacy Assistant Document Profile (.adp) version
  36. of Qt Assistant.
  37. This class is obsolete. It is provided to keep old source code working. We
  38. strongly advise against using it in new code. New code should use the Qt Help
  39. Framework introduced in Qt 4.4 and/or the version of Qt Assistant based on it
  40. (also introduced in Qt 4.4) instead.
  41. %prep
  42. %setup -q -n qt-assistant-qassistantclient-library-compat-version-%{version}
  43. %patch1 -p1 -b .build_system
  44. mkdir include
  45. cp -p %{SOURCE1} %{SOURCE2} include/
  46. %build
  47. # build assistant_adp
  48. qmake QT_PRODUCT=OpenSource
  49. make %{?_smp_mflags}
  50. # build libQtAssistantClient
  51. cd lib
  52. qmake CONFIG=create_prl
  53. make %{?_smp_mflags}
  54. # build assistant_adp translations
  55. cd ../translations
  56. lrelease assistant_adp_*.ts
  57. cd ..
  58. %install
  59. rm -rf $RPM_BUILD_ROOT
  60. # install assistant_adp
  61. make install INSTALL_ROOT=$RPM_BUILD_ROOT
  62. # install libQtAssistantClient
  63. make install INSTALL_ROOT=$RPM_BUILD_ROOT -C lib
  64. # install assistant_adp translations
  65. mkdir -p $RPM_BUILD_ROOT%{_qt4_translationdir}
  66. install -p -m644 translations/assistant_adp_*.qm \
  67. $RPM_BUILD_ROOT%{_qt4_translationdir}/
  68. # install assistant.prf mkspec
  69. install -D -p -m644 features/assistant.prf \
  70. $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features/assistant.prf
  71. # install missing headers (thanks to Fathi Boudra from Debian)
  72. install -p -m644 include/Q* $RPM_BUILD_ROOT%{_qt4_headerdir}/QtAssistant/
  73. # nuke dangling reference(s) to the buildroot
  74. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" $RPM_BUILD_ROOT%{_qt4_libdir}/*.prl
  75. # let rpm handle binaries conflicts
  76. mkdir $RPM_BUILD_ROOT%{_bindir}
  77. pushd $RPM_BUILD_ROOT%{_qt4_bindir}
  78. mv assistant_adp ../../../bin/
  79. ln -s ../../../bin/assistant_adp .
  80. popd
  81. # _debug target (see bug #196513)
  82. pushd $RPM_BUILD_ROOT%{_qt4_libdir}
  83. echo "INPUT(-lQtAssistantClient)" >libQtAssistantClient_debug.so
  84. popd
  85. # Note that we intentionally DO NOT install a .desktop file for assistant_adp
  86. # because it makes no sense to invoke it without a specific .adp file to open.
  87. # By default, it views the Qt documentation, for which we already have a menu
  88. # entry using the current version of the Qt Assistant, and there is no UI for
  89. # viewing anything different. The .adp file needs to be passed on the command
  90. # line, which is usually done by the application.
  91. %find_lang assistant_adp --with-qt --without-mo
  92. %clean
  93. rm -rf $RPM_BUILD_ROOT
  94. %post -p /sbin/ldconfig
  95. %postun -p /sbin/ldconfig
  96. %files -f assistant_adp.lang
  97. %defattr(-,root,root,-)
  98. %doc LGPL_EXCEPTION.txt LICENSE.LGPL LICENSE.GPL3
  99. %{_bindir}/assistant_adp
  100. %{_qt4_bindir}/assistant_adp
  101. %{_qt4_libdir}/libQtAssistantClient.so.4*
  102. %files devel
  103. %defattr(-,root,root,-)
  104. %{_qt4_headerdir}/QtAssistant/
  105. %{_qt4_libdir}/libQtAssistantClient.so
  106. %{_qt4_libdir}/libQtAssistantClient_debug.so
  107. %{_qt4_libdir}/libQtAssistantClient.prl
  108. %{_libdir}/pkgconfig/QtAssistantClient.pc
  109. %{_qt4_datadir}/mkspecs/features/assistant.prf
  110. %changelog
  111. * Mon Jul 4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.6.3-7
  112. - rebuilt with new toolchain.
  113. * Mon Feb 9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 4.6.3-6
  114. - rebuilt on current VineSeed
  115. - added Japanese summary
  116. * Sat Jan 07 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-5
  117. - rebuilt with qt-4.8.0
  118. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-4
  119. - fixed BR
  120. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-3
  121. - Initial build for Vine Linux
  122. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.6.3-2
  123. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  124. * Mon Jul 05 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.3-1
  125. - new upstream tarball with only the compat assistant_adp and QAssistantClient
  126. - build fixes from Debian (Fathi Boudra)
  127. - use find_lang to package the qm files (#609749)
  128. * Tue Mar 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.6.2-2
  129. - use versioned BR/Requires to avoid Conflicts
  130. * Sat Mar 13 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.2-1
  131. - first Fedora package