qjson-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139
  1. Name: qjson
  2. Summary: A qt-based library that maps JSON data to QVariant objects
  3. Summary(ja): JSON データ を QVariant Object にマッピングするためのライブラリ
  4. Version: 0.8.1
  5. Release: 2%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: GPLv2+
  8. URL: http://sourceforge.net/projects/qjson/
  9. Source0: http://downloads.sourceforge.net/project/qjson/qjson/0.8.1/%{name}-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: cmake >= 2.6
  12. BuildRequires: qt4-devel
  13. BuildRequires: doxygen
  14. %description
  15. JSON is a lightweight data-interchange format. It can represents integer, real
  16. number, string, an ordered sequence of value, and a collection of
  17. name/value pairs.QJson is a qt-based library that maps JSON data to
  18. QVariant objects.
  19. %package devel
  20. Summary: Development files for qjson
  21. Summary(ja): qjson の開発用ファイル
  22. Group: Development/Libraries
  23. Requires: %{name} = %{version}-%{release}
  24. Requires: qt4-devel
  25. %description devel
  26. The %{name}-devel package contains the libraries and header files required for
  27. developing applications that use %{name}.
  28. %prep
  29. %setup -q
  30. %build
  31. mkdir -p %{_target_platform}
  32. pushd %{_target_platform}
  33. %cmake -DQJSON_BUILD_TESTS=1 \
  34. -DCMAKE_MODULES_INSTALL_DIR=%{_datadir}/cmake/Modules/ \
  35. ..
  36. cd %{_builddir}/%{buildsubdir}/doc
  37. doxygen
  38. popd
  39. sed -i -e 's/-fno-exceptions -fno-check-new -fno-common//' \
  40. -e 's/-fno-threadsafe-statics -fvisibility=hidden -fvisibility-inlines-hidden//' \
  41. -e 's/-ansi//' %{_target_platform}/src/CMakeFiles/qjson.dir/flags.make
  42. make %{?_smp_mflags} -C %{_target_platform}
  43. %install
  44. rm -rf %{buildroot}
  45. make install DESTDIR=%{buildroot} -C %{_target_platform}
  46. %clean
  47. rm -rf %{buildroot}
  48. %post -p /sbin/ldconfig
  49. %postun -p /sbin/ldconfig
  50. %files
  51. %defattr(-,root,root,-)
  52. %doc COPYING
  53. %{_libdir}/libqjson.so.*
  54. %files devel
  55. %defattr(-,root,root,-)
  56. %doc doc/html
  57. %{_includedir}/%{name}
  58. %{_libdir}/cmake/%{name}
  59. %{_libdir}/libqjson.so
  60. %{_libdir}/pkgconfig/QJson.pc
  61. %changelog
  62. * Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.1-2
  63. - rebuild with gcc-5.4.0
  64. * Mon May 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.1-1
  65. - new upstream release
  66. * Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-6
  67. - added Japanese summary
  68. * Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-5
  69. - rebuilt with rpm-4.8.1
  70. * Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-4
  71. - re-fixed CMAKE_MODULES_INSTALL_DIR
  72. * Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-3
  73. - fixed CMAKE_MODULES_INSTALL_DIR
  74. * Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-2
  75. - initial build for Vine Linux
  76. * Sat Dec 12 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.7.1-1
  77. -0.7.1
  78. - Version upgrade
  79. - Fixed doxygen documentation (Thanks again Orcan)
  80. * Tue Dec 8 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-6
  81. -0.6.3
  82. - Fixed capitalization of the summary
  83. * Tue Dec 8 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-5
  84. -0.6.3
  85. - Moved Doxygen docs to the development package.
  86. - Corrected placement of the cmake project file (Thanks Orcan)
  87. - Fixed the running of the build tests
  88. - Corrected column length of the descriptions
  89. - Changed description of the devlepment package
  90. * Sun Dec 6 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-4
  91. -0.6.3
  92. - Additional placment of library files fix
  93. * Fri Dec 4 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-3
  94. -0.6.3
  95. - Fixed placment of library files
  96. - Activated build tests
  97. - Corrected ownership of include directory
  98. - Corrected dependacies
  99. - Added doxygen documentation
  100. - Fixed reported version in the changelogs
  101. * Sun Nov 22 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-2
  102. -0.6.3
  103. - Split off development libraries to its own package
  104. - Modified licensing in spec file to reflect GPL2 code though docs state that qjson
  105. - licensed under LPGL
  106. - Uncommeted and corrected sed line in this spec file
  107. * Sun Nov 22 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-1
  108. -0.6.3
  109. - Initial Build