qhull-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171
  1. %define name qhull
  2. %define version 2015.2
  3. # Upstream's versioning is bizarre
  4. %global tarvers 2015-src-7.2.0
  5. Summary: General dimension convex hull programs
  6. Name: %{name}
  7. Version: %{version}
  8. Release: 1%{?_dist_release}
  9. License: Qhull
  10. Group: System Environment/Libraries
  11. URL: http://www.qhull.org
  12. Source0: http://www.qhull.org/download/qhull-%{tarvers}.tgz
  13. Patch1: 0001-Link-executables-against-shared-libs.patch
  14. Patch2: 0002-Install-docs-into-subdirs.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: cmake
  17. BuildRequires: chrpath
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. %description
  21. Qhull is a general dimension convex hull program that reads a set
  22. of points from stdin, and outputs the smallest convex set that contains
  23. the points to stdout. It also generates Delaunay triangulations, Voronoi
  24. diagrams, furthest-site Voronoi diagrams, and halfspace intersections
  25. about a point.
  26. %package -n libqhull
  27. Group: System Environment/Libraries
  28. Summary: -n libqhull
  29. %description -n libqhull
  30. %{summary}
  31. %package -n libqhull_r
  32. Group: System Environment/Libraries
  33. Summary: libqhull_r
  34. %description -n libqhull_r
  35. %{summary}
  36. %package -n libqhull_p
  37. Group: System Environment/Libraries
  38. Summary: libqhull_p
  39. %description -n libqhull_p
  40. %{summary}
  41. %package devel
  42. Summary: Development files for qhull
  43. Group: Development/Libraries
  44. Requires: lib%{name} = %{version}-%{release}
  45. Requires: lib%{name}_r = %{version}-%{release}
  46. Requires: lib%{name}_p = %{version}-%{release}
  47. %description devel
  48. Qhull is a general dimension convex hull program that reads a set
  49. of points from stdin, and outputs the smallest convex set that contains
  50. the points to stdout. It also generates Delaunay triangulations, Voronoi
  51. diagrams, furthest-site Voronoi diagrams, and halfspace intersections
  52. about a point.
  53. %prep
  54. %setup -q -n %{name}-%{version}
  55. %patch1 -p1
  56. %patch2 -p1
  57. %build
  58. cd build
  59. %cmake ..
  60. make VERBOSE=1 %{?_smp_mflags}
  61. cd ..
  62. %install
  63. rm -rf ${RPM_BUILD_ROOT}
  64. cd build
  65. %make_install
  66. cd ..
  67. chrpath --delete ${RPM_BUILD_ROOT}%{_libdir}/lib*.so.*
  68. ## remove unuse files
  69. rm -rf ${RPM_BUILD_ROOT}%{_libdir}/*.a
  70. ## rename doc folder
  71. mv ${RPM_BUILD_ROOT}%{_docdir}/%{name} \
  72. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
  73. %clean
  74. rm -rf $RPM_BUILD_ROOT
  75. %post -p /sbin/ldconfig
  76. %postun -p /sbin/ldconfig
  77. %post -n libqhull -p /sbin/ldconfig
  78. %postun -n libqhull -p /sbin/ldconfig
  79. %post -n libqhull_r -p /sbin/ldconfig
  80. %postun -n libqhull_r -p /sbin/ldconfig
  81. %post -n libqhull_p -p /sbin/ldconfig
  82. %postun -n libqhull_p -p /sbin/ldconfig
  83. %files
  84. %{_bindir}/*
  85. %{_docdir}/%{name}-%{version}/
  86. %{_mandir}/man1/*
  87. %files -n libqhull
  88. %{_libdir}/libqhull.so.*
  89. %files -n libqhull_r
  90. %{_libdir}/libqhull_r.so.*
  91. %files -n libqhull_p
  92. %{_libdir}/libqhull_p.so.*
  93. %files devel
  94. %defattr(-,root,root)
  95. %{_includedir}/libqhull*
  96. %{_libdir}/libqhull.so
  97. %{_libdir}/libqhull_r.so
  98. %{_libdir}/libqhull_p.so
  99. %changelog
  100. * Tue Sep 04 2018 Toshiaki Ara <ara_t@384.jp> 2015.2-1
  101. - update to 2015.2-7.2.0
  102. - add patches from fedora package
  103. - split out libqhull, libqhull_p, libqhull_r packages
  104. - drop Provides: libqhull.so
  105. - drop Provides: libqhull_p.so
  106. * Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 2012.1-2
  107. - add Provides: libqhull.so
  108. - add Provides: libqhull_p.so
  109. * Sun Jan 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2012.1-1
  110. - update to 2012.1
  111. * Sat Feb 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2003.1-2
  112. - added Patch0 from upstream
  113. - added --disable-static to %%configure
  114. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 2003.1-1vl5
  115. - applied new versioning policy
  116. - removed *.la
  117. *Thu Jan 03 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2003.1-0vl2
  118. - rebuild on VineSeed
  119. *Thu Oct 6 2005 g-staff <g-staff@math.sci.hokudai.ac.jp> 2003.1-0vl1
  120. - taken from FC
  121. - rebuild on Vine Linux 3.2
  122. * Sun Aug 08 2004 Ralf Corsepius <ralf[AT]links2linux.de> - 2003.1-0.fdr.2
  123. - Use default documentation installation scheme.
  124. * Fri Jul 16 2004 Ralf Corsepius <ralf[AT]links2linux.de> - 2003.1-0.fdr.1
  125. - Initial Fedora RPM.