qedje-vl.spec 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. Name: qedje
  4. Version: 0.4.0
  5. Release: 7%{?_dist_release}
  6. Summary: A library combining the benefits of Edje and Qt
  7. Group: System Environment/Libraries
  8. License: GPLv3+
  9. URL: http://code.openbossa.org/projects/%{name}
  10. Source0: http://code.openbossa.org/projects/%{name}/repos/mainline/archive/0206ec8f2a802bf51455179933d8b7ab3e41a38b.tar.gz
  11. Patch0: qedje-0.4.0-fix_python_install.patch
  12. Patch1: qedje-0.4.0-fix-install.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: qt4-devel
  15. BuildRequires: eet-devel
  16. BuildRequires: qzion-devel
  17. BuildRequires: qzion-python-devel
  18. BuildRequires: cmake
  19. BuildRequires: pkgconfig
  20. BuildRequires: python-devel
  21. BuildRequires: sip-devel
  22. BuildRequires: PyQt4-devel
  23. %description
  24. The main purpose of the QEdje project is to build a bridge among components
  25. that proved to have great value for open source developers: Edje and Qt. This
  26. will extend the Qt toolkit with the flexibility of a declarative language, such
  27. as Edje, and also enable Qt widgets to be embedded into Edje UI design.
  28. %package devel
  29. Summary: Development files for %{name}
  30. Group: Development/Libraries
  31. Requires: cmake
  32. Requires: pkgconfig
  33. Requires: %{name} = %{version}-%{release}
  34. Requires: qzion-devel
  35. Requires: eet-devel
  36. %description devel
  37. The %{name}-devel package contains libraries and header files for
  38. developing applications that use %{name}.
  39. %package python
  40. Summary: Python bindings for %{name}
  41. Group: Development/Libraries
  42. Requires: PyQt4
  43. Requires: qzion-python
  44. %description python
  45. The %{name}-python package contains python bindings for %{name}
  46. %package python-devel
  47. Summary: Python bindings for %{name}
  48. Group: Development/Libraries
  49. Requires: sip
  50. Requires: PyQt4-devel
  51. Requires: qzion-python-devel
  52. Requires: %{name}-python = %{version}-%{release}
  53. %description python-devel
  54. The %{name}-python-devel package contains the development files
  55. for the python bindings for %{name}
  56. %prep
  57. %setup -q -n %{name}-mainline
  58. %patch0 -p1
  59. %patch1 -p1 -b .fix-install
  60. %build
  61. mkdir -p %{_target_platform}
  62. pushd %{_target_platform}
  63. %cmake \
  64. -DPYTHON_SITE_PACKAGES_DIR=%{python_sitearch} \
  65. -DQZION_SIP_DIR=%{_datadir}/sip/qzion \
  66. ..
  67. popd
  68. make %{?_smp_mflags} -C %{_target_platform}
  69. %install
  70. rm -rf %{buildroot}
  71. make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
  72. %clean
  73. rm -rf %{buildroot}
  74. %post -p /sbin/ldconfig
  75. %postun -p /sbin/ldconfig
  76. %files
  77. %defattr(-,root,root,-)
  78. %doc README COPYING
  79. %{_bindir}/qedje_viewer
  80. %{_libdir}/*.so.*
  81. %files devel
  82. %defattr(-,root,root,-)
  83. %{_libdir}/*.so
  84. %{_includedir}/*
  85. %{_libdir}/pkgconfig/%{name}.pc
  86. %files python
  87. %defattr(-,root,root,-)
  88. %{python_sitearch}/%{name}
  89. %files python-devel
  90. %defattr(-,root,root,-)
  91. %{_datadir}/sip/%{name}
  92. %changelog
  93. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.0-7
  94. - rebuild with gcc-5.4.0
  95. * Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.0-6
  96. - rebuilt with rpm-4.8.1 for pkg-config
  97. - added qedje-0.4.0-fix-install.patch (from mandriva)
  98. * Mon Apr 19 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.0-5
  99. - rebuilt with python-2.6
  100. * Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> -0.4.0-3
  101. - use %%cmake macro
  102. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.4.0-3
  103. - Initial build for Vine Linux
  104. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-2
  105. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  106. * Fri Mar 06 2009 John5342 <john5342 at, fedoraproject.org> 0.4.0-1
  107. - Updated to new upstream release (0.4.0)
  108. * Fri Mar 06 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.3.0-5
  109. - revert (previous borkage probably due to qt-4.5-rc1)
  110. * Wed Mar 05 2009 Caolán McNamara <caolanm@redhat.com> - 0.3.0-4
  111. - BR: phonon-devel
  112. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-3
  113. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  114. * Fri Dec 19 2008 John5342 <john5342 at, fedoraproject.org> 0.3.0-2
  115. - Fixed a license
  116. - BR: qzion-devel
  117. - devel R: qzion-devel, eet-devel
  118. * Fri Dec 19 2008 John5342 <john5342 at, fedoraproject.org> 0.3.0-1
  119. - Initial package