qca2-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239
  1. Name: qca2
  2. Version: 2.2.1
  3. Release: 1%{?_dist_release}
  4. Summary: Qt Cryptographic Architecture
  5. Summary(ja): Qt 暗号アーキテクチャ
  6. Group: System Environment/Libraries
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: LGPLv2+
  10. URL: https://userbase.kde.org/QCA
  11. Source0: http://download.kde.org/stable/qca/%{version}/qca-%{version}.tar.xz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: pkgconfig
  14. BuildRequires: cmake
  15. BuildRequires: extra-cmake-modules
  16. BuildRequires: qt5-rpm-macros
  17. BuildRequires: openssl-devel
  18. BuildRequires: qt4-devel
  19. BuildRequires: qt5-qtbase-devel
  20. Provides: qca-qt4 = %{version}-%{release}
  21. %description
  22. Taking a hint from the similarly-named Java Cryptography Architecture,
  23. QCA aims to provide a straightforward and cross-platform crypto API,
  24. using Qt datatypes and conventions. QCA separates the API from the
  25. implementation, using plugins known as Providers. The advantage of this
  26. model is to allow applications to avoid linking to or explicitly depending
  27. on any particular cryptographic library. This allows one to easily change
  28. or upgrade crypto implementations without even needing to recompile the
  29. application!
  30. %package devel
  31. Summary: Qt Cryptographic Architecture development files
  32. Summary(ja): Qt 暗号アーキテクチャの開発用ファイル
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. Requires: qt4-devel >= %{_qt4_version}
  36. Provides: qca-qt4-devel = %{version}-%{release}
  37. %description devel
  38. This packages contains the development files for QCA
  39. %package -n qca2-qt5
  40. Summary: Qt5 Cryptographic Architecture
  41. Summary(ja): Qt5 暗号アーキテクチャ
  42. Group: System Environment/Libraries
  43. Provides: qca-qt5 = %{version}-%{release}
  44. %description -n qca2-qt5
  45. Taking a hint from the similarly-named Java Cryptography Architecture,
  46. QCA aims to provide a straightforward and cross-platform crypto API,
  47. using Qt datatypes and conventions. QCA separates the API from the
  48. implementation, using plugins known as Providers. The advantage of this
  49. model is to allow applications to avoid linking to or explicitly depending
  50. on any particular cryptographic library. This allows one to easily change
  51. or upgrade crypto implementations without even needing to recompile the
  52. application!
  53. %package -n qca2-qt5-devel
  54. Summary: Qt5 Cryptographic Architecture development files
  55. Summary(ja): Qt5 暗号アーキテクチャの開発用ファイル
  56. Group: Development/Libraries
  57. Provides: qca-qt5-devel = %{version}-%{release}
  58. Requires: qca2-qt5 = %{version}-%{release}
  59. Requires: qt5-qtbase-devel
  60. %description -n qca2-qt5-devel
  61. This packages contains the development files for QCA
  62. %prep
  63. %setup -q -n qca-%{version}
  64. %build
  65. mkdir build_qt5
  66. pushd build_qt5
  67. %{cmake} .. \
  68. -DQCA_BINARY_INSTALL_DIR:STRING=%{_bindir} \
  69. -DQCA_FEATURE_INSTALL_DIR:PATH=%{_qt5_archdatadir}/mkspecs/features \
  70. -DQCA_INCLUDE_INSTALL_DIR:PATH=%{_qt5_headerdir} \
  71. -DQCA_LIBRARY_INSTALL_DIR:PATH=%{_qt5_libdir} \
  72. -DQCA_PLUGINS_INSTALL_DIR:PATH=%{_qt5_plugindir} \
  73. -DQCA_PRIVATE_INCLUDE_INSTALL_DIR:PATH=%{_qt5_headerdir} \
  74. -DQT4_BUILD:BOOL=OFF
  75. make %{?_smp_mflags}
  76. popd
  77. mkdir build_qt4
  78. pushd build_qt4
  79. %{cmake} .. \
  80. -DQCA_BINARY_INSTALL_DIR:STRING=%{_bindir} \
  81. -DQCA_FEATURE_INSTALL_DIR:PATH=%{_qt4_prefix}/mkspecs/features \
  82. -DQCA_INCLUDE_INSTALL_DIR:PATH=%{_qt4_headerdir} \
  83. -DQCA_LIBRARY_INSTALL_DIR:PATH=%{_qt4_libdir} \
  84. -DQCA_PLUGINS_INSTALL_DIR:PATH=%{_qt4_plugindir} \
  85. -DQCA_PRIVATE_INCLUDE_INSTALL_DIR:PATH=%{_qt4_headerdir} \
  86. -DQT4_BUILD:BOOL=ON
  87. make %{?_smp_mflags}
  88. popd
  89. %install
  90. rm -rf %{buildroot}
  91. make install/fast DESTDIR=%{buildroot} -C build_qt5
  92. make install/fast DESTDIR=%{buildroot} -C build_qt4
  93. %clean
  94. rm -rf $RPM_BUILD_ROOT
  95. %post -p /sbin/ldconfig
  96. %postun -p /sbin/ldconfig
  97. %post -n qca2-qt5 -p /sbin/ldconfig
  98. %postun -n qca2-qt5 -p /sbin/ldconfig
  99. %files
  100. %defattr(-,root,root,-)
  101. %license COPYING
  102. %doc README TODO
  103. %{_qt4_libdir}/libqca.so.2*
  104. %{_bindir}/mozcerts
  105. %{_bindir}/qcatool
  106. %{_mandir}/man1/qcatool.1*
  107. %dir %{_qt4_plugindir}/crypto/
  108. %{_qt4_plugindir}/crypto/*
  109. %files devel
  110. %defattr(-,root,root,-)
  111. %{_includedir}/QtCrypto
  112. %{_libdir}/libqca.so
  113. %{_libdir}/pkgconfig/qca2.pc
  114. %{_libdir}/cmake/Qca/
  115. %{_qt4_datadir}/mkspecs/features/crypto.prf
  116. %files -n qca2-qt5
  117. %doc README TODO
  118. %license COPYING
  119. %{_bindir}/mozcerts-qt5
  120. %{_bindir}/qcatool-qt5
  121. %{_mandir}/man1/qcatool-qt5.1*
  122. %{_qt5_libdir}/libqca-qt5.so.2*
  123. %dir %{_qt5_plugindir}/crypto/
  124. %{_qt5_plugindir}/crypto/*
  125. %files -n qca2-qt5-devel
  126. %{_qt5_headerdir}/QtCrypto
  127. %{_qt5_libdir}/libqca-qt5.so
  128. %{_libdir}/pkgconfig/qca2-qt5.pc
  129. %{_libdir}/cmake/Qca-qt5/
  130. %{_qt5_archdatadir}/mkspecs/features/crypto.prf
  131. %changelog
  132. * Sun Oct 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.2.1-1
  133. - new upstream release.
  134. - added Qt5 support.
  135. * Mon Jul 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.0.3-5
  136. - rebuild with gcc-5.4.0
  137. * Mon Feb 9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.0.3-4
  138. - rebuilt on current VineSeed
  139. - added patch0 from Fedora
  140. - added Japanese summary
  141. * Sun Jan 8 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.3-3
  142. - rebuilt with qt-4.8.0
  143. * Tue Mar 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.3-2
  144. - rebuilt with qt-4.7.2
  145. * Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.3-1
  146. - new upstream release
  147. - built with qt-4.7.1
  148. * Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-8
  149. - rebuilt with rpm-4.8.1
  150. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.0.2-7
  151. - rebuilt with qt-4.6.3 again
  152. - change BuildRequires: qt4-devel = %{qt4_ver} (add version)
  153. * Sat Jul 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-6
  154. - rebuilt with qt-4.6.3
  155. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.2-5
  156. - rebuilt with new toolchain, qt4-4.6.1
  157. * Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-4
  158. - rebuilt with qt-4.5.3
  159. * Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-3
  160. - Initial build for Vine Linux
  161. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.2-2
  162. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  163. * Tue May 05 2009 Sven Lankes <sven@lank.es> - 2.0.2-1
  164. - new upstream release - qt 4.5-compat-fixes
  165. * Wed Apr 08 2009 Sven Lankes <sven@lank.es> - 2.0.1-1
  166. - new upstream release
  167. - removed 64bit patch - now upstream
  168. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4
  169. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  170. * Fri May 30 2008 Dennis Gilmore <dennis@ausil.us> - 2.0.0-3
  171. - crypto.prf is in libdir not datadir
  172. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.0-2
  173. - Autorebuild for GCC 4.3
  174. * Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-1
  175. - version 2.0.0 final
  176. * Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.4.beta7
  177. - fix build on x86_64
  178. * Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.3.beta7
  179. - missing BR: openssl
  180. * Thu Sep 13 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.2.beta7
  181. - review from bug 289681 (thanks Rex)
  182. * Sun Sep 09 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.1.beta7
  183. - initial package