python3-setuptools-vl.spec 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140
  1. %{!?python3_sitelib: %define python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
  2. %{!?python3_version: %define python3_version %(python3 -c "import sys; sys.stdout.write(sys.version[:3])")}
  3. Name: python3-setuptools
  4. Version: 5.4.2
  5. Release: 1%{?_dist_release}
  6. Summary: Download, build, install, upgrade, and uninstall Python packages
  7. Summary(ja): Python パッケージのダウンロード、ビルド、インストール、アップグレードおよびアンインストール用ツール
  8. Group: Development/Tools
  9. License: PSFL/ZPL
  10. URL: https://pypi.python.org/pypi/setuptools
  11. Source0: https://pypi.python.org/packages/source/s/setuptools/setuptools-%{version}.tar.gz
  12. Source1: psfl.txt
  13. Source2: zpl.txt
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. Requires(post): alternatives
  16. BuildArch: noarch
  17. BuildRequires: python3-devel
  18. %description
  19. setuptools is a collection of enhancements to the Python distutils that allow
  20. you to more easily build and distribute Python packages, especially ones that
  21. have dependencies on other packages.
  22. %description -l ja
  23. setuptools は Python distutils の拡張機能を集めたツールです。
  24. このツールにより Python パッケージの構築や配布が簡単に行えるように
  25. なります。特に他のパッケージに依存しているパッケージを扱う際に便利
  26. です。
  27. %prep
  28. %setup -q -n setuptools-%{version}
  29. %build
  30. CFLAGS="$RPM_OPT_FLAGS" python3 setup.py build
  31. %install
  32. rm -rf $RPM_BUILD_ROOT
  33. python3 setup.py install -O1 --skip-build \
  34. --root $RPM_BUILD_ROOT \
  35. --single-version-externally-managed
  36. install -p -m 0644 %{SOURCE1} %{SOURCE2} .
  37. find $RPM_BUILD_ROOT%{python3_sitelib} -name '*.exe' | xargs rm -f
  38. # for alternatives
  39. %__rm -f $RPM_BUILD_ROOT%{_bindir}/easy_install
  40. %clean
  41. rm -rf $RPM_BUILD_ROOT
  42. %post
  43. update-alternatives --install %{_bindir}/easy_install easy_install \
  44. %{_bindir}/easy_install-%{python3_version} 20
  45. %preun
  46. if [ "$1" = "0" ]
  47. then
  48. update-alternatives --remove easy_install %{_bindir}/easy_install-%{python3_version}
  49. fi
  50. %files
  51. %defattr(-,root,root,-)
  52. %doc *.txt
  53. %{_bindir}/easy_install-%{python3_version}
  54. %{python3_sitelib}/*
  55. %changelog
  56. * Mon Mar 9 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 5.4.2-1
  57. - new package python3-setuptools: based python-setuptools
  58. * Mon Mar 9 2015 IWAI, Masaharu <iwaim.sub@gmail.com> - 5.4.2-2
  59. - alternatives for easy_install
  60. * Fri Aug 08 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 5.4.2-1
  61. - new upstream release
  62. * Sat Jul 26 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 5.4.1-1
  63. - new upstream release
  64. * Sun Jul 06 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 5.4-1
  65. - new upstream release
  66. * Sat Apr 26 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.4.4-1
  67. - new upstream release
  68. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6c11-2
  69. - rebuild with python-2.7.2
  70. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.6c11-1
  71. - new upstream release
  72. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.6c9-2
  73. - rebuild with python-2.6
  74. * Sun Dec 07 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6c9-1
  75. - new upstream release
  76. - add japanese summary and description
  77. * Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> - 0.6c3-1vl5
  78. - rebuilt with python-2.5.2
  79. - applied new versioning policy
  80. * Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6c3-1vl2
  81. - rebuilt for Vine Linux 4.0
  82. - changed Group to Development/Tools
  83. * Wed Nov 15 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  84. - Refurbished for VineLinux3.2
  85. * Tue Sep 12 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6c2-1
  86. - Upstream 0.6c2
  87. - Ghostbusting
  88. * Mon Jul 31 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6c1-2
  89. - Set perms on license files (#200768)
  90. * Sat Jul 22 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6c1-1
  91. - Version 0.6c1
  92. * Wed Jun 28 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6b3-1
  93. - Taking over from Ignacio
  94. - Version 0.6b3
  95. - Ghost .pyo files in sitelib
  96. - Add license files
  97. - Remove manual python-abi, since we're building FC4 and up
  98. - Kill .exe files
  99. * Wed Feb 15 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.6a10-1
  100. - Upstream update
  101. * Mon Jan 16 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.6a9-1
  102. - Upstream update
  103. * Sat Dec 24 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.6a8-1
  104. - Initial RPM release