python-whoosh-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208
  1. %global with_python3 1
  2. # For bootstrapping sphinxcontrib-websupport
  3. %bcond_with docs
  4. %global mod_name Whoosh
  5. Summary: Fast, pure-Python full text indexing, search, and spell checking library
  6. Name: python-whoosh
  7. Version: 2.7.4
  8. Release: 14%{?_dist_release}
  9. Group: programming
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. License: BSD
  13. URL: http://pythonhosted.org/Whoosh/
  14. Source0: https://pypi.python.org/packages/source/W/%{mod_name}/%{mod_name}-%{version}.tar.gz
  15. BuildArch: noarch
  16. BuildRequires: python-rpm-macros
  17. BuildRequires: python2-rpm-macros
  18. BuildRequires: python-devel
  19. BuildRequires: python-setuptools
  20. %if %{with docs}
  21. BuildRequires: python-sphinx
  22. %endif
  23. %{?python_provide:%python_provide python2-whoosh}
  24. %if 0%{?with_python3}
  25. BuildRequires: python3-rpm-macros
  26. BuildRequires: python3-devel
  27. BuildRequires: python3-setuptools
  28. %endif
  29. %description
  30. Whoosh is a fast, featureful full-text indexing and searching library
  31. implemented in pure Python. Programmers can use it to easily add search
  32. functionality to their applications and websites. Every part of how Whoosh
  33. works can be extended or replaced to meet your needs exactly.
  34. %if 0%{?with_python3}
  35. %package -n python3-whoosh
  36. Summary: Fast, Python3 full text indexing, search, and spell checking library
  37. %{?python_provide:%python_provide python%{python3_pkgversion}-whoosh}
  38. Group: programming
  39. %description -n python3-whoosh
  40. Whoosh is a fast, featureful full-text indexing and searching library
  41. implemented in pure Python. Programmers can use it to easily add search
  42. functionality to their applications and websites. Every part of how Whoosh
  43. works can be extended or replaced to meet your needs exactly.
  44. %endif
  45. %prep
  46. %setup -q -n %{mod_name}-%{version}
  47. %build
  48. %py2_build
  49. %if %{with docs}
  50. sphinx-build docs/source docs/html
  51. rm -f docs/html/.buildinfo
  52. rm -rf docs/html/.doctrees
  53. %endif
  54. %if 0%{?with_python3}
  55. %py3_build
  56. rm -f docs/html/.buildinfo
  57. rm -rf docs/html/.doctrees
  58. %endif
  59. %install
  60. %py2_install
  61. %if 0%{?with_python3}
  62. %py3_install
  63. %endif
  64. %if 0
  65. %check
  66. {__python2} setup.py test
  67. %if 0%{?with_python3}
  68. %{__python3} setup.py test
  69. %endif
  70. %endif
  71. %files
  72. %license LICENSE.txt
  73. %doc README.txt
  74. %if %{with docs}
  75. %doc docs/html/
  76. %endif
  77. %{python2_sitelib}/*.egg-info/
  78. %{python2_sitelib}/whoosh
  79. %if 0%{?with_python3}
  80. %files -n python%{python3_pkgversion}-whoosh
  81. %license LICENSE.txt
  82. %doc README.txt
  83. %if %{with docs}
  84. %doc docs/html/
  85. %endif
  86. %{python3_sitelib}/whoosh
  87. %{python3_sitelib}/*.egg-info/
  88. %endif
  89. %changelog
  90. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.7.4-14
  91. - rebuilt with python-3.8.
  92. * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.7.4-13
  93. - initial build for Vine Linux.
  94. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-12
  95. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  96. * Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 2.7.4-11
  97. - Rebuilt for Python 3.7
  98. * Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 2.7.4-10
  99. - Bootstrap for Python 3.7
  100. * Wed Feb 28 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.7.4-9
  101. - Update Python 2 dependency declarations to new packaging standards
  102. (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
  103. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-8
  104. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  105. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-7
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  107. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-6
  108. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  109. * Tue Dec 13 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.7.4-5
  110. - Enable tests
  111. * Mon Dec 12 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.7.4-4
  112. - Rebuild for Python 3.6
  113. - Disable python3 tests for now
  114. * Wed Oct 12 2016 Orion Poplawski <orion@cora.nwra.com> - 2.7.4-3
  115. - Ship python2-whoosh
  116. - Build python3 package for EPEL7
  117. - Modernize spec
  118. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.4-2
  119. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  120. * Sun May 01 2016 Robert Kuska <rkuska@gmail.com> - 2.7.4-1
  121. - Update to version 2.7.4
  122. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.0-2
  123. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  124. * Mon Oct 12 2015 Robert Kuska <rkuska@redhat.com> 2.7.0-1
  125. - Update to version 2.7.0
  126. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.7-5
  127. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  128. * Wed Jul 30 2014 Robert Kuska <rkuska@redhat.com> - 2.7.5-4
  129. - Change spec for el6 and epel7
  130. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.7-3
  131. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  132. * Fri May 16 2014 Robert Kuska <rkuska@redhat.com> - 2.7.5-2
  133. - Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
  134. * Mon Mar 03 2014 Robert Kuska <rkuska@redhat.com> - 2.5.7-1
  135. - Rebase to 2.5.7
  136. * Mon Jan 27 2014 Robert Kuska <rkuska@redhat.com> - 2.5.6-1
  137. - Rebase to 2.5.6
  138. * Tue Nov 19 2013 Robert Kuska <rkuska@redhat.com> - 2.5.5-1
  139. - Rebase to 2.5.5
  140. * Mon Sep 09 2013 Robert Kuska <rkuska@redhat.com> - 2.5.3-1
  141. - Rebase to 2.5.3
  142. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.1-2
  143. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  144. * Mon Jul 08 2013 Robert Kuska <rkuska@redhat.com> - 2.5.1-1
  145. - Update source
  146. - Add python3 subpackage (rhbz#979235)
  147. * Mon Apr 08 2013 Robert Kuska <rkuska@redhat.com> - 2.4.1-2
  148. - Review fixes
  149. * Fri Apr 05 2013 Robert Kuska <rkuska@redhat.com> - 2.4.1-1
  150. - Initial package