python-urllib3-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333
  1. %global srcname urllib3
  2. # When bootstrapping Python, we cannot test this yet
  3. %bcond_without tests
  4. Summary: Python HTTP library with thread-safe connection pooling and file post
  5. Name: python-%{srcname}
  6. Version: 1.25.10
  7. Release: 1%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: MIT
  12. URL: https://github.com/urllib3/urllib3
  13. Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
  14. # Unbundle ssl_match_hostname since we depend on it
  15. Source1: ssl_match_hostname_py3.py
  16. BuildArch: noarch
  17. %{?python_provide:%python_provide python2-%{srcname}}
  18. Requires: ca-certificates
  19. # Previously bundled things:
  20. Requires: python-six
  21. #Requires: python-backports-ssl_match_hostname
  22. # Secure extra requirements
  23. Requires: python-ipaddress
  24. Requires: python-pysocks
  25. BuildRequires: python-devel
  26. BuildRequires: python-rpm-macros
  27. BuildRequires: python2-rpm-macros
  28. BuildRequires: python-setuptools
  29. %description
  30. Python HTTP module with connection pooling and file POST abilities.
  31. %package -n python3-%{srcname}
  32. Summary: Python3 HTTP library with thread-safe connection pooling and file post
  33. Group: programming
  34. BuildRequires: python3-devel
  35. BuildRequires: python3-rpm-macros
  36. BuildRequires: python3-setuptools
  37. Requires: ca-certificates
  38. Requires: python3-six
  39. Requires: python3-pysocks
  40. %description -n python3-%{srcname}
  41. Python3 HTTP module with connection pooling and file POST abilities.
  42. %prep
  43. %autosetup -p1 -n %{srcname}-%{version}
  44. # Drop the dummyserver tests in koji. They fail there in real builds, but not
  45. # in scratch builds (weird).
  46. rm -rf test/with_dummyserver/
  47. # Don't run the Google App Engine tests
  48. rm -rf test/appengine/
  49. # Lots of these tests started failing, even for old versions, so it has something
  50. # to do with Fedora in particular. They don't fail in upstream build infrastructure
  51. rm -rf test/contrib/
  52. # Tests for Python built without SSL, but Fedora builds with SSL. These tests
  53. # fail when combined with the unbundling of backports-ssl_match_hostname
  54. rm -f test/test_no_ssl.py
  55. %build
  56. %py_build
  57. %py3_build
  58. %install
  59. %py_install
  60. %py3_install
  61. # Unbundle the Python 2 build
  62. rm -rf %{buildroot}/%{python_sitelib}/urllib3/packages/six.py*
  63. #rm -rf %{buildroot}/%{python_sitelib}/urllib3/packages/ssl_match_hostname/
  64. mkdir -p %{buildroot}/%{python_sitelib}/urllib3/packages/
  65. ln -s %{python_sitelib}/six.py %{buildroot}/%{python_sitelib}/urllib3/packages/six.py
  66. ln -s %{python_sitelib}/six.pyc %{buildroot}/%{python_sitelib}/urllib3/packages/six.pyc
  67. ln -s %{python_sitelib}/six.pyo %{buildroot}/%{python_sitelib}/urllib3/packages/six.pyo
  68. #ln -s %{python_sitelib}/backports/ssl_match_hostname \
  69. # %{buildroot}/%{python_sitelib}/urllib3/packages/ssl_match_hostname
  70. # Unbundle the Python 3 build
  71. rm -rf %{buildroot}/%{python3_sitelib}/urllib3/packages/six.py*
  72. rm -rf %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/six*
  73. rm -rf %{buildroot}/%{python3_sitelib}/urllib3/packages/ssl_match_hostname/
  74. mkdir -p %{buildroot}/%{python3_sitelib}/urllib3/packages/
  75. cp -a %{SOURCE1} %{buildroot}/%{python3_sitelib}/urllib3/packages/ssl_match_hostname.py
  76. ln -s %{python3_sitelib}/six.py %{buildroot}/%{python3_sitelib}/urllib3/packages/six.py
  77. ln -s %{python3_sitelib}/__pycache__/six.cpython-%{python3_version_nodots}.opt-1.pyc \
  78. %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/
  79. ln -s %{python3_sitelib}/__pycache__/six.cpython-%{python3_version_nodots}.pyc \
  80. %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/
  81. %files
  82. %license LICENSE.txt
  83. %doc CHANGES.rst README.rst CONTRIBUTORS.txt
  84. %{python_sitelib}/urllib3/
  85. %{python_sitelib}/urllib3-*.egg-info
  86. %files -n python3-%{srcname}
  87. %license LICENSE.txt
  88. %doc CHANGES.rst README.rst CONTRIBUTORS.txt
  89. %{python3_sitelib}/urllib3/
  90. %{python3_sitelib}/urllib3-*.egg-info
  91. %changelog
  92. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.25.10-1
  93. - new upstream release.
  94. * Sun Mar 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.25.8-1
  95. - new upstream release.
  96. * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.24.1-3
  97. - initial build for Vine Linux.
  98. * Tue Nov 13 2018 Jeremy Cline <jeremy@jcline.org> - 1.24.1-2
  99. - Adjust unbundling of ssl_match_hostname
  100. * Mon Oct 29 2018 Jeremy Cline <jeremy@jcline.org> - 1.24.1-1
  101. - Update to v1.24.1
  102. * Wed Jun 20 2018 Lumír Balhar <lbalhar@redhat.com> - 1.23-4
  103. - Removed unneeded dependency python[23]-psutil
  104. * Mon Jun 18 2018 Miro Hrončok <mhroncok@redhat.com> - 1.23-3
  105. - Rebuilt for Python 3.7
  106. * Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 1.23-2
  107. - Bootstrap for Python 3.7
  108. * Tue Jun 05 2018 Jeremy Cline <jeremy@jcline.org> - 1.23-1
  109. - Update to the latest upstream release (rhbz 1586072)
  110. * Wed May 30 2018 Jeremy Cline <jeremy@jcline.org> - 1.22-10
  111. - Backport patch to support Python 3.7 (rhbz 1584112)
  112. * Thu May 03 2018 Lukas Slebodnik <lslebodn@fedoraproject.org> - 1.22-9
  113. - Do not lowercase hostnames with custom-protocol (rhbz 1567862)
  114. - upstream: https://github.com/urllib3/urllib3/issues/1267
  115. * Wed Apr 18 2018 Jeremy Cline <jeremy@jcline.org> - 1.22-8
  116. - Drop the dependency on idna and cryptography (rhbz 1567862)
  117. * Mon Apr 16 2018 Jeremy Cline <jeremy@jcline.org> - 1.22-7
  118. - Drop the dependency on PyOpenSSL, it's not needed (rhbz 1567862)
  119. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.22-6
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  121. * Wed Jan 31 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.22-5
  122. - Update Python 2 dependency declarations to new packaging standards
  123. (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
  124. * Thu Jan 25 2018 Tomas Hoger <thoger@redhat.com> - 1.22-4
  125. - Fix FTBFS - Move RECENT_DATE to 2017-06-30
  126. * Fri Dec 01 2017 Jeremy Cline <jeremy@jcline.org> - 1.22-3
  127. - Symlink the Python 3 bytecode for six (rbhz 1519147)
  128. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.22-2
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  130. * Fri Jul 21 2017 Jeremy Cline <jeremy@jcline.org> - 1.22-1
  131. - Update to 1.22 (#1473293)
  132. * Wed May 17 2017 Jeremy Cline <jeremy@jcline.org> - 1.21.1-1
  133. - Update to 1.21.1 (#1445280)
  134. * Thu Feb 09 2017 Jeremy Cline <jeremy@jcline.org> - 1.20-1
  135. - Update to 1.20 (#1414775)
  136. * Tue Dec 13 2016 Stratakis Charalampos <cstratak@redhat.com> - 1.19.1-2
  137. - Rebuild for Python 3.6
  138. * Thu Nov 17 2016 Jeremy Cline <jeremy@jcline.org> 1.19.1-1
  139. - Update to 1.19.1
  140. - Clean up the specfile to only support Fedora 26
  141. * Wed Aug 10 2016 Kevin Fenzi <kevin@scrye.com> - 1.16-3
  142. - Rebuild now that python-requests is ready to update.
  143. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16-2
  144. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  145. * Wed Jun 15 2016 Kevin Fenzi <kevin@scrye.com> - 1.16-1
  146. - Update to 1.16
  147. * Thu Jun 02 2016 Ralph Bean <rbean@redhat.com> - 1.15.1-3
  148. - Create python2 subpackage to comply with guidelines.
  149. * Wed Jun 01 2016 Ralph Bean <rbean@redhat.com> - 1.15.1-2
  150. - Remove broken symlinks to unbundled python3-six files
  151. https://bugzilla.redhat.com/show_bug.cgi?id=1295015
  152. * Fri Apr 29 2016 Ralph Bean <rbean@redhat.com> - 1.15.1-1
  153. - Removed patch for ipv6 support, now applied upstream.
  154. - Latest version.
  155. - New dep on pysocks.
  156. * Fri Feb 26 2016 Ralph Bean <rbean@redhat.com> - 1.13.1-3
  157. - Apply patch from upstream to fix ipv6.
  158. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.13.1-2
  159. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  160. * Mon Dec 21 2015 Ralph Bean <rbean@redhat.com> - 1.13.1-1
  161. - new version
  162. * Fri Dec 18 2015 Ralph Bean <rbean@redhat.com> - 1.13-1
  163. - new version
  164. * Mon Dec 14 2015 Ralph Bean <rbean@redhat.com> - 1.12-1
  165. - new version
  166. * Thu Oct 15 2015 Robert Kuska <rkuska@redhat.com> - 1.10.4-7
  167. - Rebuilt for Python3.5 rebuild
  168. * Sat Oct 10 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-6
  169. - Sync from PyPI instead of a git checkout.
  170. * Tue Sep 08 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-5.20150503gita91975b
  171. - Drop requirement on python-backports-ssl_match_hostname on F22 and newer.
  172. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10.4-4.20150503gita91975b
  173. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  174. * Mon Jun 08 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-3.20150503gita91975b
  175. - Apply pyopenssl injection for an outdated cpython as per upstream advice
  176. https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning
  177. https://urllib3.readthedocs.org/en/latest/security.html#pyopenssl
  178. * Tue May 19 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-2.20150503gita91975b
  179. - Specify symlinks for six.py{c,o}, fixing rhbz #1222142.
  180. * Sun May 03 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-1.20150503gita91975b
  181. - Latest release for python-requests-2.7.0
  182. * Wed Apr 29 2015 Ralph Bean <rbean@redhat.com> - 1.10.3-2.20150429git585983a
  183. - Grab a git snapshot to get around this chunked encoding failure.
  184. * Wed Apr 22 2015 Ralph Bean <rbean@redhat.com> - 1.10.3-1
  185. - new version
  186. * Thu Feb 26 2015 Ralph Bean <rbean@redhat.com> - 1.10.2-1
  187. - new version
  188. * Wed Feb 18 2015 Ralph Bean <rbean@redhat.com> - 1.10.1-1
  189. - new version
  190. * Wed Feb 18 2015 Ralph Bean <rbean@redhat.com> - 1.10.1-1
  191. - new version
  192. * Mon Jan 05 2015 Ralph Bean <rbean@redhat.com> - 1.10-2
  193. - Copy in a shim for ssl_match_hostname on python3.
  194. * Sun Dec 14 2014 Ralph Bean <rbean@redhat.com> - 1.10-1
  195. - Latest upstream 1.10, for python-requests-2.5.0.
  196. - Re-do unbundling without patch, with symlinks.
  197. - Modernize python2 macros.
  198. - Remove the with_dummyserver tests which fail only sometimes.
  199. * Wed Nov 05 2014 Ralph Bean <rbean@redhat.com> - 1.9.1-1
  200. - Latest upstream, 1.9.1 for latest python-requests.
  201. * Mon Aug 4 2014 Tom Callaway <spot@fedoraproject.org> - 1.8.2-4
  202. - fix license handling
  203. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.2-3
  204. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  205. * Wed May 14 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 1.8.2-2
  206. - Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
  207. * Mon Apr 21 2014 Arun S A G <sagarun@gmail.com> - 1.8.2-1
  208. - Update to latest upstream version
  209. * Mon Oct 28 2013 Ralph Bean <rbean@redhat.com> - 1.7.1-2
  210. - Update patch to find ca_certs in the correct location.
  211. * Wed Sep 25 2013 Ralph Bean <rbean@redhat.com> - 1.7.1-1
  212. - Latest upstream with support for a new timeout class and py3.4.
  213. * Wed Aug 28 2013 Ralph Bean <rbean@redhat.com> - 1.7-3
  214. - Bump release again, just to push an unpaired update.
  215. * Mon Aug 26 2013 Ralph Bean <rbean@redhat.com> - 1.7-2
  216. - Bump release to pair an update with python-requests.
  217. * Thu Aug 22 2013 Ralph Bean <rbean@redhat.com> - 1.7-1
  218. - Update to latest upstream.
  219. - Removed the accept-header proxy patch which is included in upstream now.
  220. - Removed py2.6 compat patch which is included in upstream now.
  221. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-7
  222. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  223. * Tue Jun 11 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-6
  224. - Fix Requires of python-ordereddict to only apply to RHEL
  225. * Fri Mar 1 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-5
  226. - Unbundling finished!
  227. * Fri Mar 01 2013 Ralph Bean <rbean@redhat.com> - 1.5-4
  228. - Upstream patch to fix Accept header when behind a proxy.
  229. - Reorganize patch numbers to more clearly distinguish them.
  230. * Wed Feb 27 2013 Ralph Bean <rbean@redhat.com> - 1.5-3
  231. - Renamed patches to python-urllib3-*
  232. - Fixed ssl check patch to use the correct cert path for Fedora.
  233. - Included dependency on ca-certificates
  234. - Cosmetic indentation changes to the .spec file.
  235. * Tue Feb 5 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-2
  236. - python3-tornado BR and run all unittests on python3
  237. * Mon Feb 04 2013 Toshio Kuratomi <toshio@fedoraproject.org> 1.5-1
  238. - Initial fedora build.