python-urlgrabber-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343
  1. %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. Summary: A high-level cross-protocol url-grabber
  3. Name: python-urlgrabber
  4. Version: 3.10.1
  5. Release: 7%{?_dist_release}
  6. License: LGPLv2+
  7. Group: Development/Libraries
  8. URL: http://urlgrabber.baseurl.org/
  9. Source0: http://urlgrabber.baseurl.org/download/urlgrabber-%{version}.tar.gz
  10. Patch1: urlgrabber-HEAD.patch
  11. Patch2: BZ-1051554-speed-on-404-mirror.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildArch: noarch
  14. BuildRequires: python-devel
  15. BuildRequires: python-pycurl
  16. Requires: python-pycurl
  17. Provides: urlgrabber = %{version}-%{release}
  18. %description
  19. A high-level cross-protocol url-grabber for python supporting HTTP, FTP
  20. and file locations. Features include keepalive, byte ranges, throttling,
  21. authentication, proxies and more.
  22. %prep
  23. %setup -q -n urlgrabber-%{version}
  24. %patch1 -p1
  25. %patch2 -p1
  26. %build
  27. python setup.py build
  28. %install
  29. rm -rf $RPM_BUILD_ROOT
  30. python setup.py install -O1 --root=$RPM_BUILD_ROOT
  31. rm -rf $RPM_BUILD_ROOT/%{_docdir}/urlgrabber-%{version}
  32. %clean
  33. rm -rf $RPM_BUILD_ROOT
  34. %files
  35. %defattr(-,root,root,-)
  36. %doc ChangeLog README TODO LICENSE
  37. %{_bindir}/urlgrabber
  38. %attr(0755,root,root) %{_libexecdir}/urlgrabber-ext-down
  39. %{python_sitelib}/urlgrabber*
  40. %changelog
  41. * Tue Feb 3 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 3.10.1-7
  42. - Inital build for Vine Linux
  43. * Fri Oct 03 2014 Valentina Mukhamedzhanova <vmukhame@redhat.com> - 3.10.1-6
  44. - Revert porting to Python 3.
  45. * Tue Sep 09 2014 Tomas Radej <tradej@redhat.com> - 3.10.1-5
  46. - Really fixed UTF behaviour
  47. * Tue Sep 02 2014 Tomas Radej <tradej@redhat.com> - 3.10.1-4
  48. - Fixed UTF behaviour (bz #1135632)
  49. * Fri Aug 29 2014 Valentina Mukhamedzhanova <vmukhame@redhat.com> - 3.10.1-3
  50. - Don't set speed=0 on a new mirror that 404'd. BZ 1051554
  51. - Support both Python 2 and 3. BZ 985288
  52. * Sun Aug 3 2014 Tom Callaway <spot@fedoraproject.org> - 3.10.1-2
  53. - fix license handling
  54. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.10.1-1
  55. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  56. * Wed Dec 18 2013 Zdenek Pavlas <zpavlas@redhat.com> - 3.10.1-0
  57. - Update to latest HEAD.
  58. - Decrease the default_speed value. BZ 1043177
  59. - Added client-side range support. BZ 435076
  60. * Mon Dec 9 2013 Zdenek Pavlas <zpavlas@redhat.com> - 3.10-1
  61. - Process mirror retries before other queued requests.
  62. - Tell curl to return immediately on ctrl-c. BZ 1017491
  63. * Wed Oct 9 2013 Zdenek Pavlas <zpavlas@redhat.com> - 3.10-0
  64. - Update to latest HEAD.
  65. - clamp timestamps from the future. BZ 894630, 1013733
  66. - Fix the condition to enter single-connection mode. BZ 853432
  67. - Fix unit tests
  68. * Fri Sep 27 2013 Zdenek Pavlas <zpavlas@redhat.com> - 3.9.1-32
  69. - Update to latest HEAD.
  70. - Switch to max_connections=1 after refused connect. BZ 853432
  71. - Never display negative downloading speed. BZ 1001767
  72. * Thu Aug 29 2013 Zdenek Pavlas <zpavlas@redhat.com> - 3.9.1-31
  73. - Update to latest HEAD.
  74. - add ftp_disable_epsv option. BZ 849177
  75. - Spelling fixes.
  76. - docs: throttling is per-connection, suggest max_connections=1. BZ 998263
  77. - More robust "Content-Length" parsing. BZ 1000841
  78. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.9.1-30
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  80. * Tue Jun 18 2013 Zdenek Pavlas <zpavlas@redhat.com> - 3.9.1-29
  81. - Update to latest HEAD.
  82. - Fix parsing of FTP 213 responses
  83. - Switch to max_connections=1 after timing out. BZ 853432
  84. - max_connections=0 should imply the default limit.
  85. * Fri May 17 2013 Zdenek Pavlas <zpavlas@redhat.com> - 3.9.1-28
  86. - Update to latest HEAD.
  87. - Add the "minrate" option. BZ 964298
  88. - Workaround progress "!!!" end for file:// repos.
  89. - add URLGrabError.code to the external downloader API
  90. - Disable GSSNEGOTIATE to work around a curl bug. BZ 960163
  91. * Wed Mar 27 2013 Zdenek Pavlas <zpavlas@redhat.com> - 3.9.1-26
  92. - Update to latest HEAD.
  93. - Handle HTTP 200 response to range requests correctly. BZ 919076
  94. - Reset curl_obj to clear CURLOPT_RANGE from previous requests. BZ 923951
  95. * Thu Mar 7 2013 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-25
  96. - Update to latest HEAD.
  97. - fix some test cases that were failing. BZ 918658
  98. - exit(1) or /bin/urlgrabber failures. BZ 918613
  99. - clamp timestamps from the future. BZ 894630
  100. - enable GSSNEGOTIATE if implemented correctly.
  101. - make error messages more verbose.
  102. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.9.1-24
  103. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  104. * Mon Jan 7 2013 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-23
  105. - Update to latest HEAD.
  106. - Handle checkfunc unicode exceptions. BZ 672117
  107. * Thu Dec 6 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-22
  108. - Update to latest HEAD.
  109. - Improve URLGRABBER_DEBUG, add max_connections. BZ 853432
  110. * Thu Nov 1 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-21
  111. - Update to latest HEAD.
  112. - Get rid of "HTTP 200 OK" errors. BZ 871835.
  113. * Tue Sep 4 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-20
  114. - Update to latest HEAD.
  115. - Fixed BZ 851178, 854075.
  116. * Mon Aug 27 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-19
  117. - timedhosts: defer 1st update until a 1MB+ download. BZ 851178
  118. * Wed Aug 22 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-18
  119. - Update to latest HEAD, lots of enhancements.
  120. * Wed Aug 10 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-17
  121. - Fix a bug in progress display code. BZ 847105.
  122. * Wed Aug 8 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-16
  123. - Update to latest head.
  124. - Improved multi-file progress, small bugfixes.
  125. * Fri Jul 20 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-15
  126. - Update to latest head, misc bugfixes: BZ 832028, 831904, 831291.
  127. - Disable Kerberos auth. BZ 769254
  128. - copy_local bugfix. BZ 837018
  129. - send 'tries' counter to mirror failure callback
  130. * Mon May 21 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-14
  131. - timedhosts: sanity check on dl_time
  132. * Fri May 18 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-13
  133. - fix file:// profiling. BZ 822632.
  134. * Mon May 14 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-12
  135. - Update to latest HEAD
  136. - Merge multi-downloader patches
  137. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.9.1-11
  138. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  139. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.9.1-10
  140. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  141. * Fri Sep 3 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.9.1-9
  142. - new update to latest head with a number of patches collected from
  143. older bug reports.
  144. * Mon Aug 30 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.9.1-8
  145. - update to latest head patches
  146. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 3.9.1-7
  147. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  148. * Tue Apr 13 2010 James Antill <james@fedoraproject.org> 3.9.1-6
  149. - Update to upstream HEAD.
  150. - LOWSPEEDLIMIT and hdrs
  151. * Fri Feb 19 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.9.1-5
  152. - add patch to allow reset_curl_obj() to close and reload the cached curl obj
  153. * Thu Nov 12 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.1-4
  154. - reset header values when we redirect and make sure debug output will work
  155. * Wed Nov 11 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.1-3
  156. - fixing a bunch of redirect and max size bugs
  157. * Fri Sep 25 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.1-2
  158. - stupid patch
  159. * Fri Sep 25 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.1-1
  160. - 3.9.1
  161. * Tue Aug 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.0-8
  162. - ssl options, http POST string type fixes
  163. * Mon Aug 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.0-6
  164. - reget fixes, tmpfiles no longer made for urlopen() calls.
  165. * Wed Aug 5 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.0-5
  166. - apply complete patch to head fixes: timeouts, regets, improves exception raising
  167. * Tue Aug 4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.0-4
  168. - timeout patch for https://bugzilla.redhat.com/show_bug.cgi?id=515497
  169. * Thu Jul 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.0-1
  170. - new version - curl-based
  171. * Wed Apr 8 2009 James Antill <james@fedoraproject.org> 3.0.0-15
  172. - Fix progress bars for serial consoles.
  173. - Make C-c behaviour a little nicer.
  174. * Fri Mar 13 2009 Seth Vidal <skvidal at fedoraproject.org>
  175. - kill deprecation warning from importing md5 if anyone uses keepalive
  176. * Mon Mar 9 2009 Seth Vidal <skvidal at fedoraproject.org>
  177. - apply patch for urlgrabber to properly check file:// urls with the checkfunc
  178. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.0-12
  179. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  180. * Fri Nov 28 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> 3.0.0-11
  181. - Rebuild for Python 2.6
  182. * Wed Oct 14 2008 James Antill <james@fedoraproject.org> 3.0.0-10
  183. - Have the progress bar have a small bar, for a virtual size doubling.
  184. * Thu Jul 10 2008 James Antill <james@fedoraproject.org> 3.0.0-9
  185. - Make urlgrabber usable if openssl is broken
  186. - Relates: bug#454179
  187. * Sun Jun 15 2008 James Antill <james@fedoraproject.org> 3.0.0-9
  188. - Don't count partial downloads toward the total
  189. * Sat May 18 2008 James Antill <james@fedoraproject.org> 3.0.0-8
  190. - Tweak progress output so it's hopefully less confusing
  191. - Add dynamic resizing ability to progress bar
  192. - Resolves: bug#437197
  193. * Fri May 2 2008 James Antill <james@fedoraproject.org> 3.0.0-7
  194. - Fix reget's against servers that don't allow Range requests, also tweaks
  195. - reget == check_timestamp, if anyone/thing uses that.
  196. - Resolves: bug#435156
  197. - Fix minor typo in progress for single instance.
  198. * Mon Apr 7 2008 James Antill <james@fedoraproject.org> 3.0.0-6
  199. - Fix the ftp byterange port problem:
  200. - Resolves: bug#419241
  201. - Fixup the progress UI:
  202. - add function for total progress
  203. - add total progress percentagee current download line
  204. - add rate to current download line
  205. - use dead space when finished downloading
  206. - don't confuse download rate on regets.
  207. * Sat Mar 15 2008 Robert Scheck <robert@fedoraproject.org> 3.0.0-5
  208. - Make sure, that *.egg-info is catched up during build
  209. * Mon Dec 3 2007 Jeremy Katz <katzj@redhat.com> - 3.0.0-4
  210. - Ensure fds are closed on exceptions (markmc, #404211)
  211. * Wed Oct 10 2007 Jeremy Katz <katzj@redhat.com> - 3.0.0-3
  212. - fix type checking of strings to also include unicode strings; fixes
  213. regets from yum (#235618)
  214. * Mon Aug 27 2007 Jeremy Katz <katzj@redhat.com> - 3.0.0-2
  215. - fixes for package review (#226347)
  216. * Thu May 31 2007 Jeremy Katz <katzj@redhat.com> - 3.0.0-1
  217. - update to 3.0.0
  218. * Wed Dec 6 2006 Jeremy Katz <katzj@redhat.com> - 2.9.9-5
  219. - rebuild for python 2.5
  220. * Wed Dec 6 2006 Jeremy Katz <katzj@redhat.com> - 2.9.9-4
  221. - fix keepalive (#218268)
  222. * Sat Nov 11 2006 Florian La Roche <laroche@redhat.com>
  223. - add version/release to "Provides: urlgrabber"
  224. * Mon Jul 17 2006 James Bowes <jbowes@redhat.com> - 2.9.9-2
  225. - Add support for byte ranges and keepalive over HTTPS
  226. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.9.9-1.1
  227. - rebuild
  228. * Tue May 16 2006 Jeremy Katz <katzj@redhat.com> - 2.9.9-1
  229. - update to 2.9.9
  230. * Tue Mar 14 2006 Jeremy Katz <katzj@redhat.com> - 2.9.8-2
  231. - catch read errors so they trigger the failure callback. helps catch bad cds
  232. * Wed Feb 22 2006 Jeremy Katz <katzj@redhat.com> - 2.9.8-1
  233. - update to new version fixing progress bars in yum on regets
  234. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  235. - rebuilt
  236. * Wed Sep 21 2005 Jeremy Katz <katzj@redhat.com> - 2.9.6-4
  237. - don't use --record and list files by hand so that we don't miss
  238. directories (#158480)
  239. * Wed Sep 14 2005 Jeremy Katz <katzj@redhat.com> - 2.9.6-3
  240. - add directory to file list (#168261)
  241. * Fri Jun 03 2005 Phil Knirsch <pknirsch@redhat.com> 2.9.6-2
  242. - Fixed the reget method to actually work correctly (skip completely transfered
  243. files, etc)
  244. * Tue Mar 8 2005 Jeremy Katz <katzj@redhat.com> - 2.9.6-1
  245. - update to 2.9.6
  246. * Mon Mar 7 2005 Jeremy Katz <katzj@redhat.com> - 2.9.5-1
  247. - import into dist
  248. - make the description less of a book
  249. * Mon Mar 7 2005 Seth Vidal <skvidal@phy.duke.edu> 2.9.5-0
  250. - 2.9.5
  251. * Thu Feb 24 2005 Seth Vidal <skvidal@phy.duke.edu> 2.9.3-0
  252. - first package for fc3
  253. - named python-urlgrabber for naming guideline compliance