python-twitter-vl.spec 2.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. Name: python-twitter
  3. Summary: A python wrapper around the Twitter API
  4. Summary(ja): Twitter API の python ラッパー
  5. Version: 0.6
  6. Release: 2%{?_dist_release}
  7. License: ASL 2.0
  8. Group: System Environment/Libraries
  9. Source0: http://python-twitter.googlecode.com/files/%{name}-%{version}.tar.gz
  10. URL: http://code.google.com/p/python-twitter/
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildArch: noarch
  13. BuildRequires: python-devel, python-setuptools, python-simplejson
  14. Requires: python-simplejson
  15. %description
  16. This library provides a pure python interface for the Twitter API. Twitter
  17. (http://twitter.com) provides a service that allows people to connect via the
  18. web, IM, and SMS. Twitter exposes a web services API
  19. (http://twitter.com/help/api) and this library is intended to make it even
  20. easier for python programmers to use.
  21. %prep
  22. %setup -q
  23. # Scrape out python versioning
  24. for i in examples/twitter-to-xhtml.py examples/tweet.py setup.py twitter.py twitter_test.py; do
  25. sed -i 's|python2.4|python|g' $i
  26. done
  27. %build
  28. %{__python} setup.py build
  29. %install
  30. rm -rf $RPM_BUILD_ROOT
  31. %{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
  32. chmod +x $RPM_BUILD_ROOT%{python_sitelib}/twitter.py
  33. %check
  34. export PYTHONPATH=$RPM_BUILD_ROOT/%{python_sitelib}
  35. %{__python} setup.py test
  36. %clean
  37. rm -rf $RPM_BUILD_ROOT
  38. %files
  39. %defattr(-,root,root,-)
  40. %doc README PKG-INFO
  41. %{python_sitelib}/twitter.*
  42. %{python_sitelib}/python_twitter-%{version}-py*.egg-info
  43. %changelog
  44. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6-2
  45. - rebuild with python-2.7.2
  46. * Wed Apr 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6-1
  47. - initial build for Vine Linux
  48. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-3
  49. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  50. * Mon Jul 6 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6-2
  51. - fix files so they do not have hardcoded !#/usr/bin/python2.4
  52. * Thu Jul 2 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6-1
  53. - update to 0.6
  54. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5-3
  55. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  56. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.5-2
  57. - Rebuild for Python 2.6
  58. * Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.5-1
  59. - Initial package for Fedora