python-twisted-vl.spec 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define pyver %(python -c 'import sys;print(sys.version[0:3])')
  3. Summary: Event-driven networking engine in Python
  4. Summary(ja): Pythonで書かれたイベントドリブンなネットワークエンジン
  5. Name: python-twisted
  6. Version: 13.2.0
  7. Release: 1%{?_dist_release}
  8. Source0: http://pypi.python.org/packages/source/T/Twisted/Twisted-%{version}.tar.bz2
  9. License: MIT
  10. Group: Development/Languages
  11. URL: http://twistedmatrix.com/trac/
  12. Requires: python
  13. Requires: python-zope-interface
  14. Requires: pyOpenSSL
  15. BuildRequires: python, python-devel
  16. BuildRequires: python-zope-interface
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. %description
  21. Twisted is a networking engine written in Python, supporting
  22. numerous protocols. It contains a web server, numerous chat
  23. clients, chat servers, mail servers, and more.
  24. Twisted is a platform for developing internet applications.
  25. %description -l ja
  26. Twisted は Python で書かれた、多くのプロトコルをサポートする
  27. ネットワーク・エンジンです。このパッケージにはウェブサーバや
  28. 多種多様なチャット用クライアント、チャットサーバ、メールサーバ
  29. 等が含まれています。
  30. Twisted はウェブアプリケーション開発用のプラットフォームです。
  31. %package docs
  32. Summary: Documentation for Twisted
  33. Summary(ja): Twisted のドキュメント
  34. Group: Applications/Documentation
  35. # workaround to prevent find-requires error
  36. AutoReq: No
  37. %description docs
  38. This package contains various documents and examples for
  39. Twisted.
  40. %description docs -l ja
  41. このパッケージには Twisted の各種ドキュメントやサンプルが
  42. 含まれています。
  43. %prep
  44. %setup -q -n Twisted-%{version}
  45. %build
  46. %{__python} setup.py build
  47. # create plugins cache
  48. python -c "from twisted.plugin import IPlugin, getPlugins;list(getPlugins(IPlugin))" >/dev/null 2>&1
  49. %install
  50. %{__rm} -rf ${RPM_BUILD_ROOT}
  51. %{__python} setup.py install --root ${RPM_BUILD_ROOT}
  52. # install man pages
  53. %{__install} -d -m 755 "$RPM_BUILD_ROOT"/%{_mandir}/man1/
  54. %{__install} -m 644 doc/core/man/*.1 ${RPM_BUILD_ROOT}/%{_mandir}/man1/
  55. %clean
  56. %{__rm} -rf ${RPM_BUILD_ROOT}
  57. %files
  58. %defattr(-,root,root)
  59. %doc INSTALL LICENSE NEWS README
  60. #%{_bindir}/bookify
  61. %{_bindir}/cftp
  62. %{_bindir}/ckeygen
  63. %{_bindir}/conch
  64. #%{_bindir}/im
  65. %{_bindir}/lore
  66. %{_bindir}/mailmail
  67. %{_bindir}/manhole
  68. %{_bindir}/pyhtmlizer
  69. #%{_bindir}/t-im
  70. %{_bindir}/tap2deb
  71. %{_bindir}/tap2rpm
  72. %{_bindir}/tapconvert
  73. %{_bindir}/tkconch
  74. %{_bindir}/trial
  75. %{_bindir}/twistd
  76. %{python_sitearch}/twisted
  77. %{python_sitearch}/Twisted-%{version}-py%{pyver}.egg-info
  78. %{_mandir}/man1/*
  79. %files docs
  80. %defattr(-,root,root)
  81. %doc doc/*
  82. %changelog
  83. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.2.0-1
  84. - new upstream release
  85. * Sat Oct 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.2.0-1
  86. - new upstream release
  87. * Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.2.0-2
  88. - rebuild with python-2.7.2
  89. * Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 10.2.0-1
  90. - updated twisted to 10.2.0
  91. * Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 8.1.0-2
  92. - rebuilt with python-2.6.4-3
  93. * Tue Dec 23 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 8.1.0-1
  94. - initial build for Vine Linux