python-sqlalchemy-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556
  1. %global with_python3 1
  2. %global srcname SQLAlchemy
  3. Summary: Modular and flexible ORM library for python
  4. Name: python-sqlalchemy
  5. Version: 1.3.18
  6. Release: 1%{?_dist_release}
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: MIT
  11. URL: http://www.sqlalchemy.org/
  12. Source0: https://files.pythonhosted.org/packages/source/S/%{srcname}/%{srcname}-%{version}.tar.gz
  13. BuildRequires: gcc
  14. BuildRequires: python-rpm-macros
  15. BuildRequires: python2-rpm-macros
  16. BuildRequires: python-devel >= 2.7
  17. BuildRequires: python-setuptools
  18. %if 0%{?with_python3}
  19. BuildRequires: python3-rpm-macros
  20. BuildRequires: python3-devel
  21. BuildRequires: python3-setuptools
  22. %endif
  23. %{?python_provide:%python_provide python2-sqlalchemy}
  24. %description
  25. SQLAlchemy is an Object Relational Mappper (ORM) that provides a flexible,
  26. high-level interface to SQL databases. Database and domain concepts are
  27. decoupled, allowing both sides maximum flexibility and power. SQLAlchemy
  28. provides a powerful mapping layer that can work as automatically or as manually
  29. as you choose, determining relationships based on foreign keys or letting you
  30. define the join conditions explicitly, to bridge the gap between database and
  31. domain.
  32. This package includes the python 2 version of the module.
  33. %package doc
  34. Summary: Documentation for SQLAlchemy
  35. Group: documentation
  36. BuildArch: noarch
  37. %description doc
  38. Documentation for SQLAlchemy
  39. %if 0%{?with_python3}
  40. %package -n python3-sqlalchemy
  41. Summary: Modular and flexible ORM library for python
  42. Group: programming
  43. %{?python_provide:%python_provide python%{python3_pkgversion}-sqlalchemy}
  44. %description -n python3-sqlalchemy
  45. SQLAlchemy is an Object Relational Mappper (ORM) that provides a flexible,
  46. high-level interface to SQL databases. Database and domain concepts are
  47. decoupled, allowing both sides maximum flexibility and power. SQLAlchemy
  48. provides a powerful mapping layer that can work as automatically or as manually
  49. as you choose, determining relationships based on foreign keys or letting you
  50. define the join conditions explicitly, to bridge the gap between database and
  51. domain.
  52. This package includes the python 3 version of the module.
  53. %endif # with_python3
  54. %prep
  55. %setup -n %{srcname}-%{version}
  56. %build
  57. %py2_build
  58. %if 0%{?with_python3}
  59. %py3_build
  60. %endif
  61. %install
  62. %py2_install
  63. %if 0%{?with_python3}
  64. %py3_install
  65. %endif
  66. # remove unnecessary scripts for building documentation
  67. rm -rf doc/build
  68. %ifarch x86_64
  69. %files doc
  70. %doc doc examples
  71. %endif
  72. %files
  73. %license LICENSE
  74. %doc README.rst
  75. %{python2_sitearch}/*
  76. %if 0%{?with_python3}
  77. %files -n python3-sqlalchemy
  78. %license LICENSE
  79. %doc README.rst
  80. %{python3_sitearch}/*
  81. %endif # with_python3
  82. %changelog
  83. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.3.18-1
  84. - new upstream release.
  85. * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.14-1
  86. - new upstream release.
  87. - initial build for Vine Linux.
  88. * Tue Oct 30 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.12-1
  89. - version 1.2.12
  90. * Tue Aug 21 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.11-1
  91. - version 1.2.11
  92. * Sun Jul 22 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.10-1
  93. - version 1.2.10
  94. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.8-4
  95. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  96. * Sun Jun 17 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.8-3
  97. - rename patch, apply with backups
  98. - fix failing test for sqlite 3.24 instead of skipping it
  99. * Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 1.2.8-2
  100. - Rebuilt for Python 3.7
  101. * Tue Jun 05 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.8-1
  102. - version 1.2.8
  103. * Sun Apr 22 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.7-1
  104. - version 1.2.7
  105. * Sat Mar 31 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.6-1
  106. - version 1.2.6
  107. * Mon Mar 19 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.5-1
  108. - version 1.2.5
  109. * Tue Feb 27 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.4-1
  110. - version 1.2.4
  111. * Tue Feb 20 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.3-2
  112. - require gcc for building
  113. * Tue Feb 20 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.3-1
  114. - version 1.2.3
  115. * Mon Feb 12 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.2.2-3
  116. - Update Python 2 dependency declarations to new packaging standards
  117. (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
  118. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.2-2
  119. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  120. * Tue Jan 30 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.2-1
  121. - version 1.2.2
  122. * Sun Dec 31 2017 Nils Philippsen <nils@tiptoe.de> - 1.2.0-1
  123. - version 1.2.0
  124. - fix version-releases in changelog
  125. * Fri Sep 29 2017 Troy Dawson <tdawson@redhat.com> - 1.1.13-2
  126. - Cleanup spec file conditionals
  127. * Sat Aug 05 2017 Nils Philippsen <nils@tiptoe.de> - 1.1.13-1
  128. - version 1.1.13
  129. * Tue Aug 01 2017 Nils Philippsen <nils@tiptoe.de> - 1.1.12-1
  130. - version 1.1.12
  131. - remove comments with macros
  132. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.11-2
  133. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  134. * Mon Jun 26 2017 Nils Philippsen <nils@tiptoe.de> - 1.1.11-1
  135. - version 1.1.11
  136. * Sat May 27 2017 Nils Philippsen <nils@tiptoe.de> - 1.1.10-1
  137. - version 1.1.10
  138. * Thu Apr 6 2017 hguemar <hguemar@fedoraproject.org> - 1.1.9-1
  139. - Upstream 1.1.9 (RHBZ#1436464)
  140. * Wed Mar 15 2017 Nils Philippsen <nils@tiptoe.de> - 1.1.6-1
  141. - version 1.1.6
  142. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.5-2
  143. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  144. * Fri Feb 03 2017 Nils Philippsen <nils@redhat.com> - 1.1.5-1
  145. - version 1.1.5
  146. * Tue Dec 13 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.1.4-3
  147. - Enable tests
  148. * Mon Dec 12 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.1.4-2
  149. - Rebuild for Python 3.6
  150. - Disable python3 tests for now
  151. * Wed Nov 23 2016 Kevin Fenzi <kevin@scrye.com> - 1.1.4-1
  152. - Update to 1.1.4. Fixes bug #1395470
  153. * Tue Nov 8 2016 Orion Poplawski <orion@cora.nwra.com> - 1.1.3-2
  154. - Ship python2-sqlalchemy
  155. - Move docs into sub-package
  156. - Modernize spec
  157. * Mon Oct 31 2016 Kevin Fenzi <kevin@scrye.com> - 1.1.3-1
  158. - Update to 1.1.3. Fixes bug #1389638
  159. * Tue Oct 18 2016 Kevin Fenzi <kevin@scrye.com> - 1.1.2-1
  160. - Update to 1.1.2. Fixes bug #1385990
  161. * Mon Oct 10 2016 Nils Philippsen <nils@redhat.com> - 1.1.1-1
  162. - version 1.1.1
  163. * Thu Oct 06 2016 Kevin Fenzi <kevin@scrye.com> - 1.1.0-1
  164. - Update to 1.1.0. Fixes bug #1382203
  165. * Thu Aug 18 2016 Nils Philippsen <nils@redhat.com> - 1.0.14-1
  166. - version 1.0.14
  167. * Tue May 31 2016 Nils Philippsen <nils@redhat.com> - 1.0.14-1
  168. - fix source URL
  169. * Tue May 17 2016 Nils Philippsen <nils@redhat.com> - 1.0.13-1
  170. - version 1.0.13
  171. * Thu Feb 25 2016 Nils Philippsen <nils@redhat.com> - 1.0.12-1
  172. - version 1.0.12
  173. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.11-2
  174. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  175. * Fri Jan 08 2016 Kevin Fenzi <kevin@scrye.com> - 1.0.11-1
  176. - Update to 1.0.11. Fixes bug #1296757
  177. * Sat Dec 12 2015 Kevin Fenzi <kevin@scrye.com> - 1.0.10-1
  178. - Update to 1.0.10. Fixes bug #1290945
  179. * Thu Nov 12 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.9-2
  180. - Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
  181. * Wed Oct 21 2015 Nils Philippsen <nils@redhat.com> - 1.0.9-1
  182. - version 1.0.9, upstream feature and bugfix release
  183. * Mon Oct 12 2015 Robert Kuska <rkuska@redhat.com> - 1.0.8-2
  184. - Rebuilt for Python3.5 rebuild
  185. * Fri Jul 24 2015 Nils Philippsen <nils@redhat.com> 1.0.8-1
  186. - version 1.0.8, upstream bugfix release
  187. * Tue Jul 21 2015 Fedora Release Monitoring <release-monitoring@fedoraproject.org> - 1.0.7-1
  188. - Update to 1.0.7 (#1244991)
  189. * Mon Jun 29 2015 Nils Philippsen <nils@redhat.com> 1.0.6-1
  190. - version 1.0.6, upstream feature and bugfix release
  191. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.5-2
  192. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  193. * Sun Jun 07 2015 Kevin Fenzi <kevin@scrye.com> 1.0.4-1
  194. - Update to 1.0.5. Fixes bug #1229067
  195. * Fri May 08 2015 Nils Philippsen <nils@redhat.com> 1.0.4-1
  196. - version 1.0.4, upstream bugfix release
  197. * Sat May 02 2015 Kevin Fenzi <kevin@scrye.com> 1.0.3-1
  198. - Update to 1.0.3. Fixes bug #1217761
  199. * Sat Apr 25 2015 Nils Philippsen <nils@redhat.com> - 1.0.2-1
  200. - version 1.0.2, upstream bugfix release
  201. * Fri Apr 24 2015 Nils Philippsen <nils@redhat.com> - 1.0.1-1
  202. - version 1.0.1, upstream bugfix release
  203. * Fri Apr 17 2015 Nils Philippsen <nils@redhat.com> - 1.0.0-1
  204. - version 1.0.0, upstream feature release
  205. * Fri Apr 10 2015 Nils Philippsen <nils@redhat.com> - 0.9.9-1
  206. - version 0.9.9, upstream feature and bugfix release
  207. * Wed Oct 15 2014 Nils Philippsen <nils@redhat.com> - 0.9.8-1
  208. - version 0.9.8, upstream feature and bugfix release
  209. - avoid using unversioned python macros
  210. - use py.test instead of nose for tests
  211. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.7-2
  212. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  213. * Tue Jul 29 2014 Nils Philippsen <nils@redhat.com> - 0.9.7-1
  214. - version 0.9.7, upstream feature and bugfix release
  215. * Mon Jun 30 2014 Nils Philippsen <nils@redhat.com> - 0.9.6-1
  216. - version 0.9.6, upstream feature and bugfix release
  217. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.4-3
  218. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  219. * Fri May 16 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 0.9.4-2
  220. - Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
  221. * Thu May 15 2014 Nils Philippsen <nils@redhat.com> - 0.9.4-1
  222. - version 0.9.4, upstream feature and bugfix release
  223. * Thu Feb 20 2014 Nils Philippsen <nils@redhat.com> - 0.9.3-1
  224. - version 0.9.3, upstream feature and bugfix release
  225. * Wed Feb 05 2014 Nils Philippsen <nils@redhat.com> - 0.9.2-1
  226. - version 0.9.2, upstream feature and bugfix release
  227. * Tue Jan 07 2014 Nils Philippsen <nils@redhat.com> - 0.9.1-1
  228. - version 0.9.1, upstream feature and bugfix release
  229. - no need to use 2to3 for python 3.x anymore
  230. - build C extension for python 3.x
  231. - require python2-devel >= 2.6 for building
  232. * Mon Dec 09 2013 Nils Philippsen <nils@redhat.com> - 0.8.4-1
  233. - version 0.8.4, upstream bugfix release
  234. * Tue Oct 29 2013 Nils Philippsen <nils@redhat.com> - 0.8.3-1
  235. - version 0.8.3, upstream bugfix release
  236. * Wed Aug 14 2013 Nils Philippsen <nils@redhat.com> - 0.8.2-1
  237. - version 0.8.2, upstream bugfix release
  238. - drop obsolete sqlalchemy-test-bidirectional-order patch
  239. - fix bogus date in changelog
  240. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-2
  241. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  242. * Mon Apr 29 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 0.8.1-1
  243. - Upstream bugfix
  244. - Stop calling sa2to3 explicitly on the library. It seems to break mapper.py's
  245. import of collections.deque
  246. * Fri Apr 12 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 0.8.0-1
  247. - Final release of 0.8.0
  248. - Fix for a unittest that assumes order in dicts
  249. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.0-0.2.b1
  250. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  251. * Thu Nov 1 2012 Toshio Kuratomi <toshio@fedoraproject.org> - 0.8.0-0.1.b1
  252. - Update to 0.8.0 beta
  253. * Mon Aug 13 2012 Toshio Kuratomi <toshio@fedoraproject.org> - 0.7.8-4.20120813hg8535
  254. - Update to a snapshot to fix unittest errors with python-3.3
  255. * Fri Aug 3 2012 David Malcolm <dmalcolm@redhat.com> - 0.7.8-3
  256. - remove rhel logic from with_python3 conditional
  257. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.8-2
  258. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  259. * Mon Jun 18 2012 Nils Philippsen <nils@redhat.com> - 0.7.8-1
  260. - Upstream bugfix release
  261. * Tue May 15 2012 Nils Philippsen <nils@redhat.com> - 0.7.7-1
  262. - Upstream bugfix release
  263. * Tue Mar 20 2012 Nils Philippsen <nils@redhat.com> - 0.7.6-1
  264. - Upstream bugfix release
  265. * Mon Jan 30 2012 Nils Philippsen <nils@redhat.com> - 0.7.5-1
  266. - Upstream bugfix release
  267. - package README.rst instead of README as documentation
  268. * Tue Jan 10 2012 Nils Philippsen <nils@redhat.com> - 0.7.3-2
  269. - rebuild for gcc 4.7
  270. * Mon Oct 17 2011 Toshio Kuratomi <toshio@fedoraproject.org> - 0.7.3-1
  271. - Upstream bugfix release
  272. * Mon Aug 1 2011 Toshio Kuratomi <toshio@fedoraproject.org> - 0.7.2-1
  273. - Upstream bugfix release
  274. * Mon Jun 06 2011 Nils Philippsen <nils@redhat.com> - 0.7.1-1
  275. - 0.7.1 Upstream release
  276. - no need to fix examples/dynamic_dict/dynamic_dict.py anymore
  277. - use sqla_nose.py to fix %%check
  278. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.6-2
  279. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  280. * Mon Jan 17 2011 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.6-1
  281. - 0.6.6 Upstream release
  282. * Fri Dec 3 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.5-1
  283. - 0.6.5 Upstream release
  284. * Wed Sep 29 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.4-2
  285. - Filter out the C extensions from provides
  286. * Tue Sep 07 2010 Luke Macken <lmacken@redhat.com> - 0.6.4-1
  287. - 0.6.4 upstream release
  288. * Mon Aug 23 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.3-1
  289. - 0.6.3 upstream release
  290. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com>
  291. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  292. * Thu Jun 24 2010 Nils Philippsen <nils@redhat.com> - 0.6.1-1
  293. - 0.6.1 upstream release
  294. * Tue Apr 13 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6-0.4.beta3
  295. - Build beta3
  296. * Fri Mar 19 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6-0.3.beta2
  297. - Build beta2 with cextension
  298. * Sun Mar 7 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6-0.2.beta1
  299. - Build python3 package
  300. * Tue Mar 2 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6-0.1.beta1
  301. - 0.6 beta1 upstream release
  302. * Tue Feb 2 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.8-3
  303. - One last cleanup
  304. * Tue Feb 2 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.8-2
  305. - just some cleanups to older styles of building packages.
  306. * Mon Feb 1 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.8-1
  307. - Upstream bugfix release 0.5.8
  308. * Fri Aug 14 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.5-2
  309. - Upstream bugfix release 0.5.5
  310. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.4-2.p2
  311. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  312. * Fri Jun 12 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.4-1.p2
  313. - Upstream bugfix release 0.5.4p2.
  314. * Thu Apr 16 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.3-1
  315. - Upstream bugfix release.
  316. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.2-2
  317. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  318. * Wed Feb 11 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.2-1
  319. - Update to 0.5.2
  320. * Wed Jan 21 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.1-1
  321. - Update to 0.5.1.
  322. * Mon Dec 1 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5-0.1.rc4
  323. - Update to 0.5.0rc4 which works with the new pysqlite
  324. - And update test cases to work with the new pysqlite
  325. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.4.7-2
  326. - Rebuild for Python 2.6
  327. * Sun Jul 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.7-1
  328. - Update to 0.4.7.
  329. * Sun Jun 1 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.6-1
  330. - Update to 0.4.6.
  331. * Tue Apr 8 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.5-1
  332. - Update to 0.4.5.
  333. * Fri Feb 22 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.3-1
  334. - Update to 0.4.3.
  335. * Tue Dec 11 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4.2-1.p3
  336. - Update to 0.4.2p3.
  337. * Tue Dec 11 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4.1-1
  338. - Update to 0.4.1.
  339. * Wed Oct 17 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4.0-1
  340. - SQLAlchemy-0.4.0 final
  341. - Run the testsuite
  342. * Wed Oct 3 2007 Luke Macken <lmacken@redhat.com> 0.4.0-0.4.beta6
  343. - SQLAlchemy-0.4.0beta6
  344. * Tue Sep 11 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.4.beta5
  345. - Update to 0.4beta5.
  346. * Fri Sep 07 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.4.beta4
  347. - setuptools has been fixed.
  348. * Fri Aug 31 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.3.beta4
  349. - setuptools seems to be broken WRT having an active and inactive version
  350. of an egg. Have to make both versions inactive and manually setup a copy
  351. that can be started via import. (Necessary for the sqlalchemy0.3 compat
  352. package.)
  353. * Tue Aug 28 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.2.beta4
  354. - Modify setuptools to handle the -devel subpackage split in F-8.
  355. * Mon Aug 27 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.4.0-0.1.beta4
  356. - Update to 0.4 beta4.
  357. * Tue Jul 24 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.10-2
  358. - Remove python-abi Requires. This is automatic since FC4+.
  359. * Tue Jul 24 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.10-1
  360. - Update to new upstream version 0.3.10
  361. * Fri Mar 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.6-1
  362. - Update to new upstream version 0.3.6
  363. * Sat Mar 10 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.5-1
  364. - Update to new upstream version 0.3.5
  365. - Simplify the files listing
  366. * Tue Jan 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.4-2
  367. - Remember to upload the source tarball to the lookaside cache.
  368. * Tue Jan 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.4-1
  369. - Update to new upstream version 0.3.4
  370. * Mon Jan 01 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.3-1
  371. - Update to new upstream version 0.3.3
  372. * Sat Dec 09 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.1-2
  373. - Bump and rebuild for python 2.5 on devel.
  374. - BuildRequire: python-devel as a header is missing otherwise.
  375. * Fri Nov 24 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.1-1
  376. - Update to new upstream version 0.3.1
  377. * Sat Sep 16 2006 Shahms E. King <shahms@shahms.com> 0.2.7-2
  378. - Rebuild for FC6
  379. * Thu Aug 17 2006 Shahms E. King <shahms@shahms.com> 0.2.7-1
  380. - Update to new upstream version
  381. * Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 0.2.6-2
  382. - Include, don't ghost .pyo files per new guidelines
  383. * Tue Aug 08 2006 Shahms E. King <shahms@shahms.com> 0.2.6-1
  384. - Update to new upstream version
  385. * Fri Jul 07 2006 Shahms E. King <shahms@shahms.com> 0.2.4-1
  386. - Update to new upstream version
  387. * Mon Jun 26 2006 Shahms E. King <shahms@shahms.com> 0.2.3-1
  388. - Update to new upstream version
  389. * Wed May 31 2006 Shahms E. King <shahms@shahms.com> 0.2.1-1
  390. - Update to new upstream version