python-sphinxcontrib-serializinghtml-vl.spec 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124
  1. %global pypi_name sphinxcontrib-serializinghtml
  2. # when bootstrapping sphinx, we cannot run tests yet
  3. %bcond_with check
  4. Summary: Sphinx extension for serialized HTML
  5. Name: python-%{pypi_name}
  6. Version: 1.1.4
  7. Release: 3%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: BSD
  12. URL: http://sphinx-doc.org/
  13. Source0: %{pypi_source}
  14. BuildArch: noarch
  15. BuildRequires: gettext
  16. BuildRequires: python3-rpm-macros
  17. BuildRequires: python3-devel
  18. BuildRequires: python3-setuptools
  19. %if %{with check}
  20. BuildRequires: python3-pytest
  21. BuildRequires: python3-sphinx >= 1:2
  22. %endif
  23. %description
  24. sphinxcontrib-serializinghtml is a sphinx extension which outputs "serialized"
  25. HTML files (json and pickle).
  26. %package -n python3-%{pypi_name}
  27. Summary: %{summary}
  28. Group: programming
  29. %{?python_provide:%python_provide python3-%{pypi_name}}
  30. %description -n python3-%{pypi_name}
  31. sphinxcontrib-serializinghtml is a sphinx extension which outputs "serialized"
  32. HTML files (json and pickle).
  33. %prep
  34. %autosetup -n %{pypi_name}-%{version}
  35. find -name '*.mo' -delete
  36. %build
  37. for po in $(find -name '*.po'); do
  38. msgfmt --output-file=${po%.po}.mo ${po}
  39. done
  40. %py3_build
  41. %install
  42. %py3_install
  43. # Move language files to /usr/share
  44. pushd %{buildroot}%{python3_sitelib}
  45. for lang in `find sphinxcontrib/serializinghtml/locales -maxdepth 1 -mindepth 1 -type d -not -path '*/\.*' -printf "%f "`;
  46. do
  47. test $lang == __pycache__ && continue
  48. install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
  49. mv sphinxcontrib/serializinghtml/locales/$lang/LC_MESSAGES/*.mo %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
  50. done
  51. rm -rf sphinxcontrib/serializinghtml/locales
  52. ln -s %{_datadir}/locale sphinxcontrib/serializinghtml/locales
  53. popd
  54. %find_lang sphinxcontrib.serializinghtml
  55. %if %{with check}
  56. %check
  57. %pytest
  58. %endif
  59. %files -n python3-%{pypi_name} -f sphinxcontrib.serializinghtml.lang
  60. %license LICENSE
  61. %doc README.rst
  62. %{python3_sitelib}/sphinxcontrib/
  63. %{python3_sitelib}/sphinxcontrib_serializinghtml-%{version}-py%{python3_version}-*.pth
  64. %{python3_sitelib}/sphinxcontrib_serializinghtml-%{version}-py%{python3_version}.egg-info/
  65. %changelog
  66. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.4-3
  67. - initial build for Vine Linux.
  68. * Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4-2
  69. - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  70. * Mon Jun 01 2020 Charalampos Stratakis <cstratak@redhat.com> - 1.1.4-1
  71. - Update to 1.1.4 (#1808637)
  72. * Sat May 23 2020 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-8
  73. - Rebuilt for Python 3.9
  74. * Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-7
  75. - Bootstrap for Python 3.9
  76. * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-6
  77. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  78. * Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-5
  79. - Rebuilt for Python 3.8.0rc1 (#1748018)
  80. * Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-4
  81. - Rebuilt for Python 3.8
  82. * Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-3
  83. - Bootstrap for Python 3.8
  84. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-2
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  86. * Mon May 20 2019 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-1
  87. - Update to 1.1.3 (#1697444)
  88. * Mon Mar 04 2019 Miro Hrončok <mhroncok@redhat.com> - 1.1.1-1
  89. - Initial package.