python-sphinxcontrib-qthelp-vl.spec 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119
  1. %global pypi_name sphinxcontrib-qthelp
  2. # when bootstrapping sphinx, we cannot run tests yet
  3. %bcond_with check
  4. Summary: Sphinx extension for QtHelp documents
  5. Name: python-%{pypi_name}
  6. Version: 1.0.3
  7. Release: 3%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: BSD
  12. URL: http://sphinx-doc.org/
  13. Source0: %{pypi_source}
  14. BuildArch: noarch
  15. BuildRequires: gettext
  16. BuildRequires: python3-devel
  17. BuildRequires: python3-setuptools
  18. %if %{with check}
  19. BuildRequires: python3-pytest
  20. BuildRequires: python3-sphinx >= 1:2
  21. %endif
  22. %description
  23. sphinxcontrib-qthelp is a sphinx extension which outputs QtHelp document.
  24. %package -n python3-%{pypi_name}
  25. Summary: %{summary}
  26. Group: programming
  27. %{?python_provide:%python_provide python3-%{pypi_name}}
  28. %description -n python3-%{pypi_name}
  29. sphinxcontrib-qthelp is a sphinx extension which outputs QtHelp document.
  30. %prep
  31. %autosetup -n %{pypi_name}-%{version}
  32. find -name '*.mo' -delete
  33. %build
  34. for po in $(find -name '*.po'); do
  35. msgfmt --output-file=${po%.po}.mo ${po}
  36. done
  37. %py3_build
  38. %install
  39. %py3_install
  40. # Move language files to /usr/share
  41. pushd %{buildroot}%{python3_sitelib}
  42. for lang in `find sphinxcontrib/qthelp/locales -maxdepth 1 -mindepth 1 -type d -not -path '*/\.*' -printf "%f "`;
  43. do
  44. test $lang == __pycache__ && continue
  45. install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
  46. mv sphinxcontrib/qthelp/locales/$lang/LC_MESSAGES/*.mo %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
  47. done
  48. rm -rf sphinxcontrib/qthelp/locales
  49. ln -s %{_datadir}/locale sphinxcontrib/qthelp/locales
  50. popd
  51. %find_lang sphinxcontrib.qthelp
  52. %if %{with check}
  53. %check
  54. %pytest
  55. %endif
  56. %files -n python3-%{pypi_name} -f sphinxcontrib.qthelp.lang
  57. %license LICENSE
  58. %doc README.rst
  59. %{python3_sitelib}/sphinxcontrib/
  60. %{python3_sitelib}/sphinxcontrib_qthelp-%{version}-py%{python3_version}-*.pth
  61. %{python3_sitelib}/sphinxcontrib_qthelp-%{version}-py%{python3_version}.egg-info/
  62. %changelog
  63. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.3-3
  64. - initial build for Vine Linux.
  65. * Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-2
  66. - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  67. * Mon Jun 01 2020 Charalampos Stratakis <cstratak@redhat.com> - 1.0.3-1
  68. - Update to 1.0.3 (#1808636)
  69. * Sat May 23 2020 Miro Hrončok <mhroncok@redhat.com> - 1.0.2-8
  70. - Rebuilt for Python 3.9
  71. * Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 1.0.2-7
  72. - Bootstrap for Python 3.9
  73. * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-6
  74. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  75. * Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.2-5
  76. - Rebuilt for Python 3.8.0rc1 (#1748018)
  77. * Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.2-4
  78. - Rebuilt for Python 3.8
  79. * Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.2-3
  80. - Bootstrap for Python 3.8
  81. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-2
  82. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  83. * Fri Mar 01 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.2-1
  84. - Initial package