python-sphinxcontrib-applehelp-vl.spec 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119
  1. %global pypi_name sphinxcontrib-applehelp
  2. # when bootstrapping sphinx, we cannot run tests yet
  3. %bcond_with check
  4. Summary: Sphinx extension for Apple help books
  5. Name: python-%{pypi_name}
  6. Version: 1.0.2
  7. Release: 3%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: BSD
  12. URL: http://sphinx-doc.org/
  13. Source0: %{pypi_source}
  14. BuildArch: noarch
  15. BuildRequires: gettext
  16. BuildRequires: python3-rpm-macros
  17. BuildRequires: python3-devel
  18. BuildRequires: python3-setuptools
  19. %if %{with check}
  20. BuildRequires: python3-pytest
  21. BuildRequires: python3-sphinx >= 1:2
  22. %endif
  23. %description
  24. sphinxcontrib-applehelp is a sphinx extension which outputs Apple help books.
  25. %package -n python3-%{pypi_name}
  26. Summary: %{summary}
  27. Group: programming
  28. %{?python_provide:%python_provide python3-%{pypi_name}}
  29. %description -n python3-%{pypi_name}
  30. sphinxcontrib-applehelp is a sphinx extension which outputs Apple help books.
  31. %prep
  32. %autosetup -n %{pypi_name}-%{version}
  33. find -name '*.mo' -delete
  34. %build
  35. for po in $(find -name '*.po'); do
  36. msgfmt --output-file=${po%.po}.mo ${po}
  37. done
  38. %py3_build
  39. %install
  40. %py3_install
  41. # Move language files to /usr/share
  42. pushd %{buildroot}%{python3_sitelib}
  43. for lang in `find sphinxcontrib/applehelp/locales -maxdepth 1 -mindepth 1 -type d -not -path '*/\.*' -printf "%f "`;
  44. do
  45. test $lang == __pycache__ && continue
  46. install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
  47. mv sphinxcontrib/applehelp/locales/$lang/LC_MESSAGES/*.mo %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
  48. done
  49. rm -rf sphinxcontrib/applehelp/locales
  50. ln -s %{_datadir}/locale sphinxcontrib/applehelp/locales
  51. popd
  52. %find_lang sphinxcontrib.applehelp
  53. %if %{with check}
  54. %check
  55. %pytest
  56. %endif
  57. %files -n python3-%{pypi_name} -f sphinxcontrib.applehelp.lang
  58. %license LICENSE
  59. %doc README.rst
  60. %{python3_sitelib}/sphinxcontrib/
  61. %{python3_sitelib}/sphinxcontrib_applehelp-%{version}-py%{python3_version}-*.pth
  62. %{python3_sitelib}/sphinxcontrib_applehelp-%{version}-py%{python3_version}.egg-info/
  63. %changelog
  64. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.2-3
  65. - initial build for Vine Linux.
  66. * Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-2
  67. - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  68. * Mon Jun 01 2020 Charalampos Stratakis <cstratak@redhat.com> - 1.0.2-1
  69. - Update to 1.0.2 (#1808632)
  70. * Sat May 23 2020 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-8
  71. - Rebuilt for Python 3.9
  72. * Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-7
  73. - Bootstrap for Python 3.9
  74. * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-6
  75. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  76. * Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-5
  77. - Rebuilt for Python 3.8.0rc1 (#1748018)
  78. * Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-4
  79. - Rebuilt for Python 3.8
  80. * Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-3
  81. - Bootstrap for Python 3.8
  82. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-2
  83. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  84. * Fri Mar 01 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-1
  85. - Initial package