python-rpm-macros-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178
  1. %{!?rpmmacrodir:%global rpmmacrodir %{_sysconfdir}/rpm}
  2. Name: python-rpm-macros
  3. Version: 3.8
  4. Release: 1%{?_dist_release}
  5. Summary: The unversioned Python RPM macros
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. Packager: tomop
  9. License: MIT
  10. Source0: macros.python
  11. Source1: macros.python-srpm
  12. Source2: macros.python2
  13. Source3: macros.python3
  14. Source4: macros.platform-python
  15. BuildArch: noarch
  16. # For %%python3_pkgversion used in %%python_provide
  17. Requires: python-srpm-macros
  18. Obsoletes: python-macros < 3
  19. Provides: python-macros = %{version}-%{release}
  20. %description
  21. This package contains the unversioned Python RPM macros, that most
  22. implementations should rely on.
  23. You should not need to install this package manually as the various
  24. python?-devel packages require it. So install a python-devel package instead.
  25. %package -n python-srpm-macros
  26. Summary: RPM macros for building Python source packages
  27. %description -n python-srpm-macros
  28. RPM macros for building Python source packages.
  29. %package -n python2-rpm-macros
  30. Summary: RPM macros for building Python 2 packages
  31. # Would need to be different for each release - worth it?
  32. #Conflicts: python2-devel < 2.7.11-3
  33. Requires: python-rpm-macros
  34. Requires: python-srpm-macros
  35. %description -n python2-rpm-macros
  36. RPM macros for building Python 2 packages.
  37. %package -n python3-rpm-macros
  38. Summary: RPM macros for building Python 3 packages
  39. # Would need to be different for each release - worth it?
  40. #Conflicts: python3-devel < 3.5.1-3
  41. Requires: python-rpm-macros
  42. Requires: python-srpm-macros
  43. %description -n python3-rpm-macros
  44. RPM macros for building Python 3 packages.
  45. #%package -n platform-python-rpm-macros
  46. #Summary: RPM macros for building Platform-Python packages
  47. #%description -n platform-python-rpm-macros
  48. #RPM macros for building Platform-Python packages.
  49. %prep
  50. %build
  51. %install
  52. mkdir -p %{buildroot}/%{rpmmacrodir}
  53. install -m 644 %{SOURCE0} %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} \
  54. %{buildroot}/%{rpmmacrodir}/
  55. %files
  56. %{rpmmacrodir}/macros.python
  57. %files -n python-srpm-macros
  58. %{rpmmacrodir}/macros.python-srpm
  59. %files -n python2-rpm-macros
  60. %{rpmmacrodir}/macros.python2
  61. %files -n python3-rpm-macros
  62. %{rpmmacrodir}/macros.python3
  63. #%files -n platform-python-rpm-macros
  64. #%{rpmmacrodir}/macros.platform-python
  65. %exclude %{rpmmacrodir}/macros.platform-python
  66. %changelog
  67. * Wed Apr 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.8-1
  68. - updated to 3.8.
  69. * Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-26
  70. - updated macros.
  71. * Mon Dec 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-25
  72. - fixed a typo.
  73. * Wed Sep 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-24
  74. - fixed a path to install.
  75. * Tue Sep 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-23
  76. - initial build for Vine Linux.
  77. * Wed Aug 02 2017 Tomas Orsava <torsava@redhat.com> - 3-22
  78. - Add platform-python macros (https://fedoraproject.org/wiki/Changes/Platform_Python_Stack)
  79. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3-21
  80. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  81. * Fri Mar 03 2017 Michal Cyprian <mcyprian@redhat.com> - 3-20
  82. - Revert "Switch %%__python3 to /usr/libexec/system-python"
  83. after the Fedora Change https://fedoraproject.org/wiki/Changes/Making_sudo_pip_safe
  84. was postponed
  85. * Fri Feb 17 2017 Michal Cyprian <mcyprian@redhat.com> - 3-19
  86. - Switch %%__python3 to /usr/libexec/system-python
  87. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3-18
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  89. * Mon Jan 23 2017 Michal Cyprian <mcyprian@redhat.com> - 3-17
  90. - Add --no-deps option to py_install_wheel macros
  91. * Tue Jan 17 2017 Tomas Orsava <torsava@redhat.com> - 3-16
  92. - Added macros for Build/Requires tags using Python dist tags:
  93. https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  94. * Thu Nov 24 2016 Orion Poplawski <orion@cora.nwra.com> 3-15
  95. - Make expanded macros start on the same line as the macro
  96. * Wed Nov 16 2016 Orion Poplawski <orion@cora.nwra.com> 3-14
  97. - Fix %%py3_install_wheel (bug #1395953)
  98. * Wed Nov 16 2016 Orion Poplawski <orion@cora.nwra.com> 3-13
  99. - Add missing sleeps to other build macros
  100. - Fix build_egg macros
  101. - Add %%py_build_wheel and %%py_install_wheel macros
  102. * Tue Nov 15 2016 Orion Poplawski <orion@cora.nwra.com> 3-12
  103. - Add %%py_build_egg and %%py_install_egg macros
  104. - Allow multiple args to %%py_build/install macros
  105. - Tidy up macro formatting
  106. * Wed Aug 24 2016 Orion Poplawski <orion@cora.nwra.com> 3-11
  107. - Use %%rpmmacrodir
  108. * Tue Jul 12 2016 Orion Poplawski <orion@cora.nwra.com> 3-10
  109. - Do not generate useless Obsoletes with %%{?_isa}
  110. * Fri May 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-9
  111. - Make python-rpm-macros require python-srpm-macros (bug #1335860)
  112. * Thu May 12 2016 Jason L Tibbitts III <tibbs@math.uh.edu> - 3-8
  113. - Add single-second sleeps to work around setuptools bug.
  114. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3-7
  115. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  116. * Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-6
  117. - Fix typo in %%python_provide
  118. * Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-5
  119. - Handle noarch python sub-packages (bug #1290900)
  120. * Wed Jan 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-4
  121. - Fix python2/3-rpm-macros package names
  122. * Thu Jan 7 2016 Orion Poplawski <orion@cora.nwra.com> 3-3
  123. - Add empty %%prep and %%build
  124. * Mon Jan 4 2016 Orion Poplawski <orion@cora.nwra.com> 3-2
  125. - Combined package
  126. * Wed Dec 30 2015 Orion Poplawski <orion@cora.nwra.com> 3-1
  127. - Initial package