python-requests-vl.spec 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117
  1. Summary: Python HTTP for Humans
  2. Name: python-requests
  3. Version: 2.24.0
  4. Release: 1%{?_dist_release}
  5. Group: programming
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. Packager: iwaim
  9. License: ASLv2
  10. URL: https://pypi.python.org/pypi/requests
  11. Source0: https://pypi.python.org/packages/source/r/requests/requests-%{version}.tar.gz
  12. # Explicitly use the system certificates in ca-certificates.
  13. # https://bugzilla.redhat.com/show_bug.cgi?id=904614
  14. Patch0: patch-requests-certs.py-to-use-the-system-CA-bundle.patch
  15. # https://bugzilla.redhat.com/show_bug.cgi?id=1450608
  16. Patch2: Remove-tests-that-use-the-tarpit.patch
  17. # Use 127.0.0.1 not localhost for socket.bind() in the Server test
  18. # class, to fix tests in Koji's no-network environment
  19. # This probably isn't really upstreamable, because I guess localhost
  20. # could technically be IPv6 or something, and our no-network env is
  21. # a pretty odd one so this is a niche requirement.
  22. Patch3: requests-2.12.4-tests_nonet.patch
  23. BuildArch: noarch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  25. Requires: python
  26. Requires: python-urllib3
  27. Requires: python-chardet
  28. Requires: python-idna
  29. BuildRequires: python-rpm-macros
  30. BuildRequires: python3-rpm-macros
  31. BuildRequires: python-devel
  32. BuildRequires: python-setuptools
  33. BuildRequires: python3-devel
  34. BuildRequires: python3-rpm-macros
  35. BuildRequires: python3-setuptools
  36. %description
  37. Requests is an Apache2 Licensed HTTP library, written in Python, for human beings.
  38. %package -n python3-requests
  39. Summary: Python HTTP for Humans
  40. Group: programming
  41. Requires: python3
  42. Requires: python3-urllib3
  43. Requires: python3-chardet
  44. Requires: python3-idna
  45. %description -n python3-requests
  46. Requests is an Apache2 Licensed HTTP library, written in Python, for human beings.
  47. %prep
  48. %autosetup -p1 -n requests-%{version}
  49. # Unbundle the certificate bundle from mozilla.
  50. rm -rf requests/cacert.pem
  51. # env shebang in nonexecutable file
  52. sed -i '/#!\/usr\/.*python/d' requests/certs.py
  53. %build
  54. %py2_build
  55. %py3_build
  56. %install
  57. rm -rf $RPM_BUILD_ROOT
  58. %py2_install
  59. %py3_install
  60. %clean
  61. rm -rf $RPM_BUILD_ROOT
  62. %files
  63. %defattr(-,root,root,-)
  64. %license LICENSE
  65. %doc README* HISTORY*
  66. %{python_sitelib}/requests
  67. %{python_sitelib}/requests-%{version}-py*.egg-info
  68. %files -n python3-requests
  69. %defattr(-,root,root,-)
  70. %license LICENSE
  71. %doc README* HISTORY*
  72. %{python3_sitelib}/requests
  73. %{python3_sitelib}/requests-%{version}-py*.egg-info
  74. %changelog
  75. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.24.0-1
  76. - new upstream release.
  77. * Wed Apr 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.23.0-1
  78. - new upstream release.
  79. - updated patches.
  80. * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.20.1-2
  81. - fixed R:.
  82. - imported Patch0-4 from rawhide.
  83. * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.20.1-1
  84. - new upstream release.
  85. - add python2 support.
  86. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.1-2
  87. - rebuild with python3-3.5.2
  88. * Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 2.5.1-1
  89. - Initial build.