python-qt5-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762
  1. # prevent anything matching from being scanned for provides
  2. %define filter_provides_in(P) %{expand: \
  3. %global __filter_prov_cmd %{?__filter_prov_cmd} %{__grep} -v %{-P} '%*' | \
  4. }
  5. # prevent anything matching from being scanned for requires
  6. %define filter_requires_in(P) %{expand: \
  7. %global __filter_req_cmd %{?__filter_req_cmd} %{__grep} -v %{-P} '%*' | \
  8. }
  9. # filter anything matching out of the provides stream
  10. %define filter_from_provides() %{expand: \
  11. %global __filter_from_prov %{?__filter_from_prov} | %{__sed} -e '%*' \
  12. }
  13. # filter anything matching out of the requires stream
  14. %define filter_from_requires() %{expand: \
  15. %global __filter_from_req %{?__filter_from_req} | %{__sed} -e '%*' \
  16. }
  17. # actually set up the filtering bits
  18. %define filter_setup %{expand: \
  19. %global _use_internal_dependency_generator 0 \
  20. %global __deploop() while read FILE; do /usr/lib/rpm/rpmdeps -%{1} ${FILE}; done | /bin/sort -u \
  21. %global __find_provides /bin/sh -c "%{?__filter_prov_cmd} %{__deploop P} %{?__filter_from_prov}" \
  22. %global __find_requires /bin/sh -c "%{?__filter_req_cmd} %{__deploop R} %{?__filter_from_req}" \
  23. }
  24. %global with_python3 1
  25. %global python3_dbus_dir %(%{__python3} -c "import dbus.mainloop; print(dbus.mainloop.__path__[0])")
  26. %global with_python2 1
  27. %global python_dbus_dir %(%{__python} -c "import dbus.mainloop; print(dbus.mainloop.__path__[0])")
  28. # enable/disable individual modules
  29. # drop power64, it's not supported yet (than)
  30. %ifarch %{ix86} x86_64 %{arm} aarch64 mips mipsel mips64el
  31. %global webengine 0
  32. %endif
  33. %global webkit 0
  34. #global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
  35. %global rpm_macros_dir %{_sysconfdir}/rpm
  36. %global py3_sipdir %{_datadir}/sip/PyQt5
  37. Summary: PyQt5 is Python bindings for Qt5
  38. Name: python-qt5
  39. Version: 5.15.0
  40. Release: 1%{?_dist_release}
  41. Group: programming
  42. Vendor: Project Vine
  43. Distribution: Vine Linux
  44. License: GPLv3+
  45. Url: https://www.riverbankcomputing.com/software/pyqt/
  46. Source0: PyQt5-%{version}.tar.gz
  47. Source1: macros.pyqt5
  48. # wrapper, see https://bugzilla.redhat.com/show_bug.cgi?id=1193107#c9
  49. Source2: pylupdate5.sh
  50. Source3: pyrcc5.sh
  51. Source4: pyuic5.sh
  52. ## upstream patches
  53. ## upstreamable patches
  54. Patch0: python-qt5_sipdir.patch
  55. BuildRequires: chrpath
  56. BuildRequires: findutils
  57. BuildRequires: qt5-rpm-macros
  58. BuildRequires: pkgconfig(dbus-1)
  59. BuildRequires: pkgconfig(dbus-python)
  60. BuildRequires: pkgconfig(phonon4qt5)
  61. BuildRequires: pkgconfig(Qt5Core)
  62. #BuildRequires: pkgconfig(Enginio)
  63. BuildRequires: pkgconfig(Qt5Bluetooth)
  64. BuildRequires: pkgconfig(Qt5DBus)
  65. #BuildRequires: pkgconfig(Qt5Declarative)
  66. BuildRequires: qt5-qtdeclarative-devel
  67. BuildRequires: pkgconfig(Qt5Designer)
  68. BuildRequires: pkgconfig(Qt5Gui) pkgconfig(Qt5Multimedia)
  69. BuildRequires: pkgconfig(Qt5Location)
  70. BuildRequires: pkgconfig(Qt5Nfc)
  71. BuildRequires: pkgconfig(Qt5Network) pkgconfig(Qt5OpenGL)
  72. BuildRequires: pkgconfig(Qt5Positioning)
  73. BuildRequires: pkgconfig(Qt5Quick) pkgconfig(Qt5QuickWidgets)
  74. #BuildRequires: pkgconfig(Qt5Script)
  75. BuildRequires: pkgconfig(Qt5Sensors)
  76. BuildRequires: pkgconfig(Qt5SerialPort)
  77. BuildRequires: pkgconfig(Qt5Sql) pkgconfig(Qt5Svg) pkgconfig(Qt5Test)
  78. BuildRequires: pkgconfig(Qt5X11Extras)
  79. BuildRequires: pkgconfig(Qt5Xml) pkgconfig(Qt5XmlPatterns)
  80. BuildRequires: pkgconfig(Qt5WebChannel)
  81. BuildRequires: pkgconfig(Qt5WebSockets)
  82. BuildRequires: sip-devel >= 4.18
  83. %if 0%{?with_python2}
  84. BuildRequires: python-devel python
  85. BuildRequires: python-rpm-macros
  86. BuildRequires: python-enum34
  87. %endif # with_python2
  88. %if 0%{?with_python3}
  89. BuildRequires: python3-devel python3
  90. BuildRequires: python3-rpm-macros
  91. BuildRequires: python3-sip-devel >= 4.18
  92. BuildRequires: dbus-python3
  93. %endif # with_python3
  94. # when split out
  95. %if 0%{?webengine} || 0%{?webkit}
  96. Obsoletes: python-qt5 < 5.5.1-10
  97. %endif
  98. Requires: %{name}-rpm-macros = %{version}-%{release}
  99. Requires: python-qt5-base = %{version}-%{release}
  100. Requires: dbus-python
  101. BuildRequires: qt5-qtbase-private-devel
  102. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  103. %{?_sip_api:Requires: sip-api(%{_sip_api_major}) >= %{_sip_api}}
  104. %filter_provides_in %{python_sitearch} %{?_qt5_plugindir}
  105. %if 0%{?with_python3}
  106. %filter_provides_in %{python3_sitearch} %{?_qt5_plugindir}
  107. %endif
  108. %filter_setup
  109. Provides: PyQt5 = %{version}-%{release}
  110. Provides: PyQt5%{?_isa} = %{version}-%{release}
  111. Provides: python-PyQt5 = %{version}-%{release}
  112. Provides: python-PyQt5%{?_isa} = %{version}-%{release}
  113. Provides: python2-PyQt5 = %{version}-%{release}
  114. Provides: python2-PyQt5%{?_isa} = %{version}-%{release}
  115. Provides: python2-qt5 = %{version}-%{release}
  116. Provides: python2-qt5%{?_isa} = %{version}-%{release}
  117. %description
  118. PyQt5 is Python bindings for Qt5.
  119. %if 0%{?with_python2}
  120. %package base
  121. Summary: Python bindings for Qt5 base
  122. Group: programming
  123. Requires: %{name}-rpm-macros = %{version}-%{release}
  124. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  125. %{?_sip_api:Requires: python-pyqt5-sip-api(%{_sip_api_major}) >= %{_sip_api}}
  126. Requires: dbus-python
  127. Obsoletes: python-qt5 < 5.5.1-10
  128. Provides: python-PyQt5-base = %{version}-%{release}
  129. Provides: python-PyQt5-base%{?_isa} = %{version}-%{release}
  130. %{?python_provide:%python_provide python-qt5-base}
  131. %description base
  132. %{summary}.
  133. %package devel
  134. Summary: Development files for %{name}
  135. Group: programming
  136. Requires: %{name}%{?_isa} = %{version}-%{release}
  137. Requires: qt5-qtbase-devel
  138. Requires: sip-devel
  139. Provides: PyQt5-devel = %{version}-%{release}
  140. Provides: python-PyQt5-devel = %{version}-%{release}
  141. %description devel
  142. Files needed to build other bindings for C++ classes that inherit from any
  143. of the Qt5 classes (e.g. KDE or your own).
  144. %endif
  145. %package rpm-macros
  146. Summary: RPM macros %{name}
  147. Group: programming
  148. # when split out
  149. Conflicts: python-qt5 < 5.6
  150. Conflicts: python3-qt5 < 5.6
  151. BuildArch: noarch
  152. %description rpm-macros
  153. %{summary}.
  154. %package -n python3-qt5
  155. Summary: Python 3 bindings for Qt5
  156. Group: programming
  157. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  158. %{?_sip_api:Requires: python3-sip-api(%{_sip_api_major}) >= %{_sip_api}}
  159. # when split out
  160. %if 0%{?webengine} || 0%{?webkit}
  161. Obsoletes: python3-qt5 < 5.5.1-10
  162. %endif
  163. Provides: python3-PyQt5 = %{version}-%{release}
  164. Provides: python3-PyQt5%{?_isa} = %{version}-%{release}
  165. Requires: %{name}-rpm-macros = %{version}-%{release}
  166. Requires: python3-qt5-base = %{version}-%{release}
  167. Requires: dbus-python3
  168. %description -n python3-qt5
  169. %{summary}.
  170. %package -n python3-qt5-base
  171. Summary: Python 3 bindings for Qt5 base
  172. Group: programming
  173. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  174. %{?_sip_api:Requires: python3-pyqt5-sip-api(%{_sip_api_major}) >= %{_sip_api}}
  175. Provides: python3-PyQt5-base = %{version}-%{release}
  176. Provides: python3-PyQt5-base%{?_isa} = %{version}-%{release}
  177. Requires: %{name}-rpm-macros = %{version}-%{release}
  178. Requires: dbus-python3
  179. %{?python_provide:%python_provide python3-qt5-base}
  180. %description -n python3-qt5-base
  181. %{summary}.
  182. %package -n python3-qt5-devel
  183. Summary: Python 3 bindings for Qt5
  184. Group: programming
  185. Requires: python3-qt5%{?_isa} = %{version}-%{release}
  186. Requires: qt5-qtbase-devel
  187. Requires: python3-sip-devel
  188. Provides: python3-PyQt5-devel = %{version}-%{release}
  189. %description -n python3-qt5-devel
  190. Files needed to build other bindings for C++ classes that inherit from any
  191. of the Qt5 classes
  192. %package doc
  193. Summary: Developer documentation for %{name}
  194. Group: documentation
  195. BuildArch: noarch
  196. Provides: PyQt5-doc = %{version}-%{release}
  197. %description doc
  198. %{summary}.
  199. %if 0%{?webengine}
  200. %package webengine
  201. Summary: Python bindings for Qt5 WebEngine
  202. Group: programming
  203. BuildRequires: pkgconfig(Qt5WebEngine)
  204. BuildRequires: qt5-qtwebengine-devel
  205. Obsoletes: python-qt5 < 5.5.1-10
  206. Requires: %{name}%{?_isa} = %{version}-%{release}
  207. %description webengine
  208. %package -n python3-qt5-webengine
  209. Summary: Python bindings for Qt5 WebEngine
  210. Group: programming
  211. Obsoletes: python3-webengine < 5.5.1-13
  212. Obsoletes: python3-qt5 < 5.5.1-10
  213. Requires: python3-qt5%{?_isa} = %{version}-%{release}
  214. %description -n python3-qt5-webengine
  215. %endif
  216. %if 0%{?webkit}
  217. %package webkit
  218. Summary: Python bindings for Qt5 Webkit
  219. Group: programming
  220. BuildRequires: pkgconfig(Qt5WebKit) pkgconfig(Qt5WebKitWidgets)
  221. Obsoletes: python3-webkit < 5.5.1-12
  222. Obsoletes: python-qt5 < 5.5.1-10
  223. Requires: %{name}%{?_isa} = %{version}-%{release}
  224. %description webkit
  225. %package -n python3-qt5-webkit
  226. Summary: Python bindings for Qt5 Webkit
  227. Group: programming
  228. Obsoletes: python3-qt5 < 5.5.1-10
  229. Requires: python3-qt5%{?_isa} = %{version}-%{release}
  230. %description -n python3-qt5-webkit
  231. %endif
  232. %debug_package
  233. %prep
  234. %setup -q -n PyQt5-%{version}%{?snap:-snapshot-%{snap}}
  235. %patch0 -p1
  236. %build
  237. PATH=%{_qt5_bindir}:$PATH ; export PATH
  238. # Python 2 build:
  239. %if 0%{?with_python2}
  240. mkdir %{_target_platform}
  241. pushd %{_target_platform}
  242. %{__python} ../configure.py \
  243. --assume-shared \
  244. --confirm-license \
  245. --no-designer-plugin \
  246. --no-qml-plugin \
  247. --qmake=%{_qt5_qmake} \
  248. --no-qsci-api \
  249. --verbose \
  250. --dbus=/usr/include/dbus-1.0/ \
  251. QMAKE_CFLAGS_RELEASE="%{optflags}" \
  252. QMAKE_CXXFLAGS_RELEASE="%{optflags} -I/usr/%{_lib}/dbus-1.0/include/" \
  253. QMAKE_LFLAGS_RELEASE="%{?__global_ldflags}"
  254. make %{?_smp_mflags}
  255. popd
  256. %endif # with_python2
  257. # Python 3 build:
  258. %if 0%{?with_python3}
  259. mkdir %{_target_platform}-python3
  260. pushd %{_target_platform}-python3
  261. %{__python3} ../configure.py \
  262. --assume-shared \
  263. --confirm-license \
  264. --qmake=%{_qt5_qmake} \
  265. %ifarch x86_64
  266. --qsci-api --qsci-api-destdir=%{_qt5_datadir}/qsci \
  267. %else
  268. --no-qsci-api \
  269. %endif
  270. %{?py3_sip:--sip=%{_bindir}/python3-sip} \
  271. %{?py3_sipdir:--sipdir=%{py3_sipdir}} \
  272. --verbose \
  273. %{?python3_sip_incdir} \
  274. --dbus=/usr/include/dbus-1.0/ \
  275. QMAKE_CFLAGS_RELEASE="%{optflags}" \
  276. QMAKE_CXXFLAGS_RELEASE="%{optflags} -I/usr/%{_lib}/dbus-1.0/include/" \
  277. QMAKE_LFLAGS_RELEASE="%{?__global_ldflags}"
  278. make %{?_smp_mflags}
  279. popd
  280. %endif # with_python3
  281. %install
  282. # Python 3 build:
  283. %if 0%{?with_python3}
  284. %make_install INSTALL_ROOT=%{buildroot} -C %{_target_platform}-python3
  285. if [ "%{_prefix}" != "/usr" ]; then
  286. cp -ru %{buildroot}/usr/* %{buildroot}%{_prefix}/
  287. rm -rf %{buildroot}/usr/*
  288. fi
  289. %if "%py3_sipdir" == "%{_datadir}/sip/PyQt5"
  290. # copy files to old location for compat purposes temporarily
  291. mkdir -p %{buildroot}%{_datadir}/python3-sip
  292. cp -alf %{buildroot}%{py3_sipdir} \
  293. %{buildroot}%{_datadir}/python3-sip/PyQt5
  294. %endif
  295. if [ "%{_prefix}" != "/usr" ]; then
  296. cp -ru %{buildroot}/usr/* %{buildroot}%{_prefix}/ || echo "Nothing to copy"
  297. rm -rf %{buildroot}/usr/*
  298. fi
  299. # ensure .so modules are executable for proper -debuginfo extraction
  300. find %{buildroot} -type f -name '*.so' | xargs chmod a+rx
  301. #for i in %%{buildroot}%%{python3_sitearch}/PyQt5/*.so %%{buildroot}%%{python3_dbus_dir}/pyqt5.so ; do
  302. #test -x $i || chmod a+rx $i
  303. #done
  304. %endif # with_python3
  305. # Python 2 build:
  306. %if 0%{?with_python2}
  307. %make_install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  308. if [ "%{_prefix}" != "/usr" ]; then
  309. cp -ru %{buildroot}/usr/* %{buildroot}%{_prefix}/
  310. rm -rf %{buildroot}/usr/*
  311. fi
  312. # ensure .so modules are executable for proper -debuginfo extraction
  313. find %{buildroot} -type f -name '*.so' | xargs chmod a+rx
  314. #for i in %%{buildroot}%%{python2_sitearch}/PyQt5/*.so %%{buildroot}%%{python2_dbus_dir}/pyqt5.so ; do
  315. #test -x $i || chmod a+rx $i
  316. #done
  317. %endif # with_python2
  318. # remove Python3 code from Python2 directory, fixes FTBFS like PyQt4 (#564633)
  319. rm -rfv %{buildroot}%{python2_sitearch}/PyQt5/uic/port_v3/
  320. # remove Python2 code from Python3 directory (for when/if we support python3 here)
  321. rm -rfv %{buildroot}%{python3_sitearch}/PyQt5/uic/port_v2/
  322. # rpm macros
  323. install -p -m644 -D %{SOURCE1} \
  324. %{buildroot}%{rpm_macros_dir}/macros.pyqt5
  325. sed -i \
  326. -e "s|@@NAME@@|%{name}|g" \
  327. -e "s|@@EPOCH@@|%{?epoch}%{!?epoch:0}|g" \
  328. -e "s|@@VERSION@@|%{version}|g" \
  329. -e "s|@@EVR@@|%{?epoch:%{epoch:}}%{version}-%{release}|g" \
  330. %{buildroot}%{rpm_macros_dir}/macros.pyqt5
  331. %if 0%{?with_python3}
  332. # install wrappers to handle both/either python2/python3
  333. # TODO: consider alternatives? -- rex
  334. rm -fv %{buildroot}%{_bindir}/{pyrcc5,pylupdate5,pyuic5}
  335. install -p -m755 -D %{SOURCE2} %{buildroot}%{_bindir}/pylupdate5
  336. install -p -m755 -D %{SOURCE3} %{buildroot}%{_bindir}/pyrcc5
  337. install -p -m755 -D %{SOURCE4} %{buildroot}%{_bindir}/pyuic5
  338. sed -i \
  339. -e "s|@PYTHON3@|%{__python3}|g" \
  340. -e "s|@PYTHON2@|%{__python2}|g" \
  341. %{buildroot}%{_bindir}/{pyrcc5,pylupdate5,pyuic5}
  342. %endif
  343. %if 0%{?with_python2}
  344. %files
  345. #{python_sitearch}/PyQt5/Enginio.so
  346. %{python_sitearch}/PyQt5/QtBluetooth.so
  347. %{python_sitearch}/PyQt5/QtDesigner.so
  348. %{python_sitearch}/PyQt5/QtHelp.so
  349. %{python_sitearch}/PyQt5/QtLocation.so
  350. %{python_sitearch}/PyQt5/QtMultimedia.so
  351. %{python_sitearch}/PyQt5/QtMultimediaWidgets.so
  352. %{python_sitearch}/PyQt5/QtNfc.so
  353. %{python_sitearch}/PyQt5/QtPositioning.so
  354. %{python_sitearch}/PyQt5/QtQml.so
  355. %{python_sitearch}/PyQt5/QtQuick.so
  356. %{python_sitearch}/PyQt5/QtQuickWidgets.so
  357. %{python_sitearch}/PyQt5/QtSensors.so
  358. %{python_sitearch}/PyQt5/QtSerialPort.so
  359. %{python_sitearch}/PyQt5/QtSvg.so
  360. %{python_sitearch}/PyQt5/QtWebChannel.so
  361. %{python_sitearch}/PyQt5/QtWebSockets.so
  362. %{python_sitearch}/PyQt5/QtX11Extras.so
  363. %{python_sitearch}/PyQt5/QtXmlPatterns.so
  364. %files base
  365. %doc NEWS README
  366. %license LICENSE
  367. %{python_dbus_dir}/pyqt5.so
  368. %dir %{python_sitearch}/PyQt5/
  369. %{python_sitearch}/PyQt5-%{version}%{?snap:.%{snap}}.dist-info
  370. %{python_sitearch}/PyQt5/__init__.py*
  371. %{python_sitearch}/PyQt5/Qt.so
  372. %{python_sitearch}/PyQt5/QtCore.so
  373. %{python_sitearch}/PyQt5/QtDBus.so
  374. %{python_sitearch}/PyQt5/QtGui.so
  375. %{python_sitearch}/PyQt5/QtNetwork.so
  376. %{python_sitearch}/PyQt5/QtOpenGL.so
  377. %{python_sitearch}/PyQt5/QtPrintSupport.so
  378. %{python_sitearch}/PyQt5/QtSql.so
  379. %{python_sitearch}/PyQt5/QtTest.so
  380. %{python_sitearch}/PyQt5/QtWidgets.so
  381. %{python_sitearch}/PyQt5/QtXml.so
  382. %{python_sitearch}/PyQt5/_QOpenGLFunctions_2_0.so
  383. %{python_sitearch}/PyQt5/_QOpenGLFunctions_2_1.so
  384. %{python_sitearch}/PyQt5/_QOpenGLFunctions_4_1_Core.so
  385. # *was* in -devel
  386. %{_bindir}/pylupdate5
  387. %{_bindir}/pyrcc5
  388. %{_bindir}/pyuic5
  389. %{python_sitearch}/PyQt5/uic/
  390. %{python_sitearch}/PyQt5/pylupdate.so
  391. %{python_sitearch}/PyQt5/pylupdate_main.py*
  392. %{python_sitearch}/PyQt5/pyrcc.so
  393. %{python_sitearch}/PyQt5/pyrcc_main.py*
  394. %if 0%{?webengine}
  395. %files webengine
  396. %{python_sitearch}/PyQt5/QtWebEngine.*
  397. %{python_sitearch}/PyQt5/QtWebEngineCore.*
  398. %{python_sitearch}/PyQt5/QtWebEngineWidgets.*
  399. %endif
  400. %if 0%{?webkit}
  401. %files webkit
  402. %{python_sitearch}/PyQt5/QtWebKit.*
  403. %{python_sitearch}/PyQt5/QtWebKitWidgets.*
  404. %endif
  405. %files devel
  406. %{_datadir}/sip/PyQt5/
  407. %endif
  408. %files rpm-macros
  409. %{rpm_macros_dir}/macros.pyqt5
  410. %if 0%{?with_python3}
  411. %files -n python3-qt5
  412. #{python3_sitearch}/PyQt5/Enginio.*
  413. %{python3_sitearch}/PyQt5/QtBluetooth.*
  414. %{python3_sitearch}/PyQt5/QtDesigner.*
  415. %{python3_sitearch}/PyQt5/QtHelp.*
  416. %{python3_sitearch}/PyQt5/QtLocation.*
  417. %{python3_sitearch}/PyQt5/QtMultimedia.*
  418. %{python3_sitearch}/PyQt5/QtMultimediaWidgets.*
  419. %{python3_sitearch}/PyQt5/QtNfc.*
  420. %{python3_sitearch}/PyQt5/QtPositioning.*
  421. %{python3_sitearch}/PyQt5/QtQml.*
  422. %{python3_sitearch}/PyQt5/QtQuick.*
  423. %{python3_sitearch}/PyQt5/QtQuickWidgets.*
  424. %{python3_sitearch}/PyQt5/QtSensors.*
  425. %{python3_sitearch}/PyQt5/QtSerialPort.*
  426. %{python3_sitearch}/PyQt5/QtSvg.*
  427. %{python3_sitearch}/PyQt5/QtWebChannel.*
  428. %{python3_sitearch}/PyQt5/QtWebSockets.*
  429. %{python3_sitearch}/PyQt5/QtX11Extras.*
  430. %{python3_sitearch}/PyQt5/QtXmlPatterns.*
  431. %files -n python3-qt5-base
  432. %doc NEWS README
  433. %license LICENSE
  434. %{python3_dbus_dir}/pyqt5.so
  435. %dir %{python3_sitearch}/PyQt5/
  436. %{python3_sitearch}/PyQt5-%{version}%{?snap:.%{snap}}.dist-info
  437. #{python3_sitearch}/PyQt5/__pycache__/__init__.*
  438. %{python3_sitearch}/PyQt5/__init__.py*
  439. %{python3_sitearch}/PyQt5/Qt.*
  440. %{python3_sitearch}/PyQt5/QtCore.*
  441. %{python3_sitearch}/PyQt5/QtDBus.*
  442. %{python3_sitearch}/PyQt5/QtGui.*
  443. %{python3_sitearch}/PyQt5/QtNetwork.*
  444. %{python3_sitearch}/PyQt5/QtOpenGL.*
  445. %{python3_sitearch}/PyQt5/QtPrintSupport.*
  446. %{python3_sitearch}/PyQt5/QtSql.*
  447. %{python3_sitearch}/PyQt5/QtTest.*
  448. %{python3_sitearch}/PyQt5/QtWidgets.*
  449. %{python3_sitearch}/PyQt5/QtXml.*
  450. %{python3_sitearch}/PyQt5/_QOpenGLFunctions_2_0.*
  451. %{python3_sitearch}/PyQt5/_QOpenGLFunctions_2_1.*
  452. %{python3_sitearch}/PyQt5/_QOpenGLFunctions_4_1_Core.*
  453. # plugins
  454. %{_qt5_plugindir}/PyQt5/
  455. %{_qt5_plugindir}/designer/libpyqt5.so
  456. %{python3_sitearch}/PyQt5/uic/
  457. # *was* in python3-qt5-devel
  458. %{_bindir}/pylupdate5
  459. %{_bindir}/pyrcc5
  460. %{_bindir}/pyuic5
  461. %{python3_sitearch}/PyQt5/pylupdate.so
  462. %{python3_sitearch}/PyQt5/pylupdate_main.py*
  463. #{python3_sitearch}/PyQt5/__pycache__/pylupdate_main*
  464. %{python3_sitearch}/PyQt5/pyrcc.so
  465. %{python3_sitearch}/PyQt5/pyrcc_main.py*
  466. #{python3_sitearch}/PyQt5/__pycache__/pyrcc_main*
  467. %if 0%{?webengine}
  468. %files -n python3-qt5-webengine
  469. %{python3_sitearch}/PyQt5/QtWebEngine.*
  470. %{python3_sitearch}/PyQt5/QtWebEngineCore.*
  471. %{python3_sitearch}/PyQt5/QtWebEngineWidgets.*
  472. %endif
  473. %if 0%{?webkit}
  474. %files -n python3-qt5-webkit
  475. %{python3_sitearch}/PyQt5/QtWebKit.*
  476. %{python3_sitearch}/PyQt5/QtWebKitWidgets.*
  477. %endif
  478. %files -n python3-qt5-devel
  479. %{py3_sipdir}/
  480. # compat location
  481. %dir %{_datadir}/python3-sip/
  482. %{_datadir}/python3-sip/PyQt5/
  483. %endif # with_python3
  484. %ifarch x86_64
  485. %files doc
  486. #doc doc/*
  487. %doc examples/
  488. # avoid dep on qscintilla-python, own %%_qt5_datadir/qsci/... here for now
  489. %dir %{_qt5_datadir}/qsci/
  490. %dir %{_qt5_datadir}/qsci/api/
  491. %dir %{_qt5_datadir}/qsci/api/python/
  492. %doc %{_qt5_datadir}/qsci/api/python/PyQt5.api
  493. %endif
  494. %changelog
  495. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.15.0-4
  496. - new upstream release.
  497. - built with python-3.8.
  498. * Fri Jul 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.3-3
  499. - rebuilt with qt5-5.12.8.
  500. * Mon Mar 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.3-2
  501. - rebuilt with qt5-5.12.7.
  502. * Tue Oct 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.3-1
  503. - new upstream release.
  504. * Sat Jan 27 2018 Toshiaki Ara <ara_t@384.jp> - 5.6-7
  505. - rebuild under current VineSeed
  506. * Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6-6
  507. - initial build for Vine Linux.
  508. * Wed Jul 06 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-5
  509. - BR: qt5-qtbase-private-devel
  510. - python3-qt5: add versioned qt5 dep (like base python-qt5 pkg has)
  511. * Wed Jun 29 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-4
  512. - rebuild (qt5)
  513. * Wed Jun 15 2016 Than Ngo <than@redhat.com> - 5.6-3
  514. - drop ppc ppc64 ppc64le, it's not supported yet
  515. * Mon May 02 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-2
  516. - -rpm-macros: Conflicts: python(3)-qt5 < 5.6
  517. * Mon Apr 25 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-1
  518. - PyQt5-5.6
  519. * Wed Apr 13 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.5.1-20
  520. - rebuild (sip), re-enable -webengine for secondary archs
  521. * Thu Mar 24 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-19
  522. - limit -webengine support to just primary archs (for now)
  523. * Thu Mar 24 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-18
  524. - -rpm-macros subpkg
  525. * Tue Mar 15 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-17
  526. - rebuild (qt5-qtenginio)
  527. * Mon Mar 14 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-16
  528. - -webengine: add ExclusiveArch (matching qt5-qtwebengine's)
  529. * Mon Mar 07 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-15
  530. - add Obsoletes for misnamed -webengine/-webkit pkgs (#1315025)
  531. * Sat Mar 05 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-14
  532. - python-qt5 is not built with $RPM_OPT_FLAGS (#1314998)
  533. * Thu Mar 03 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-13
  534. - fix python3-qt5-webengine name
  535. * Thu Mar 03 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-12
  536. - fix python3-qt5-webkit name
  537. * Wed Mar 02 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-11
  538. - use safer subdir builds
  539. * Wed Mar 02 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-10
  540. - -webengine,-webkit subpkgs
  541. * Sat Feb 27 2016 Christian Dersch <lupinix@mailbox.org> - 5.5.1-9
  542. - Enabled QtWebEngine for Fedora >= 24
  543. * Sat Feb 27 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-8
  544. - rebuild
  545. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.1-7
  546. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  547. * Mon Feb 01 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-6
  548. - explicitly set CFLAGS,CXXFLAGS,LFLAGS
  549. * Wed Jan 13 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.5.1-5
  550. - %%description: mention PyQt5
  551. * Mon Dec 07 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-4
  552. - rebuild (qt5), Provides: python2-qt5
  553. * Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.5.1-3
  554. - Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
  555. * Mon Nov 02 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-2
  556. - rebuild (qt5)
  557. * Mon Oct 26 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-1
  558. - 5.5.1
  559. - enable qtenginio, fix pyuic5 wrapper, use %%license
  560. * Mon Oct 12 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5-2
  561. - rebuild (qt5)
  562. * Thu Jul 30 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5-1
  563. - 5.5
  564. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.4.2-2
  565. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  566. * Fri Jun 12 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.2-1
  567. - 5.4.2
  568. * Fri Jun 05 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-5
  569. - wrong python release used in pyuic5 launch script (#1193107)
  570. - -doc: add qsci doc QyQt5.api content
  571. - enable Qt5WebChannel/Qt5WebSockets support
  572. * Fri Jun 05 2015 Sandro Mani <manisandro@gmail.com> - 5.4.1-4
  573. - Add patch to fix python3 sip installation dir (#1228432)
  574. * Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 5.4.1-3
  575. - Rebuilt for GCC 5 C++11 ABI change
  576. * Wed Mar 25 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.1-2
  577. - rebuild (sip)
  578. * Thu Feb 26 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.1-1
  579. - 5.4.1
  580. * Wed Feb 25 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-6
  581. - rebuild (sip)
  582. * Tue Jan 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-5
  583. - +macros.pyqt5
  584. * Fri Jan 02 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-4
  585. - -devel: restore dep on base pkg
  586. * Sun Dec 28 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.4-3
  587. - python3-qt5-devel subpkg
  588. * Sat Dec 27 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4-2
  589. - ensure .so modules are executable (for proper -debuginfo extraction)
  590. * Fri Dec 26 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4-1
  591. - 5.4
  592. * Thu Nov 13 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-6
  593. - restore python3 support
  594. * Tue Nov 11 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-5
  595. - pkgconfig(QtOpenGL) being satisfied by qt4 devel (#1162415)
  596. * Thu Nov 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-4
  597. - try to determine dbus-python install paths dynamically (#1161121)
  598. * Thu Nov 06 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.3.2-3
  599. - Build failure in sipQtWebKitWidgestQWebInspector: qprinter.h not found (#1160932)
  600. - python2_sitelib should be python2_sitearch (#1161121)
  601. * Mon Sep 15 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-1
  602. - PyQt-gpl-5.3.2
  603. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
  604. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  605. * Sun Jul 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.1-1
  606. - PyQt-gpl-5.3.1
  607. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3-3
  608. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  609. * Mon Jun 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3-2
  610. - python3: (Build)Requires: python3-dbus
  611. * Mon Jun 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3-1
  612. - PyQt-gpl-5.3
  613. - +Qt5Bluetooth,Qt5Quick,Qt5SerialPorts support
  614. * Mon May 12 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-2
  615. - rebuild (f21-python)
  616. - +Qt5Positioning,Qt5Sensors support
  617. * Sun Mar 16 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
  618. - PyQt-5.2.1
  619. * Sat Mar 08 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> 5.2-5
  620. - Rebuild against fixed qt5-qtbase to fix -debuginfo (#1065636)
  621. * Sat Feb 15 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-4
  622. - python3-qt5 support
  623. * Thu Feb 13 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-3
  624. - Provides: PyQt5
  625. * Thu Feb 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-2
  626. - BR: python2-devel, use %%__python2 macro
  627. * Wed Jan 08 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-1
  628. - PyQt-5.2