python-pyxml-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135
  1. %define module PyXML
  2. #%define pyver %(python -c 'import sys;print(sys.version[0:3])')
  3. #%define pysite %{_libdir}/python%{pyver}/site-packages
  4. %define pyinc %{_includedir}/python%{pyver}
  5. Summary: XML libraries for python
  6. Summary(ja): Python XML ライブラリ
  7. Name: python-pyxml
  8. Version: 0.8.4
  9. Release: 7%{?_dist_release}
  10. URL: http://pyxml.sourceforge.net/
  11. Source0: http://prdownloads.sourceforge.net/pyxml/PyXML-%{version}.tar.gz
  12. Patch0: PyXML-0.7.1-intern.patch
  13. Patch1: PyXML-0.8.4-cvs20041111-python2.4-backport.patch
  14. Patch2: PyXML-memmove.patch
  15. Patch3: PyXML-0.8.4-python2.6.patch
  16. License: Apacheish
  17. Group: Development/Libraries
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: python-devel, expat-devel
  20. BuildRequires: python-setuptools
  21. Requires: python, libexpat
  22. Obsoletes: %{module}
  23. Provides: %{module}
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. %description
  27. An XML package for Python. The distribution contains a validating XML
  28. parser, an implementation of the SAX and DOM programming interfaces
  29. and an interface to the Expat parser.
  30. %prep
  31. %setup -q -n %{module}-%{version}
  32. %patch0 -p1 -b .intern
  33. %patch1 -p1 -b .python2.4-backport
  34. %patch2 -p1
  35. %patch3 -p1
  36. # iconv to use utf8
  37. for file in CREDITS ANNOUNCE doc/xml-howto.txt doc/xml-ref.txt README; do
  38. iconv -f iso8859-1 -t utf-8 -o tmp $file
  39. mv tmp $file
  40. done
  41. %build
  42. CFLAGS="%{optflags}" \
  43. %{_bindir}/python -c 'import setuptools; execfile("setup.py")' build --with-libexpat=%{_prefix}
  44. %install
  45. %__rm -rf %{buildroot}
  46. %{_bindir}/python -c 'import setuptools; execfile("setup.py")' install --skip-build install --root=%{buildroot}
  47. %{_bindir}/python -O %{_libdir}/python%{pyver}/compileall.py \
  48. %{buildroot}%{python_sitearch}
  49. %clean
  50. %__rm -rf %{buildroot}
  51. %files
  52. %defattr(-,root,root)
  53. %doc LICENCE ANNOUNCE CREDITS README README.* TODO doc/*
  54. %{_bindir}/*
  55. %{python_sitearch}/*
  56. %changelog
  57. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.4-7
  58. - rebuild with VineSeed environment
  59. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.4-6
  60. - rebuild with python-2.7.2
  61. * Sat Jun 06 2009 Shu KONNO <owa@bg.wakwak.com> 0.8.4-5
  62. - rebuilt with python-2.6
  63. - added Patch0-4 from Fedora
  64. * Wed Dec 24 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 0.8.4-12
  65. - Patch for 'as' reserved keyword (bug #477783)
  66. * Thu Jul 27 2006 Florian La Roche <laroche@redhat.com> - 0.8.4-4
  67. - don't check memmove
  68. * Thu Nov 11 2004 Miloslav Trmac <mitr@redhat.com> - 0.8.4-0.cvs20041111.1
  69. - Backport xml.sax.saxutils fix from Python 2.4b2
  70. * Fri Jun 28 2002 Trond Eivind Glomsrød <teg@redhat.com>
  71. - A fix for the expatreader
  72. * Sat Jun 06 2009 Shu KONNO <owa@bg.wakwak.com> 0.8.4-4
  73. - spec in utf-8 properly
  74. - use rpm macros: pyver, python_sitearch
  75. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.8.4-3vl5
  76. - rebuilt with python-2.5.2
  77. - applied new versioning policy and spec in utf-8
  78. * Wed Feb 27 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.8.4-2vl3
  79. - rebuild with expat-2.0.1
  80. * Mon May 8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.4-2vl2
  81. - fixed Japanese summary
  82. - changed Group:
  83. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.4-2vl1
  84. - initial build for Vine Linux
  85. * Wed May 4 2005 Gotz Waschk <waschk@mandriva.org> 0.8.4-2mdk
  86. - use external libexpat
  87. - enable xpath and xslt
  88. * Thu Dec 16 2004 Guillaume Rousse <guillomovitch@mandrake.org> 0.8.4-1mdk
  89. - new version
  90. - changed name
  91. * Sun Dec 05 2004 Michael Scherer <misc@mandrake.org> 0.8.3-4mdk
  92. - Rebuild for new python
  93. * Mon Nov 01 2004 Michael Scherer <misc@mandrake.org> 0.8.3-3mdk
  94. - [DIRM]
  95. * Sat Apr 10 2004 Michael Scherer <misc@mandrake.org> 0.8.3-2mdk
  96. - [DIRM]
  97. * Wed Aug 20 2003 Austin Acton <aacton@yorku.ca> 0.8.3-1mdk
  98. - 0.8.3
  99. * Tue Aug 12 2003 Per Oyvind Karlsen <peroyvind@linux-mandrake.com> 0.8.2-4mdk
  100. - rebuild for new python
  101. * Sat Mar 29 2003 David Walluck <walluck@linux-mandrake.com> 0.8.2-3mdk
  102. - release
  103. * Tue Mar 25 2003 David Walluck <david@anti-microsoft.org> 0.8.2-2plf
  104. - spec file cleanups
  105. * Sun Jan 26 2003 David Walluck <david@anti-microsoft.org> 0.8.2-1plf
  106. - release