python-pysocks-vl.spec 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147
  1. %global pypi_name PySocks
  2. %global modname pysocks
  3. %global sum A Python SOCKS client module
  4. Summary: %{sum}
  5. Name: python-%{modname}
  6. Version: 1.7.1
  7. Release: 1%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: BSD
  12. URL: https://github.com/Anorov/%{pypi_name}
  13. Source0: https://files.pythonhosted.org/packages/source/P/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
  14. BuildArch: noarch
  15. BuildRequires: python-devel
  16. BuildRequires: python-setuptools
  17. BuildRequires: python-rpm-macros
  18. BuildRequires: python2-rpm-macros
  19. %{?python_provide:%python_provide python2-%{modname}}
  20. %global _description \
  21. A fork of SocksiPy with bug fixes and extra features.\
  22. \
  23. Acts as a drop-in replacement to the socket module. Featuring:\
  24. \
  25. - SOCKS proxy client for Python 2.6 - 3.x\
  26. - TCP and UDP both supported\
  27. - HTTP proxy client included but not supported or recommended (you should use\
  28. urllib2's or requests' own HTTP proxy interface)\
  29. - urllib2 handler included.
  30. %description
  31. %_description
  32. %package -n python3-%{modname}
  33. Summary: %{sum}
  34. Group: programming
  35. BuildRequires: python3-devel
  36. BuildRequires: python3-setuptools
  37. BuildRequires: python3-rpm-macros
  38. %{?python_provide:%python_provide python3-%{modname}}
  39. %description -n python3-%{modname}
  40. %_description
  41. This package is for Python3 version %{python3_version} only.
  42. %prep
  43. %autosetup -n %{pypi_name}-%{version}
  44. # drop useless 3rdparty code
  45. rm -rfv test/bin
  46. %build
  47. %py2_build
  48. %py3_build
  49. %install
  50. %py2_install
  51. %py3_install
  52. %check
  53. %files
  54. %doc README.md
  55. %license LICENSE
  56. %{python_sitelib}/socks.py*
  57. %{python_sitelib}/sockshandler.py*
  58. %{python_sitelib}/%{pypi_name}-%{version}*
  59. %files -n python3-%{modname}
  60. %doc README.md
  61. %license LICENSE
  62. %{python3_sitelib}/socks.py*
  63. %{python3_sitelib}/sockshandler.py*
  64. %{python3_sitelib}/__pycache__/*socks*
  65. %{python3_sitelib}/%{pypi_name}-%{version}-*
  66. %changelog
  67. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.1-1
  68. - new upstream release.
  69. * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.6.8-7
  70. - initial build for Vine Linux.
  71. * Sun Nov 11 2018 Kevin Fenzi <kevin@scrye.com> - 1.6.8-6
  72. - Add upstream patch to avoid DeprecationWarning. Fixes bug #1648583
  73. * Wed Oct 03 2018 Raphael Groner <projects.rg@smart.ms> - 1.6.8-5
  74. - add python3_other subpackage for epel7
  75. - prepare removal of python2 subpackage in Fedora
  76. - use pypi macros
  77. - try to enable tests provided actually from tarball
  78. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.8-4
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  80. * Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 1.6.8-3
  81. - Rebuilt for Python 3.7
  82. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.8-2
  83. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  84. * Fri Dec 22 2017 Kevin Fenzi <kevin@scrye.com> - 1.6.8-1
  85. - Update to 1.6.8. Fixes bug #1528490
  86. * Mon Sep 11 2017 Carl George <carl@george.computer> - 1.6.7-1
  87. - Latest upstream
  88. - Add setuptools dependency
  89. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.7-5
  90. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  91. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.7-4
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  93. * Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.5.7-3
  94. - Rebuild for Python 3.6
  95. * Mon Nov 28 2016 Tim Orling <ticotimo@gmail.com> - 1.5.7-2
  96. - Ship python34-pysocks in EL6
  97. * Sat Sep 17 2016 Kevin Fenzi <kevin@scrye.com> - 1.5.7-1
  98. - Update to 1.5.7
  99. * Fri Sep 16 2016 Orion Poplawski <orion@cora.nwra.com> - 1.5.6-6
  100. - Ship python34-pysocks in EPEL7
  101. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.6-5
  102. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  103. * Fri Jul 15 2016 Ralph Bean <rbean@redhat.com> - 1.5.6-4
  104. - Change our conflicts on python-SocksiPy to an obsoletes/provides.
  105. https://bugzilla.redhat.com/show_bug.cgi?id=1334407
  106. * Mon May 09 2016 Ralph Bean <rbean@redhat.com> - 1.5.6-3
  107. - Fix typo in explicit conflicts.
  108. * Tue May 03 2016 Ralph Bean <rbean@redhat.com> - 1.5.6-2
  109. - We don't actually need setuptools here.
  110. * Mon May 02 2016 Ralph Bean <rbean@redhat.com> - 1.5.6-1
  111. - Initial package for Fedora