python-pyrex-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151
  1. %define python_sitelib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(0)')
  2. %define packagename Pyrex
  3. Name: python-pyrex
  4. Version: 0.9.9
  5. Release: 3%{?_dist_release}
  6. BuildArch: noarch
  7. Summary: A compiler/language for writing Python extension modules.
  8. Group: Development/Languages
  9. License: Public Domain
  10. URL: http://www.cosc.canterbury.ac.nz/~greg/python/%{packagename}/
  11. Source0: http://www.cosc.canterbury.ac.nz/~greg/python/%{packagename}/%{packagename}-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  13. BuildRequires: python-devel
  14. BuildRequires: nkf
  15. BuildRequires: findutils
  16. Requires: python-devel
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. %description
  20. Pyrex is Python with C types. It is specially designed to allow you to
  21. write extension modules for Python that have the speed of C and the
  22. simplicity and readability of Python. You write your code in a Python-like
  23. language with C-typed variables, then use the pyrexc compiler to transform
  24. it into a C representation. This is useful for speeding up critical sections
  25. of your Python code or wrapping an external library.
  26. Please see the documentation for how to get the best performance from your
  27. code.
  28. %prep
  29. %setup -q -n %{packagename}-%{version}
  30. %build
  31. python setup.py build
  32. # Remove some Macintosh-isms
  33. find . -name '.DS_Store' -exec rm -f \{\} \;
  34. for i in CHANGES.txt ToDo.txt Demos/Makefile.nodistutils Tools/*
  35. do
  36. nkf -Lu --in-place $i
  37. done
  38. find Doc -type f | xargs nkf -Lu --in-place
  39. %install
  40. rm -rf $RPM_BUILD_ROOT
  41. python setup.py install --skip-build --root $RPM_BUILD_ROOT
  42. %clean
  43. rm -rf $RPM_BUILD_ROOT
  44. %files
  45. %defattr(-,root,root,-)
  46. %doc USAGE.txt README.txt CHANGES.txt ToDo.txt Demos Doc Tools
  47. %{python_sitelib}/Pyrex*
  48. %exclude %{python_sitelib}/Pyrex/Mac
  49. %{_bindir}/pyrexc
  50. %changelog
  51. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.9-3
  52. - rebuild with VineSeed environment
  53. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.9-2
  54. - rebuild with python-2.7.2
  55. * Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.9-1
  56. - new upstream release
  57. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8.4-2
  58. - rebuild with python-2.6
  59. * Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8.4
  60. - new upstream release
  61. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.9.3-1vl5
  62. - rebuilt with python-2.5.2
  63. - added pythonlib macro
  64. - applied new versioning policy
  65. * Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
  66. - initial build for Vine Linux
  67. * Tue Mar 22 2005 Jeremy Katz <katzj@redhat.com> - 0.9.3-0
  68. - update to 0.9.3
  69. - add patch to fix generated code to build with gcc4
  70. - require python-abi and python-devel instead of conflicting with
  71. newer python-devel
  72. * Mon Nov 8 2004 Jeremy Katz <katzj@redhat.com> - 0:0.9.2.1-3
  73. - rebuild against python 2.4
  74. * Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9.2.1-2
  75. - Added Steve Grubb's spec file patch (RH Bug #130200)
  76. * Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9.2.1-1
  77. - New upstream version
  78. - Pyrex-0.9-split-base-types.patch synced for new version
  79. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  80. - rebuilt
  81. * Thu Jun 03 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9-5
  82. - Built to rawhide
  83. * Wed May 19 2004 Florian La Roche <Florian.LaRoche@redhat.de>
  84. - use rpm macros to determine lib64 usage
  85. * Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9-3
  86. - Added Pyrex-0.9-split-base-types.patch which fixes
  87. long unsigned int bug showing up in dbus python binding
  88. builds for the x86_64 arch
  89. - Added regex hack to spec to work around a bug in python's
  90. distutils which would install files into /usr/lib instead of
  91. /usr/lib64 on 64 bit archs
  92. * Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9-2
  93. - Was informed that the epoch change was not needed so the epoch
  94. was reverted back to 0
  95. * Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> - 1:0.9-1
  96. - Upped the epoch so as to avoid clashes with the Fedora extra package
  97. * Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9-1
  98. - Transfered to Red Hat Fedora's main tree
  99. - Removed need for LONG_LONG patch
  100. * Mon Feb 02 2004 Toshio Kuratomi <toshio@tiki-lounge.com> - 0:0.9-0.fdr.4
  101. - Removed the site-packages directory from the directories owned by the
  102. package
  103. * Mon Feb 02 2004 Toshio Kuratomi <toshio@tiki-lounge.com> - 0:0.9-0.fdr.3
  104. - My mistake: rpm automatically removes %%ghost files, no need to script
  105. it manually.
  106. - python distutils --record=FILE option doesn't record directories so include
  107. the site-packages/[directories] manually
  108. * Wed Jan 15 2003 Toshio Kuratomi <toshio@tiki-lounge.com> - 0:0.9-0.fdr.2
  109. - Merge changes from Michel Alexandre Salim <salimma[AT]users.sf.net>
  110. + Require build system's python version because directories are named
  111. pythonX.Y
  112. + Create *.pyo files and %ghost them (Privleged user with python optimize
  113. turned on may generate them, but they aren't needed for operation.
  114. + Do not include the Mac Pyrex compiler stuff
  115. + Change license to Public Domain
  116. - Script to remove any %%ghost files on package removal
  117. - Patch around an incompatible change between python 2.2 and python 2.3's
  118. definition of LONG_LONG being renamed to PY_LONG_LONG
  119. * Thu Jan 09 2003 Toshio Kuratomi <toshio@tiki-lounge.com> - 0:0.9-0.fdr.1
  120. - Initial RPM release.