python-pycurl-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191
  1. %define modname pycurl
  2. Name: python-%{modname}
  3. Version: 7.43.0.4
  4. Release: 1%{?_dist_release}
  5. Summary: A Python interface to libcurl
  6. Summary(ja): libcurl の Python インタフェース
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2+
  11. URL: http://pycurl.io/
  12. Source0: https://dl.bintray.com/pycurl/pycurl/pycurl-%{version}.tar.gz
  13. # drop link-time vs. run-time TLS backend check (#1446850)
  14. Patch2: 0002-python-pycurl-7.43.0-tls-backend.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  16. BuildRequires: python-rpm-macros
  17. BuildRequires: python-devel
  18. BuildRequires: python2-rpm-macros
  19. BuildRequires: curl-devel >= 7.19.0
  20. BuildRequires: openssl-devel
  21. BuildRequires: openldap-devel
  22. # During its initialization, PycURL checks that the actual libcurl version
  23. # is not lower than the one used when PycURL was built.
  24. # Yes, that should be handled by library versioning (which would then get
  25. # automatically reflected by rpm).
  26. # For now, we have to reflect that dependency.
  27. %define libcurl_sed '/^#define LIBCURL_VERSION "/!d;s/"[^"]*$//;s/.*"//;q'
  28. %define curlver_h /usr/include/curl/curlver.h
  29. %define libcurl_ver %(sed %{libcurl_sed} %{curlver_h} 2>/dev/null || echo 0)
  30. Requires: curl >= %{libcurl_ver}
  31. Provides: %{modname} = %{version}-%{release}
  32. %description
  33. PycURL is a Python interface to libcurl. PycURL can be used to fetch
  34. objects identified by a URL from a Python program, similar to the
  35. urllib Python module. PycURL is mature, very fast, and supports a lot
  36. of features.
  37. %package -n python3-%{modname}
  38. Summary: A Python3 interface to libcurl
  39. Summary(ja): libcurl の Python3 インタフェース
  40. Group: programming
  41. BuildRequires: python3-devel
  42. BuildRequires: python3-rpm-macros
  43. %description -n python3-%{modname}
  44. PycURL is a Python interface to libcurl. PycURL can be used to fetch
  45. objects identified by a URL from a Python program, similar to the
  46. urllib Python module. PycURL is mature, very fast, and supports a lot
  47. of features.
  48. %prep
  49. %autosetup -n %{modname}-%{version} -p1
  50. # remove binaries packaged by upstream
  51. rm -f tests/fake-curl/libcurl/*.so
  52. # remove a test-case that relies on sftp://web.sourceforge.net being available
  53. rm -f tests/ssh_key_cb_test.py
  54. # remove a test-case that fails in Koji
  55. rm -f tests/seek_cb_test.py
  56. # remove tests depending on the 'flaky' nose plug-in
  57. grep '^import flaky' -r tests | cut -d: -f1 | xargs rm -fv
  58. # drop options that are not supported by nose
  59. sed -e 's/ --show-skipped//' \
  60. -e 's/ --with-flaky//' \
  61. -i tests/run.sh
  62. %build
  63. %py_build -- --with-openssl
  64. %py3_build -- --with-openssl
  65. %check
  66. #export PYTHONPATH=$PWD/build/lib*
  67. #%{__python} tests/test_internals.py -q
  68. %install
  69. rm -rf %{buildroot}
  70. export PYCURL_SSL_LIBRARY=openssl
  71. %py_install
  72. %py3_install
  73. rm -rf %{buildroot}%{_datadir}/doc/pycurl
  74. %clean
  75. rm -rf %{buildroot}
  76. %files
  77. %defattr(-,root,root,-)
  78. %license COPYING-LGPL COPYING-MIT
  79. %doc ChangeLog README.rst examples doc tests
  80. %{python_sitearch}/*
  81. %files -n python3-%{modname}
  82. %defattr(-,root,root,-)
  83. %license COPYING-LGPL COPYING-MIT
  84. %doc ChangeLog README.rst examples doc tests
  85. %{python3_sitearch}/*
  86. %changelog
  87. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0.4-1
  88. - new upstream release: the latest version with python2 support.
  89. * Wed Apr 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0.2-1
  90. - new upstream release.
  91. - added python3 support.
  92. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.19.0-5
  93. - rebuild with VineSeed environment
  94. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.19.0-4
  95. - rebuild with python-2.7.2
  96. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 7.19.0-3
  97. - rebuild with python-2.6
  98. * Sat Aug 8 2009 Shu KONNO <owa@bg.wakwak.com> - 7.19.0-2
  99. - spec in utf-8
  100. - added BR: openldap-devel
  101. * Thu Aug 6 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 7.19.0-1
  102. - initial build for VineSeed
  103. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.19.0-4
  104. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  105. * Fri Apr 17 2009 Stepan Kasal <skasal@redhat.com> - 7.19.0-3
  106. - fix typo in the previous change
  107. * Fri Apr 17 2009 Stepan Kasal <skasal@redhat.com> - 7.19.0-2
  108. - add a require to reflect a dependency on libcurl version (#496308)
  109. * Thu Mar 5 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.19.0-1
  110. - Update to 7.19.0
  111. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.18.2-3
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  113. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 7.18.2-2
  114. - Rebuild for Python 2.6
  115. * Thu Jul 3 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.18.2-1
  116. - Update to 7.18.2
  117. - Thanks to Ville Skytt辰 re-enable the tests and fix a minor problem
  118. with the setup.py. (Bug # 45400)
  119. * Thu Jun 5 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.18.1-1
  120. - Update to 7.18.1
  121. - Disable tests because it's not testing the built library, it's trying to
  122. test an installed library.
  123. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 7.16.4-3
  124. - Autorebuild for GCC 4.3
  125. * Thu Jan 3 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.4-2
  126. - BR openssl-devel
  127. * Wed Aug 29 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.4-1
  128. - Update to 7.16.4
  129. - Update license tag.
  130. * Sat Jun 9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.2.1-1
  131. - Update to released version.
  132. * Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.0-0.1.20061207
  133. - Update to a CVS snapshot since development has a newer version of curl than is in FC <= 6
  134. * Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-4
  135. - Add -DHAVE_CURL_OPENSSL to fix PPC build problem.
  136. * Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-3
  137. - Don't forget to Provide: pycurl!!!
  138. * Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-2
  139. - Remove INSTALL from the list of documentation
  140. - Use python_sitearch for all of the files
  141. * Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-1
  142. - First version for Fedora Extras