python-ldap-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define openldap_version 2.1.22
  3. ### Abstract ###
  4. Name: python-ldap
  5. Version: 2.3.11
  6. Release: 5%{?_dist_release}
  7. Epoch: 0
  8. License: Python
  9. Group: System Environment/Libraries
  10. Summary: An object-oriented API for Python to access LDAP directory servers
  11. Summary(ja): Python 用 LDAP インタフェースモジュール
  12. URL: http://python-ldap.sourceforge.net/
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Source0: http://download.sourceforge.net/python-ldap/python-ldap-%{version}.tar.gz
  15. ### Patches ###
  16. #Patch0: python-ldap-2.2.0-dirs.patch
  17. Patch0: python-ldap-2.3.11-dirs.patch
  18. ### Dependencies ###
  19. Requires: openldap >= %{openldap_version}
  20. ### Build Dependencies ###
  21. # the openldap from RHL <= 9 and RHEL <= 3 is too old for python-ldap
  22. BuildRequires: openldap-devel >= %{openldap_version}
  23. BuildRequires: openssl-devel
  24. BuildRequires: python-devel >= 2.2
  25. BuildRequires: cyrus-sasl-devel
  26. %description
  27. python-ldap provides an object-oriented API for working with LDAP within
  28. Python programs. It allows access to LDAP directory servers by wrapping the
  29. OpenLDAP 2.x libraries, and contains modules for other LDAP-related tasks
  30. (including processing LDIF, LDAPURLs, LDAPv3 schema, etc.).
  31. %description -l ja
  32. python-ldap により、Python プログラムから LDAP へアクセスするための
  33. オブジェクト志向 API が提供されます。OpenLDAP 2.x のライブラリのラッパー
  34. として動作し、LDAP ディレクトリサーバへのアクセスを行うことができます。
  35. また他に LDIF、LDAPURL、LDAPv3 スキーマといった LDAP 関連用のモジュールも
  36. 収録されています。
  37. %prep
  38. %setup -q -n python-ldap-%{version}
  39. %patch0 -p0 -b .dirs
  40. # clean up cvs hidden files
  41. rm -rf Demo/Lib/ldap/.cvsignore Demo/.cvsignore Demo/Lib/ldif/.cvsignore Demo/Lib/ldap/async/.cvsignore \
  42. Demo/Lib/.cvsignore Demo/Lib/ldapurl/.cvsignore
  43. # Fix interpreter
  44. sed -i 's|#! python|#!/usr/bin/python|g' Demo/simplebrowse.py
  45. %build
  46. %{__python} setup.py build
  47. %install
  48. rm -rf $RPM_BUILD_ROOT
  49. %{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
  50. %clean
  51. rm -rf $RPM_BUILD_ROOT
  52. %files
  53. %defattr(-,root,root,-)
  54. %doc LICENCE CHANGES README TODO Demo
  55. %{python_sitearch}/_ldap.so
  56. %{python_sitearch}/dsml.py*
  57. %{python_sitearch}/ldapurl.py*
  58. %{python_sitearch}/ldif.py*
  59. %{python_sitearch}/ldap/
  60. %{python_sitearch}/python_ldap-%{version}-*.egg-info
  61. %changelog
  62. * Fri Nov 02 2018 Toshiaki Ara <ara_t@384.jp> 2.3.11-5
  63. - rebuild with openssl-1.1.1
  64. * Fri Dec 26 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.11-4
  65. - rebuilt with cyrus-sasl 2.1.26
  66. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.11-3
  67. - rebuild with VineSeed environment
  68. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.11-2
  69. - rebuild with python-2.7.2
  70. * Mon Apr 19 2010 Shu KONNO <owa@bg.wakwak.com> 2.3.11-1
  71. - updated python-ldap to 2.3.11
  72. - updated Patch0: python-ldap-%{version}-dirs.patch
  73. - rebuilt with python-2.6, openldap-2.4.21
  74. * Sat Apr 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.3.5-2
  75. - rebuilt with openldap-2.4.11
  76. * Tue Feb 3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.3.5-1
  77. - initial build for Vine Linux
  78. * Fri Jan 16 2009 Tomas Mraz <tmraz@redhat.com> - 0:2.3.5-3
  79. - rebuild with new openssl
  80. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0:2.3.5-2
  81. - Rebuild for Python 2.6
  82. * Wed Sep 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:2.3.5-1
  83. - fix license tag
  84. - update to 2.3.5
  85. * Sun Feb 17 2008 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.1-3.fc9
  86. - Rebuild with GCC 4.3
  87. * Wed Dec 05 2007 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.1-2.fc9
  88. - Rebuild against new openssl.
  89. * Wed Oct 10 2007 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.1-1.fc8
  90. - Update to 2.3.1
  91. * Fri Jun 08 2007 Matthew Barnes <mbarnes@redhat.com> - 0:2.3.0-1.fc8
  92. - Update to 2.3
  93. - Spec file cleanups.
  94. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0:2.2.0-3
  95. - rebuild against python 2.5
  96. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com>
  97. - rebuild
  98. * Wed May 17 2006 Matthew Barnes <mbarnes@redhat.com> - 2.2.0-2
  99. - Put back the epoch line... happy beehive?
  100. * Mon May 15 2006 Matthew Barnes <mbarnes@redhat.com> - 2.2.0-1
  101. - Update to 2.2.0
  102. - Update python-ldap-2.0.6-rpath.patch and rename it to
  103. python-ldap-2.2.0-dirs.patch.
  104. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:2.0.6-5.2.1
  105. - bump again for double-long bug on ppc(64)
  106. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0:2.0.6-5.2
  107. - rebuilt for new gcc4.1 snapshot and glibc changes
  108. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  109. - rebuilt
  110. * Tue Nov 8 2005 Tomas Mraz <tmraz@redhat.com> - 2.0.6-5
  111. - rebuilt with new openssl
  112. * Tue Mar 22 2005 Warren Togami <wtogami@redhat.com> - 2.0.6-4
  113. - add LICENCE (#150842)
  114. - simplify python reqs
  115. - remove invalid rpath
  116. * Wed Mar 16 2005 Dan Williams <dcbw@redhat.com> - 0:2.0.6-2
  117. - rebuilt to pick up new libssl.so.5
  118. * Tue Feb 8 2005 David Malcolm <dmalcolm@redhat.com> - 0:2.0.6-1
  119. - 2.0.6
  120. * Tue Nov 16 2004 Nalin Dahyabhai <nalin@redhat.com> - 0:2.0.1-3
  121. - rebuild (#139161)
  122. * Mon Aug 30 2004 David Malcolm <dmalcolm@redhat.com> - 0:2.0.1-2
  123. - Rewrote description; added requirement for openldap
  124. * Tue Aug 17 2004 David Malcolm <dmalcolm@redhat.com> - 0:2.0.1-1
  125. - imported into Red Hat's packaging system from Fedora.us; set release to 1
  126. * Wed Jun 30 2004 Panu Matilainen <pmatilai@welho.com> 0:2.0.1-0.fdr.1
  127. - update to 2.0.1
  128. * Sun Dec 07 2003 Panu Matilainen <pmatilai@welho.com> 0:2.0.0-0.fdr.0.4.pre16
  129. - fix spec permissions + release tag order (bug 1099)
  130. * Sat Dec 6 2003 Ville Skyttä <ville.skytta at iki.fi> 0:2.0.0-0.fdr.0.pre16.3
  131. - Stricter python version requirements.
  132. - BuildRequire openssl-devel.
  133. - Explicitly build *.pyo, install them as %%ghost.
  134. - Own more installed dirs.
  135. - Remove $RPM_BUILD_ROOT at start of %%install.
  136. * Wed Dec 03 2003 Panu Matilainen <pmatilai@welho.com> 0:2.0.0-0.fdr.0.pre16.2
  137. - duh, build requires python-devel, not just python...
  138. * Wed Dec 03 2003 Panu Matilainen <pmatilai@welho.com> 0:2.0.0-0.fdr.0.pre16.1
  139. - Initial Fedora packaging.