python-inotify-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215
  1. %global with_python3 1
  2. %global oname pyinotify
  3. Summary: Monitor filesystem events with Python under Linux
  4. Name: python-inotify
  5. Version: 0.9.6
  6. Release: 3%{?_dist_release}
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: MIT
  11. URL: https://github.com/seb-m/pyinotify
  12. Source0: https://github.com/seb-m/pyinotify/archive/0.9.6.tar.gz#/pyinotify-%{version}.tar.gz
  13. Source1: %{oname}
  14. Patch01: pyinotify-0.9.6-epoint.patch
  15. BuildArch: noarch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  17. BuildRequires: python-rpm-macros
  18. BuildRequires: python-devel python-setuptools python2-rpm-macros
  19. %if 0%{?with_python3}
  20. BuildRequires: python3-devel python3-setuptools python3-rpm-macros
  21. %endif
  22. %description
  23. This is a Python module for watching filesystems changes. pyinotify
  24. can be used for various kind of fs monitoring. pyinotify relies on a
  25. recent Linux Kernel feature (merged in kernel 2.6.13) called
  26. inotify. inotify is an event-driven notifier, its notifications are
  27. exported from kernel space to user space.
  28. %package examples
  29. Summary: Examples for Python inotify module
  30. Group: programming
  31. Requires: python-inotify = %{version}-%{release}
  32. %description examples
  33. This package includes some examples usage of the Python inotify module.
  34. %if 0%{?with_python3}
  35. %package -n python3-inotify
  36. Summary: Monitor filesystem events with Python under Linux
  37. Group: programming
  38. %description -n python3-inotify
  39. This is a Python 3 module for watching filesystems changes. pyinotify
  40. can be used for various kind of fs monitoring. pyinotify relies on a
  41. recent Linux Kernel feature (merged in kernel 2.6.13) called
  42. inotify. inotify is an event-driven notifier, its notifications are
  43. exported from kernel space to user space.
  44. This is the Python 3 build of pyinotify
  45. %endif # if with_python3
  46. %prep
  47. %setup -q -n %{oname}-%{version}
  48. %patch01 -p1
  49. sed -i '1c#! %{__python3}' python3/pyinotify.py
  50. rm -rf %{py3dir}
  51. cp -a . %{py3dir}
  52. %build
  53. %py2_build
  54. %if 0%{?with_python3}
  55. pushd %{py3dir}
  56. %py3_build
  57. popd
  58. %endif
  59. %install
  60. %{__rm} -rf %{buildroot}
  61. %py2_install
  62. %{__install} -D -m 0755 -p %{SOURCE1} %{buildroot}%{_bindir}/python2-%{oname}
  63. %{__chmod} 0755 %{buildroot}%{python_sitelib}/%{oname}.py
  64. %if 0%{?with_python3}
  65. pushd %{py3dir}
  66. %py3_install
  67. popd
  68. %{__install} -D -m 0755 -p %{SOURCE1} %{buildroot}%{_bindir}/python3-%{oname}
  69. %{__sed} -i -e 's/^python /python3 /' %{buildroot}%{_bindir}/python3-%{oname}
  70. ln -sf python3-%{oname} %{buildroot}%{_bindir}/%{oname}
  71. %{__chmod} 0755 %{buildroot}%{python3_sitelib}/%{oname}.py
  72. %endif
  73. # examples
  74. %{__install} -d -m 0755 %{buildroot}%{_datadir}/%{oname}
  75. %{__cp} -a python2/examples/* %{buildroot}%{_datadir}/%{oname}
  76. %clean
  77. %{__rm} -rf %{buildroot}
  78. %files
  79. %defattr(-, root, root, -)
  80. %license COPYING
  81. %doc ACKS README.md
  82. %{_bindir}/python2-%{oname}
  83. %{python_sitelib}/%{oname}*
  84. %files examples
  85. %defattr(-, root, root, -)
  86. %{_datadir}/%{oname}
  87. %if 0%{?with_python3}
  88. %files -n python3-inotify
  89. %defattr(-, root, root, -)
  90. %license COPYING
  91. %doc ACKS README.md
  92. %{_bindir}/%{oname}
  93. %{_bindir}/python3-%{oname}
  94. %{python3_sitelib}/%{oname}*
  95. %{python3_sitelib}/__pycache__/%{oname}*
  96. %endif
  97. %changelog
  98. * Wed Aug 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.6-3
  99. - fixed dependency.
  100. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.6-2
  101. - rebuilt with python-3.8.
  102. * Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.6-1
  103. - new upstream release.
  104. * Sun Feb 8 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.5-1
  105. - new upstream release.
  106. * Mon Jun 10 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.4-1
  107. - new upstream release.
  108. * Thu Oct 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.3-2
  109. - initial build for Vine Linux.
  110. * Wed Feb 01 2012 Terje Rosten <terje.rosten@ntnu.no> - 0.9.3-1
  111. - 0.9.3
  112. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.2-2
  113. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  114. * Mon May 02 2011 Terje Rosten <terje.rosten@ntnu.no> - 0.9.2-1
  115. - 0.9.2
  116. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.1-2
  117. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  118. * Mon Feb 07 2011 Terje Rosten <terje.rosten@ntnu.no> - 0.9.1-1
  119. - 0.9.1
  120. * Wed Aug 25 2010 Thomas Spura <tomspur@fedoraproject.org> - 0.9.0-3
  121. - rebuild with python3.2
  122. http://lists.fedoraproject.org/pipermail/devel/2010-August/141368.html
  123. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 0.9.0-2
  124. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  125. * Sat Jun 19 2010 Terje Rosten <terje.rosten@ntnu.no> - 0.9.0-1
  126. - 0.9.0
  127. - Add python 3 subpackage
  128. - License changed to MIT
  129. * Sun Dec 06 2009 Terje Rosten <terje.rosten@ntnu.no> - 0.8.8-1
  130. - 0.8.8
  131. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-2.git20090518
  132. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  133. * Mon May 18 2009 Terje Rosten <terje.rosten@ntnu.no> - 0.8.6-1.git20090518
  134. - Update to latest git, fixing bz #500934.
  135. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-2.git20090208
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  137. * Sun Feb 8 2009 Terje Rosten <terje.rosten@ntnu.no> - 0.8.1-1.git20090208
  138. - 0.8.1
  139. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.8.0-4.r
  140. - Rebuild for Python 2.6
  141. * Sun Jun 22 2008 Terje Rosten <terjeros@phys.ntnu.no> - 0.8.0-3.r
  142. - rebuild
  143. * Tue Jun 17 2008 Terje Rosten <terjeros@phys.ntnu.no> - 0.8.0-2.r
  144. - 0.8.0r
  145. - add wrapper in /usr/bin
  146. * Mon Jun 16 2008 Terje Rosten <terjeros@phys.ntnu.no> - 0.8.0-1.q
  147. - 0.8.0q
  148. - Update url, license and source url
  149. * Sat Feb 9 2008 Terje Rosten <terjeros@phys.ntnu.no> - 0.7.1-2
  150. - Rebuild
  151. * Wed Aug 08 2007 Terje Rosten <terjeros@phys.ntnu.no> - 0.7.1-1
  152. - New upstream release: 0.7.1
  153. - Fix license tag
  154. * Mon Jun 25 2007 Terje Rosten <terjeros@phys.ntnu.no> - 0.7.0-3
  155. - Remove autopath from example package (bz #237464)
  156. * Tue Mar 27 2007 Terje Rosten <terjeros@phys.ntnu.no> - 0.7.0-2
  157. - Fix email address
  158. * Tue Mar 6 2007 Terje Rosten <terjeros@phys.ntnu.no> - 0.7.0-1
  159. - Initial build