python-imaging-vl.spec 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154
  1. Summary: The Python Imaging Library
  2. Summary(ja): Python イメージ処理ライブラリ
  3. Name: python-imaging
  4. Version: 1.1.7
  5. Release: 4%{?_dist_release}
  6. License: Distributable
  7. Group: Development/Languages
  8. URL: http://www.pythonware.com/products/pil
  9. Source0: http://effbot.org/downloads/Imaging-%{version}.tar.gz
  10. Patch0: Imaging-1.1.7-setup.lib64.patch
  11. Patch1: Imaging-1.1.7-freetype-2.5.x.patch
  12. BuildRequires: python-devel >= 2.6
  13. BuildRequires: libjpeg-devel libpng-devel zlib-devel freetype2-devel
  14. BuildRequires: xorg-x11-devel
  15. BuildRequires: sane-devel
  16. Requires: python >= 2.6
  17. Requires: libjpeg >= 6a
  18. Requires: libpng >= 1.0.12
  19. Requires: zlib >= 1.1.4
  20. Requires: freetype2 >= 2.1.3
  21. Provides: Imaging, python-PIL
  22. Obsoletes: Imaging < %{version}
  23. Obsoletes: python-PIL < %{version}
  24. Obsoletes: python-Imaging <= %{version}
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. Distribution: Vine Linux
  27. Vendor: Project Vine
  28. Packager: owa
  29. %description
  30. The Python Imaging Library (PIL) adds image processing capabilities
  31. to your Python environment. This library provides extensive file
  32. format support, an efficient internal representation, and fairly
  33. powerful image processing capabilities.
  34. %description -l ja
  35. Python Imaging Library (PIL) は Python 環境にイメージ処理能力を加えます.
  36. このライブラリには広範なファイル型式への対応, 効果的な内部表現, そして
  37. 真にパワフルなイメージ処理能力が備わっています.
  38. %prep
  39. %setup -q -n Imaging-%{version}
  40. %ifarch x86_64
  41. %patch0 -p1 -b .lib64~
  42. %endif
  43. %patch1 -p1 -b .ft
  44. %build
  45. python setup.py build_ext -i
  46. python selftest.py
  47. %install
  48. rm -rf $RPM_BUILD_ROOT
  49. python setup.py install --root=$RPM_BUILD_ROOT
  50. mkdir -p $RPM_BUILD_ROOT%{_includedir}/python%{pyver}/PIL
  51. cp -p libImaging/*.h $RPM_BUILD_ROOT%{_includedir}/python%{pyver}/PIL/
  52. mkdir -p $RPM_BUILD_ROOT%{python_sitearch}/Sane
  53. pushd Sane
  54. python setup.py install --root=$RPM_BUILD_ROOT --install-lib=%{python_sitearch}/Sane
  55. install -m644 demo_numarray.py $RPM_BUILD_ROOT%{python_sitearch}/Sane
  56. install -m644 CHANGES README sanedoc.txt $RPM_BUILD_ROOT%{python_sitearch}/Sane
  57. popd
  58. %clean
  59. rm -rf $RPM_BUILD_ROOT
  60. %files
  61. %defattr(-, root, root)
  62. %doc BUILDME CHANGES CONTENTS README
  63. %doc Docs
  64. %dir %{python_sitearch}/PIL
  65. %dir %{python_sitearch}/Sane
  66. %{_bindir}/pil*.py
  67. %{_includedir}/python%{pyver}/PIL/*.h
  68. %{python_sitearch}/PIL.pth
  69. %{python_sitearch}/PIL/*
  70. %{python_sitearch}/Sane/*
  71. %changelog
  72. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.7-4
  73. - rebuild with VineSeed environment
  74. - add Patch0 (Imaging-1.1.7-freetype-2.5.x.patch)
  75. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.7-3
  76. - rebuild with python-2.7.2
  77. * Sat May 07 2011 Shu KONNO <owa@bg.wakwak.com> 1.1.7-2
  78. - install PIL with setup.py
  79. - install Sane with setup.py
  80. - install %{_bindir}/pil*.py
  81. - added BR: sane-devel
  82. * Thu Feb 03 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.7-1
  83. - new upstream release
  84. - recreated Patch0
  85. * Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-3
  86. - rebuild for python-2.6
  87. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-2vl5
  88. - rebuilt with python-2.5.2
  89. * Sat Jun 14 2008 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-1vl5
  90. - applied new versioning policy and spec in utf-8
  91. - added BuildRequires: xorg-x11-devel
  92. - fixed typo at Distribution
  93. * Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-0vl4
  94. - fixed prereq, buildrequires pkgs
  95. * Wed Mar 21 2007 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-0vl2
  96. - updated Imaging to 1.1.6
  97. - added BuildRequires: XOrg-devel zlib-devel libjpeg-devel libpng-devel freetype2-devel
  98. * Sat Oct 14 2006 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl5
  99. - added Imaging-1.1.5-setup.lib64.patch
  100. - rebuilt for x86_64 architecture support
  101. * Wed May 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> python-imaging-1.1.5-0vl4
  102. - changed Group:
  103. * Fri Oct 07 2005 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl3
  104. - rebuilt
  105. * Sun May 22 2005 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl2
  106. - changed package name 'python-Imaging' to 'python-imaging'
  107. * Fri May 20 2005 Shu KONNO <owa@bg.wakwak.com> python-Imaging-1.1.5-0vl1
  108. - changed package name 'Imaging' to 'python-Imaging'
  109. - updated Python Imaging Library (PIL) to 1.1.5
  110. - rebuilt with python-2.4
  111. * Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 1.1.3-0vl1
  112. - updated 1.1.3
  113. * Thu Jul 26 2001 Satoshi MACHINO <machino@vinelinux.org> 1.1.2-0vl1
  114. - updated 1.1.2
  115. * Thu Aug 03 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
  116. - Imaging-1.1-0vl1
  117. - build on VineSeed
  118. * Sun Mar 7 1999 MATSUMOTO Shoji <vine@flatout.org>
  119. - make spec