python-idna-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176
  1. %global with_python3 1
  2. %global srcname idna
  3. Name: python-%{srcname}
  4. Version: 2.10
  5. Release: 1%{?_dist_release}
  6. Summary: Internationalized Domain Names in Applications (IDNA)
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: BSD and Python and Unicode
  11. URL: https://github.com/kjd/idna
  12. Source0: https://pypi.io/packages/source/i/%{srcname}/%{srcname}-%{version}.tar.gz
  13. BuildArch: noarch
  14. BuildRequires: python-rpm-macros
  15. BuildRequires: python-devel
  16. BuildRequires: python-setuptools
  17. %if 0%{?with_python3}
  18. BuildRequires: python%{python3_pkgversion}-rpm-macros
  19. BuildRequires: python%{python3_pkgversion}-devel
  20. BuildRequires: python%{python3_pkgversion}-setuptools
  21. %endif # with_python3
  22. %{?python_provide:%python_provide python2-%{srcname}}
  23. %description
  24. A library to support the Internationalised Domain Names in Applications (IDNA)
  25. protocol as specified in RFC 5891 <http://tools.ietf.org/html/rfc5891>. This
  26. version of the protocol is often referred to as "IDNA2008" and can produce
  27. different results from the earlier standard from 2003.
  28. The library is also intended to act as a suitable drop-in replacement for the
  29. "encodings.idna" module that comes with the Python standard library but
  30. currently only supports the older 2003 specification.
  31. %if 0%{?with_python3}
  32. %package -n python%{python3_pkgversion}-%{srcname}
  33. Summary: Internationalized Domain Names in Applications (IDNA)
  34. Group: programming
  35. %{?python_provide:%python_provide python%{python3_pkgversion}-%{srcname}}
  36. %description -n python%{python3_pkgversion}-%{srcname}
  37. A library to support the Internationalised Domain Names in Applications (IDNA)
  38. protocol as specified in RFC 5891 <http://tools.ietf.org/html/rfc5891>. This
  39. version of the protocol is often referred to as "IDNA2008" and can produce
  40. different results from the earlier standard from 2003.
  41. The library is also intended to act as a suitable drop-in replacement for the
  42. "encodings.idna" module that comes with the Python standard library but
  43. currently only supports the older 2003 specification.
  44. %endif # with_python3
  45. %prep
  46. %setup -q -n %{srcname}-%{version}
  47. # Remove bundled egg-info
  48. rm -rf %{srcname}.egg-info
  49. %build
  50. %py_build
  51. %if 0%{?with_python3}
  52. %py3_build
  53. %endif # with_python3
  54. %install
  55. %if 0%{?with_python3}
  56. %py3_install
  57. %endif # with_python3
  58. %py_install
  59. %check
  60. #{__python2} setup.py test
  61. %if 0%{?with_python3}
  62. #{__python3} setup.py test
  63. %endif # with_python3
  64. %files
  65. %license LICENSE.rst
  66. %doc README.rst HISTORY.rst
  67. %{python_sitelib}/%{srcname}
  68. %{python_sitelib}/%{srcname}-%{version}-py%{python_version}.egg-info
  69. %if 0%{?with_python3}
  70. %files -n python%{python3_pkgversion}-%{srcname}
  71. %license LICENSE.rst
  72. %doc README.rst HISTORY.rst
  73. %{python3_sitelib}/%{srcname}
  74. %{python3_sitelib}/%{srcname}-%{version}-py%{python3_version}.egg-info
  75. %endif # with_python3
  76. %changelog
  77. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.10-1
  78. - new upstream release.
  79. * Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.7-4
  80. - initial build for Vine Linux.
  81. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7-3
  82. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  83. * Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 2.7-2
  84. - Rebuilt for Python 3.7
  85. * Tue Jun 12 2018 Jeremy Cline <jeremy@jcline.org> - 2.7-1
  86. - Update to v2.7 (rhbz 1589803)
  87. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-4
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  89. * Fri Jan 19 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.5-3
  90. - Update Python 2 dependency declarations to new packaging standards
  91. (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
  92. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-2
  93. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  94. * Tue Mar 07 2017 Jeremy Cline <jeremy@jcline.org> - 2.5-1
  95. - Update to version 2.5
  96. * Wed Mar 01 2017 Jeremy Cline <jeremy@jcline.org> - 2.4-1
  97. - Update to version 2.4
  98. * Tue Feb 28 2017 Paul Wouters <pwouters@redhat.com> - 2.3-1
  99. - Resolves: rhbz#1427499 Update to 2.3 for IDNAError bugfix and memory improvement
  100. * Thu Feb 09 2017 Jeremy Cline <jeremy@jcline.org> - 2.2-1
  101. - Update to version 2.2 (#1406757)
  102. * Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.1-3
  103. - Rebuild for Python 3.6
  104. * Mon Nov 28 2016 Orion Poplawski <orion@cora.nwra.com> - 2.1-2
  105. - Ship python2-idna
  106. - Enable python3 for EPEL
  107. - Modernize spec
  108. * Mon Oct 17 2016 tom.prince@ualberta.net - 2.1-1
  109. - Bump version.
  110. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0-4
  111. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  112. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.0-3
  113. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  114. * Wed Nov 04 2015 Robert Kuska <rkuska@redhat.com> - 2.0-2
  115. - Rebuilt for Python3.5 rebuild
  116. * Thu Aug 13 2015 Paul Wouters <pwouters@redhat.com> - 2.0-1
  117. - Update to 2.0 which is required by python-cryptography
  118. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-2
  119. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  120. * Wed Dec 31 2014 tom.prince@ualberta.net - 1.0-1
  121. - Bump version.
  122. * Mon Oct 27 2014 tom.prince@ualberta.net - 0.8-3
  123. - Update licences.
  124. * Sat Jul 12 2014 tom.prince@ualberta.net - 0.8-2
  125. - Be more specfic about .egg-info directories.
  126. - Use python2-devel
  127. * Sat Jul 12 2014 tom.prince@ualberta.net - 0.8-1
  128. - Initial package.