python-funcparserlib-vl.spec 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117
  1. Summary: Recursive descent parsing library for Python based on functional combinators
  2. Name: python-funcparserlib
  3. Version: 0.3.6
  4. Release: 2%{?_dist_release}
  5. Group: programming
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: MIT License
  9. URL: https://pypi.org/project/funcparserlib/
  10. Source0:https://pypi.python.org/packages/source/f/funcparserlib/funcparserlib-%{version}.tar.gz
  11. BuildArch: noarch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
  13. BuildRequires: python-rpm-macros
  14. BuildRequires: python-devel
  15. BuildRequires: python-setuptools
  16. BuildRequires: python2-rpm-macros
  17. Requires: python
  18. %description
  19. Parser combinators are just higher-order functions that take parsers as
  20. their arguments and return them as result values. Parser combinators are:
  21. - First-class values
  22. - Extremely composable
  23. - Tend to make the code quite compact
  24. - Resemble the readable notation of xBNF grammars
  25. Parsers made with funcparserlib are pure-Python LL(*) parsers. It means
  26. that it's very easy to write them without thinking about look-aheads and
  27. all that hardcore parsing stuff. But the recursive descent parsing is a
  28. rather slow method compared to LL(k) or LR(k) algorithms.
  29. So the primary domain for funcparserlib is parsing little languages or
  30. external DSLs (domain specific languages).
  31. %package -n python3-funcparserlib
  32. Summary: Recursive descent parsing library for Python based on functional combinators
  33. Group: programming
  34. BuildRequires: python3-devel
  35. BuildRequires: python3-setuptools
  36. BuildRequires: python3-rpm-macros
  37. Requires: python3
  38. %description -n python3-funcparserlib
  39. Parser combinators are just higher-order functions that take parsers as
  40. their arguments and return them as result values. Parser combinators are:
  41. - First-class values
  42. - Extremely composable
  43. - Tend to make the code quite compact
  44. - Resemble the readable notation of xBNF grammars
  45. Parsers made with funcparserlib are pure-Python LL(*) parsers. It means
  46. that it's very easy to write them without thinking about look-aheads and
  47. all that hardcore parsing stuff. But the recursive descent parsing is a
  48. rather slow method compared to LL(k) or LR(k) algorithms.
  49. So the primary domain for funcparserlib is parsing little languages or
  50. external DSLs (domain specific languages).
  51. %prep
  52. %setup -q -n funcparserlib-%{version}
  53. %build
  54. %py2_build
  55. %py3_build
  56. %install
  57. %__rm -rf %{buildroot}
  58. %py2_install
  59. %py3_install
  60. sed -i \
  61. -e 's/except NoParseError, e:/except NoParseError as e:/' \
  62. %{buildroot}%{python3_sitelib}/funcparserlib/parser.py
  63. %clean
  64. %__rm -rf %{buildroot}
  65. %files
  66. %defattr(-,root,root,-)
  67. %license LICENSE
  68. %doc CHANGES README doc examples
  69. %{python_sitelib}/funcparserlib-%{version}-py*.egg-info
  70. %{python_sitelib}/funcparserlib
  71. %files -n python3-funcparserlib
  72. %defattr(-,root,root,-)
  73. %license LICENSE
  74. %doc CHANGES README doc examples
  75. %{python3_sitelib}/funcparserlib*
  76. %changelog
  77. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.3.6-2
  78. - rebuilt with python-3.8.
  79. * Thu Nov 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.3.6-1
  80. - new upstream release.
  81. - added python3 support.
  82. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.5-3
  83. - rebuild with VineSeed environment
  84. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.5-2
  85. - rebuild with python-2.7.2
  86. * Mon May 16 2011 IWAI, Masaharu <iwai@alib.jp> 0.3.5-1
  87. - Initial build.