python-ethtool-vl.spec 3.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %{!?python_ver: %define python_ver %(%{__python} -c "import sys ; print sys.version[:3]")}
  3. Summary: Ethernet settings python bindings
  4. Summary(ja): ethtool の python バインディング
  5. Name: python-ethtool
  6. Version: 0.3
  7. Release: 4%{?_dist_release}
  8. URL: http://git.kernel.org/?p=linux/kernel/git/acme/python-ethtool.git
  9. Source: http://userweb.kernel.org/~acme/python-ethtool/%{name}-%{version}.tar.bz2
  10. License: GPLv2
  11. Group: System Environment/Libraries
  12. BuildRequires: python-devel
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. %description
  17. Python bindings for the ethtool kernel interface, that allows querying and
  18. changing of ethernet card settings, such as speed, port, autonegotiation, and
  19. PCI locations.
  20. %prep
  21. %setup -q
  22. %build
  23. %{__python} setup.py build
  24. %install
  25. rm -rf %{buildroot}
  26. %{__python} setup.py install --skip-build --root %{buildroot}
  27. mkdir -p %{buildroot}%{_sbindir}
  28. cp -p pethtool.py %{buildroot}%{_sbindir}/pethtool
  29. cp -p pifconfig.py %{buildroot}%{_sbindir}/pifconfig
  30. %clean
  31. rm -rf %{buildroot}
  32. %files
  33. %defattr(-,root,root)
  34. %doc COPYING
  35. %{_sbindir}/pethtool
  36. %{_sbindir}/pifconfig
  37. %{python_sitearch}/ethtool.so
  38. %if "%{python_ver}" >= "2.5"
  39. %{python_sitearch}/*.egg-info
  40. %endif
  41. %changelog
  42. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3-4
  43. - rebuild with VineSeed environment
  44. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3-3
  45. - rebuild with python-2.7.2
  46. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.3-2
  47. - rebuild with python-2.6
  48. * Wed Sep 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1
  49. - initial build for Vine Linux
  50. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-5
  51. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  52. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-4
  53. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  54. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.3-3
  55. - Rebuild for Python 2.6
  56. * Fri Sep 5 2008 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.3-2
  57. - Rewrote build and install sections as part of the fedora review process
  58. BZ #459549
  59. * Tue Aug 26 2008 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.3-1
  60. - Add get_flags method from the first python-ethtool contributor, yay
  61. - Add pifconfig command, that mimics the ifconfig tool using the
  62. bindings available
  63. * Wed Aug 20 2008 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.2-1
  64. - Expand description and summary fields, as part of the fedora
  65. review process.
  66. * Tue Jun 10 2008 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.1-3
  67. - add dist to the release tag
  68. * Tue Dec 18 2007 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.1-2
  69. - First build into MRG repo
  70. * Tue Dec 18 2007 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.1-1
  71. - Get ethtool code from rhpl 0.212